PDA

View Full Version : Webserver folder not showing up in AFP




Buckaroo
Jul 24, 2012, 01:52 AM
I'm sure there is a simple fix, but I could not find anything on the internet or here.

I have a colocated Mac Mini Snow Leopard Server. It works pretty good, but recently I upgraded my home iMac to Lion 10.7.4. In the past, the only way I could update my website in the WebServer folder (located in the ServerHD/Library/WebServer) was via AFP. Now that I have upgraded to Lion on my iMac I can not view the WebServer folder via AFP. It keeps coming up with the folders in the "serveradmin" library instead of the top level. I tried to move the webserver folder to another location and change the "Web" (in Admin Tools) from the old location to the user location and it will not allow a browser to access the web page in that user.

I've even reviewed the UAM's, but I don't know which one to delete.



Buckaroo
Jul 24, 2012, 03:13 AM
It took me over 4 hours, but I finally figure it out.

I was not aware that you could "File Share" a specific folder. After I saw that I was able to finally get another folder to allow me to copy a file into the server via AFP (the folder was labeled as being able to share), I then looked around in Admin tools and under File Sharing, clicked on Volumes and Browse and was able to navigate to the WebServer folder and enable sharing.

What a pain.

One good thing did come out of all this mess, I finally got a 2nd URL to work on my server, and it was pure luck that I figured it out.

Les Kern
Jul 24, 2012, 06:54 AM
It took me over 4 hours, but I finally figure it out.



One good thing did come out of all this mess, I finally got a 2nd URL to work on my server, and it was pure luck that I figured it out.

Excellent. And that "luck" thing? I count on it.
:)