PDA

View Full Version : Since ML/New OS X Server Install I get a Profile Manager Error.




eyepea
Jul 26, 2012, 06:37 AM
I was running Lion with Lion Server on a MM Server (current model). Since upgrading ML and then upgrading OS X Server today I am getting an error when I start the server App and then to do anything (like share a drive). Server still seems to work and share my drives as it did in Lion but I can't change/update anything with Server because it keeps brining up the error even though I am not touching Profile Manager.

The Error in a pop up window says:

Multiple errors occurred on the server while processing commands.

The error occurred while reading settings for the Profile Manager service.


I don't use Profile Manager and the switch is set to "Off". And really only use the Server App for file sharing but I want to keep the App as it works better for sharing my drives than OS X File Sharing.

I can't seem to fix the error so is there a way to clear server settings? Can I reset Server somehow or can I delete the App and reinstall it? I am thinking of this option because then I can just reconfig the Server.

Anyone know of this error or something I can try?

:(

IP.



jwsmiths
Jul 28, 2012, 10:35 PM
I was running Lion with Lion Server on a MM Server (current model). Since upgrading ML and then upgrading OS X Server today I am getting an error when I start the server App and then to do anything (like share a drive). Server still seems to work and share my drives as it did in Lion but I can't change/update anything with Server because it keeps brining up the error even though I am not touching Profile Manager.

The Error in a pop up window says:

Multiple errors occurred on the server while processing commands.

The error occurred while reading settings for the Profile Manager service.


I don't use Profile Manager and the switch is set to "Off". And really only use the Server App for file sharing but I want to keep the App as it works better for sharing my drives than OS X File Sharing.

I can't seem to fix the error so is there a way to clear server settings? Can I reset Server somehow or can I delete the App and reinstall it? I am thinking of this option because then I can just reconfig the Server.

Anyone know of this error or something I can try?

:(

IP.

Try this: http://support.apple.com/kb/HT5349

Worked for me. Still have one, I believe unrelated error in Server.app but I'm working on that one too.

eyepea
Jul 29, 2012, 03:17 AM
Thanks for that.

I ended up reinstalling ML and OS X Server from scratch to fix the problem and understandably it worked. I don't think OS X Server (ML Version) installs well over the top of Lion Server, particularly when you have settings in place. I also think it may have had something to do with my AirPort Extreme because I noticed coincidentally that Lion server had put a Network rule in AAE that related to Profile Manager. Too much of a coincidence.

IP.