PDA

View Full Version : airplay in ML older Mac!!!




avw5000
Jul 27, 2012, 02:49 PM
Hi I've been working on a project with airplay mirroring for old Macs I'm having trouble with terminal command if I get this terminal command we will be able to use airplay mirroring another macs.

Background: i have found .plist files for airplay mirroring in /library/preferences

i have a terminal command that goes

cd /Library/Preferences hit enter

sudo echo -n enabled > com.apple.airplaymirroring BrowseAllInterfaces 1

but when i hit enter i get permissions denied

Any idea on how to fix the permission so that we can all us this



kryten2
Jul 27, 2012, 04:39 PM
This isn't going to work. If you're lucky you've just made yourself a com.apple.airplaymirroring file with the following line in it :

enabled BrowseAllInterfaces 1

If you want to edit plist files use Property List Editor or look at the defaults command. Use a copy of the com.apple.airplaymirroring.plist file to try.

Info : http://developer.apple.com/library/mac/#documentation/Darwin/Reference/ManPages/man1/defaults.1.html

ikuragames
Jul 27, 2012, 08:24 PM
You're using sudo to give root permissions to the command, however the stdin redirect '>' is not in scope of the command - so doesn't get the root permission. You're basically just getting echo to run as root, rather than getting root permissions on the file...

Use: sudo sh -c "<your command here>"

This will put the file redirection in scope for sudo.

avw5000
Jul 27, 2012, 10:21 PM
sudo thing worked...but cannot get the preferences to change in display preferences...any ideas

subsonix
Jul 28, 2012, 03:57 AM
sudo thing worked...but cannot get the preferences to change in display preferences...any ideas

Plist files are XML files not plain text files, as was mentioned you need to use plist editor or possibly use defaults, you can also edit the file manually in a text editor if you are familiar with XML.

FrancoisC
Jul 28, 2012, 02:09 PM
Not going to work.

Even if you get the option to appear, when you "enable" it, it won't do a thing. Your Mac lacks the hardware to use it.

If it was a software solution, it could work, but slowly.

But in this case, Apple use one of intel's technology integrated only in their latest CPU.

Do some research on "Intel QuickSync", you'll see.

avw5000
Jul 30, 2012, 11:45 PM
Thanks for the help everyone...still tryin cause i believe that we come with a work around like we did for airdrop in os x 10.7 Lion. Ill let you guys know.

DaveGee
Jul 31, 2012, 06:57 AM
sudo echo -n enabled > com.apple.airplaymirroring BrowseAllInterfaces 1


This is the wrong syntax. I believe you're looking for something lie this.

defaults write com.apple.AirplayMirriorng BrowseAllInterfaces 1

However this assumes AppleMirrioring is the name of the .plist file AND that simply 'enabling' a feature magically makes it work. Unfortunately it usually doesn't work that way.

For example:

defaults write com.apple.cpu ivybridge 1

doesn't give your machine an ivybridge CPU when you only really have a C2D.