PDA

View Full Version : Can't change status in iMessages




iphonejunkie
Jul 28, 2012, 05:49 PM
When I go to Messages > My Status the status options are greyed out. Does anyone know how to change status?



whynot83706
Jul 28, 2012, 06:07 PM
I am having same problem, also can you share screen?

Arelunde
Jul 28, 2012, 06:43 PM
Open iMessage and get the preferences from the menu bar under "Messages" on the menu bar. There are options there to indicate how your availability should be displayed to others.

TofSanity
Jul 28, 2012, 08:43 PM
Open iMessage and get the preferences from the menu bar under "Messages" on the menu bar. There are options there to indicate how your availability should be displayed to others.

did this work for anyone else? everything is grey for me as well.

dcorban
Jul 29, 2012, 01:14 AM
It seems that status is not supported with iMessage accounts. If it is the only type of account you have enabled, then status is not able to be set.

I guess this means you are always "online" via iMessage as long as the account is enabled.

tido2012
Jul 29, 2012, 01:41 AM
I was having the same issue, but was able to fix it by doing the following:
1st- Go to iMessages preferences: you get there by clicking iMessages and then on the top you will see where it says Messages, click that and then go down and click preferences.

2nd- Under General select "Show status in menu bar": I couldn't get it to work without doing this.

3rd- A small Messages icon pops up to the left of your WiFi info: its exact location may vary depending on what all you have installed on your computer.

I hope this helps :)

devman
Jul 29, 2012, 02:38 AM
your AIM account has to be enabled.

Status has no meaning for iMessage/Messages. You are always available to receive a message. There is no online/offline. You can always send a message to an iMessage user.

Agathon
Jul 29, 2012, 02:44 AM
It seems that status is not supported with iMessage accounts. If it is the only type of account you have enabled, then status is not able to be set.

It's like a phone number. You can always be reached at it.

I think the problem that some people are having is that they can't bear to not answer a message they receive. Quite how someone could have that sort of hang up is beyond me.

If you don't want to know about the message, turn alerts and banners off via the switch at the hidden top of the notifications panel.

bushido
Jul 29, 2012, 04:31 AM
not possible, would be rather pointless to be enabled anyway because how is an iPad or an iPhone supposed to see the status?

Arelunde
Jul 29, 2012, 12:49 PM
What's the difference between iMessage and AIM? Does it have anything to do with iMessage only working between Mac/iOS devices? Or does iMessage work with any device? Everyone I know has an iPhone, it seems.

----------

I was having the same issue, but was able to fix it by doing the following:
1st- Go to iMessages preferences: you get there by clicking iMessages and then on the top you will see where it says Messages, click that and then go down and click preferences.

2nd- Under General select "Show status in menu bar": I couldn't get it to work without doing this.

3rd- A small Messages icon pops up to the left of your WiFi info: its exact location may vary depending on what all you have installed on your computer.

I hope this helps :)

There are a bunch of options that seem to be what others are looking for when you click the message bubble in the menu bar.

dcorban
Jul 31, 2012, 12:55 PM
The menubar options do nothing when you only have iMessage enabled. They are clickable, but do not change, and have no effect. They are only for use with AIM/Jabber/etc.