PDA

View Full Version : Need help displaying subtitles on ATV3




ZZ Bottom
Jul 28, 2012, 09:17 PM
Hey all. I've scoured the forums searching for an answer, but nothing seems to be working for me. I am trying to have subtitles display on Apple TV 3 from Shows/Movies from iTunes library.

I have enabled subtitles in settings on ATV (set to English). I recently ripped Breaking Bad episodes to stream locally, which using handbrake I choose subtitles forced in (not burned in). While attempting to watch an episode with some Spanish parts, I cannot seam to get subtitles to display. I have verified that they display fine playing the m4v in VLC, so they obviously are within the container.

On all the forum posts I find, everyone says either press and hold center button (which only displays chapters) or to press up twice (which does nothing). I've tried every combination of pressing and holding I can find, but nothing brings up any options to enable subtitles.

Is there something that was changed on the ATV3 iOS version that makes it less compatible?

Any advice is appreciated. Tried to watch Kill Bill today and it kinda sucks not knowing what the Japanese voice over is saying.



T5BRICK
Jul 28, 2012, 09:24 PM
On my ATV3, I just hold down the middle button and select the subtitles I want to see. If that isn't working for you go into Settings > Audio & Video > Close Captioning and turn it on. Also, set "Subtitle Language" to the language you'd like it to default to.

ZZ Bottom
Jul 28, 2012, 09:47 PM
Thank you for the reply. I currently have subtitles set to English, closed captioning on, and while pressing center button during a video I get no other options besides chapters (on a video that I intentionally chose to keep subtitles in handbrake, and which displays subtitles in VLC).

Have you personally used handbrake? Do you know if handbrake's method of retaining subtitles is incompatible with ATV 3? It seems like my only other option is to burn in subtitles, which seems less desirable as they will be grainier than if the system rendered them.

T5BRICK
Jul 28, 2012, 10:06 PM
I thought I'd gotten it working on Handbrake at one point, but it's been a while since I ripped anything.

ZZ Bottom
Jul 28, 2012, 10:32 PM
I thought I'd gotten it working on Handbrake at one point, but it's been a while since I ripped anything.

Do you recall having to burn in the subtitles?

On a separate note, I just followed a method to add subtitles (srt file) to a .m4v that had no subtitles included. After doing so, using a windows app called Yamb, I was able to have VLC recognize a subtitle track. However, from iTunes I cannot get any subtitles to show with the same video even after re-adding it to the library. And yes I do have subtitles enabled and CC enabled in iTunes preferences.

Again thanks for any advice. Have a bad feeling all of the DVDs I've already ripped using Handbrake are going to be useless if they have any scenes with subtitles.

T5BRICK
Jul 28, 2012, 11:11 PM
Do you recall having to burn in the subtitles?

I'm pretty sure they were not burned in.

I just came across this thread, maybe it has some tips you could use?

http://forums.macrumors.com/showthread.php?t=1345467

mic j
Jul 29, 2012, 09:02 AM
You didn't mention whether or not your file source was standard dvd or BR. And, the way I read your post, you only need forced subtitles. If that is the case you need to do this to burn in the forced subtitles with Handbrake:

For dvd: go to subtitles tab, under track select "foreign audio search" and make sure forced and burned in are selected.

For BR: you need to do the same, but you need to download the latest nightly build of Handbrake and use that instead of the current stable release version (0.9.8).

If you don't want or can't re-rip using HB, you will need to download a srt file that contains forced subs and add it to your file using something like Subler.

If you want to do something else with subtitles, let me know specifically what you want and we can figure out what to do.

Chazz08
Jan 9, 2014, 01:38 PM
On my ATV3, I just hold down the middle button and select the subtitles I want to see. If that isn't working for you go into Settings > Audio & Video > Close Captioning and turn it on. Also, set "Subtitle Language" to the language you'd like it to default to.

THANK YOU! This was my answer! Thanks a ton!