PDA

View Full Version : Safari 6 OS 10.8 - Can't establish a secure connection




lentife
Jul 29, 2012, 05:36 AM
Hi everyone! I have difficulties with Safari 6 on OS 10.8 Mountain Lion... When i attempt to connect to various secure http sites, Safari will fail to connect, saying "safari can't open the page because safari can't establish a secure connection to the server" Other times, a small rectangle will appear within the address bar labelled https, and all will be well. It's quite random and irritating. To get it to word again, sometimes a relaunch does the trick, sometimes I have to reset safari. Is there something I can do?
Thanks!



maflynn
Jul 29, 2012, 05:40 AM
I've not incurred that problem myself. Did you try clearing out the cache? (Safari menu->Empty Cache)?

Tander
Jul 29, 2012, 05:47 AM
I've just tried a secure connection (Https://mail.domain.co.za/owa) and works fine here.

lentife
Jul 29, 2012, 05:55 AM
I've not incurred that problem myself. Did you try clearing out the cache? (Safari menu->Empty Cache)?

I thought resetting safari would empty the cache. Anyway I did it now and it's currently working. The problem is that it's pretty random. Sometimes it works many hours, then suddenly all https sites don't work anymore until I relaunch / reset safari.. That's pretty annoying. The issues definitely came up with safari 6, as in Lion it worked fine. (I'm on a mid 2011 MBA 13")

Beavington
Jul 29, 2012, 06:53 AM
I am was having the same issue. Seems to be most secure sites... including parts of the apple website. Have reset Safari twice and still not access many sites that require a secure connection .. including my bank

Solved by restarting safari..... turning off Rapport in system preferences....then restarting safari again..... then restarting rapport

pikeg123
Jul 29, 2012, 04:50 PM
I found what helped was re-installing Rapport.. Downloaded again from Trusteer's website and it seems fine at the moment

fdwhite
Jul 30, 2012, 09:26 AM
Ive been having the same problem as well. It works if I delete the cache file but the problem returns the next day, so I have to delete the file daily. I havent tried deleting / reinstalling rapport yet.

wouteronline
Jul 31, 2012, 01:27 AM
I'm having the same problem but don't have Rapport installed.

Dingthing
Jul 31, 2012, 05:28 AM
I am finding that safari wont connect to any site, on a random basis, though I haven't yet tried the fix here, i.e. clearing cache. I will have 6 tabs open, and they won't update after a point in use. Only once had the secure site connection issue raised. How do we report this to Apple?

adamtheturtle
Jul 31, 2012, 05:33 AM
I've not incurred that problem myself. Did you try clearing out the cache? (Safari menu->Empty Cache)?

This has been moved to the Develop menu (enabled under Safari->Preferences->Advanced).

TrusteerSupport
Jul 31, 2012, 08:15 AM
Hello lentife,

The new version of Trusteer Rapport (1204.75) supports Safari 6 for Mountain Lion. You can download it via your bank's website or from our website in this link (http://www.trusteer.com/support/en/leopard-105x-snow-leopard-106x-lion-107x-and-mountain-lion-108x).
For further assistnace feel free to contact us here (http://www.trusteer.com/support/en/report-problem), we operate a 24/7 free technical support center and would be happy to help with any issue.

Trusteer Technical Support

CrazyMacUser
Jul 31, 2012, 06:36 PM
Hi, I am having the same problems as you mention here since installing Mountain Lion; however, they only seem to occur on certain WiFi connections. When I connect using LAN at work, everything works fine.

I also cannot send emails using SSL, I cannot connect to MSN and I cannot open Dropbox.

All these issues happen on my home WiFi.

Any clues as to how to solve this?

tkeryder31
Aug 1, 2012, 09:52 PM
I was having the same issues (working off LAN, non WiF)i, could not connect to any https site, even apple sites. After doing some searching I downloaded Trusteer Rapport, uninstalled the program and then reinstalled the latest version. Everything seems to be working just fine now.

Keeks
Aug 2, 2012, 12:25 AM
I don't have Rapport and have the same issue; I found the solution to this problem somewhere on the web. I don't know exactly what I am changing but is easy to be done and solves the problem. You can undone this changes easily, so give it a try.

Open System Preferences and choose Network.
From the list of connections select WiFi or Ethernet (whichever you use or one at a time) and click advanced...
Select the Hardware option and change the MTU setting to 1300
You may need to put custom in order to introduce the number.
Save and Apply the changes.

I don't remember if I restarted my Mac, so first quit your browser, reopen it and try to go to a secure site, it happens with Facebook and even with the help forums at Apple.

I am sorry that I can't give credit to the guy how post this somewhere else.

chicagozfinest
Aug 23, 2013, 04:20 PM
I tried reducing the MTU to 1300 (using WiFi and ethernet) to no avail. Is anyone still experiencing this issue?

This seems specific to 10.8. A couple of older ones (10.6 &*10.5) worked as expected. One thing to note that I am trying to connect to a server with a self-signed cert. So if everything worked as expected, Safari would pop up and "Are you sure you want to go here?" screen (as it did in 10.6). Does anyone know of anything else I can try?