PDA

View Full Version : Mountain Lion and font rendering - samples inside




v0n
Jul 29, 2012, 10:00 AM
After installation of Mountain Lion on my 2008 Mac Pro I immediately noticed font rendering issue, where in my experience most of the sans serif fonts in highlighted menus, in terminal and on websites appeared to be fatter, bolder, with fluffy edges and more iOS looking than my usual OSX I'm used to for years. To my surprise the usual trick of changing font smoothing by issuing command in terminal:
defaults -currentHost write -globalDomain AppleFontSmoothing -int 2
didn't work and I would get reply:
The domain/default pair of (kCFPreferencesAnyApplication, AppleFontSmoothing)
does not exist

despite the fact Font smoothing was enabled in System Preferences. Disabling font smoothing would revert fonts to their beautiful, smooth shape as I know it for years and smoothing tweak in terminal would work again, almost as if there was a bug and "font smoothing" setting in System Preferences of Mountain Lion worked in reverse to that of Lion - unticking would enable it, ticking would disable it. Bear with me for a second though, this post is not just about smoothing option in prefs.

The weird thing is - when I popped in to discuss this issue on one of the UK computer forums, and shown them screen shots, rather large number of people said I got it all wrong, and OSX should be displaying everything in bolder font and that they never experienced it looking any different!
It's a surprise to me, I have three macs at home, 7 macs at work, never experienced this font boldness bug before on any of the OSX's, to be honest, I couldn't work or stand it for more than 5 minutes, but I thought it would be interesting to see what mac community thinks about it.

So, macinoshians - which of the following do you see on your Mountain Lion screens and which do you think is "normal" OSX look.

Example 1 - front page of this great site in Safari:
Top. Mountain Lion on my MP08 default, smoothing in System Preferences
Bottom. The way Lion on my MP08 and every mac in my life see it
http://ocuk.filmsuk.com/fontsm1.jpg
http://ocuk.filmsuk.com/fontsm2.jpg

As a benchmark - for comparison:
from left to right:
1. Mountain Lion 2. Lion default/Mountain Lion with smoothing off 3. MS Windows smoothing 4. No smoothing at all
http://ocuk.filmsuk.com/fontsm7.jpg

Example 2: terminal (iTerm)
Top. Mountain Lion default, smoothing in System Preferences on
Bottom. Lion default, smoothing in System Preferences on
http://ocuk.filmsuk.com/fontsm25.jpg
http://ocuk.filmsuk.com/fontsm24.jpg

Example 3 - fragment of steampowered "news" page:
Top. Mountain Lion default, smoothing in System Preferences on
Bottom. Lion default, smoothing in System Preferences on
http://ocuk.filmsuk.com/fontsm22.jpg
http://ocuk.filmsuk.com/fontsm23.jpg

So, to me, all "top" examples look wrong. However, a lot of people I asked today claim they have never seen OSX looking any different than the "top" examples.
What's your take on it - let's not quote the pictures, just point top/ML look or bottom/Lion look. If your Mountain Lion doesn't look like my screenshots, but looks like my screenshots of Lion, post it too - there will be some bug report to fill. :)



v0n
Jul 31, 2012, 05:56 AM
I guess I was the only one with this bug then? :D

gymrat2k
Jul 31, 2012, 06:10 AM
I guess I was the only one with this bug then? :D

I experienced the same thing upgrading from Lion to ML. Noticed the "fatter" fonts immediately on ML, but not a show stopping bug. Also not a large enough problem to warrant the thorough research to try to change back to the default/previous appearance.

Enough interest in the matter to subscribe to this thread though :)

MyRomeo
Jul 31, 2012, 06:11 AM
Can't say that I have noticed but I shall check when back home later.

MacRenegade
Jul 31, 2012, 06:36 AM
Well, the bold version is the default rendering setting for Macs, so assume that's what most people are familiar with. I however, just like you, can't stand that bold version and have been using the lighter one for several years.

The bold version doesn't even make sense. Why antialias black text using all the colors of the rainbow? The lighter setting always antialiases text using shades of the text color.

I have not experienced the bug you're talking about, though.

Also, since you have to get close to the screen to really see the difference, almost compare pixels, a higher quality JPEG setting would be better, or just use PNG as they are OS screenshots and not photographs (which would take a lot of space in the PNG format).

mabaker
Jul 31, 2012, 07:05 AM
That was the very first thing I noticed after upgrading. At first it was annoying but I am kind of getting used to it as the hours go by.

It looks cleaner this way, but to experience the cleanerness you need a good monitor.

Fumoffu
Jul 31, 2012, 07:11 AM
It's the first thing i noticed when i installed Mountain Lion.

I have never seen OSX looking any different than the "BOTTOM" examples (i've had Macbook Pro, Mac Pro and Mac Mini).

Thanks for giving me the solution, i disabled font smoothing and now i have my "traditional" fonts, I would have hated these new fat fonts...

borostef
Jul 31, 2012, 07:46 AM
The same thing happened to me after upgrading from Lion to Mountain Lion.

Beta Particle
Jul 31, 2012, 08:03 AM
You appear to have had subpixel font rendering disabled on Lion, using the "Best for CRT" font rendering. That is absolutely not how fonts are supposed to look in OS X on a flat panel display.

My guess is that they have finally removed the legacy font rendering options from OS X. (I am not at a Mac to check right now)

Previously, you were able to choose from: Best for CRT Light Medium - best for Flat Panel Strong
Then the option was changed to "Use LCD font smoothing when available" which was equivalent to the old "Medium" setting.

The reason for this, is that they switched to hardware accelerated font rendering, but did not port over the older rendering options.

You were able to select the older options by using a terminal command, but then fonts were rendered via software rendering, with lower performance.

Especially with Mountain Lion being designed with Retina-capable Macs in mind, I would have to imagine that they have now removed the software-based options for performance reasons, or possibly because they are no longer relevant at that kind of pixel density.

The bold version doesn't even make sense. Why antialias black text using all the colors of the rainbow? The lighter setting always antialiases text using shades of the text color.It makes sense because monitors display images using RGB subpixels. Utilising this subpixel structure allows for much better font rendering, at the expense of potential color fringing on the edges of text if you sit too close.

http://upload.wikimedia.org/wikipedia/commons/0/0d/Subpixel_demonstration_%28Quartz%29.png
Source (http://en.wikipedia.org/wiki/Subpixel_rendering)

matrix07
Jul 31, 2012, 08:05 AM
I prefer the top one, which looks like evrything on iOS.

doug in albq
Jul 31, 2012, 10:07 AM
Hmmm, I entered this setting for light rendering....

defaults -currentHost write -globalDomain AppleFontSmoothing -int 1

and it worked for me...I could instantly see the difference. This on 10.8

________________________

Mac OS X 10.6 simplified the font smoothing (anti-aliasing) for Mac OS X and all apps within it, but for some the change is unwelcome. If you feel like your screen looks different, it probably does, and the change can be very profound on certain LCD displays. Using the Terminal we can adjust the font smoothing to the same precision that we could prior to 10.6, so launch the Terminal and enter the following command:

defaults -currentHost write -globalDomain AppleFontSmoothing -int 2

the 2 on the end is for medium smoothing which used to be called ‘best for flat panel’, 1 is for light smoothing, and 3 is for strong smoothing. After you execute the command you’ll want to reload the Finder and other apps that are open to see the changes in effect, you can reload the Finder by killing it:

killall Finder

Now your font smoothing will be reflected in the settings you chose.

warpmoon
Aug 6, 2012, 08:44 AM
I installed 10.8 yesterday and instantly saw this issue. Highly annoying!

Turning font smoothing off is the only option that has worked for me so far, setting the AppleFontSmoothing to anything from 1 to 3 has not helped.

Lri
Aug 30, 2012, 02:20 AM
I installed 10.8 yesterday and instantly saw this issue. Highly annoying!

Turning font smoothing off is the only option that has worked for me so far, setting the AppleFontSmoothing to anything from 1 to 3 has not helped.

defaults write -g AppleFontSmoothing -int 0 should also disable LCD font smoothing (subpixel rendering). You have to reopen applications to apply the changes. The key could also be overridden in ~/Library/Preferences/ByHost/.GlobalPreferences.*.plist.

The reason for this, is that they switched to hardware accelerated font rendering, but did not port over the older rendering options.

You were able to select the older options by using a terminal command, but then fonts were rendered via software rendering, with lower performance.

Adding an AppleFontSmoothing key still works at least on non-Retina displays. Can you point out to any sources that it would disable hardware accelerated text rendering?

Beta Particle
Aug 30, 2012, 04:27 AM
Changing AppleFontSmoothing in the property lists still works at least on non-Retina displays. Can you point out to any sources that it would disable hardware acceleration?I can’t seem to find anything now, with Google prioritising recent articles on searches these days.

Back when Snow Leopard came out, I seem to recall reading that this is the reason why the other font smoothing options were removed.

anentropic
Oct 24, 2013, 04:25 PM
Each time I upgrade OS X I have to Google this hack again... the two apps I find most affected by the fuzzy bold fonts problem are Sublime Text 2 and iTerm2. I just had to look again now I'm on Mavericks...

I'm not sure why this works for some people, not for me:
defaults -currentHost write -globalDomain AppleFontSmoothing -int 1

Same with turning off 'LCD font smoothing'... that just makes the Chrome address bar look ugly, prefer it switched on.

The command that fixes things for me is:
defaults write -g AppleFontSmoothing -int 0

brdeveloper
Oct 27, 2013, 09:59 AM
The command that fixes things for me is:
defaults write -g AppleFontSmoothing -int 0

I'm really annoyed with the new Preview.app in Mavericks. On my C2D Macbook, sometimes font smoothness takes around one second to be applied after scrolling. That makes me think I have a kind of eye impairment. Really annoying reading PDFs. Is there a way to reinstall Snow Leopard's Preview? I've tried every solution posted here but, although they doesn't seem to work with Preview. I think this new Mavericks iOS-like feature "drag to update" made things worse. Now, any subtle dragging movement caused by two-fingers scrolling triggers the font-smoothing process.