PDA

View Full Version : Why is Chrome Forcing my MBP to use Discrete Graphics?!




AdDaMan
Jul 29, 2012, 03:51 PM
Have just upgraded to ML and now it seems Chrome is Forcing My 2011 MBP to Use the Radeon Graphics card instead of the integrated and its to do with the Chrome Helper.


Anyone else have this?

Thanks



charlieegan3
Jul 29, 2012, 03:53 PM
just run gfxcardstatus or wait for chrome updates

AdDaMan
Jul 29, 2012, 03:58 PM
i do run gfxcardstatus but that hardly answers my question does it!

JacaByte
Jul 29, 2012, 04:09 PM
The chrome helper used to come on for flash video and animations, now it turns on to help with animations for Chrome in general. (Hence, it's a chrome helper app.) Use power switching if it's a problem, just keep in mind that if you switch between discrete and integrated while Chrome is running flash will get goofed up.

AdDaMan
Jul 29, 2012, 04:12 PM
So do you think this will be patched soon by google?

RioAsks
Aug 1, 2012, 08:08 AM
I have the same problem too! before I upgraded to ML, last time I checked chrome doesn't use discrete graphics. but after I upgraded to ML, chrome only uses discrete graphics. it's really annoying cause it's eating my battery life twice as fast.:/

polinux
Aug 1, 2012, 09:02 AM
There is another issue.

When I have 26" monitor plugged on Thunderbolt it forces Discreet ATI 6770 and if i choose integrated my second monitor goes off and doesnt show anything. :(

Anyone found way aroud that. I'd love to have it running on integrated as much as possible. :)

Beta Particle
Aug 1, 2012, 09:08 AM
Most browsers these days are implementing hardware acceleration, and due to OS X's way of determining whether the discrete graphics should be used or not, it will switch over.

Unless Apple create some way for developers to specify that the discrete graphics card is not required when making specific API calls that normally trigger the switch, it's going to happen more frequently, especially as apps are updated to support retina displays. (apps will benefit from graphics acceleration much more at higher resolutions)

muhviehstarr
Nov 24, 2012, 12:57 AM
Hey guys,

i think i found an solution.


goto about:flags and look for GPU-Compositing in all pages and deactivate it.

AdDaMan
Nov 24, 2012, 06:42 AM
Where?!

throAU
Nov 24, 2012, 07:12 AM
So do you think this will be patched soon by google?

It's not a google problem. OS X itself is enabling the GPU when certain libraries in OS X are called.

Yes, you can probably stop chrome enabling it by turning off chrome features, but that is side-stepping the real problem.

The GPU auto switching in the MBPs is mildly retarded.

IMHO - on battery, the discrete GPU should be turned off 100% of the time. You get horrible battery life with it enabled - and anything that requires it to run well will kill your battery in under an hour anyway.

The MBAs and other macs get by without a discrete gpu for most of the tasks i use my machine for on battery. There should at least be a tickbox in the power settings for "force integrated graphics on battery" or similar.

(yes i know about gfxcardstatus. doesn't mean apple shouldn't fix it themselves)

authority11
Nov 23, 2013, 03:35 PM
Chrom is still forcing me into using the discrete graphics on my Early 2013 rMBP. Has this been fixed and somehow I don't have the fix or is this still happening for others?