PDA

View Full Version : Mac looses connection when sleeping




sflomenb
Jul 29, 2012, 06:07 PM
I use LogMeIn to remotely access my Mac. I did this on Lion with no problem and worked when my iMac was asleep. Now, on Mountain Lion, it doesn't work when my Mac is asleep. Of course, I can prevent my Mac from going into sleep mode, but is there a way I can keep it connected to the internet while it is in sleep mode? I have an iMac connected to Ethernet, so it obviously doesn't support Power Nap. Thanks.



eNJayBe
Jul 31, 2012, 04:21 PM
I have a similar problem, I can't connect to iTunes from my AppleTV any more when my Mac is sleeping.

iVoid
Jul 31, 2012, 09:21 PM
Under the Energy Saver System pref there should be a 'Wake for network access" checkbox. Make sure it's checked. I don't have ML in front of me, so hopefully it's still there.

hafr
Aug 1, 2012, 02:44 AM
I have a similar problem, I can't connect to iTunes from my AppleTV any more when my Mac is sleeping.

Same here, but it works with the Remote app from Apple (for iOS devices), so I just use that to get the library to show up on the screen. It was the same with Lion sometimes.

It's like the ATV doesn't send an equally "important" signal as the Remote app...

aln
Aug 1, 2012, 09:27 AM
I'm exactly with the same issue before I let my download programs active during the night and the next day everything was downloaded, now when the mac goes into hibernation, the connection to the network is cut, and stop downloads and remote access as well.

I really need to fix this or unfortunately going back to the snow leopard where everything worked fine.

Under the Energy Saver System pref there should be a 'Wake for network access" checkbox. Make sure it's checked. I don't have ML in front of me, so hopefully it's still there.

I've done this, selected and unbselected this option, but the problem continues.

rrdesign
Aug 16, 2012, 10:21 AM
I have the same problem. Just updated today to ML but noticed straight away that my wifi is going of when the computer goes to sleep. Really a problem for me as i have online backup and don't want my screen to be on constantly. Hope apple comes with a fix soon or someone else offcourse :-)

dyn
Aug 16, 2012, 05:06 PM
This has been normal behaviour for years. When the Mac sleeps there is no network connectivity. You can put just the display to sleep (ctrl-shift-eject does this). This will turn off the display and conserve power whilst still keeping the Mac turned on and thus the network connection(s).

In Snow Leopard they changed this. They introduced a feature called Wake on Demand (http://support.apple.com/kb/HT3774). I've linked to the official Apple support document where you can find more info about this feature like how to set it up and how it works exactly. Do note the information about Mac notebooks in clamshell mode at the bottom of the page! It says that you need to use it with the poweradapter plugged in.

Baximus
Aug 17, 2012, 01:37 PM
Same problem here, my iMac is also loosing connection while at sleep. Normally you could wake it up if you needed (from another mac). Also when downloading sleep mode kicks in after 10 minutes (is the setting in energy savings) but when there is network activity it should stay on!!

Anybody have the same isseu?

Already contacted apple about it, there looking in to it.

sflomenb
Aug 17, 2012, 02:31 PM
Same problem here, my iMac is also loosing connection while at sleep. Normally you could wake it up if you needed (from another mac). Also when downloading sleep mode kicks in after 10 minutes (is the setting in energy savings) but when there is network activity it should stay on!!

Anybody have the same isseu?

Already contacted apple about it, there looking in to it.

They responded to you?

Suzatlarge
Aug 17, 2012, 07:38 PM
[snip] a feature called Wake on Demand (http://support.apple.com/kb/HT3774). I've linked to the official Apple support document where you can find more info about this feature like how to set it up and how it works exactly.
Good info, and I checked into it. My iMac does support this feature. "Wake for network access" is selected in system (energy) preferences - has been before and after ML upgrade. My wi-fi network is via a 2011 Airport Extreme, and my system profiler (specifically known as "System Information.app") states "Wake on wireless:supported."

However, under ML it just doesn't work- although it did under SL and Lion. The computer goes to sleep after I haven't touched the mouse or keyboard for an hour (as set - the display sleeps after 15 minutes, and I'm no techie but I do know that difference), whether or not it's in the middle of a download or upload. I've been uploading some files for online storage, using Safari, so no worries about "3rd party apps" causing the iMac to misbehave.

Prior to ML, my iMac's sleep settings were just the same as they are now. But my iMac wouldn't stop downloads or uploads in progress at the time sleep was supposed to occur per those settings. And if I left the browser open at bedtime, I would find my fresh emails, notifications, etc., already loaded when I woke up the iMac in the morning. None of that happens now.

I've sent in a bug report on the Apple site. I know, I won't receive a personal reply to that. I don't have time to fuss with any other method of contacting them. I've done both SMC and PRAM resets, checked all settings, read the cited article. It's just not working like they say it's supposed to. I'll try to live with it, but if it's not fixed I suppose I'll have to live with setting "computer sleep" to "never" if I want a download, upload or application task to continue to completion more than an hour after I stand up from my desk. And remember to change the setting back again.

About application tasks - having something like a batch file conversion or DVD file ripping job in progress also doesn't prevent the computer from sleeping under ML although it did under all prior OS's. Apparently if there's been no physical touch of keyboard or mouse for an hour, my iMac just doesn't care what's happening, be it download, upload, network activity, or an application process in progress - it's beddybye time. I'm just getting started using Lightroom, and I expect to have to set the sleep time to "never" unless I want to babysit mass file imports.

Basically, I have to literally hold the iMac's "hand" or set it to never sleep, if I want it to finish lengthy tasks.

I am so so sorry I listened to my expert friends and did this upgrade.

resipsa17
Aug 18, 2012, 01:12 PM
I'm having the same problem. My iMac is connected via ethernet (not just a wifi issue - in fact, I don't have this problem with my MBA, which is connected via wifi). Internet never disconnected on SL or Lion, but now it drops when computer sleeps.

I spent at least an hour with apple support over multiple calls trying to find a solution. I'll go ahead and submit a bug report also. This is a significant problem as it makes accessing my iMac remotely impossible, unless I keep the computer awake 24/7.

Major flaw in ML. Glad I'm not the only one though, gives me hope there will be a fix.

Baximus
Aug 19, 2012, 03:47 AM
@sflomenb
there will be an escalation report. So apple is going to look at it.

I will get a email when they have a solution/patch/update.

sflomenb
Aug 23, 2012, 05:24 PM
10.8.1 has NOT addressed the problem.

Baximus
Aug 24, 2012, 04:57 PM
No indeed. Kinda hoping for it, have not yet heard something from apple!

Baximus
Aug 28, 2012, 07:24 AM
Do we all have the same 27" iMac Late 2009? Maybe thats the problem?

sflomenb
Aug 28, 2012, 07:38 AM
Do we all have the same 27" iMac Late 2009? Maybe thats the problem?

Well, I do at least. This problem should be fixable. This never happened to me on Lion, so Apple should be able to fix this with a Software Update.

resipsa17
Aug 28, 2012, 10:32 AM
I'm on an early 2009 24". Spent many more hours with senior techs trying everything under the sun. Only thing left to try is clean install (which I have little hope for).

Because this worked flawlessly in Lion, there should be a software fix. Send a bug report here: http://www.apple.com/feedback/macosx.html.

If we make enough noise, hopefully they'll address it.

resipsa17
Sep 13, 2012, 10:17 AM
Just thought I would resurrect this thread to update - after several hours with apple techs and no resolution, my last option was to do a clean install of ML. I was procrastinating on that for a couple weeks. During that time, Time Warner had some issues in my neighborhood, including sporadic service and outages.

After they serviced the nodes, my wake on lan problems stopped. I'm not 100% sure that was the issue, but I haven't made any other changes to my iMac and I don't think any ML updates have been pushed to my computer. Curious if anyone else with problems has seen a change.

jimbenedick
Oct 13, 2012, 12:56 PM
I have had the same problem since upgrading to ML from SL.

eNJayBe
Oct 16, 2012, 04:22 PM
The latest Apple TV update seemed to fix it for me, maybe along with 10.8.2.

oubiwann
Oct 22, 2012, 12:30 PM
Network is still disconnecting after 10.8.2 update.

sbhabyn
Nov 15, 2012, 09:33 AM
Since upgrading to ML, my problem is that I share the printer on my wife's iMAC which is located in another part of our property, and when her computer is not 'awake' and being used, I get a message on my iMAC every 30 seconds or so to say that there is a connection error. Cannot find a way to turn this off. Any ideas ? Her iMAC energy settings are unchanged since we upgraded from SL and should allow for network access.

To keep my iMAC awake when doing long downloads etc, get 'Caffeine' a free app available form the Apple Store. You can set it to keep your machine awake for specified periods. Excellent !

josepmba
Aug 9, 2013, 05:19 PM
Hi all, probably you already have found a solution for the "automatic Shutdown" problem. Anyway, I recently had the same problem and found the following solution:

System Config Menu > Security & Privacy > Enable changes by selecting the padlock and entering your system password > Advanced menu (lower right corner) > Disable the first option "Shutdown after .... minutes"

Hope this will work for you, good luck !!!

Josep

9000
Sep 30, 2013, 09:57 PM
Very big problem for me. I can't connect to my home Mac anymore because it goes to sleep and won't respond to WOL since there's no connection anymore.

adamtkincaid
Dec 17, 2013, 08:01 PM
Hey guys, new to the forum.

Bumping this, hope it's ok. Any new ideas? I have 10.9 and no luck.

GreenYogi
Jan 5, 2014, 05:37 AM
Hi!
I found a solution to this Wifi not reconnecting after sleep.
One has to Reset the System Management Controller (SMC)

http://support.apple.com/kb/HT3964?viewlocale=en_US

basically, turn off the mac, unplug the power cord, wait 15 seconds, plugin and wait 5 seconds before to press the switch on.

On restart, my Wifi was up and running, just like it used to be with Mountain Lion.

Hope that will work for ya'll. :cool:

However if it's not enough, I found more tips:

"Apple reseller recommends to create a new network location and then restart my mac while pressing alt+cmd+P+R and hold the keys while it restarts for four times."

and also...

"I had the same issue - disabling (un-checking) "Wake for Wi-Fi network access" in System Prefs, Energy Saver seems to have fixed it."

best of luck...