PDA

View Full Version : Chrome/gmail notifications not showing up in notification center sidebar




Action
Jul 30, 2012, 01:53 AM
I have desktop notifications enabled for gmail in chrome. When I get a new email (while the gmail tab is open), the notification center displays the popup banner fine. However, after the banner goes away, the notification is gone for good -- it doesn't appear in the notification center sidebar like notifications from other apps. Is anyone else having this issue?



fins831
Jul 30, 2012, 01:58 AM
Go into system preference, Notifications, find chrome and select Alerts instead of Banner

see if this fixes it.

Action
Jul 30, 2012, 02:07 AM
Go into system preference, Notifications, find chrome and select Alerts instead of Banner

see if this fixes it.

It shows an alert, but, like the banner, it doesn't appear in the notification center sidebar.

Action
Jul 30, 2012, 10:30 AM
Anyone else having this issue?

Sylon
Jul 30, 2012, 10:37 AM
I just tested it, after figuring out how to enable desktop alerts, and they are not appearing in NC after the banner goes away.

pronojitsaha
Jul 30, 2012, 12:45 PM
I just tested it, after figuring out how to enable desktop alerts, and they are not appearing in NC after the banner goes away.

Same here, whether in banner mode or alert mode, the chrome notifications do not appear in the NC tray. I have seen other forums where people have the same issue. I believe its a NC bug, but will be glad if someone provides a solution or chrome & NC fixes this soon.

slumpey326
Jul 30, 2012, 12:52 PM
I have desktop notifications enabled for gmail in chrome. When I get a new email (while the gmail tab is open), the notification center displays the popup banner fine. However, after the banner goes away, the notification is gone for good -- it doesn't appear in the notification center sidebar like notifications from other apps. Is anyone else having this issue?

quick question, how do you enable desktop notifications for gmail in chrome?

Action
Jul 30, 2012, 02:30 PM
quick question, how do you enable desktop notifications for gmail in chrome?

gmail.com > settings > general > desktop notifications

slumpey326
Jul 30, 2012, 07:20 PM
gmail.com > settings > general > desktop notifications

I cant get my gmail notifications to work, yet the calendar ones work just fine. Is anyone else having this problem.

Action
Jul 30, 2012, 09:04 PM
I cant get my gmail notifications to work, yet the calendar ones work just fine. Is anyone else having this problem.

The gmail notifications only work if gmail is currently open in a tab and the email you receive is from a different account (sending myself an email never triggered the notification).

Sylon
Jul 30, 2012, 10:29 PM
gmail.com > settings > general > desktop notifications


There is also a link that you have to click, along with the circle option to select, to allow the browser to have access to your desktop. Its in the same spot as the option to select, it says something like "click here to enable desktop notifications" or something like that (I dunno, I'm at work, can't check from here).

Action
Jul 30, 2012, 11:03 PM
It turns out the notification IS appearing in the sidebar, it just disappears when the banner does. Looks like someone reported it as a Chrome bug, but apparently the issue is with gmail itself:

http://code.google.com/p/chromium/issues/detail?id=139379

pronojitsaha
Jul 31, 2012, 06:48 AM
It turns out the notification IS appearing in the sidebar, it just disappears when the banner does. Looks like someone reported it as a Chrome bug, but apparently the issue is with gmail itself:

http://code.google.com/p/chromium/issues/detail?id=139379

Yes exactly....I too noticed the same. The notification appears in the sidebar as long as the banner/alert is there, and removes itself from the sidebar when the banner/alert goes away.

Bobby.e
Jul 31, 2012, 06:52 AM
Chrome just has its own notifications. NC doesn't support it as of yet.

Action
Jul 31, 2012, 12:19 PM
Looks like the Checker Plus for Gmail extension solves these issues:

https://chrome.google.com/webstore/detail/oeopbcgkkoapgobdbedcemjljbihmemj

Just set the notifications to "Text notification window" to get Notification Center alerts. You can customize how long they remain in the sidebar as well.

pronojitsaha
Aug 9, 2012, 08:33 AM
Looks like the Checker Plus for Gmail extension solves these issues:

https://chrome.google.com/webstore/detail/oeopbcgkkoapgobdbedcemjljbihmemj

Just set the notifications to "Text notification window" to get Notification Center alerts. You can customize how long they remain in the sidebar as well.

I installed checker plus. But its only giving me desktop notification and no notification centre alerts. Am I missing something here?

jasonsav
Aug 11, 2012, 11:11 AM
I installed checker plus. But its only giving me desktop notification and no notification centre alerts. Am I missing something here?

After installing the extension did you select the notification option "Text notifications" ?

jackoatmon
Aug 11, 2012, 10:28 PM
Same problem. Checker extension with text notifications doesn't fix it. Looks like we'll be waiting for an NC update. I really wish there was a good way to get gmail to show up in there with out it going through a mail client.