PDA

View Full Version : Calendar erroneously adds alerts to new events




kronborg
Aug 2, 2012, 04:06 PM
All default alerts are turned off in settings. When I create a new event, all seems fine on the Mac (it says no alerts), but when the event syncs to my iPhone and iPad, on there it has an alert set for "on day of event". I'm using iCloud as the only calendar account on all devices.

Are any of you having the same problem?



kronborg
Aug 4, 2012, 01:56 AM
Also, when editing a timed event (that e.g. runs from 12 to 13 on a day) into a full-day event, the event suddenly runs for two full days when synced to my iPhone/iPad. The day chosen and the next. Also says I'm free on the event (on the iPhone/iPad), even though it should say busy, as shown on the Mac.

I'm not the only one seeing this, right? Could it be solved by editing a plist file or something? I found another user with the same problem (http://forums.macresource.com/read/1/1403682#msg-1403820), but that's it.

jennyp
Aug 5, 2012, 11:20 AM
All default alerts are turned off in settings. When I create a new event, all seems fine on the Mac (it says no alerts), but when the event syncs to my iPhone and iPad, on there it has an alert set for "on day of event". I'm using iCloud as the only calendar account on all devices.

Are any of you having the same problem?

YES I am getting this. I thought it was the "Week Calendar" app but it happens to the default iPhone calendar app, too.

Every time I create a new event on my Mac, when I later view it on my iPhone I find it has been given an alert at midnight. Which means I have to go through each new event on my iPhone and clear out those alerts, since I don't want to be woken up at midnight.

I can't believe we're the only two getting this. Intensely annoying!

UPDATE: To make matters worse, after I've deleted the unwanted alarm, and then move the event on from one day to another, the alarm re-appears. This effectively stops me from using iCal !

kronborg
Aug 6, 2012, 02:58 AM
Thanks for your reply. I've sent a bug report to Apple, hoping they will fix this soon.

UPDATE: To make matters worse, after I've deleted the unwanted alarm, and then move the event on from one day to another, the alarm re-appears. This effectively stops me from using iCal !

Yep, every time I create or edit an event, this happens. Calendar is really only useful for viewing my calendars at this point.

jennyp
Aug 6, 2012, 04:04 AM
I meant "Calendar" when I said "iCal" - forgot the name change ... I'll also send a bug report

kronborg
Aug 7, 2012, 02:58 PM
There's a fellow user with a similar problem here: http://forums.macrumors.com/showthread.php?t=1417600

Seems like it's a problem with iCloud. When testing with a Google calendar, no alerts were added. So annoying!

MasterMac
Aug 17, 2012, 02:00 PM
On your iPhone (and iPad), go to Settings->Mail, Contacts, and Calendars, and scroll down to the bottom where it says "Default Alert Times". Are all of those set to None as well?

I know you mentioned it in the original post, but it sounded like you only checked those settings on the Mac, and not the iOS side.

kronborg
Aug 17, 2012, 04:03 PM
On your iPhone (and iPad), go to Settings->Mail, Contacts, and Calendars, and scroll down to the bottom where it says "Default Alert Times". Are all of those set to None as well?

Yes, they are all set to None. I even tried to set them to something else, and then back to None, for the settings to re-register or whatever, but didn't help. Thanks for posting, still :) Let's see if the .1 update makes the alerts go away.

To clarify: No alerts are added when events are created/edited on the iPhone/iPad. Only Calendar on the Mac is at fault.

jennyp
Aug 19, 2012, 06:58 PM
Yes I tried the same things too but no joy. And with me too it's triggered by events created (or moved) on the Mac desktop Calendar app, not by events created on iOS (unless they're later moved ahead on the Mac Calendar).

dcorban
Aug 19, 2012, 10:33 PM
To clarify: No alerts are added when events are created/edited on the iPhone/iPad. Only Calendar on the Mac is at fault.
In Calendar preferences under the Alerts tab, make sure those options are set to "none".

I had the same "problem" as you, and doing this stopped the alerts from being added.

kronborg
Aug 20, 2012, 01:30 AM
In Calendar preferences under the Alerts tab, make sure those options are set to "none".

I had the same "problem" as you, and doing this stopped the alerts from being added.

All default alerts are turned off in settings.

:) Are you using iCloud calendars? I still don't know if this can be reproduced on any Mac w/ Mountain Lion. But I guess I would know by now, if that was the case.

gr8tfly
Aug 20, 2012, 01:41 AM
Same problem here. I seemed to have fixed it by disabling the default alert in OS X Calendar (as mentioned above).

This problem seems to have cropped up since the upgrade to ML - I don't think it's iCloud. Just my gut level feeling, anyway. It's been hard replicate, so all the evidence I have is anecdotal.

kronborg
Aug 20, 2012, 01:56 AM
This problem seems to have cropped up since the upgrade to ML

Yep.

I don't think it's iCloud. Just my gut level feeling, anyway.

The thing is, no alerts are added to events created for a Google calendar.

jennyp
Aug 20, 2012, 02:23 AM
In Calendar preferences under the Alerts tab, make sure those options are set to "none".

I had the same "problem" as you, and doing this stopped the alerts from being added.

I've set all those options to "none", under all types of calendar, so it's not "problem" in inverted commas, it's a problem, and a damned annoying one, too.

Also, the alert/alarm that occurs is "on day of event, at 00:00" which isn't even an option in the drop-down menus in that setting.

macbook yes
Aug 26, 2012, 11:52 PM
I have time same issue, but it sets alerts at time of event. Every hour of the freaking day I have an alarm going off. I have checked my settings on my iphone, ipad, and macbook and none are set to set alerts. I'm pretty annoyed and this has made iCal, which I have been using for almost 4 years, unusable. Please tell me someone has found a fix.

kronborg
Aug 27, 2012, 03:46 AM
I have time same issue, but it sets alerts at time of event. Every hour of the freaking day I have an alarm going off. I have checked my settings on my iphone, ipad, and macbook and none are set to set alerts. I'm pretty annoyed and this has made iCal, which I have been using for almost 4 years, unusable. Please tell me someone has found a fix.

I haven't found a fix. And OS X 10.8.1 didn't include one. The files that store the default alert settings for Calendar (~/Library/Calendars/*.caldav/ServerDefaultAlarms and/or LocalDefaultAlarms) look correct. I have found some additional users experiencing the bug:

https://discussions.apple.com/thread/4160870
https://discussions.apple.com/thread/4178761
https://discussions.apple.com/thread/4193511

Let Apple know by submitting a bug report, if you haven't already.

Apple who?
Aug 29, 2012, 09:35 PM
Also having the problem with alerts being set automatically for any appointment set in calendar on my MacBook. And then feeding alerts to all devices. Sounds like a clock factory when I forget to turn them off. Count me among those who will upgrade my devices to Microsoft going forward. I have more bugs in my apple devices then I ever did in pc land

dcorban
Aug 31, 2012, 04:59 PM
Have you checked the setting both on your iPhones and Macs? I don't have an iPad, but I assume it is there also.

jennyp
Sep 1, 2012, 03:34 AM
Have you checked the setting both on your iPhones and Macs? I don't have an iPad, but I assume it is there also.

Yes, I have checked the "settings".

I also tried turning it off and then turning it back on again.

Critterbug
Sep 17, 2012, 09:04 PM
I am so tired of going through 30-50 calendar events every time I change anything in ML, it makes an alert in IOS.(I have hundreds of repeating events! :mad:
This is driving me crazy, and I'm having trouble finding fixes on the apple support pages as well.
Has anyone come up with a solution?

Mal
Sep 17, 2012, 09:43 PM
Have any of you checked your settings on iCloud.com yet? Go to the Calendar app there, click the gear and choose Preferences, and scroll down. Look for this setting:

https://dl.dropbox.com/u/12428034/Screen%20Shot%202012-09-17%20at%2010.41.13%20PM.PNG

That's the most likely culprit. I had the same issue with a Google Calendar at one point.

jW

kronborg
Sep 18, 2012, 02:08 AM
Has anyone come up with a solution?

No! It has become amazingly annoying that I have to grab my iPhone or iPad whenever I'm sitting in from of the computer, and want to add or edit an event. The bug even affects Fantastical (since it depends on Calendar in some way, I think). I asked the developers about it, and they confirmed the bug, but didn't know of any workaround!

Have any of you checked your settings on iCloud.com yet?

Thanks for the input, but yes, I've double-checked that setting from day one.

Critterbug
Sep 18, 2012, 11:50 PM
Have any of you checked your settings on iCloud.com yet? Go to the Calendar app there, click the gear and choose Preferences, and scroll down. Look for this setting:

Image (https://dl.dropbox.com/u/12428034/Screen%20Shot%202012-09-17%20at%2010.41.13%20PM.PNG)

That's the most likely culprit. I had the same issue with a Google Calendar at one point.

jW

I wish it were that easy! But that was the best idea I've tried yet. :)

jennyp
Sep 19, 2012, 03:37 AM
Have any of you checked your settings on iCloud.com yet? Go to the Calendar app there, click the gear and choose Preferences, and scroll down. Look for this setting:

Image (https://dl.dropbox.com/u/12428034/Screen%20Shot%202012-09-17%20at%2010.41.13%20PM.PNG)

That's the most likely culprit. I had the same issue with a Google Calendar at one point.

jW


That's one of the first settings I checked, and it doesn't make any difference. Also it's notable that my spurious alarm goes off "on the day of the event at 00:00" - which isn't even an option in those settings.

It's maddening having to delete these alarms every evening, or alternatively, only create events on my iPhone.

It's an Apple bug, unacknowledged, and damned annoying.

dcorban
Sep 19, 2012, 06:40 AM
Try enabling that option, but set it for a different time. See if it then sets that alert as well as the "00:00" alert for new items.

kronborg
Sep 19, 2012, 10:18 AM
Try enabling that option, but set it for a different time. See if it then sets that alert as well as the "00:00" alert for new items.

When setting the iCloud.com alert setting to "1 hour before", events created via iCloud.com get that single alert attached (showing on all devices). Events created in Calendar on the Mac still only get the midnight alert set.

Thing is, when creating an event in Calendar on the Mac, no alerts are visible there. iCloud.com also shows no alerts for such events. It's only on the iPhone and iPad the rogue alerts are showing.

dcorban
Sep 19, 2012, 11:40 AM
There are individual settings on the iPhone and iPad themselves as well. Have you confirmed the settings there?

kronborg
Sep 20, 2012, 07:52 AM
Good news, everyone!

After updating my iPad to iOS 6, the alarms don't show up anymore! So it must have been a problem with iOS 5 somehow.

Yesterday I was on the phone with an Apple technician, but he and his colleagues had not heard about the problem, and didn't know how to solve it. We tried creating a new user on the Mac (and then create an event in Calendar), and tried to restore the iPhone as new (and then load events created on the Mac). Nothing worked.

The other problem, where a timed event is edited into a full-day event, and afterwards shows up on the iPhone/iPad as a two-day event, still persists in iOS 6, however. But that's much less annoying than the damn alarms. I'm still in contact with the technician, and will try to solve that some way.

There are individual settings on the iPhone and iPad themselves as well. Have you confirmed the settings there?

Naturally :)

jennyp
Sep 20, 2012, 12:48 PM
Yep - after the recent iOS 6 and Mountain Lion updates the bug has disappeared for me. Hooray!

jennyp
Sep 20, 2012, 06:13 PM
I spoke too soon. I'm still getting unwanted alerts on the iPhone after creating events on the iMac.

kronborg
Oct 5, 2012, 10:11 AM
I spoke too soon. I'm still getting unwanted alerts on the iPhone after creating events on the iMac.

That's too bad. Still no luck? The unwanted alerts are gone on iOS 6 on both my iPhone and iPad.

Do your (unwanted) alerts actually go off? I discovered that mine did not.

jennyp
Oct 5, 2012, 10:17 AM
They've just stopped occurring - I think there must have been some residual stuff going on, but it's OK now. Case closed I hope! :)

kronborg
Oct 5, 2012, 10:19 AM
Great! Let's hope they're never coming back.

chikidee
Dec 23, 2012, 12:31 AM
My all day events are still creating alerts at around midnight (actually 12:50am), even though my iPhone and iPad are updated to OS version 6.0.1. I have my all-day alert default, on all devices, set to "off."

Critterbug
Dec 23, 2012, 11:47 PM
My all day events are still creating alerts at around midnight (actually 12:50am), even though my iPhone and iPad are updated to OS version 6.0.1. I have my all-day alert default, on all devices, set to "off."

I got just one the other day. I'm hoping it was an orphan.

jgagne
Feb 9, 2014, 05:54 PM
I had the exact same problem (had 3 default alarms set to popup-10 minutes, mail-10 minutes and mail-1 day), which was extremely annoying, and all my calendar options on Mac, iPhone and iPad were off. Here's what worked for me :

Have any of you checked your settings on iCloud.com yet? Go to the Calendar app there, click the gear and choose Preferences, and scroll down. Look for this setting:

Image (https://dl.dropbox.com/u/12428034/Screen%20Shot%202012-09-17%20at%2010.41.13%20PM.PNG)

That's the most likely culprit. I had the same issue with a Google Calendar at one point.

jW

When I went on iCloud.com in the preferences, this option was set to "None". However, I have turned it on, saved preferences, opened preferences again, put it back to "None" and then saved again, and it fixed my problem !

Thanks again Mal.