PDA

View Full Version : Safari 6 search bar, 2-3 second lag?




baryon
Aug 4, 2012, 01:41 PM
Whenever I type something into the new Safari search/URL bar that is NOT a URL but a search term, and I press Enter, nothing happens for about 2-3 seconds: nothing loads, nothing changes. Only then will Google show up and start loading with the search results.

When searching directly from Google.com, there is no such lag, so the issue is not related to my connection being slow. Also, there was never a lag like this with the older, separate Safari search bars.

Is it just my system or is this a real bug?



ugp
Aug 5, 2012, 02:48 PM
I have this issue with everything anymore with Safari. Even opening Safari to the home page which is set to Google.com it pauses for a few seconds and then finally loads. Using Chrome I do not have this issue and my wife doesn't have this issue with Lion under the previous Safari version.

Krazy Bill
Aug 5, 2012, 02:56 PM
This happens with me as well. I believe this is tied into Apple's insistence that things need to be slowed down so we notice how pretty things are when new windows/tabs are created and so we'll enjoy the animations.

Personally, I just wish they'd all go away.

baryon
Aug 6, 2012, 10:35 AM
Glad I'm not the only one!

I doubt this is intentional, since we're all used to fast computers and responsive interfaces, and while Apple does tend to slow animations down, they always do that to show what's happening. With the Safari 6 search bar, nothing seems to happen at all for 3 seconds, so I don't see how that's helpful.

I find myself pressing Cmd+Shift+H all the time to go Home to Google, and then searching from there… But then you could do that 10 years ago too, and I'd think technology advanced since then…

How come Chrome got this right the first time, many years ago??

btbrossard
Aug 6, 2012, 10:53 AM
Is it just my system or is this a real bug?
I just tested this on my iMac and didn't notice any lag between hitting enter and the search page loading.

baryon
Aug 7, 2012, 09:02 AM
I just tested this on my iMac and didn't notice any lag between hitting enter and the search page loading.

Thanks for checking! So that means it's not an intentional feature, but rather a bug. Also, it seems to happen but not often enough for lots of people to complain.

ugp
Aug 7, 2012, 04:39 PM
I made a setting change in Safari that has seemed to help my loading lag time.