PDA

View Full Version : Integrated address/search field doesn't find internal websites




iVoid
Aug 4, 2012, 06:51 PM
It seems that Safari 6's integrated address/search field can't handle internal websites.

Such as:

owa
myhost
thathost

It does a Google search on these items, but IMHO the proper behavior would be to try and resolve in DNS first, then if that fails try to do a google search.

Anyone else notice this?

It basically will break access to most internal websites for companies that people are used to just typing the host name to resolve. The search domain seems to be set correct by DHCP, so this is either a bug or or Apple deciding that searching for the entry is better than trying dns first.



ilium007
Aug 8, 2012, 11:44 PM
Experiencing exact same here trying to access an internal site. Safari is doing a Google lookup rather than query internal DNS. A dig at the terminal shows resolution is working fine.

Comeagain?
Aug 8, 2012, 11:55 PM
Create a bookmark. Then you can type the bookmark name.

phyrexia
Aug 9, 2012, 02:26 AM
I noticed this; it seems like you have to add '.local' to the end of local hostnames now.

iVoid
Aug 28, 2012, 05:25 PM
When you have hundreds of local servers, it's not really practical to bookmark them all.

The .local trick does work, but I might as well type our domain address then.

I've found that (sometimes) putting a slash / after the host name works to resolve internally, but oddly not every time.

It also puts up a list of what you can do with the typed name, so you can select "go to site xxxx" to goto the local host.

Going to take some retraining of our users.