PDA

View Full Version : Recurrent wifi PB since Lion not fixed




Romf
Aug 6, 2012, 12:48 PM
I know lots of people will come here and tell me that "everything works fine for them", but I bought my Macbookair late 2010 with SL and had NO wifi problems.
With Lion it started that when opening the mba (was in sleep then), with wifi on it didnt reconnect automatically to the previous wifi network (which was still active).
Some tips (remove all wifi networks from keychain and etc) and updates (there was a Lion update about this) helped, but the problem came back from time to time.

I upgraded to SL and love it since then. I can tell I find my MBA being efficient much quicker when waking up from sleep. BUT the silly wifi problem is back. When I open the MBA, wifi is "searching" then stays on without connecting, and I have to click on icon, choose the network to reconnect (dont even have to re enter password).

Can't believe this bug appeared in Lion and is still there. So yes, there are some fixes on the internet, and I'll try them, but really after pages of users having this kind of problem under Lion, do we still have to make some tricks and manual fixes to what should work out of the box (and worked under SL)? Too bad cos its the only problem I have until now...



astrorider
Aug 6, 2012, 12:56 PM
Does this happen every time you wake from sleep?
If so, do you have "Remember networks this computer has joined" checked in the Network System Preferences?
And, is the network you want to auto-join at the top of your preferred networks (this shouldn't be necessary but was more a stab in the dark)?

Romf
Aug 6, 2012, 12:59 PM
Does this happen every time you wake from sleep?
If so, do you have "Remember networks this computer has joined" checked in the Network System Preferences?
And, is the network you want to auto-join at the top of your preferred networks (this shouldn't be necessary but was more a stab in the dark)?

No, it doesnt happen all the time. In fact, in the beginning it wasnt happening but it started again...
I didnt try yet what we can find on some websites, and maybe it will work. But this problem is known since Lion (and acknowledged, as there was an updated about it) but still some have this... Am just a little disapointed :)

astrorider
Aug 6, 2012, 01:10 PM
Unfortunately, given the length of time you've had this problem and over multiple operating systems and updates, I'm guessing Apple believes there is no problem, or the problem isn't on their end (i.e. it's a router problem or something else outside their control).

So, fixing it is probably going to fall on your shoulders to troubleshoot the problem. Have you tried changing channels on your router? Maybe there's some interference on the channel you're on that causes your Macbook to have difficulty hooking up when it first awakes.

I know you didn't want to hear it, but I'm also running a 2010 Macbook Air (have had both Snow Leopard and Lion) and I might remember a problem like what you're describing a long time ago, but I think it was addressed by a software update at some point, and I haven't had that problem in a long time. I'm saying this only to give you hope that there's some configuration of your machine and router that should result in successful connections waking from sleep.