PDA

View Full Version : Mountain Lion changed my admin account




smokeyrabbit
Aug 7, 2012, 11:30 AM
MacBook late 2009, 8 GB RAM, 240 GB SSD, was running Lion just fine. This is an App Store purchase. During the Mountain Lion install it went to sleep and upon waking said it couldn't be installed on this computer. The only option it gave me when choosing a startup disk was OS X 10.8 Server (!) so I selected that and now I'm stuck on Cupertino time (I live in CT) and my admin password no longer works. In fact it downgraded my user account to a Standard account. I have never had any other users on this machine.

How can I restore my account to an admin account?

PS this is my 1st attempt to upgrade to Mountain Lion on this machine. All attempts to upgrade my iMac i7 from 2010 failed. I've tried downloading the ML installer 6 times with the same result. It reports that OS X 10.8 can't be installed on this computer after the install screen.



Blipp
Aug 7, 2012, 12:22 PM
Wipe and reload to your desired OS. Why is your iMac install failing? Are you using a legit copy of ML? If it's legit from the App Store I'd delete the installer and try downloading a new one for starters.

Also don't let your Mac go to sleep during the install...

smokeyrabbit
Aug 7, 2012, 02:24 PM
Fixed it by enabling root user and changing my account back to Admin in System Prefs>Users & Groups.

ML seems faster than Lion so far.