PDA

View Full Version : Random red tints on some images in mountain lion.




timotay89
Aug 8, 2012, 04:27 PM
First, this is NOT a repost of me previously posting about this problem. I originally said the problem was in Safari and I posted in the appropriate forum about it, but this problem is more than Safari, it's throughout the operating system.

I'm running Mountain Lion on an early 2008 15 inch MBP. Various parts have been replaced over the years (screen bezel, top cover, cover around trackpad/keyboard, battery, RAM upgraded) but I doubt this has to do with my problem.

(All images are below)

My computer gives images a red (or pinkish) tint sometimes. With Safari, it's whenever I zoom in on a webpage (either pinching or double tapping).

Then I noticed that it also happens when I used quicklook to look at a .rar file. Attached is the problem with an automator thing I made. There's no problem with folders though.

Now it happened again, this time for en ENTIRE keynote presentation. The tint didn't appear when I created or modified the presentation, only when I went to view it on my computer.

When I get home, I'll connect my computer to my TV and see if it has the tint on another display, but until then, has anyone else had this problem? It's got to be something with the operating system (as it didn't happen with Leopard, Snow Leopard, or Lion).

Also, I installed Mountain Lion directly from the Mac App Store, no clean installation or whatever.

I'm currently verifying (and then repairing) any disk permissions. I'll update here if the problem persists.

Any help would be greatly appreciated.

EDIT:

Repairing permissions did nothing to fix the problem.



DeGarmo
Aug 11, 2012, 05:52 PM
i have the same problem.

timotay89
Aug 16, 2012, 09:37 PM
I ended up calling apple support. They said to reinstall mountain lion... That's the plan for tomorrow.

Finally someone else with the problem though.

iccir
Aug 17, 2012, 06:10 AM
I ended up calling apple support. They said to reinstall mountain lion... That's the plan for tomorrow.

Finally someone else with the problem though.

That looks like "colorize 1x artwork" from Quartz Debug, do you have developer tools installed?

timotay89
Sep 1, 2012, 05:59 PM
That looks like "colorize 1x artwork" from Quartz Debug, do you have developer tools installed?

I don't think I do, but I ended up installing and reinstalling mountain lion. It fixed the problem.

I'm happy I did it though, I've never started fresh and since I realized I didn't need to pull everything back from Time Machine, I ended up with 40-50GB of space that I didn't have before.

mbultraslan
Sep 9, 2012, 03:55 PM
This issue cause of selected 'highlight non-retina images' option. To fix it install mountain tweaks app (http://tweaksapp.com/app/mountain-tweaks/) go to mountain lion tweaks tab click no button 'highlight non-retina images' option then restart safari.. that is it....

OS X Factor
Sep 29, 2012, 09:22 AM
I have the same problem here. Although I first noticed it in Safari, I see the issue is in other programs like Lightroom and Preview. Seems to happen mostly on PNGs.

I'm going to try reinstalling the OS to see if that helps.

take2hikes
Oct 12, 2012, 11:09 AM
I had this same issue, and did not connect it to the use of the Mountain Lion Tweaks application. I had enabled the highlighting as I thought it would be a neat feature, but didn't know what to expect.

After Googling this new red tinge around most of the images on my computer (even my background - which I didn't realize) I found this forum.

Thanks to mbultraslan for leading me to the right solution!


This issue cause of selected 'highlight non-retina images' option. To fix it install mountain tweaks app (http://tweaksapp.com/app/mountain-tweaks/) go to mountain lion tweaks tab click no button 'highlight non-retina images' option then restart safari.. that is it....