PDA

View Full Version : Issue when swiping Forward and Back in Safari




J.C
Aug 10, 2012, 04:15 AM
Since upgrading to ML and Safari 6 I've been experiencing this annoying problem. In Safari rather than clicking the Forward and Back buttons I exclusively use the two finger swipe gesture on my MacBook Air trackpad. Along with the page navigation, Safari also does that cool animation where one page is swiped away revealing the next/previous page beneath it.

But in ML after that happens, the original page flashes back an screen quickly, before finally again displaying the other page.

Is anyone else experiencing this? Is there a fix? It doesn't seem to happen with the buttons just the trackpad gesture.



sshhoott
Aug 10, 2012, 02:54 PM
Since upgrading to ML and Safari 6 I've been experiencing this annoying problem. In Safari rather than clicking the Forward and Back buttons I exclusively use the two finger swipe gesture on my MacBook Air trackpad. Along with the page navigation, Safari also does that cool animation where one page is swiped away revealing the next/previous page beneath it.

But in ML after that happens, the original page flashes back an screen quickly, before finally again displaying the other page.

Is anyone else experiencing this? Is there a fix? It doesn't seem to happen with the buttons just the trackpad gesture.

Try to reset Safari (Safari > Reset Safari). And then also repair permissions.

J.C
Aug 10, 2012, 04:53 PM
Done. It worked! Fingers crossed it stays this way. Thanks heaps for the suggestion!!!