PDA

View Full Version : A minor annoying Apple tv mirroring issue. Anybody?




L1mera1n
Aug 12, 2012, 05:01 AM
Lets start with this. I have an early macbook pro 2011 and the newest apple tv. I am able to mirror my macbook through my apple tv, but here is the issue.

My apple tv hibernate when not in use it (this is normal of course).
But when I wake it up from sleep mode, then suddenly Im not able to airplay anymore. The airplay icon is gone on my macbook pro. The icon only returns if i do the following.

I have to restart my apple tv and then, on my macbook pro I have to log off my wifi network, wait a few seconds, log back on, and then the airplay icon pops up ready to use.

This I have to do every time. Its frustrating. Anybody heard of this?

This is so unapplelike! But maybe its just me having this issue. Except for this Im a happy camper. But the airplay feature was the main reason I upgraded to ML.



Ksh
Aug 12, 2012, 05:18 AM
Uhm didn't manage to reproduce the issue, checked now with mba 2012 and atv3, but since you have to renew de wifi session, ┐could not be related with your router settings?.

Just remind me a similar issue I had when multiple devices were connected to wifi network and some of them just woke up from sleep.Finally discovered there was an ip conflict (sleeping device always tried to to assign an existing ip when waking up) so solved using static ip's instead of dynamics :) Just give it a try,hope this helps.

Regards

L1mera1n
Aug 13, 2012, 10:29 AM
My biggest fear! Im no computer wiz but I tried to use static and force my mac and atv on the same ip, but no success. Its probably some router settings as you said. I always use standard settings when hooking up my router (d-link) I believe. Probably wouldn't be a problem if I had the Apple router. Hehe

Thanks for the reply

lostless
Aug 13, 2012, 12:25 PM
My biggest fear! Im no computer wiz but I tried to use static and force my mac and atv on the same ip, but no success. Its probably some router settings as you said. I always use standard settings when hooking up my router (d-link) I believe. Probably wouldn't be a problem if I had the Apple router. Hehe

Thanks for the reply

You can't have 2 devices with the same ip address in a network. That will definitely make both devices not work.

L1mera1n
Aug 13, 2012, 02:30 PM
Proves my stupidity. Haha. I have no clue what Im doing. Hoped it would work. Just dont know what Im doing wrong. The macbook and apple tv is on the same wifi and there's no airplay icon. Returns only if I do the above written "fix". Frustrating! Both devices are on dynamic ip by the way.

Ksh
Aug 13, 2012, 04:18 PM
Uhm I'm afraid you tried in the opposite way hehe

Anyway before going further with network settings have a look to official Airplay troubleshooting (http://support.apple.com/kb/TS4215)

Regards.

lj1722
Jun 6, 2013, 04:54 PM
I have the same problem. I should say had. I believe I have solved it as well. I have a dual band router so it broadcasts 2 networks, one in 2.4 gHz and the second in 5 gHz. I gave them the same name for simplicity sake. Then devices will connect to whichever one they can and there is no guessing. While most of my devices are on the 5 gHz there are a few on the 2.4 gHz network as well. When the ATV3 would connect initially it would connect to the 5 gHz network. If something didn't connect to it than it would drop down to the 2.4 gHz apparently. As they are separate networks then my MBP couldn't see it. The solution is to rename the networks separately. Hope this helps.

Also, if you know how to enable port forwarding, that will speed up your ATV alot! For me the mirroring is almost instant once I set up port forwarding.