PDA

View Full Version : [Resolved] iMessage Does Not Work




modit
Aug 12, 2012, 06:27 PM
I've tried to send an iMessage from my iMac running Mountain Lion to my iPhone and it's not working for me. I haven't received a single text on my iPhone from a Mac.

The iMac's messaging app shows me offline despite having my iPhone associated with an iCloud. Both sides use @me.com address.

Any ideas?

Thanks!



Icy1007
Aug 12, 2012, 08:12 PM
Make sure both devices are set up using the same accounts.

[Messages] -> [Preferences]

Make sure you have all the addresses that you wish to receive from in this list. (Red Arrow).

*I've whitened out my details*

On your iPhone/iPad the same settings are under [Settings] -> [Messages] -> [Receive At]

ihav0frnds
Aug 12, 2012, 08:25 PM
so people who imessage my phone number, it won't send to my comp?

it seems like i have to start the convo from my mac to keep it going between both phone and mac...

MacDawg
Aug 12, 2012, 08:32 PM
so people who imessage my phone number, it won't send to my comp?

it seems like i have to start the convo from my mac to keep it going between both phone and mac...

Until iOS 6 yes
It has to be sent to your Apple ID not your phone #

ihav0frnds
Aug 12, 2012, 08:41 PM
ah ok...a bit disappointed by mountain lion thus far then.

i feel like battery is noticeably less.

Icy1007
Aug 12, 2012, 08:52 PM
I've just told people who have iPhones/iPads to stop sending messages to my phone number. I give them my iCloud ID and tell them to use that. It works just as I expect.

Though, it will be nice when iOS 6 is out so I can integrate my phone number as well.

modit
Aug 13, 2012, 05:54 PM
Make sure both devices are set up using the same accounts.

[Messages] -> [Preferences]

Make sure you have all the addresses that you wish to receive from in this list. (Red Arrow).

*I've whitened out my details*

On your iPhone/iPad the same settings are under [Settings] -> [Messages] -> [Receive At]

Well I've tried what you said and it's not working (not receiving messages on my iPhone).

Any other suggestions :(

Icy1007
Aug 13, 2012, 07:05 PM
Well I've tried what you said and it's not working (not receiving messages on my iPhone).

Any other suggestions :(

You need to make sure the address your sending to is setup on your iPhone's messages settings. It will work if you set that up.

ie. setup iPhone to receive at xyz@gmail.com. Send an iMessage to xyz@gmail.com.

Your iPhone will get the message.

If not, then you haven't set it up correctly.

lpeedin
Aug 13, 2012, 07:14 PM
Not sure but I don't think you can send an iMessage to yourself.

Icy1007
Aug 13, 2012, 07:19 PM
Sure you can.

I have my mac and iPhone set up to receive at the same 4 addresses. If I send to any of them, both my mac and iPhone receive it.

It actually gets posted twice on my devices. Once as the sender and once as the receiver.

modit
Aug 13, 2012, 07:34 PM
You need to make sure the address your sending to is setup on your iPhone's messages settings. It will work if you set that up.

ie. setup iPhone to receive at xyz@gmail.com. Send an iMessage to xyz@gmail.com.

Your iPhone will get the message.

If not, then you haven't set it up correctly.

I think I have. I have receive at 2 Addresses on my iPhone: My phone number and my @me.com address.

On my Mac, my preferences state that I can be reached at my @me.com

I'm running 5.1.1 on my iPhone.

Any other ideas?

I'm willing to work this out :(

Icy1007
Aug 13, 2012, 07:43 PM
I think I have. I have receive at 2 Addresses on my iPhone: My phone number and my @me.com address.

On my Mac, my preferences state that I can be reached at my @me.com

I'm running 5.1.1 on my iPhone.

Any other ideas?

I'm willing to work this out :(

Well if you only want to send your phone a message you can send it to your phone number from your Mac.

Try adding another email address to both your Mac messages and your iPhone.

Or send a message to your @me.com address from your phone. Your Mac should get it if it's setup properly.

modit
Aug 13, 2012, 08:17 PM
Well if you only want to send your phone a message you can send it to your phone number from your Mac.

Try adding another email address to both your Mac messages and your iPhone.

Or send a message to your @me.com address from your phone. Your Mac should get it if it's setup properly.

Forgive me but I just found out my problem :o:o:o

The account I was trying to send messages from my iMac (a family member's @me.com account) was NOT enabled. I simply turned it on and sent a text to my iPhone and it now works.

Thanks Icy1007 and everyone else helping me troubleshoot this issue.

Greatly appreciated!

Icy1007
Aug 13, 2012, 08:22 PM
Forgive me but I just found out my problem :o:o:o

The account I was trying to send messages from my iMac (a family member's @me.com account) was NOT enabled. I simply turned it on and sent a text to my iPhone and it now works.

Thanks Icy1007 and everyone else helping me troubleshoot this issue.

Greatly appreciated!

Yep yep. No problem.