PDA

View Full Version : Jitter / frame skips playing HD iTunes TV on ATV3 & Panasonic LED TV




PolarBare
Aug 13, 2012, 08:15 PM
I am seeing visual jitter in the playback of HD iTunes TV content via ATV3. By "jitter", I mean that it looks like there are frame skips and/or discontinuities in the motion.

I am quite certain it is not a buffering problem. I have a fast network, it is connected by ethernet (not WiFi), there is plenty of buffered video, and there is never a glitch in the digital audio.

TV is the latest, top of the line Panasonic LED, with 24P cinema playback capability.

Specs:
Game of Thrones HD downloaded from iTunes to PC
Apple TV3 Connected to PC via ethernet set to 1080P 60 Hz output
Panasonic TC-L55WT50 55" Full HD 3D Smart Viera LED TV

Seeking advice as to what is causing the jitter / jerky playback / appearance of frame skips and what, if anything can be done to resolve this issue.



MacinJosh
Aug 13, 2012, 08:44 PM
Does this happen with *all* HD content or just GoT? AFAIK ATV3 doesn't support 24P so the problem might be relating to it. The 1080P 60Hz and 50Hz is an indication of that. What *possibly* is happening is that your ATV performs a pulldown and sends the picture to the TV at 30fps (60Hz) and the TV tries playing back at 24P resulting in the problems you're seeing. Try setting the TV manually to a different, matching mode if possible. Or put ATV in auto output and TV auto input if possible and see if it makes a difference.

EDIT: I'd like to add, that any pulldown will cause some kind of jittering especially in panning shots. Apple TV will do that period. No way around it regardless of your telly. Well, ok, playing PAL source (25fps) and outputting at 50Hz to a TV set for 50Hz will result in super smooth picture. Problem is, most material, especially film is 24P or 23.9 whatever. So there's nothing you can do about that kind of jitter. But you make it sound like it's more than that though which would be caused by a misconfiguration of some type as I mention above..

I am seeing visual jitter in the playback of HD iTunes TV content via ATV3. By "jitter", I mean that it looks like there are frame skips and/or discontinuities in the motion.

I am quite certain it is not a buffering problem. I have a fast network, it is connected by ethernet (not WiFi), there is plenty of buffered video, and there is never a glitch in the digital audio.

TV is the latest, top of the line Panasonic LED, with 24P cinema playback capability.

Specs:
Game of Thrones HD downloaded from iTunes to PC
Apple TV3 Connected to PC via ethernet set to 1080P 60 Hz output
Panasonic TC-L55WT50 55" Full HD 3D Smart Viera LED TV

Seeking advice as to what is causing the jitter / jerky playback / appearance of frame skips and what, if anything can be done to resolve this issue.

betman
Apr 15, 2014, 02:42 PM
I'm currently experiencing some weird jitter when using Apple TV, regardless of whether I'm playing the tv show in question from the cloud or streaming from my own library. I am also using a Panasonic LED TV.

What's strange is that the jitter only happens on 1080p 60Hz, which is what Apple TV defaults to in my case when set to Auto. But when I switch to 1080p 50Hz all the jitter goes away and the picture is smooth. Any ideas why this is so?

sandmanfvr
Apr 15, 2014, 03:02 PM
http://forums.macrumors.com/showthread.php?t=1718030

I think this is like that above, 6.1 caused this. I just got my apple tv and it has 6.1 and so far no issue like this, knock on wood. I may be just random bug, I hope it is fixed as I want a stable firmware to lock my apple tv into as I do home sharing and as long as it works, that is all I want.