PDA

View Full Version : G4 Cube's speakers don't work, but usb isn't broken.




daizhuo
Aug 21, 2012, 05:40 AM
hi,guys. i am confuse that G4 Cube speakers would need so much power? i plug it to usb port, sometimes it works, but sometimes didn't work, and when it didn't wokr it would cause usb no power to output, mouse and keyboard wouldn't work. my G4 Cube, 1.8g cpu, 1.5g ram, 120g hd. without the speakers, mouse and keyboard would work again. should i replace my logic board? or any else way to solve it ? i had tried reset pram and pmu.



havokalien
Aug 21, 2012, 10:35 AM
The vrm that supplies power to your system sounds like its going bad, either that or the cube power supply is on the way out. Both are known failure points. The power supply is only just over 200 watts I believe and the VRM if it's stock was not able to run the new chips, if it has an updated VRM for the 1.8 processor It still may be faulty. The parts are still a decade old.

Good luck

daizhuo
Aug 21, 2012, 11:50 AM
The vrm that supplies power to your system sounds like its going bad, either that or the cube power supply is on the way out. Both are known failure points. The power supply is only just over 200 watts I believe and the VRM if it's stock was not able to run the new chips, if it has an updated VRM for the 1.8 processor It still may be faulty. The parts are still a decade old.

Good luck

Thank you for your replying!
It means that I have to replace the vrm and the power supply for speakers works well? or I just need to replace vrm? Cube power supply isn't easy to go bad or not?

Intell
Aug 21, 2012, 04:22 PM
The Cube's power supply is likely not the cause. Even a dual 1.8Ghz Cube doesn't use more than 70 watts. Don't forget, the Cube's power supply is able to power the massive 23" ADC screen that takes 70 watts of its own.

The Cube speakers need 10 watts to work at full volume. The Cube is the only PPC Mac that has these ports and most Macs made in 2007 and later have them as well. Also Apple's screens with a USB hub in them are able to power them at full volume no matter what computer they are used with. Inside the Cube, both USB ports share a 20 watt source so that two Cube speakers can be plugged in at the same time.

Have you tried switching the two devices? Maybe one port is going bad. Some Cubes develop a bad USB port over time. Do you have another Mac you can test the speakers on?

havokalien
Aug 21, 2012, 05:33 PM
Vrm are totally susceptible to failure. Power supplies dying also is a known issue. The ADC standby when plugged in allowed the non fan cooled power supply and VRM ( aftermarket ) or otherwise to burn up. The proof is on eBay, power supplies and vrms for sale. Just one of those things. When I got mine bothe the power supply, VRM and adc video card were fried from being plugged in and not used ( owner told me he only used it lightly and one day it did not turn on ). After using another cube all three parts were dead. Through looking on the Internet and asking others I came same conclusion as they did. When not in use I unplug mine. I have a stock VRM, 7500 adc video ( bracket modified to fit ) and new power supply ( old stock ). Also I would check as I know the 17 and 15 inch monitors could power the USB speakers I think the 23 did not as the original video card could not drive it so they did not include the higher power ports on it. I'll check on my cube tonight and see.

Good luck.

jbarley
Aug 21, 2012, 06:04 PM
Do you have another Mac you can test the speakers on?
The cube speakers, (originals) will only work with the cube.
It appears the standard usb ports on most computers do not have enough power to drive them, except in a few cases at barely audible levels.

Intell
Aug 21, 2012, 06:38 PM
The cube speakers, (originals) will only work with the cube.
It appears the standard usb ports on most computers do not have enough power to drive them, except in a few cases at barely audible levels.

They work on any Mac running OS 9.0.2 with USB ports. But for full volume a high power USB port like those found on most Macs made after 2007 and on Studio/Cinema Displays work. Even a standard Dell box with Mac OS X on it will drive them. The only part of them that is unique to the Cube is the startup chime.

jbarley
Aug 21, 2012, 07:08 PM
In my previous message I was repeating what I had read while as a Cube owner I was cruising the CubeOwner Portal (http://www.cubeowner.com/forums/index.php?act=home)
Your post Inell, got me curious enough to drag out my cube speakers and run some tests.
The will work on my G5 quad at reduced volume, for whatever reason they will not work at all on my 2009 mac mini.
That's my story, and I'm sticking to it...

Intell
Aug 21, 2012, 08:25 PM
In Mac OS 10.6.3 through 10.6.8 Apple removed the needed driver from the kext. They can be put back in with the correct replacement kext. They also work without problem in Lion and Mountain Lion. I use mine on my Blackbook all the time. Work very well.

jbarley
Aug 21, 2012, 08:34 PM
Good to know, I just love these forums, always something new to learn.

daizhuo
Aug 22, 2012, 11:35 AM
In Mac OS 10.6.3 through 10.6.8 Apple removed the needed driver from the kext. They can be put back in with the correct replacement kext. They also work without problem in Lion and Mountain Lion. I use mine on my Blackbook all the time. Work very well.

My MacBook 2008 late version with moutain lion installed can't drive the g4 cube speakers. No enough power to supply them. It seems that I have to replace the mother board and VRM? I think my power supply is ok.

Nameci
Aug 22, 2012, 12:24 PM
You need a kext from SL in order for it to work

jbarley
Aug 22, 2012, 01:49 PM
You need a kext from SL in order for it to work
No sound with these speakers on my mini running 10.6.8.
According to Intell's post the files needed might be found in 10.6.0 -> 10.6.2

Nameci
Aug 22, 2012, 04:55 PM
No sound with these speakers on my mini running 10.6.8.
According to Intell's post the files needed might be found in 10.6.0 -> 10.6.2

Yes, there are some discussions about on the apple support forums. You might want to check that out.

Intell
Aug 22, 2012, 05:46 PM
One of the late 2008 Macbook's USB port is a high power one and the other is a standard 500mAh one. The Cube speakers work on Lion, it would seem that Apple removed support for them from 10.8.

daizhuo
Aug 27, 2012, 07:14 PM
I have tried to replace VRM with more powerfull and even logic board,but usb still can't drive the original speaker. Pluging it to the cube and the usb would lost power again and again. I can't find what happen to my G4 cube. Anyone have a suggestion?

Intell
Aug 27, 2012, 07:17 PM
Which VRM board did you put into it? The problem may be with the speakers.

daizhuo
Aug 28, 2012, 12:40 PM
Which VRM board did you put into it? The problem may be with the speakers.

Thank you!
I put Giga C-VRM into my cube with sonnect 1.8G cpu, speaker still can't work,speaker works fine in other original g4 cube.
And I found that ATI 16M video card cant't work with GIGA C-VRM.
My cube with two fan wired with DVD drive power port. But I test this and found it wouldn't affect the VRM.
I never test the CPU,but I don't think a broken CPU would use so many power. And I right?