PDA

View Full Version : MBA Repair question




8percent
Sep 6, 2012, 05:10 PM
My keyboard is still not inputting correct characters, but at least it has started charging now and holding on to that charge which is an improvement from before.

I did an SMC reset and started on the PRAM reset only I don't know what to do after the 'choose english' option :)

i cant login because when i try typing the keys, my keyboard is typing in a bogus script. i know this because i failed the password 3x, got to the hint menu, and can now see what it is typing. it's typing non-typical characters.


It is probably water damaged. I would like to fix it ((everything seems operational except i'm trying to get the keyboard to input correctly)). i did see a little light physical corrosion around the parts to the right under the trackpad, and up by the battery connector (+/-). nothing else notable.

i'm not complete newbie, taken a macbook (old from 07) apart before to replace a keyboard, but that's about it. i still qualify as a diy newbie. :)

thank you for reading, hope to get some ideas about the input! (and if anyone suggests brushing clean the corrosion, can I do that if i just take d/c the battery? thank you.)

P.S. Here is an update: I was able to reset the PRAM which I don't know what I should do with. But I opened the internet option, and was able to run thru my keyboard and identify all the keys it was displaying. Here is that list:

Q/q - nothing
W/w - upside down "
E/e - ' (tilted a bit to right)
R/r - % with extra small zero on bottom row
T/t - ^ reversed reversed
Y/y - A with 'e' accent tilted above it
U/u - sideways : in the middle
I/i - ^ carrot
O/o - proper zero, or O with diagonal line thru it
P/p - ?pi
[/{ - "
]/} - apostrophe '
\ /| - >> double, small, closer
both capital and lowercase

A/a = nothing
S/s = I with tilted line (such as e above) above it
D/d - I with an upside down carrot (such as t above) above it
F/f - I with umlaut above it
G/g - ~ only more squashed looking (nasal accent)
H/h - O with tilted line (such as e above) above it
J/j - O with upside down carrot (such as t above) above it
K/k - dark apple
L/l - O with line in opposite direction to h (above)
;/: - U with tilted line (sich as e above) above it
'/" - AE

return worked this time (in safari under PRAM reset) but not on regular keyboard for login
space works

Z/z- nothing
X/x - period?
C/c - C with tail (french)
V/v - diamond in middle
B/b - short horizontal line in middle
N/n - ?looks like umlaut
M/m - A with a ^ carrot on it
,/< - upper - line (like diacritic)
./> - upside down rounded carrot
/ / ?- updside down question mark

keys highlight multiple spaces at once instead of moving the cursor.

the upper keys work 'but a bit funky'

Also types exact same thing if I try 'option-W' then shows same as the "w" key above, or 'option-C' = the french C with a tail on it.



SpoekGTi
Sep 7, 2012, 08:55 AM
Try to get in while using an USB keyboard, if it still types weird then it maybe the logic board that has issues and not the keyboard

wolfpuppies3
Sep 7, 2012, 10:31 AM
I'm sure you know that, if it is water damaged as you suspect, then the repair price is around $750 for a new logic board. Most MBAirs aren't worth $750 at a used price.

Team Timm
Sep 7, 2012, 10:34 AM
How old is your MBA?

8percent
Sep 12, 2012, 06:47 PM
Thanks, yes I saw somewhere advertised refurbished airbooks for ~$500 (myservice.com). I bought it in February 2012. It has always had issues. I don't know how it would have gotten water damaged, but I took it apart and looks like the battery cable was corroded, and some various spots on the boards.

I bought it from apple.com but its not longer eligible for returns either. I mean you win some lose some, but I've had nothing but trouble with this device returning it for services 3 times in the few months that I had it.

Meanwhile I do have a Macbook 2008, which works, but seems incredibly slow. There's something wrong with it, but I don't know what and I created a different thread to try and work on it.

So I'll order a usb keyboard and try it out.

I appreciate all of your feedback!

calvol
Sep 12, 2012, 07:02 PM
Sure it's not a virus? Trojan.vundu acts like that.

GGJstudios
Sep 13, 2012, 09:24 AM
Sure it's not a virus? Trojan.vundu acts like that.
There are no Mac OS X viruses in the wild, and no Mac OS X malware that exists produces the OP's symptoms. Trojan.vundu isn't a virus and it only affects Windows, not Mac OS X.

Mac Virus/Malware FAQ (http://guides.macrumors.com/Mac_Virus/Malware_FAQ)

gnasher729
Sep 13, 2012, 10:16 AM
Your description sounds like the "option" or "alt" key is stuck on your keyboard. You get all the interesting characters that you normally get when "option" is pressed. Maybe cleaning the keyboard and especially the option key helps.

I don't know exactly what your keyboard looks like, but mine has an option key on each side besides the "ctrl" key, so each of them could cause that problem.

8percent
Sep 14, 2012, 04:49 PM
Hi and thank you.

So I got a replacement little keyboard USB and it worked to get in. At least I can backup the data.

However now it is not charging the battery (at zero) and unplugging the power turns it off. SO I will try opening again and see if the corrosion there reappeared. If so I think I would be able to use it a semi-functional even more delicate but at least useful gear. I mean definitely wouldn't be the one I use to climb Mt Everest. And no kids allowed!

Thank you, for now this suffices as I look into the other factors. I already knew it was not a virus, and that one mentioned affects windows OS anyway. But thank for suggesting a keyboard, even if it wont work completely correctly, at least it usable.

My next concern is if they sell a power adaptor for MBA for the car, for travelling. I'd like to use this to entertain my son on our cross-country trip. (It does seem to be charging right now (seems slower), but I'll take a look inside to assess if the corrosion came back or something).

I think I might try (after the move and entertaining the kid thing) and clean it up with the toothbrush. I read someone online you can get denatured alcohol to clean circuitboards and use a toothbrush. I'm willing to try that, and who knows. It does seem to operate correctly except a few glitches.

Satisfied customer for assistance. I might be back but will post a new thread when I attempt to clean it, if having questions then. Thank you everyone.