PDA

View Full Version : Launching IOS 5.1 Simulator in XCode 4.4.1 crashes (tried direct start too)




Varsuuk
Sep 8, 2012, 05:26 PM
I just got off a frustratingly useless support call with Apple.

I bought a MacBook Pro before Mountain Lion was released. I didn't have much time to play with it. About all I did was follow along with an Oreilly book through the first simple buid/compile (basically an empty "flashlight" app) then a second Hello World app with button. Both built and ran fine.

Upgraded to Mtn Lion. Also received an update to XCode. Couple weeks later finally tried it out with same project and compiled fine but when I tried to run it it reports that the Simulator crashed. Which it does each time. Tried clean new project with same problem.

Tried many things like uninstall/reinstall. Uninstall + manual uninstall of anything I could grep relating to xcode/iossimulator in Library and ~/Library.

I am completely new to MacOS and XCode etc... I am a C++ dev on Linux (and years back Windows) so clueless here.

I know it is not a "standard" problem because if so, I'd read everywhere no one can run code post ML release. So, any clues how I can determine what to do next?

Apple says I have to pay the $99 to be able to look at and post in xcode forums. I don't have much time to do own projects so I don't want to sign up until I actually had time to learn how to code in ObjectiveC and the framework since it may be months from now I don't want to "waste" my sub.

If I had a CODING problem I'd sign up if couldnt find answers elsewhere. But this is just a crash hitting RUN from a (somewhat) fresh install.

----------



Crash report:

Process: iPhone Simulator [416]
Path: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/Applications/iPhone Simulator.app/Contents/MacOS/iPhone Simulator
Identifier: com.apple.iphonesimulator
Version: 5.1 (272.21)
Code Type: X86 (Native)
Parent Process: launchd [149]
User ID: 501

Date/Time: 2012-09-08 17:13:04.866 -0400
OS Version: Mac OS X 10.8.1 (12B19)
Report Version: 10

Interval Since Last Report: 31748 sec
Crashes Since Last Report: 6
Per-App Interval Since Last Report: 6 sec
Per-App Crashes Since Last Report: 4
Anonymous UUID: FE91B155-1A0A-4C18-84DA-3DEA5A30033C

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000acc01000

VM Regions Near 0xacc01000:
__OBJC 00000000acc00000-00000000acc01000 [ 4K] rw-/rwx SM=PRV /usr/lib/libobjc.A.dylib
--> Submap 00000000acc01000-00000000acc02000 r-x/rwx process-only submap
__IMPORT 00000000acc01000-00000000acc02000 [ 4K] rw-/rw- SM=COW /usr/lib/libobjc.A.dylib

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 ??? 0xacc01000 objc_assign_ivar + 0
1 libobjc.A.dylib 0x992fed47 object_setIvar + 353
2 libobjc.A.dylib 0x992febda object_setInstanceVariable + 80
3 com.apple.AppKit 0x99746461 -[NSNibOutletConnector establishConnection] + 486
4 com.apple.AppKit 0x9971815f -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1002
5 com.apple.AppKit 0x996f6762 loadNib + 373
6 com.apple.AppKit 0x996f5b3a +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 233
7 com.apple.AppKit 0x99846774 +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 154
8 com.apple.AppKit 0x996f580f +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 709
9 com.apple.AppKit 0x996f1688 NSApplicationMain + 447
10 com.apple.iphonesimulator 0x000027b5 0x1000 + 6069

Thread 1:
0 libsystem_kernel.dylib 0x9493b0ee __workq_kernreturn + 10
1 libsystem_c.dylib 0x9861a04c _pthread_workq_return + 45
2 libsystem_c.dylib 0x98619e19 _pthread_wqthread + 448
3 libsystem_c.dylib 0x98601cca start_wqthread + 30

Thread 2:: Dispatch queue: com.apple.libdispatch-manager
0 libsystem_kernel.dylib 0x9493b9ae kevent + 10
1 libdispatch.dylib 0x92452cc5 _dispatch_mgr_invoke + 993
2 libdispatch.dylib 0x924527fd _dispatch_mgr_thread + 53

Thread 3:
0 libsystem_kernel.dylib 0x9493b0ee __workq_kernreturn + 10
1 libsystem_c.dylib 0x9861a04c _pthread_workq_return + 45
2 libsystem_c.dylib 0x98619e19 _pthread_wqthread + 448
3 libsystem_c.dylib 0x98601cca start_wqthread + 30

Thread 4:
0 libsystem_kernel.dylib 0x9493b0ee __workq_kernreturn + 10
1 libsystem_c.dylib 0x9861a04c _pthread_workq_return + 45
2 libsystem_c.dylib 0x98619e19 _pthread_wqthread + 448
3 libsystem_c.dylib 0x98601cca start_wqthread + 30

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0xacbfa47c ebx: 0x00028e54 ecx: 0xbffff898 edx: 0x0000000c
edi: 0x992febf4 esi: 0x000000d0 ebp: 0xbffff8a8 esp: 0xbffff87c
ss: 0x00000023 efl: 0x00010246 eip: 0xacc01000 cs: 0x0000001b
ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f
cr2: 0xacc01000
Logical CPU: 2

Binary Images:
0x1000 - 0x25ff7 com.apple.iphonesimulator (5.1 - 272.21) <4708E226-3344-3E68-9593-654A94B599EA> /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/Applications/iPhone Simulator.app/Contents/MacOS/iPhone Simulator
0x31000 - 0x14fff3 com.apple.WebKit (8536 - 8536.25) <5365AA39-A1A7-315D-AA1C-0C564909C0E0> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit
0x1ff000 - 0xe89ff3 com.apple.WebCore (8536 - 8536.24) <06F7EC1E-A7F2-37F1-ADC6-687284E661D8> /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
0x167b000 - 0x1688ffb com.apple.Librarian (1.1 - 1) <C8D82AA3-AE5E-3B6D-A8D1-847856057186> /System/Library/PrivateFrameworks/Librarian.framework/Versions/A/Librarian
0x8fe88000 - 0x8febae57 dyld (210.2.3) <23516BE4-29BE-350C-91C9-F36E7999F0F1> /usr/lib/dyld
0x90007000 - 0x90008fff liblangid.dylib (116) <E13CC8C5-5034-320A-A210-41A2BDE4F846> /usr/lib/liblangid.dylib
0x9004b000 - 0x90059fff libxar.1.dylib (105) <343E4A3B-1D04-34A3-94C2-8C7C9A8F736B> /usr/lib/libxar.1.dylib
0x90180000 - 0x90183ffb com.apple.TCC (1.0 - 1) <C1B2A1EB-9EA2-3340-8611-F788C87A951F> /System/Library/PrivateFrameworks/TCC.framework/Versions/A/TCC
0x90184000 - 0x902dbff7 com.apple.audio.toolbox.AudioToolbox (1.8 - 1.8) <6856CA9B-BF08-341B-AEE9-91CC258D4534> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
0x902dc000 - 0x90321ff7 com.apple.NavigationServices (3.7 - 200) <F6531764-6E43-3AF3-ACDD-8A5551EF016A> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/NavigationServices.framework/Versions/A/NavigationServices
0x90322000 - 0x905dfff3 com.apple.security (7.0 - 55178.0.1) <EB90D52E-27EC-3874-BA15-C69976F1067A> /System/Library/Frameworks/Security.framework/Versions/A/Security
0x90867000 - 0x90870ffd com.apple.audio.SoundManager (4.0 - 4.0) <ABC5FE40-B222-36EB-9905-5C8C4BFD8C87> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CarbonSound.framework/Versions/A/CarbonSound
0x90874000 - 0x908dafff com.apple.print.framework.PrintCore (8.0 - 387) <84DFC4F0-3186-3C59-9EBD-9EF2C3561A43> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/PrintCore.framework/Versions/A/PrintCore
0x908db000 - 0x908e5fff com.apple.speech.recognition.framework (4.1.5 - 4.1.5) <B855E8B4-2EE3-3BFF-8547-98A0F084F9AF> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SpeechRecognition.framework/Versions/A/SpeechRecognition
0x908e6000 - 0x90919ff3 com.apple.GSS (3.0 - 2.0) <B1D719C1-B000-3BE3-B747-329D608585DD> /System/Library/Frameworks/GSS.framework/Versions/A/GSS
0x9091a000 - 0x90924fff libsystem_notify.dylib (98.5) <7EEE9475-18F8-3099-B0ED-23A3E528ABE0> /usr/lib/system/libsystem_notify.dylib
0x90925000 - 0x90928ffd libCoreVMClient.dylib (24.4) <C54E8FD0-61EC-3DC8-8631-54288AC66AC8> /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libCoreVMClient.dylib
0x90929000 - 0x90956ffb com.apple.CoreServicesInternal (153 - 153) <DB105788-CCF5-3678-88C5-65A7267DC581> /System/Library/PrivateFrameworks/CoreServicesInternal.framework/Versions/A/CoreServicesInternal
0x91690000 - 0x9170aff7 com.apple.securityfoundation (6.0 - 55115.4) <A959B2F5-9D9D-3C93-A62A-7399594CF238> /System/Library/Frameworks/SecurityFoundation.framework/Versions/A/SecurityFoundation
0x91767000 - 0x91784fff libxpc.dylib (140.37) <F61095FA-B2CF-3CD8-9088-9D9FC18B38BC> /usr/lib/system/libxpc.dylib
0x91785000 - 0x91791ffc libkxld.dylib (2050.9.2) <301804CB-55F1-3A9B-BC45-DEB020C22C6F> /usr/lib/system/libkxld.dylib
0x917ac000 - 0x917b8ffd com.apple.CrashReporterSupport (10.8.1 - 412) <9BBEBED1-DEDD-3258-A8CC-F46EC5CDD4F7> /System/Library/PrivateFrameworks/CrashReporterSupport.framework/Versions/A/CrashReporterSupport
0x917b9000 - 0x917ddfff libJPEG.dylib (843) <04383F74-067F-3E98-882F-21F5B9578984> /System/Library/Frameworks/ImageIO.framework/Versions/A/Resources/libJPEG.dylib
0x917de000 - 0x917f3fff com.apple.speech.synthesis.framework (4.1.10 - 4.1.10) <20E394D6-D9BA-3C1D-993A-533B60EF3B63> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/SpeechSynthesis.framework/Versions/A/SpeechSynthesis
0x917f4000 - 0x91812ffb com.apple.Ubiquity (1.2 - 234.2) <BEFF43DE-CF72-3E66-90C8-CAECAFD5F3ED> /System/Library/PrivateFrameworks/Ubiquity.framework/Versions/A/Ubiquity
0x9183f000 - 0x91843ff7 libmacho.dylib (829) <5280A013-4F74-3F74-BE0C-7F612C49F1DC> /usr/lib/system/libmacho.dylib
0x91844000 - 0x91845fff libdnsinfo.dylib (453.16) <6441AEC9-3916-3BF6-BE54-9C25E2BE61E1> /usr/lib/system/libdnsinfo.dylib
0x91846000 - 0x918b5ffb com.apple.Heimdal (3.0 - 2.0) <1ABF438B-30E6-3165-968C-E2EA1A9DF1FD> /System/Library/PrivateFrameworks/Heimdal.framework/Versions/A/Heimdal
0x91f43000 - 0x91f9dfff com.apple.Symbolication (1.3 - 93) <684ECF0D-D416-3DF8-8B5B-3902953853A8> /System/Library/PrivateFrameworks/Symbolication.framework/Versions/A/Symbolication
0x9209b000 - 0x9209cffd libunc.dylib (25) <58599CBF-E262-3CEA-AFE1-35560E0177DC> /usr/lib/system/libunc.dylib
0x9209d000 - 0x920affff libbsm.0.dylib (32) <DADD385E-FE53-3458-94FB-E316A6345108> /usr/lib/libbsm.0.dylib
0x920b0000 - 0x92199ff7 libxml2.2.dylib (22.3) <015A4FA6-5BB9-3F95-AFB8-B9281E22685B> /usr/lib/libxml2.2.dylib
0x9219a000 - 0x9219afff com.apple.CoreServices (57 - 57) <956C6C6D-A5DD-314F-9C57-4A61D41F30CE> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

....
MUCHO Snipping
....

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 2
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 289
thread_create: 0
thread_set_state: 0


VM Region Summary:
ReadOnly portion of Libraries: Total=137.3M resident=61.6M(45%) swapped_out_or_unallocated=75.7M(55%)
Writable regions: Total=71.7M written=1896K(3%) resident=2864K(4%) swapped_out=0K(0%) unallocated=68.9M(96%)

REGION TYPE VIRTUAL
=========== =======
CG image 4K
CG shared images 96K
CoreServices 2048K
MALLOC 60.4M
MALLOC guard page 48K
Memory tag=35 7108K
Stack 66.0M
VM_ALLOCATE 40K
__DATA 6232K
__DATA/__OBJC 180K
__IMAGE 528K
__IMPORT 4K
__LINKEDIT 38.3M
__OBJC 1768K
__OBJC/__DATA 56K
__PAGEZERO 4K
__TEXT 99.0M
__UNICODE 544K
mapped file 113.6M
shared memory 308K
=========== =======
TOTAL 395.9M

Model: MacBookPro9,1, BootROM MBP91.00D3.B06, 4 processors, Intel Core i7, 2.7 GHz, 8 GB, SMC 2.1f170
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In, 512 MB
Graphics: NVIDIA GeForce GT 650M, NVIDIA GeForce GT 650M, PCIe, 1024 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54333531533643465238432D50422020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54333531533643465238432D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF5), Broadcom BCM43xx 1.0 (5.106.98.81.21)
Bluetooth: Version 4.0.9f8 10405, 2 service, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: APPLE HDD HTS727575A9E362, 750.16 GB
Serial ATA Device: MATSHITADVD-R UJ-8A8
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1a100000 / 2
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0x1a110000 / 3
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1d100000 / 2
USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0x1d180000 / 3
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0252, 0x1d183000 / 6
USB Device: BRCM20702 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x1d181000 / 5
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821d, 0x1d181300 / 9
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x1d182000 / 4



Varsuuk
Sep 8, 2012, 05:50 PM
Read on another thread matching some of the crash report (was about Loadbar or something?) to start in safe try it then restart in regular and still works...

Well, it RAN the Simulator in safe but once rebooted it was back to crashing.

Have one more idea, after that seems what Apple offered as FIRST thing to try might be what I will have to do - re-OS :(

I thout Apple was going to be less issues than Windows (if not less than Gentoo/Ubuntu)

Varsuuk
Sep 8, 2012, 11:19 PM
Nope, tried starting the simulator in safe mode selecting reset and then restarting the pc in normal mode.

Worked in safe, in regular...not so much. Perhaps I can look at what is running at the time different but Im a noob to MAC ;P

ArtOfWarfare
Sep 9, 2012, 12:51 AM
I'm running the exact same build of Mac OS X and the exact same build of iOS Simulator with no issues. That combined with the fact you say it works in Safe Boot suggests to me that either you or something you installed has modified the contents of your library in a very bad way.

Not many things modify the library... anything that would do that would require you to enter your password first. What can you think of that you needed to give your password to before installing?

(Oh, and would you mind editing your first post to have the crash log in between [ code ] tags? This page is rendering a little funny with some of those lines being so long without a space.)

Varsuuk
Sep 9, 2012, 02:04 AM
Sorry, will do the code edit after this reply. New to this.

I expected that it was something installed on my setup. I am a bit sleepy and cannot think of this sort of thing at this moment other than the last thing I installed:

Parallels 8. I installed that the day before trying Xcode again (and first time since Mountain Lion) Used to run VirtualBox - to remove that I ran uninstaller for virt box.

I will give thought to what else tomorrow after can get some time (little 5yo ;) ) - I can obviously think of all the updates that were available from App store to apps that came with the mac as well as an update to Xcode, iir. I added Office 2011, but that was on pre-ML version as well and worked then. Calibre I think I might have updated. I believe the Nook read failed attempt was after couldnt get Simulator.

Eclipse, Kindle, were on old working Lion version as well. I think I updated Java only AFTER this issue (again through app store) - Google Music Manager I have downloaded and installed but not yet setup - asks me each boot.

Like said, will look later for this.


If I have to reinstall/repair - does this Ctrl-R version of ML repair overwrite things in such way that things like Itunes loses authorization slot if I dont fire deauth etc?

Thanks SOOOO much for reply.

----------

Oh, and to be clear again ('cos I have...issues... with 'clarity', my apologies):

Originally thought was something like "XCode doesn't run" before realizing I can start the Simulator separately and repeated the crash/doesn't start issue.

After that, when I started in safe mode, I choose reset on the simulator to give that a try - no luck. Thabnks - let me know if I need to post any other logs or screenshots or...