PDA

View Full Version : Quicklook "sticking" on blank window




Makosuke
Sep 14, 2012, 05:39 PM
I've been having an ongoing issue with QuickLook on two different Macs that has persisted through an upgrade from 10.7 through 10.8 (now 10.8.1). It's a major enough bug, and one I can't seem to find much about, that it can't be universal, but since it's on both of my home computers and lasted through a major OS update it's obviously something about either my configuration or something I've got installed that's doing it, and I'm hoping somebody can help me pin it down.

The symptom is thus:

Finder Quicklook works fine for a while. Then, at some point randomly, quicklooking a file (movie or image) will result in the quicklook window being blank white. If I hit space twice more--closing and re-opening the quicklook window--it will display the image correctly. Similiarly, if I resize the window, the image will appear as soon as the contents of the window redraw.

Essentially, the contents of the Quicklook window are not getting updated live until a redraw is forced by a resize or reopening the window. This makes Quicklook more or less unusable. If I quit and reopen Finder (either force quit or a "regular" quit via an added menu item), Quicklook returns to normal functioning behavior again for a while.

My assumption is that it's something in Quicktime doing this, but the only QT plugin I'm running at this point (I think) is Flip4Mac, and the behavior was the same with both the 2.x version and the current 3.0 beta. I had Perian installed before, but removed it due to the major issues it caused with browser-embedded HTML5 video (did they ever fix that?).

Suggestions? Diagnostics I can try?