PDA

View Full Version : iTunes server gone on 1 Mac




Impyke
Sep 15, 2012, 04:55 PM
hi,

I got two mac's with Mountain Lion and have a problem with 1 of them with getting an firefly server be visible in iTunes.

I know it worked before on this Mac, but just not visible under the sharing tab of iTunes.
I already had this problem with Lion as well for sure, but never paid attention to it.

The firefly server is running on a Qnap NAS and i can access it from the finder without any problems. And the other Mac is working like a charm.

Is it possible to reset these settings? Strange behavior is also that if i enable home sharing, the sharing tab in iTunes completely disapears (not sure if thats normal behavior though).

Can someone help me with this strange issue? reinstall of iTunes is not possible anymore because its needed by the OS.

tia!



Impyke
Sep 17, 2012, 03:15 PM
Anyone can help please to reset this itunes settings?

Draeconis
Sep 17, 2012, 03:22 PM
You can easily remove iTunes (or any other 'critical' OS X app) with the terminal;

sudo rm -rf /Applications/iTunes.app

Try removing the iTunes prefs in /user/Library/Preferences/com.Apple.iTunes.plist

Impyke
Sep 17, 2012, 04:06 PM
You can easily remove iTunes (or any other 'critical' OS X app) with the terminal;

sudo rm -rf /Applications/iTunes.app

Try removing the iTunes prefs in /user/Library/Preferences/com.Apple.iTunes.plist

Thanks, i tried that, indeed my iTunes settings are reset with the prefs file and also reinstalled iTunes completely, but unfortunately no qnap/itunes server will pop-up under the shared tab in iTunes. More ideas? or just reinstall machine? (which i don't prefer)...

marzer
Sep 17, 2012, 04:18 PM
hi,

I got two mac's with Mountain Lion and have a problem with 1 of them with getting an firefly server be visible in iTunes.

I know it worked before on this Mac, but just not visible under the sharing tab of iTunes.
I already had this problem with Lion as well for sure, but never paid attention to it.

The firefly server is running on a Qnap NAS and i can access it from the finder without any problems. And the other Mac is working like a charm.

Is it possible to reset these settings? Strange behavior is also that if i enable home sharing, the sharing tab in iTunes completely disapears (not sure if thats normal behavior though).

Can someone help me with this strange issue? reinstall of iTunes is not possible anymore because its needed by the OS.

tia!

Sorry to ask the obvious - Are you sure you have library sharing enabled in iTunes prefs? It can be blocked under iTunes parental controls.

http://www.apple.com/itunes/inside-itunes/2010/11/manage-access-to-content-with-parental-controls.html

Impyke
Sep 17, 2012, 04:33 PM
Sorry to ask the obvious - Are you sure you have library sharing enabled in iTunes prefs? It can be blocked under iTunes parental controls.

http://www.apple.com/itunes/inside-itunes/2010/11/manage-access-to-content-with-parental-controls.html

its not checked in the parental controls tabs in iTunes setting, so its not "disabled"..

Impyke
Sep 17, 2012, 04:51 PM
the strange thing is, that when i enable home sharing, the tab sharing is disapearing from the left bar.. when i disable it, and reenable it, but don't login, the sharing tab is back again :S... is this normal behavior? i really think something is really going crazy with sharing tab on this iMac with iTunes.

Impyke
Sep 20, 2012, 05:23 PM
so...... i guess this would be a fresh install of snow leopard, lion and mountain lion? :-(.. really strange behavior, and for sure strange because of other iMac is working without any problem....

Impyke
Sep 25, 2012, 04:23 PM
I installed both iMacs to 10.8.2, and still have this problem with 1 iMac.
Some guru who can point me to the right direction?

marzer
Sep 25, 2012, 04:34 PM
I installed both iMacs to 10.8.2, and still have this problem with 1 iMac.
Some guru who can point me to the right direction?

So did you do a fresh install? Have you shut off firewall to make sure it wasn't interfereing?

As a test, enable Library Sharing (not Home Sharing) under iTunes Prefs on the other Mac and see if it shows up on the Mac in question. Of course you need content loaded in the iTunes library to share it out.

Impyke
Sep 26, 2012, 11:17 AM
So did you do a fresh install? Have you shut off firewall to make sure it wasn't interfereing?

As a test, enable Library Sharing (not Home Sharing) under iTunes Prefs on the other Mac and see if it shows up on the Mac in question. Of course you need content loaded in the iTunes library to share it out.

Thanks, tried that options, but it didn't work. Today i made a time machine backup and re-installed the iMac and its working again, i really don't know what the exact problem was, but its working now!