PDA

View Full Version : Possible for ML to disrupt entire WiFi network?




swingerofbirch
Sep 16, 2012, 02:20 AM
Our family has been having non-stop WiFi problems and the only thing that is different is that I now have a MacBook Pro with Mountain Lion on the network, and I'm starting to wonder if it could be affecting our entire network as it's the only new variable, and the problems seem to have started at the same time.

Our network is set up with cable Internet coming into the house, which is connected to an Airport Extreme Base Station. There are two other Airport Expreses in the house that are set to extend the network that the Airport Extreme Base Station has created.

In terms of clients, there is my Mountain Lion MBP, another Lion MBP, a Snow Leopard Mac Mini, a Snow Leopard iMac, two Apple TVs, and and iPod touch.

So we know that if there is a kink in the system, it's an Apple product.

The problem is that frequently on all of our computers we have to turn off WiFi (from the computer itself) and turn it back on to get the Internet to work. One complication could be that the iMac with Snow Leopard is constantly connected to the MacBook Pro with Mountain Lion via screen sharing. The iMac remotely views the MBP's screen.

Since these problems started, the iMac will stop viewing the MacBook Pro's screen periodically by not updating and by staying stuck on the display's content from the time it stopped working. I can temporarily fix this by connecting to the iMac through the MBP via screen sharing and then clicking anywhere on the iMac's view of the MBP which forces the iMac's view to update. However, I have found that I can only view the iMac through the MBP via screen sharing if both computers are currently on the same router. This is presumably what causes the iMac to stop viewing the MBP, as well. I believe this is the case because when I go to AirPort Utility to check which clients are connected to which router, the problem seems to occur when the MBP and iMac are connected to different routers. When I see that my MBP is connected to an Airport Express and the iMac connected to the Airport Extreme Base Station, I remotely reset the Airport Express, then quickly turn off WiFi on the MBP, and turn it back on to get it to "catch" the AirPort Extreme Base Station's signal before the Airport Express is back online. Once the computers are on the same router, I can remotely view the iMac from the MBP, which allows me to then click on the iMac's view of the MBP, which causes it to return to viewing in real time.

This isn't the only problem though. The other computers on the network need to turn WiFi off and on constantly to stay connected to the Internet. And when I used AirPlay audio from the Mountain Lion MBP to an Apple TV today, the audio cut out about half the time and would rever to playing through the internal speakers.

In terms of troubleshooting, we've tried unplugging every single device in the house: every wireless router, every client, and the cable modem, and left them unplugged for 10 minutes. It seemed to help for a while, but that may have been a coincidence. In any case, the problem is still there.

Is it possible that Mountain Lion screen sharing with Snow Leopard could cause problems for the entire network? Is it possible that Mountain Lion by itself has issues that could cause problems for an entire WiFi network?

I only ask for your help here because when I call Apple with these sorts of problems they can't help me. And I know some of you guys are really smart.

If you read all this, thank you.



iFoggy
Sep 16, 2012, 11:55 AM
In what I also experienced I would say yes even though it makes no logical sense, my setup is similar but all Apple....extreme, express, Mac Pro, Mac mini, iPhone 4S and iPad 2.....all rock solid wifi wise prior to ML, install ML on Pro and Mini and constant issues all over.

Loads of 'possible' solutions on line, only thing that worked for me was finding this one and doing it on all ML devices, then reboot Extreme then Express and bang all is good with the world again, good luck hope it works for you.

Open finder and go to where you,can enter a folder path.
Enter: /library/preferences/systemconfiguration
Now take the systemconfiguration folder and Delete it
Provide your password then delete and empty the trash
Restart Your Computer

swingerofbirch
Sep 16, 2012, 05:53 PM
In what I also experienced I would say yes even though it makes no logical sense, my setup is similar but all Apple....extreme, express, Mac Pro, Mac mini, iPhone 4S and iPad 2.....all rock solid wifi wise prior to ML, install ML on Pro and Mini and constant issues all over.

Loads of 'possible' solutions on line, only thing that worked for me was finding this one and doing it on all ML devices, then reboot Extreme then Express and bang all is good with the world again, good luck hope it works for you.

Open finder and go to where you,can enter a folder path.
Enter: /library/preferences/systemconfiguration
Now take the systemconfiguration folder and Delete it
Provide your password then delete and empty the trash
Restart Your Computer

Thanks very much! I'm going to try this as soon as I back everything up just in case. Will update to let people know if it fixes the issues.