PDA

View Full Version : iMessages ( Complicated )




RawMuk
Sep 19, 2012, 01:40 PM
I don't understand the update

iMessages sent to your phone number now appear in Messages on your Mac

How do i get it working on my Macbook late 2009



heisenberg123
Sep 19, 2012, 01:42 PM
I don't understand the update

iMessages sent to your phone number now appear in Messages on your Mac

How do i get it working on my Macbook late 2009


did you add it to your preferences?

RawMuk
Sep 19, 2012, 01:44 PM
no option to add ( Phone Number ) Just add another email

khaledm87
Sep 19, 2012, 01:54 PM
got the same problem..
not managing to make it work.

got no option in iMessages preferences to add number or anything..

:(

blueroom
Sep 19, 2012, 01:58 PM
Works on my 2010 MacBook Pro and iPhone 4

You guys do have an iPhone running iOS6 right with iMessages configured on your iPhones right...

khaledm87
Sep 19, 2012, 01:59 PM
Works on my 2010 MacBook Pro and iPhone 4

You guys do have an iPhone running iOS6 right with iMessages configured on your iPhones right...

got an iPhone 4 running 5.1.1
Do I need iOS 6 ?!

blueroom
Sep 19, 2012, 02:00 PM
got an iPhone 4 running 5.1.1
Do I need iOS 6 ?!

Yes, whatcha waiting for?

khaledm87
Sep 19, 2012, 02:02 PM
losing the jailbreak ? losing half of my life ?

RawMuk
Sep 19, 2012, 02:03 PM
Either it's because I have a late 2009 Macbook pro, or it's because somethings wrong..

http://i.imgur.com/EBCpi.jpg

blueroom
Sep 19, 2012, 02:12 PM
Either it's because I have a late 2009 Macbook pro, or it's because somethings wrong..

Image (http://i.imgur.com/EBCpi.jpg)

And you're on iOS 6 on your iPhone and you've configured it on the iPhone /settings/messages?

----------

losing the jailbreak ? losing half of my life ?

Pick one. What exactly are you going to lose?

RawMuk
Sep 19, 2012, 02:17 PM
IOS6, Indeed.

You can be reached by Imessage at:

(Tick) +4478.......
(Tick) Email Address

Start New Conversations from:

(Tick) +4478.......
(Un Tick) Email Address

khaledm87
Sep 19, 2012, 02:17 PM
Pick one. What exactly are you going to lose?

haha, I meant that the jailbreak IS my half life.

blueroom
Sep 19, 2012, 02:21 PM
haha, I meant that the jailbreak IS my half life.

How's that?

polyh3dron
Sep 19, 2012, 02:23 PM
Set iMessages up again on your iOS 6 device first.

Your iMessage settings window will change after and look like this:

http://i.minus.com/iZagSPOQhUT5r.png

blueroom
Sep 19, 2012, 02:27 PM
And reboot your iPhone.

RawMuk
Sep 19, 2012, 02:29 PM
Disabled iMessages, Rebooted :) Worked thanks guys

ice40i
Sep 19, 2012, 02:32 PM
I have 2 iPhones both running on ios 6 already, Can you add both numbers im stuck at work and cant try.

RawMuk
Sep 19, 2012, 02:36 PM
i guess if you have them using the same apple id,

BadboyHouse
Sep 19, 2012, 02:57 PM
Messages on my macbook pro still isn't giving me any options for using my mobile number. Have updated iphone to ios6, rebooted twice, disabled imessage and rebooted, enabled it and rebooted. Plus rebooted mac.

Is there something else I need to do?

Schmitty11
Sep 19, 2012, 03:07 PM
I'll try to put this a simple as possible...

Does these update truly unify? I tried Messages when it was in beta and actually liked it. But when I would send them from my phone or MacBook, the people who would receive my messages would complain that my contact was coming up as my email (Apple ID) and the only way to fix it was to stop using messages on the Mac and unlink imessage from my Apple ID, then my regular contact name would show again. (Note all of this early this year) Does this "unification" Make it so my contact name will show regardless of what device I send it from?

Iron Chef
Sep 19, 2012, 04:08 PM
Seems to be a trend with people in the 2009 MBP camp who can't link their iPhone # to iMessage. If anyone figures it out, I bet a lot of people would appreciate a step-by-step complete with screenshots.

I did a quick search for 'IMESSAGE' on Twitter and it seems many people are having the problem

BadboyHouse
Sep 19, 2012, 04:14 PM
My MBP is late 2011. All updates installed etc.

Just wont bring up any options for linking phone number. It's damn frustrating.

aarmstrong27
Sep 19, 2012, 04:17 PM
One important thing you have to do is go to applied.apple.com and log in. Then verify/add your mobile number. Once your mobile number is associated with your appleID, you should just have to reset and BAM!

aarmstrong27
Sep 19, 2012, 04:22 PM
pic

BadboyHouse
Sep 19, 2012, 04:23 PM
One important thing you have to do is go to applied.apple.com and log in. Then verify/add your mobile number. Once your mobile number is associated with your appleID, you should just have to reset and BAM!

I checked that already. My mobile number has been associated for ages. Makes no difference - still no options to link in Messages.

aarmstrong27
Sep 19, 2012, 04:31 PM
I checked that already. My mobile number has been associated for ages. Makes no difference - still no options to link in Messages.

Weird. One thing I noticed was that sometimes Apples servers are behind. Most likely the case today with all the software downloads. Keep signing out of Messages and then back in. That kicked it through for several people on here a few weeks back when we started testing 10.8.2

----------

Just dug a little more on here. You need to sign out (not just turn off) of iMessage on your iPhone, then sign back in. It will re-register with the network and should push out your mobile number. At that point, your number should be in preferences on your Mac and you should be able to select it. Some people are also having to Reset Network Settings on their iPhones to get it to register.

Iron Chef
Sep 19, 2012, 04:39 PM
Tried the reset network settings on my iPhone...didn't work :(

How do you sign out of iMessage on the iPhone? I only see the on/off toggle

Edit: I GOT IT TO WORK. Here's what I did (piecing everyones advice together)

1) Make sure iOS 6 is installed on your iPhone and synced to iTunes 10.7
2) Sign out of your iMessage and close the app
2) On iPhone, Settings -> Messages -> Turn off iMessage
3) Turn iMessage back on (it will say waiting for activiation)
4) It will give you an option for using your Apple ID. Click that
5) Add your Apple ID
6) Open iMessage on your desktop and it should prompt you about merging #s

aarmstrong27
Sep 19, 2012, 04:45 PM
Tried the reset network settings on my iPhone...didn't work :(

How do you sign out of iMessage on the iPhone? I only see the on/off toggle

Settings->Messages->Send & Receive->Click your Apple ID at the top->Sign Out

BadboyHouse
Sep 19, 2012, 04:50 PM
Settings->Messages->Send & Receive->Click your Apple ID at the top->Sign Out

Mine says "Use your Apple ID" As I'm using my mobile number. No option to sign out when using mobile number.

At least a few of us are having problems. Must be a problem at apples end.

Iron Chef
Sep 19, 2012, 05:00 PM
Mine says "Use your Apple ID" As I'm using my mobile number. No option to sign out when using mobile number.

At least a few of us are having problems. Must be a problem at apples end.

Click the add Apple ID and add it

aarmstrong27
Sep 19, 2012, 05:06 PM
Mine says "Use your Apple ID" As I'm using my mobile number. No option to sign out when using mobile number.

At least a few of us are having problems. Must be a problem at apples end.

Click "Use Your Apple ID" and sign in.

sammjordan
Sep 20, 2012, 12:07 AM
Should my phone number be showing up in iMessage on my iPad as well? Or is this just between iPhone and Mac?

BadboyHouse
Sep 20, 2012, 12:30 AM
Click "Use Your Apple ID" and sign in.

Won't this be telling messages to use my apple I'd though??? I want to use my mobile number.

aarmstrong27
Sep 20, 2012, 08:26 AM
Won't this be telling messages to use my apple I'd though??? I want to use my mobile number.

No. Once you log in, you will be able to set your caller ID as your mobile number. Also, as soon as you sign in, your mobile number should show up on your Mac in Messages.

Trust me. I've been using it for almost 3 weeks now. :)

dcorban
Sep 20, 2012, 09:10 AM
I'll try to put this a simple as possible...

Does these update truly unify? I tried Messages when it was in beta and actually liked it. But when I would send them from my phone or MacBook, the people who would receive my messages would complain that my contact was coming up as my email (Apple ID) and the only way to fix it was to stop using messages on the Mac and unlink imessage from my Apple ID, then my regular contact name would show again. (Note all of this early this year) Does this "unification" Make it so my contact name will show regardless of what device I send it from?

You can select what your "caller id" is on your iMessages. By default, it is your Apple ID. Why wouldn't your message recipients simply add your email address to their contact? The name they see is determined by their phone. If they have your email address in your contact information, your name will show. Otherwise, it will just show the email address.

Both the Mac and iOS have the option to select where your messages originate. You are free to select your phone number or any email addresses you have associated with iMessage.

BadboyHouse
Sep 20, 2012, 03:35 PM
Tried the reset network settings on my iPhone...didn't work :(

How do you sign out of iMessage on the iPhone? I only see the on/off toggle

Edit: I GOT IT TO WORK. Here's what I did (piecing everyones advice together)

1) Make sure iOS 6 is installed on your iPhone and synced to iTunes 10.7
2) Sign out of your iMessage and close the app
2) On iPhone, Settings -> Messages -> Turn off iMessage
3) Turn iMessage back on (it will say waiting for activiation)
4) It will give you an option for using your Apple ID. Click that
5) Add your Apple ID
6) Open iMessage on your desktop and it should prompt you about merging #s

This worked for me. Thanks v.much!

BeachChair
Sep 20, 2012, 05:40 PM
Following some of the advice given here, I got it to work. What I did:

1. Made sure my phone number was input in the right box at appleid.apple.com
2. Deactivated iMessages on the iOS device
3. Checked off "Enable this account" in the Messages app preferences on the Mac
4. Rebooted both devices
5. Activated iMessages on the iOS device
6. Checked "Enable this account" in the Messages app preferences on the Mac

I am sure some of those steps are redundant. Good luck with it.