PDA

View Full Version : Update iOS 6, now can't send MMS.




savannadavis
Sep 20, 2012, 10:13 AM
I updated my iPhone 4S yesterday and now I cannot send picture messages. it is driving me insane. I have unlimited messaging so there's no reason it should not work. I tried restarting my phone and a message pops up and says that MMS requires a phone number.. my number is correct, and it still fails to send.



SandboxGeneral
Sep 20, 2012, 10:15 AM
I updated my iPhone 4S yesterday and now I cannot send picture messages. it is driving me insane. I have unlimited messaging so there's no reason it should not work. I tried restarting my phone and a message pops up and says that MMS requires a phone number.. my number is correct, and it still fails to send.

Are you trying to use iMessage or a regular cellular text [SMS/MMS] message?

Go to Settings, then Messages and scroll down. Ensure MMS Messaging is switched on.

savannadavis
Sep 20, 2012, 10:18 AM
neither work, iMessage and regular text messages. And MMS is switched on.

SandboxGeneral
Sep 20, 2012, 10:21 AM
neither work, iMessage and regular text messages. And MMS is switched on.

Under Settings --> Phone --> My Number, is your correct telephone number there?

Under Settings --> Messages --> Send & Receive --> You can be reached by iMessage at, do you have your telephone number selected as well as an email address?

Under Settings --> Messages --> Send & Receive --> Start new conversations from, is your telephone number selected there?

texasbelle9
Sep 20, 2012, 01:11 PM
I double checked all those sections and I still cannot send or receive pictures through iMessage either. :-/

Ishimaru
Sep 20, 2012, 01:33 PM
Reset network settings. This was a bug in Beta 3. No clue why it came back up now.

Zakoson2120
Sep 21, 2012, 06:25 PM
I can't either I've tried several times and it always fails. It worked fine until I updated yesterday to IOS 6. It's getting frustrating.

cyks
Sep 21, 2012, 06:35 PM
Add me to the list of 'Not Delivered' as well.

Zakoson2120
Sep 21, 2012, 06:38 PM
I don't know why it's not working it was working flawlessly then I upgraded now nothing can't send pictures in iMessage or in a standard MMS... What a let down.

DenverSteveo
Sep 22, 2012, 04:24 PM
Reset network settings. This was a bug in Beta 3. No clue why it came back up now.

Tried this. It works if only sending over cellular. As soon as I set up my local secure wifi connection again, the problem returns.

Zakoson2120
Sep 22, 2012, 09:15 PM
I can't send or recieve them over 3G or WIFI... Which sucks. Any idea when they will update this issue?

Felicide
Sep 23, 2012, 08:47 AM
Under Settings --> Phone --> My Number, is your correct telephone number there?

Under Settings --> Messages --> Send & Receive --> You can be reached by iMessage at, do you have your telephone number selected as well as an email address?

Under Settings --> Messages --> Send & Receive --> Start new conversations from, is your telephone number selected there?

I'm having the same issue. I tried looking at these three.
Under my number, yes my number is there.
Under iMessage, no my telephone number is not selected but an email is (messages are sending through iMessage with email)
Under send and receive, my telephone number is grayed so I cannot select it.

Also, when I turn iMessage on it says "waiting for activation" and nothing ever happens after that.

ndredsox
Sep 23, 2012, 09:07 AM
I'm having the same issue. I tried looking at these three.
Under my number, yes my number is there.
Under iMessage, no my telephone number is not selected but an email is (messages are sending through iMessage with email)
Under send and receive, my telephone number is grayed so I cannot select it.

Also, when I turn iMessage on it says "waiting for activation" and nothing ever happens after that.

Having the same issue. I did an erase iPhone via find my iPhone yesterday and since then it has not allowing imessage or facetime. I am wondering if I have to wait 24 hours after I wiped. I have tried everything, including a restore as a new iPhone.

Did you happen to erase from find my iPhone?

SandboxGeneral
Sep 23, 2012, 09:13 AM
I'm having the same issue. I tried looking at these three.
Under my number, yes my number is there.
Under iMessage, no my telephone number is not selected but an email is (messages are sending through iMessage with email)
Under send and receive, my telephone number is grayed so I cannot select it.

Also, when I turn iMessage on it says "waiting for activation" and nothing ever happens after that.

Check your iTunes account on the phone and be sure it's signed it. That's really the last thing I can think of to check, save doing a full restore.

Richard A
Sep 23, 2012, 09:44 AM
Can't send pictures using iMessage over my wireless network either, but can using LTE. Went to a friends house and was able to send on their network.

For those having this issue, are you using Comcast for your home network? My is and doesn't work, my friends's network is not Comcast and it worked there.

komiothebeat
Sep 23, 2012, 09:46 AM
my phone seemed to be freaking out yesterday when i got it, not until making a few phone calls (to parents and friends) and then switching LTE on, THEN off again, that my messages and everything started working again

ZacNicholson
Sep 23, 2012, 01:32 PM
my imessage is working but not the mms. it was working fine on ios 5. but since i updated it doesn't work. i want to be sexting with this girl and she is to poor to have an iphone.

Grams452
Sep 23, 2012, 03:18 PM
I updated my iPhone 4S yesterday and now I cannot send picture messages. it is driving me insane. I have unlimited messaging so there's no reason it should not work. I tried restarting my phone and a message pops up and says that MMS requires a phone number.. my number is correct, and it still fails to send.

My grandsons did that I went to settings then phone then I just saves his number now he can send pics

DenverSteveo
Sep 24, 2012, 12:38 PM
Can't send pictures using iMessage over my wireless network either, but can using LTE. Went to a friends house and was able to send on their network.

For those having this issue, are you using Comcast for your home network? My is and doesn't work, my friends's network is not Comcast and it worked there.

I confirmed that this seems to be the case when I arrived at work this morning. I can send photos via Wi-Fi just fine across my office's "non-Comcast" network. I also had success this morning at Starbucks sending photos via iMessage, MMS, and email.

At this point, it seems as if IOS 6 and Comcast aren't playing well together...

Can anyone else confirm that their issues are limited to connectivity over a Comcast network?

Foo4Everlong
Sep 24, 2012, 01:12 PM
Yes, I have Comcast as well and ever since the iOS 6 update I have not been able to send MMS through wifi both on my iPad and on my new iPhone 5. I can send text through iMessage but not pictures or videos. I tried rebooting my wifi recently to no avail. I did not reset the wifi I just unplugged for several minutes. I believe here is a reset button on the wifi. Just as extra info I have a Comcast XFinity wifi box. I can send through 4G no problem. And I also was at another place with different wifi and I was able to send both pictures and text from there. This issue is driving me nuts as I enjoy sending pics. Oh, by the way, my iPad 1 which did not get the iOS 6 update can send pictures and videos through wifi. Please any help would be greatly appreciated. Thanks much. Later

DenverSteveo
Sep 24, 2012, 02:09 PM
Here is a solution that came up on the Apple Support Forum regarding this issue:

"Well I spent a hours on the phone with Apple care and the guy submitted a ticket to the higher ups. Nothing ever came of that though. I figure that the iphone 5 has to be sending pics/videos through a different port or with added security and the xfinity gateway blocks it.

I called Comcast yesterday and the rep was trying to turn my gateway into just a modem, but it wouldn't listen to her commands. I decided that it's not worth the hassle and am returning the gateway to comcast. I went out and bought a stand alone comcast modem for $99 at best buy, but if you don't want to do that, you could always just exchange the gateway for a separate modem and router at the comcast office. My parents have comcast and they rent their modem and router from comcast, but the router is netgear and is a separate unit.

So my current set up is a comcast cable modem: Motorola Surfboard docsis 3.0 high-speed cable modem and an older b/g netgear router that I had in the closet. Everything works great and my iMessage can now send photos and videos with no issues. The Xfinity gateway is the issue, at least for me it was."


I'm guessing that this may be the issue that quite a few of us are experiencing. I hope it helps!

Msyspencer
Sep 24, 2012, 06:35 PM
I have a modem and wireless router not bought from Comcast although I have Comcast Internet service, and I'm unable to text pictures to anyone without iOS 5 or 6. I can't send to them while connected to wifi nor mobile Internet (tmobile so no 3G).

ITS ME DAVID
Sep 25, 2012, 12:36 AM
I'm having the same problems on my new iPhone 5 and 4s with ios6 on the other line with att I reset networks did a hard reset even restored and nothing I have mms enabled my phone # is listed under my phone settings etc

Illest
Sep 29, 2012, 12:33 AM
Here is a solution that came up on the Apple Support Forum regarding this issue:

"Well I spent a hours on the phone with Apple care and the guy submitted a ticket to the higher ups. Nothing ever came of that though. I figure that the iphone 5 has to be sending pics/videos through a different port or with added security and the xfinity gateway blocks it.

I called Comcast yesterday and the rep was trying to turn my gateway into just a modem, but it wouldn't listen to her commands. I decided that it's not worth the hassle and am returning the gateway to comcast. I went out and bought a stand alone comcast modem for $99 at best buy, but if you don't want to do that, you could always just exchange the gateway for a separate modem and router at the comcast office. My parents have comcast and they rent their modem and router from comcast, but the router is netgear and is a separate unit.

So my current set up is a comcast cable modem: Motorola Surfboard docsis 3.0 high-speed cable modem and an older b/g netgear router that I had in the closet. Everything works great and my iMessage can now send photos and videos with no issues. The Xfinity gateway is the issue, at least for me it was."


I'm guessing that this may be the issue that quite a few of us are experiencing. I hope it helps!

I'm experiencing the samething. My temporary fix is to turn off WiFi, send the MMS and then turn wiFi back on, but this is only when I'm home.

Does anyone know a better solution?

CarlosQG
Oct 2, 2012, 09:23 PM
Sorry to bring this up again but has anyone found a solution for this terrible bug? I can't send photos through WhatsApp, Mail, Facebook (it won't even load new notifications) I can't search on Soundhound, can't share photos on Instagram and can't make FaceTime calls...

This is driving me crazy. First time I'm losing patience with an Apple product...

sitoP
Oct 3, 2012, 01:23 AM
I know everyone wont want to do this but i have fixed my phone as far as not being able to send mms to anyone other than iphones. The issue was some how after the ios 6 upgrade my apn settings changed. I had seen a video on youtube about a similar issue except with jailbroken users and tmobile where the user had to manually change the settings. so i tether jailbroke my iphone and installed cydia manually after which i installed leimobile which allowed me to see the apn settings as well as change the faulty one in mms. long story short 2 hours of work i can now send mms to my girlfriend again. id be glad to help anyone with questions and ill post some links that helped me.

http://forum.xda-developers.com/showthread.php?t=1706503
http://www.youtube.com/watch?v=G-3ZOY1i4Vo

Nkethan36
Oct 3, 2012, 01:54 AM
I am having the same problem ever since I updated my phone to iOS 6 I cannot send picture messages or recieve any please help it is frustrating my boyfriend I'd in the army and I'm trying to send him pictures of our kids

Zimmy68
Oct 3, 2012, 05:31 AM
This happened to my wife.
I switched phones (gave her my 4S and got the 5).
AT&T simply forgot to add back the text message service to her line.
You may just need to call AT&T and check.

Midnight972002
Oct 29, 2012, 01:45 PM
Well after trying everything under the sun to get my picture texting to work I finally am told by apple that its not a apple problem its a ATT problem. I spoke with ATT and they tell me since my Iphone is on a pre paid account that they don't support picture texting. It worked fine with IOS5...trying to figure out if I can go back to the previous operating system. I also have used a app called Viber that works great for calling and texting.

keiths34
Nov 15, 2012, 11:55 AM
I have found a fix to this!!!!!! after updating my 3gs to ios 6, my imessage and mms were both not working. Tried for hours upon hours to fix it to no avail. UNTIL YESTERDAY!!!!

Now that they have the jailbreak for IOS6, you can fix the mms!!!!! You must Jailbreak the iphone. There are many videos and links on how to do this. and add source http://beta.leimobile.com/repo after doing this, go into it and add "EditAPN"....This will allow you to manually change your APN settings.

go to settings>general>cellular> You should now be able to scroll down and see "Cellular data network" tap this. And edit the settings as follows.

Scroll down to where it says MMS

APN: wap.cingular
Username: -
Password: -
MMSC: http://mmsc.cingular.com/
MMS Proxy: wireless.cingular.com
MMS Max Message Size- 1048576
MMS UA Prof URL- http://www.apple.com/mms/usaprof.rdf

Tap Cellular in the left corner and YOU ARE DONE!!!! ENJOY!!!

NathanA
Nov 20, 2012, 04:43 AM
Scroll down to where it says MMS

APN: wap.cingular
[snip]

Your post is very interesting to me for a different but related reason (http://forums.macrumors.com/showthread.php?t=1486898). Can I ask you...

1) ...are you an AT&T customer?
2) ...what APN settings were in there for MMS before you changed them?

-- Nathan

Brianbazar
Jan 6, 2013, 09:49 PM
I am running 6.0 and had the same issue on Tmobile running a factory unlocked 4s.. I found you tube from everything apple and followed his instructions and that fixed the problem. However, I do not know if what I did means that my messages will be secure, or if they all now go to someone elses server. Does anyone know if this is safe?

fjd726
Mar 4, 2013, 05:56 PM
Anyone have a fix for this? I updated a week ago to 6.1.2 and I'm not able to send MMS through Imessage. I am able to receive MMS though. After sending on my end, it says delivered but other person does not receive it.

Gazwa
Mar 21, 2013, 06:02 AM
Re not being able to send mms

What worked fur me

Restore your iPhone so it's wiped and has freshly installed firmware , all your stuff will be wiped ( u can make backup Ofcourse)

Once wiped and restored i Set it up as new iPhone in iTunes

Problem seems to return at this point if u restore from backup. Especially if u restore gallery and messages something seems to be corrupted there

So I had backup my contacts (which I can't do without) to iCloud then restored contacts after the firmware install.


All fixed