PDA

View Full Version : UPDATED: Slow Shutdown Time With 10.8.2 AND 10.8.3




Pages : [1] 2

Prof.
Sep 20, 2012, 08:38 PM
Anyone else experiencing this? I have the new 2012 MacBook Pro, and since the release of 10.8.2, my shutdown time has gone from 1 to 3 seconds, to 30 seconds.

Still experiencing slow shutdown with 10.8.3 :(



cpm619
Sep 20, 2012, 09:10 PM
yeah I have definitely experienced this issue as well use to shut down in a few seconds now it takes at least 20.

Mike MA
Sep 21, 2012, 04:16 AM
Same for me - even with all applications closed beforehand... :mad:

4God
Sep 21, 2012, 04:17 AM
Yep, me too. What's up with that?

holy-piranha
Sep 21, 2012, 05:27 AM
Unfortunately, same here too.

2012 rMBP, same apps runnings, same settings etc as 10.8.1 and earlier - however, shutdown gone from 2-3 secs to 10-15+ secs.

Would REALLY welcome any thoughts / ideas / feedback! :)

Cheers.

itegypt
Sep 21, 2012, 06:24 AM
+1

3rd Rock
Sep 21, 2012, 07:46 AM
Thought it was just mine but add me to the list.... Not Good. Please come back if anyone has some thoughts as to why. :mad: I did a clean install, not an upgrade. All applications closed.

Perhaps we can all use the Apple feedback report linked below...I left a feedback just now.


http://www.apple.com/feedback/macosx.html

I have a MacMini, 16 GB ram, 5400 rpm Hdd, Integrated video.

dfine1966
Sep 21, 2012, 07:57 AM
Same here. Even tried PRAM reset. Have 2011 iMac. Never had slow startups or slow shutdowns until 10.8.2.

Zmijutin
Sep 21, 2012, 08:28 AM
Still slow shutdown/restart times with 10.8.0, 10.8.1 and latest 10.8.2. I just don't get it. MBP i7 and 6G SSD isn't enough for a 2 second restart?

ultraspiracle
Sep 21, 2012, 05:32 PM
Same here, even with an SSD it's slow now...

Mr. McMac
Sep 21, 2012, 05:34 PM
Same for me - even with all applications closed beforehand... :mad:

Same here

ultraspiracle
Sep 21, 2012, 07:51 PM
Another thread on this topic on the Apple discussion board - https://discussions.apple.com/message/19679581?ac_cid=tw123456#19679581

gnipun
Sep 21, 2012, 09:58 PM
I had the same problem (Actually, I had the same problem with 10.8.0) but then I got it fixed by performing the following steps:

1. Shut down your computer with "Reopen windows when logging..." CHECKED. (The shut down will be slow this time ~ 20 seconds)
2. Turn your computer on
3. Shut down with "Reopen windows when logging..." UNCHECKED. It now shuts down in 2 seconds

Note: with 10.8.2, my MacBook seems to shuts down in about 2 seconds whether I leave it checked or unchecked.

Good Luck!

Eatsleepdrivesc
Sep 21, 2012, 10:29 PM
I had the same problem (Actually, I had the same problem with 10.8.0) but then I got it fixed by performing the following steps:

1. Shut down your computer with "Reopen windows when logging..." CHECKED. (The shut down will be slow this time ~ 20 seconds)
2. Turn your computer on
3. Shut down with "Reopen windows when logging..." UNCHECKED. It now shuts down in 2 seconds

Note: with 10.8.2, my MacBook seems to shuts down in about 2 seconds whether I leave it checked or unchecked.

Good Luck!


This worked for me! Thanks!

pedrofan
Sep 21, 2012, 11:00 PM
Just clean system caches and the restart will be super fast. This has worked for me for ages.

Open terminal and write these commands:


sudo chown root:admin / (enter password when asked)

sudo kextcache -system-prelinked-kernel

sudo kextcache -system-caches



I have this commands in dashboard notes, so every time boot up gets slow I use them to restore it. With a ssd drive it makes reboot ultra fast.

ultraspiracle
Sep 22, 2012, 12:12 AM
Thanks for the suggestion. That didn't help my situation - (LOL). But, the menu bar disappeared and wouldn't come back for like a minute. ;)

That's not the first time I've seen this happen either, but it's ONLY happened since 10.8.2.

Should have stuck with Lion...it was SO fast and stable....

Prof.
Sep 22, 2012, 05:59 AM
I cleared my system caches with Disk Doctor (available on the Mac App Store) and it appears, for now, to have fixed the slow shutdown time.

MacMan988
Sep 22, 2012, 09:29 AM
I have the same issue. I have done a clean installation of ML and currently only iPhoto and iMovie is installed apart form what comes with the ML.

My start up time is slow (around 40 seconds) and i started ignoring it. But now the shut down time has come to the same situation...

3rd Rock
Sep 22, 2012, 10:46 AM
I had the same problem (Actually, I had the same problem with 10.8.0) but then I got it fixed by performing the following steps:

1. Shut down your computer with "Reopen windows when logging..." CHECKED. (The shut down will be slow this time ~ 20 seconds)
2. Turn your computer on
3. Shut down with "Reopen windows when logging..." UNCHECKED. It now shuts down in 2 seconds

Note: with 10.8.2, my MacBook seems to shuts down in about 2 seconds whether I leave it checked or unchecked.

Good Luck!

Didn't work for me either. Tried a few times and no go. Thanks anyway

bushido
Sep 22, 2012, 11:54 AM
i reset my PRAM and it shut down quickly .... once :(:mad:

thatoneguy82
Sep 23, 2012, 11:18 PM
I had the same problem (Actually, I had the same problem with 10.8.0) but then I got it fixed by performing the following steps:

1. Shut down your computer with "Reopen windows when logging..." CHECKED. (The shut down will be slow this time ~ 20 seconds)
2. Turn your computer on
3. Shut down with "Reopen windows when logging..." UNCHECKED. It now shuts down in 2 seconds

Note: with 10.8.2, my MacBook seems to shuts down in about 2 seconds whether I leave it checked or unchecked.

Good Luck!

Just clean system caches and the restart will be super fast. This has worked for me for ages.

Open terminal and write these commands:


sudo chown root:admin / (enter password when asked)

sudo kextcache -system-prelinked-kernel

sudo kextcache -system-caches



I have this commands in dashboard notes, so every time boot up gets slow I use them to restore it. With a ssd drive it makes reboot ultra fast.

I tried both methods and I'm still having a slow shutdown. Also, I have slower start-up times since ML. Odd because I have a Samsung 830 SSD.

Other methods?

colloc
Sep 23, 2012, 11:24 PM
I tried both methods and I'm still having a slow shutdown. Also, I have slower start-up times since ML. Odd because I have a Samsung 830 SSD.

Other methods?

How long's your start up/shut off time? Also you Mac's specifications?

thatoneguy82
Sep 23, 2012, 11:46 PM
How long's your start up/shut off time? Also you Mac's specifications?
EDIT:

Used a stopwatch and from off to gray Apple and wheel spinning is ~30 seconds and login screen is about ~40 seconds. Around 15-20 seconds. I have a mid-2010 MBP. i5 2.53Ghz 8GB RAM 25GB GB Samsung 830 HD and WD Blue 1TB HDD in the optibay.

ultraspiracle
Sep 24, 2012, 03:40 AM
Mine is mid 2012, 2.7 GHz, 500 SSD, 16GB RAM. 30 seconds or more.

jffluis
Sep 24, 2012, 04:49 AM
Let's wait for a fix.

http://www.youtube.com/watch?v=FGBhQbmPwH8&feature=player_detailpage#t=47s

SR45
Sep 24, 2012, 08:48 AM
MacMini 2011 > 5400 rpm Hdd >16 GB Ram > Integrated Video > Only "Pages" > "Ad Blocker" installed on system

22/25 second Shut down

40 seconds Boot up

colloc
Sep 24, 2012, 08:57 AM
EDIT:

Used a stopwatch and from off to gray Apple and wheel spinning is ~30 seconds and login screen is about ~40 seconds. Around 15-20 seconds. I have a mid-2010 MBP. i5 2.53Ghz 8GB RAM 25GB GB Samsung 830 HD and WD Blue 1TB HDD in the optibay.

Your start up time is really long for a SSD-powered MBP. From watching several the start up tests on youtube I think yours should have been only about 15 secs. Seems like shutdown time is not the only thing that is worsen in 10.8.2.

Prof.
Sep 24, 2012, 12:39 PM
As I mentioned before, I cleared my system caches and it seemed to fix the problem. Unfortunately, the problem is back - my new MacBook Pro is slow-to-shutdown again. :(

ultraspiracle
Sep 24, 2012, 09:47 PM
As I mentioned before, I cleared my system caches and it seemed to fix the problem. Unfortunately, the problem is back - my new MacBook Pro is slow-to-shutdown again. :(

That's pretty interesting...

vmz
Sep 25, 2012, 08:54 AM
+1. Hope Apple will fix it soon.

Dreamer2go
Sep 25, 2012, 09:04 AM
hey guys
my startup is okay with rMBP

but when I restart (as i want to go to boot camp), I always receive a Spinning Gear every time I "shut down" Mac OSX

does it happen to you?

famusc
Sep 25, 2012, 01:51 PM
I tried this on my mba mid 2012

sudo atsutil databases -remove

and it solved slow shutdown. But it works once.
I have to retype it everytime.

Wuold you try and report?

alberto85
Sep 27, 2012, 03:43 AM
I was with the same problem. Finally i've solved my problem. The problem was a Widget in Dashboard. If i loaded the Dashboard, slow shutdown and if not, fast shutdown.

The problematic widget for me was Wunderground Weather widget. Hope can help someone

razmarino
Sep 27, 2012, 03:59 AM
same here on 2011mba/i7/256ssd.. tried everything, but it stills very slow to boot up and shutdown after clean install of 10.8.2. but have to admit, that everything else is much more faster and stable than on 10.7.5

SR45
Sep 27, 2012, 08:19 AM
I was with the same problem. Finally i've solved my problem. The problem was a Widget in Dashboard. If i loaded the Dashboard, slow shutdown and if not, fast shutdown.

The problematic widget for me was Wunderground Weather widget. Hope can help someone

Only widget in dashboard and still slow down issues on Shut Down

Thanks anyway.....

Mike MA
Sep 27, 2012, 08:20 AM
same here on 2011mba/i7/256ssd.. tried everything, but it stills very slow to boot up and shutdown after clean install of 10.8.2. but have to admit, that everything else is much more faster and stable than on 10.7.5

Also went through all the proposals recommended the last few days - nothing worked for me either. Shutdown time still increased from approximately 1 (10.8.1 and before) to 15 seconds (10.8.2) with no heavy usage or whatsoever. Startup is the same as before.

Now it's Apple's turn.....

Zmijutin
Sep 27, 2012, 09:13 AM
I was with the same problem. Finally i've solved my problem. The problem was a Widget in Dashboard. If i loaded the Dashboard, slow shutdown and if not, fast shutdown.

The problematic widget for me was Wunderground Weather widget. Hope can help someone

I don't even use dashboard but shutdowns are still slow

wrldwzrd89
Sep 28, 2012, 06:53 AM
Weird. I'm having the exact OPPOSITE happening since 10.8.2. I have a 2011 iMac 27". Typical times are below.

Cold boot: 30 seconds
Warm boot: 20 seconds
Shut down: <5 seconds (!)

I have no idea why shutting down is that fast. It's so fast that my timing method can't accurately capture it.

MacBird
Sep 28, 2012, 02:42 PM
I followed the advice to delete Google Chrome and it shuts down very quickly now. It also fixed the missing sounds in Apple Mail after sleep. I'll keep my fingers crossed that Chrome was the culprit.

colloc
Sep 28, 2012, 08:56 PM
Weird. I'm having the exact OPPOSITE happening since 10.8.2. I have a 2011 iMac 27". Typical times are below.

Cold boot: 30 seconds
Warm boot: 20 seconds
Shut down: <5 seconds (!)

I have no idea why shutting down is that fast. It's so fast that my timing method can't accurately capture it.

Do you have chrome currently installed?

Colombianito
Sep 28, 2012, 09:18 PM
I have been following this thread because I too have had slow shutdown times. I deleted chrome, deleted cache, launch agents and launch demons. I was still getting around 30 second shutdowns.

When shutting down and leaving reopen windows when logging back in unchecked I am still getting 30 second shutdowns.

However, if I CHECK it, I get around 5 second shutdowns.

I am running a 13-inch, Early 2011 Macbook Pro, 2.7 GHz Intel Core i7, 16 GB 1600 MHz DDR3, and Samsung 830 512GB SDD.

velo
Sep 28, 2012, 10:21 PM
I've tried all the suggestions and still get slow shutdown times on a 2012 mba.

Deleting Chrome worked once but the very next shutdown went back to being slow.

ParryD
Sep 29, 2012, 02:43 AM
It surely has to do with Mountain Lion rather than all our machines. Have a MBP 13 Late 2011 bought in June 2012 with Lion 10.7.4 and have experienced Slow boot-up, Slow Shut down & less battery backup with upgrading to ML.

Deleted my system Caches, LaunchAgents & LaunchDaemons; also tried with checking & unchecking of login window but no luck. I am experiencing 35 secs to Login Screen & 10-15 secs thereafter. And shut down is 25-30secs.

Have tried Apple Support Communities and just had a word with Apple Support all they have to say is we have tried all troubleshooting only last resort is a Clean Install.

wrldwzrd89
Sep 29, 2012, 04:58 AM
Do you have chrome currently installed?
Hmm. Odd. I do have Chrome installed, and set as the default browser... but that 5s shutdown must have been a one-time blip, because the next time I shut it down, it took 35s. Surely having 2 external drives connected isn't helping.

Zmijutin
Sep 29, 2012, 06:06 AM
I have been following this thread because I too have had slow shutdown times. I deleted chrome, deleted cache, launch agents and launch demons. I was still getting around 30 second shutdowns.

When shutting down and leaving reopen windows when logging back in unchecked I am still getting 30 second shutdowns.

However, if I CHECK it, I get around 5 second shutdowns.

I am running a 13-inch, Early 2011 Macbook Pro, 2.7 GHz Intel Core i7, 16 GB 1600 MHz DDR3, and Samsung 830 512GB SDD.

same thing here. Doesn't make any sense?!

yanki01
Sep 30, 2012, 11:14 AM
mid 09 MBP and its slow here.

marshy82
Oct 1, 2012, 04:00 AM
deleting the java folder from library worked for me, shutdown time gone back to 2 seconds

Thanks :)

colloc
Oct 1, 2012, 04:38 AM
deleting the java folder from library worked for me, shutdown time gone back to 2 seconds

Thanks :)

Make sure it's a permanent fix. Many of us here got the same problem again after a 1 time fast shutdown.

razmarino
Oct 1, 2012, 05:07 AM
Make sure it's a permanent fix. Many of us here got the same problem again after a 1 time fast shutdown.
confirmin' this

Zmijutin
Oct 1, 2012, 10:39 AM
That's good for some of you, but I don't have Java folder in my Library :confused:

Lunchb0x8
Oct 1, 2012, 10:55 PM
Mine seems to be fixed after doing all of the following (in this order);

the kext script listed earlier
Select the SSD as the boot drive
check the open applications on startup, reboot and uncheck.
Verify and repair disk permissions
Run automation scripts for all on Onyx.

Now I get a 2-4 second shutdown and a 9 second boot.

EDIT: I deleted the Java folders, but it was fixed before this (just did it for good measure.

EDIT 2: I am now getting slow as a dog shut downs again.

marshy82
Oct 2, 2012, 10:13 AM
Make sure it's a permanent fix. Many of us here got the same problem again after a 1 time fast shutdown.

your right :mad: shutdown a few times and now it has gone back to 30 seconds

colloc
Oct 2, 2012, 10:21 AM
Mine seems to be fixed after doing all of the following (in this order);

the kext script listed earlier
Select the SSD as the boot drive
check the open applications on startup, reboot and uncheck.
Verify and repair disk permissions
Run automation scripts for all on Onyx.

Now I get a 2-4 second shutdown and a 9 second boot.

EDIT: I deleted the Java folders, but it was fixed before this (just did it for good measure.

EDIT 2: I am now getting slow as a dog shut downs again.

You must be asian! Dogs are not slow FYI :apple:

Atarikid
Oct 2, 2012, 01:45 PM
Some people don't want to understand what has been written before. :)
So again.

Apple knows about this issue and there is NO fix for this. Whatever you do, it will always revert to the same problem (memory hashes that cannot be released on shutdown).

This means: we will have to wait for a OSX update to fix it.

vea1083
Oct 3, 2012, 11:38 AM
Some people don't want to understand what has been written before. :)
So again.

Apple knows about this issue and there is NO fix for this. Whatever you do, it will always revert to the same problem (memory hashes that cannot be released on shutdown).

This means: we will have to wait for a OSX update to fix it.
Atarikid,

Hello, I have filed a bug report with Apple last afternoon, I was wondering where you got this information that Apple is aware of this issue. Did you get this from AppleCare?

To other posters,

Now, I would like that anyone that is experiencing this issue to do the following with their Macs. I would like you guys to boot them in Verbose mode, this function will make your Mac show a BIOS type boot up (don't worry, the computer will automatically switch to a normal OS X GUI mode when it gets into the user account or log in screen. When it comes time for a shutdown, the computer will switch to BIOS mode again and show which processes are running at shutdown time and which are taking the longest.

To boot your Mac in verbose mode do the following steps as outlines on this Apple Support Article (located at http://support.apple.com/kb/HT1492):

Starting up in verbose mode:
1. Shut down your Mac if it is on.
2. Press the power button to start the computer.
3. Immediately press and hold the Command (Apple) key any of the following:
the "v" key for verbose mode. (Command-V).

In my case what is holding up the shutdown is the launchd.peruser.501 process. I saw that during the shutdown the system made multiple attempts to close it down and it took the computer about 20 seconds to do so.

If my theory is correct, that same process should show on most Macs that are experiencing the issue. This is happening to me on a Mac that has had to clean installs of OS X Mountain Lion 10.8.2 using the "full" Mac App Store 10.8.2 installer which was released about 2 weeks ago.

In addition to that theory, a member in the Apple Support forums mentioned that the issue seems to be derived to a persistently enabled Resume feature that is trying to save the computer's state during shutdown. You can read the topic here:
https://discussions.apple.com/message/19800407#19800407

That's my insight and I would appreciate any help on this matter in order to build a good case on this bug and provide evidence to Apple engineering that this long shutdown issue in OS X Mountain Lion is a legitimate one!

Again thanks!

Mike MA
Oct 5, 2012, 03:28 AM
Anyone else seeing the issue fixed under 10.8.2?

Edited: Mine still is slow occasionally...

SR45
Oct 5, 2012, 07:38 AM
Anyone else seeing the issue fixed under 10.8.2?

No. That is when I got the slow down....

I have filed a bug report with Apple over a week ago. Everyone should do same and hope Apple will take notice.

Edited: Yup, I get the .501 as well Vea1083

SR45
Oct 5, 2012, 07:51 AM
OK everyone.....

Just noticed a few minutes ago, that my shutdown went from about 20 seconds to about 4 seconds and I did nothing, no changes on my part. What I did yesterday was download the OS supplemental from Apples Update site and that is it. That was yesterday, but when I shutdown yesterday a couple times after the update, the shutdown time was still 20 seconds. Today I have shutdown three times to make sure it was not a flute and shutdown is now about 4 seconds.

Anyone else notice this ?

SR45
Oct 5, 2012, 08:22 AM
This is Nutty....

After 5 very fast shutdowns, its now back up to a 20 second shutdown again. What the heck is doing this ?

I give up :(

Mr. McMac
Oct 5, 2012, 08:31 AM
This is Nutty....

After 5 very fast shutdowns, its now back up to a 20 second shutdown again. What the heck is doing this ?

I give up :(

My Mac's still do it after the update. Hopefully Apple will find a fix soon.

BTW, I knew the sleep shortcut, but not the shutdown one. I thank you :)

SR45
Oct 5, 2012, 09:07 AM
This is so odd that the shutdown was so fast today at first, but now back up to the longer time. Cannot figure this out one bit. Oh well, just have to wait it out :(

You are welcome Mr. McMac

Prof.
Oct 5, 2012, 09:17 AM
The 10.8.2 supplemental update fixed the slow shutdown time for a few mins, but now it's back to 30+ seconds to shut down.

RMSko
Oct 8, 2012, 09:12 AM
The 10.8.2 supplemental update fixed the slow shutdown time for a few mins, but now it's back to 30+ seconds to shut down.

Exact same thing happened for me. I'm wondering whether it has something to do with iCloud and contact/Safari syncing.

RMSko
Oct 8, 2012, 09:48 AM
One thing to add that is strange. If I shut down with Safari open, the shut down time goes to 2 seconds. I have no idea why having Safari open changes things though. Anyone have any thoughts?

SR45
Oct 8, 2012, 11:50 AM
One thing to add that is strange. If I shut down with Safari open, the shut down time goes to 2 seconds. I have no idea why having Safari open changes things though. Anyone have any thoughts?

Tried this. Instead of 20 second shutdown, it took 11 seconds, which is an improvement. Will keep on trying. Nothing else to do ;) :D

Edit: Second try with Safari open only, now the shut down speed took 2 seconds. Goodness. Think I will continue to do it this way.

RMSko
Oct 8, 2012, 01:03 PM
Tried this. Instead of 20 second shutdown, it took 11 seconds, which is an improvement. Will keep on trying. Nothing else to do ;) :D

Edit: Second try with Safari open only, now the shut down speed took 2 seconds. Goodness. Think I will continue to do it this way.

Yup, I'm getting similar results. The real question is why???

xgman
Oct 8, 2012, 01:24 PM
Yeah that is odd. Sometimes I wish there was an app that just pulled the plug on all shut down sluggish operations. Quite frankly you should be able to just power on & off like a tv at this point in time. Booting up seems so 90's.

Mike MA
Oct 9, 2012, 04:36 AM
Yeah that is odd. Sometimes I wish there was an app that just pulled the plug on all shut down sluggish operations. Quite frankly you should be able to just power on & off like a tv at this point in time. Booting up seems so 90's.

Well, that's why they've introduced things like sleep or standby mode - but with the battery draining issues appearing since Lion (yes, even in sleep mode - even though things got better with 10.8.2) this actually isn't a great option either.

So at the moment you can chose between Windows-like shutdown times or charging your battery twice a day :rolleyes:

Krazy Bill
Oct 9, 2012, 10:16 AM
Yeah that is odd. Sometimes I wish there was an app that just pulled the plug on all shut down sluggish operations. Quite frankly you should be able to just power on & off like a tv at this point in time. Booting up seems so 90's.Just hold the power button down for 3 seconds. :D

But you really don't want that kind of app. The OS needs to close files and save restore points "gracefully".

SR45
Oct 9, 2012, 11:27 AM
Just hold the power button down for 3 seconds. :D

But you really don't want that kind of app. The OS needs to close files and save restore points "gracefully".

What restore points ? Windows OS yes, but I've never seen one for OS X

xgman
Oct 9, 2012, 11:30 AM
The leave Safari open test didn't shut down any faster for me.

SR45
Oct 9, 2012, 12:31 PM
The leave Safari open test didn't shut down any faster for me.

Mine did for awhile, but now it does not for some reason. I give up on this until apple comes out with a fix if they ever do... :(

Krazy Bill
Oct 9, 2012, 12:57 PM
What restore points ? Windows OS yes, but I've never seen one for OS XI mean... OSX is writing your current session to disk so it can be restored on a reboot.

JBat
Oct 9, 2012, 01:14 PM
This worked for me! Thanks!

This one didn't work for me.

----------

I just received my 13" Air yesterday - 2.0, 256, 8 gigs - and it came with ML installed, which I was then prompted to update to .2. I don't have much of a point of reference, but I'm experiencing what others are experiencing; slow shutdown and start-up.

Prof.
Oct 9, 2012, 02:28 PM
No. That is when I got the slow down....

I have filed a bug report with Apple over a week ago. Everyone should do same and hope Apple will take notice.

Edited: Yup, I get the .501 as well Vea1083
Where did you go to file a bug report?

3rd Rock
Oct 9, 2012, 04:09 PM
I reported right here..

http://www.apple.com/feedback/macosx.html

SR45
Oct 9, 2012, 04:13 PM
You can file a Bug report at this link below as well..

https://bugreport.apple.com/cgi-bin/WebObjects/RadarWeb.woa/wa/signIn

----------

I mean... OSX is writing your current session to disk so it can be restored on a reboot.


Got it. ;)

SR45
Oct 9, 2012, 04:48 PM
Just sent a bug report myself. Just have to wait it out. Apple normally does not respond unless this issue is reported in the mainstream media...

razmarino
Oct 9, 2012, 05:00 PM
looks like a problem founded - appleeventsd process causes slow shutdown.. killin it gives a temporary solution

Prof.
Oct 9, 2012, 07:15 PM
But report submitted. Let's hope the engineer team actually reads these things... :rolleyes:

Krazy Bill
Oct 10, 2012, 01:28 PM
Just sent a bug report myself. Just have to wait it out. Apple normally does not fix things unless this issue is reported in the mainstream media...

I corrected your grammar. :D

SR45
Oct 10, 2012, 01:35 PM
I corrected your grammar. :D

Thank you. That was an oversight on my part.. ;) :D

Badagri
Oct 10, 2012, 02:15 PM
It bugs me so much to see Windows 7 64bit shuts down in less than 5 seconds and as we all know Mountain Lion can take 20 - 30+ seconds. At least with Lion you hit shutdown then it was click. Black screen. 1 second was all it took.

colloc
Oct 10, 2012, 07:30 PM
It bugs me so much to see Windows 7 64bit shuts down in less than 5 seconds and as we all know Mountain Lion can take 20 - 30+ seconds. At least with Lion you hit shutdown then it was click. Black screen. 1 second was all it took.
completely agree

Mike MA
Oct 12, 2012, 09:56 AM
You can file a Bug report at this link below as well..

https://bugreport.apple.com/cgi-bin/WebObjects/RadarWeb.woa/wa/signIn[COLOR="#808080"]

Bug report submitted. Really wonder how long this will take. I mean, look at the number of people being affected - just can't believe that no one from the developer/ testing teams was aware...back to the Mac...

krasnoyarsk
Oct 14, 2012, 05:03 AM
I tried both methods and I'm still having a slow shutdown. Also, I have slower start-up times since ML. Odd because I have a Samsung 830 SSD.

Other methods?

I have the same SSD and the Terminal solution did help. Thanks to the author!

colloc
Oct 14, 2012, 11:26 AM
I have the same SSD and the Terminal solution did help. Thanks to the author!

How long does your system start up with an SSD in ML? The previous users reported having 30-40 secs startup with SSD equipped MBP, which is very odd.

Prof.
Oct 14, 2012, 11:39 AM
30-40 seconds to boot up with an SSD?! That's crazy! My MBP takes that long with a 7200 RPM HDD.

colloc
Oct 14, 2012, 01:16 PM
30-40 seconds to boot up with an SSD?! That's crazy! My MBP takes that long with a 7200 RPM HDD.

Yeah I know. I am planning to install my Samsung 830, and if this is true, I am sticking with Lion again.

Mike MA
Oct 15, 2012, 02:58 PM
How long does your system start up with an SSD in ML? The previous users reported having 30-40 secs startup with SSD equipped MBP, which is very odd.

16,9 seconds with automatic login activated - faster than the current shutdown :rolleyes:

Rob C
Oct 15, 2012, 09:24 PM
Im also using a Samsung 830 SSD, in ML my MBP starts up in about 17 seconds everytime, but as with everyone else my shutdown speed is slower than this...

Its not the end of the world as i just walk off, but would be nice for it to be sorted!!

colloc
Oct 15, 2012, 10:02 PM
Was it faster when you were running Lion?

Rob C
Oct 15, 2012, 10:15 PM
Was it faster when you were running Lion?

I dont know as i didnt have SSD when i had Lion :(

Badagri
Oct 16, 2012, 02:46 PM
Bug report submitted. Really wonder how long this will take. I mean, look at the number of people being affected - just can't believe that no one from the developer/ testing teams was aware...back to the Mac...

Anyone at Apple has to know about this to even Tim. Do none of them shutdown their computers? how can such a problem be not known.

ljx718
Oct 16, 2012, 08:47 PM
looks like a problem founded - appleeventsd process causes slow shutdown.. killin it gives a temporary solution

this. shut down before quitting the process is 25+, after its ~2 sec

colloc
Oct 16, 2012, 10:03 PM
Anyone at Apple has to know about this to even Tim. Do none of them shutdown their computers? how can such a problem be not known.

Probably they are too busy working on their retina macbook pros. Us cMBR have the least of their attention.

Krazy Bill
Oct 16, 2012, 11:18 PM
looks like a problem founded - appleeventsd process causes slow shutdown.. killin it gives a temporary solutionDitto here. Shutdown almost immediate.

I just hope I just didn't nuke my iCloud account or create havoc on a Pentagon server somewhere.

Skoopman
Oct 17, 2012, 06:11 AM
Ditto here. Shutdown almost immediate.

I just hope I just didn't nuke my iCloud account or create havoc on a Pentagon server somewhere.

Lol no, appleeventsd just delivers some Apple events to Finder.

RMSko
Oct 24, 2012, 02:49 PM
Ditto here. Shutdown almost immediate.

I just hope I just didn't nuke my iCloud account or create havoc on a Pentagon server somewhere.
I have slow shutdown and don't have appleeventsd running. Can someone confirm tho that this is a permanent fix and that the problem did not reoccur. It seems like most of the other fixes suggested did fix the problem, but then it returned after a few days.

ryannazaretian
Oct 24, 2012, 04:24 PM
I just did a full drive wipe (zeroed out), installed OSX using Internet Recovery, Updated all the software, and guess what... still slow shutdown! I have NO 3rd party tools installed, and the drive is about as virgin as you can get.

So... it's truly an OSX thing?

Other ideas...
Who here has an all OEM Mac? Meaning: You have not opened the case to your Mac, and all components attached or inside of the computer are stock to your computer?

You might be curious as to why I did a full wipe... basically... Windows was messing up bad on me... OSX had its own issues (MacPort would not work at all, and I wanted TortoiseHG). Figured it was time to reinstall both, and I'd rather have a fully clean slate to work on rather than one not zeroed out. Zeroing out a SSD increases performance initially.

Mike MA
Oct 24, 2012, 06:11 PM
Just quickly wanted to share that the Apple Developer Team contacted me today after submitting a bug report last week.

So at least they beginn to show some interest. Anybody else got a response yet?

colloc
Oct 24, 2012, 09:26 PM
ML clean install, SSD installed, boot time 10 secs, shutdown time still as long as ever.

maxonthemac
Oct 28, 2012, 02:02 PM
Hi all! I'm at my first post, but think I have some useful information to share.

As correctly pointed out in post #79, in my case the slow shutdown was due to the appleeventsd process hanging.

To discover it, I went through 2 steps:

booting in verbose mode (http://support.apple.com/kb/HT1492) and checking the messages issued during shutdown; you may notice repeated attempts to quit a specific process; in my case, they addressesed some stuck com.apple.coreservices.appleevents task;
launching the Console application from the Spotlight and browsing through one of the system-wide launchd-shutdown logs; in my case, I found that the above mentioned task was killed after an expired timeout of 20 seconds; not much surprisingly, my shutdown took 22 seconds (=20 seconds for the timeout + the usual 2 seconds I normally experienced for the shutdown).

So, the culprit apparently was a service managed by launchd. launchd is a daemon that takes care of starting, stopping, and monitoring many system-wide and user-specific services. From the documentation (man page) of launchd.plist, when one of these services is to be stopped, it is sent a SIGTERM signal to halt gracefully. If it does not react within the predefined 20 seconds timeout, it is hardly terminated with a SIGKILL.

So, I have put the following workaround in place.
The default timeout value can be changed by editing the .plist XML file that describes the service parameters. For the case of appleeventsd, this file is /System/Library/LaunchDaemons/com.apple.coreservices.appleevents.plist. So, I made a backup copy of this file and carefully edited it by adding the following 2 lines right before the two final closing tags </dict> and </plist>:
<key>ExitTimeOut</key>
<integer>2</integer>
Be very careful when editing this file and, really, make a backup copy, because there are chances that a wrong edit may screw some system components (most notably, the Finder application).

It took a reboot cycle to make launchd fetch the updated timeout value, but this did the trick: the appleeventsd service is still reported as stuck during shutdown, but at least only 2 seconds are waited before giving up waiting, totaling 4 (=2+2) seconds of shutdown time. I know, it's a very dirty workaround but, until a proper fix comes, it makes me very happy! :D


A couple of side notes:

In my personal experience there have been different services intermittently affected by this issue but, ultimately, killing appleeventsd seems to have (hopefully) permanently solved the slow shutdown problem for me.
I have just noticed that a similar solution has already been independently posted elsewhere: https://discussions.apple.com/thread/4339540?start=60&tstart=0. If only I could find it earlier...


I would really like to also post this to the relevant Apple Discussions forums, but it seems the system decided not to let me even create a nickname, leaving me with a mysterious "An unknown error has occurred" message. Apparently, logging in to Apple Discussions is another problem that has been suffered for long by many people, therefore I'm giving up on that (for now...)

I hope this helps someone.

Mike MA
Oct 28, 2012, 04:22 PM
I hope this helps someone.

You should file a bug report dealing with your findings:

https://bugreport.apple.com/cgi-bin/WebObjects/RadarWeb.woa/wa/signIn

As I stated before, Apple began to show some interest after I provided some system logs.

RS2
Oct 28, 2012, 04:23 PM
These terminal commands should also fix the problem then and kill the services after 2 seconds:

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.coreservices.appleevents.plist

sudo defaults write /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut -int 2

sudo launchctl load /System/Library/LaunchDaemons/com.apple.coreservices.appleevents.plist

MacMan988
Oct 28, 2012, 09:24 PM
I love apple products. But it would have been even better if Apple spends a bit more on software QA than this. Specially since Apple products always comes with a larger price tag attached.

----------

You should file a bug report dealing with your findings:

https://bugreport.apple.com/cgi-bin/WebObjects/RadarWeb.woa/wa/signIn

As I stated before, Apple began to show some interest after I provided some system logs.

When I try to login to that link you have given, it gives the following error.


An error has occurred. Please report the error to Apple Inc. by emailing the error detail to devbugs@apple.com.

I think apple should start reading about software testing before releasing their next software product....

maxonthemac
Oct 30, 2012, 05:22 AM
I think the solution proposed by RS2 in this post (http://forums.macrumors.com/showpost.php?p=16163178&postcount=105) implements even more cleanly what I have proposed in the workaround I have described.

I'm not sure whether the -w option of launchctl is required, though. AFAIK, what it does is to permanently flag the affected service as "Disabled", so that it is never loaded at reboot (or whenever it would need to). Given that here we just want the service to be temporarily unloaded (so that launchd can fetch the configuration change without rebooting) and that the launchctl unload -w is immediately compensated by a launchctl load -w, I think the -w can be safely avoided overall.

P.S. I'm still suspicious about what could be causing appleeventsd to hang, but still could not consistently ascribe this to any specific softwares I am using. The only thing I have noticed is that, the more applications I run since boot, the more likely it is that appleeventsd needs to be killed. Apparently, just starting and immediately closing an Office application (Word, Excel, PowerPoint) significantly increases the chance that the hang happens for me.

RS2
Oct 30, 2012, 06:48 AM
I'm not sure whether the -w option of launchctl is required, though.

You are totally right, I will correct the terminal commands in the post above.

razmarino
Oct 30, 2012, 07:00 AM
These terminal commands should also fix the problem then and kill the services after 2 seconds:

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.coreservices.appleevents.plist

sudo defaults write /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut -int 2

sudo launchctl load /System/Library/LaunchDaemons/com.apple.coreservices.appleevents.plist
still 20sec to shutdown.. am i missing smth?

maxonthemac
Oct 30, 2012, 07:36 AM
still 20sec to shutdown.. am i missing smth?

Maybe it's some other service that is slowing down your shutdown. You can attempt discovering which one by booting in verbose mode (http://support.apple.com/kb/HT1492) and looking at the messages issued during shutdown, or by opening the Console application and browsing through the system-wide and user-specific launchd-shutdown logs. Of course, provided that it's some launchd managed service that is causing the slowdown.

razmarino
Oct 30, 2012, 07:52 AM
EDIT: Everythin is fine) its like a pain relief! thx maxonthemac & RS2!! now i can go to sleep without irritation every time when turnin off this machine)

RS2
Oct 30, 2012, 10:09 AM
When I compare the launchd-shutdown logs there are two processes that are killed after 20 seconds.

com.apple.launchd 1 com.apple.securityd 15 Exit timeout elapsed (20 seconds)
com.apple.launchd 1 com.apple.securityd 15 Sent SIGKILL signal

com.apple.launchd 1 com.apple.coreservices.appleevents 63 Exit timeout elapsed (20 seconds)
com.apple.launchd 1 com.apple.coreservices.appleevents 63 Sent SIGKILL signal

Looks like the securityd daemon is supposed to do something at shutdown but is also killed?

sudo defaults read /System/Library/LaunchDaemons/com.apple.securityd

{
BeginTransactionAtShutdown = 1;
EnableTransactions = 1;
Label = "com.apple.securityd";
LaunchOnlyOnce = 0;
MachServices = {
"com.apple.SecurityServer" = {
ResetAtClose = 1;
};
};
ProgramArguments = (
"/usr/sbin/securityd",
"-i"
);
RunAtLoad = 1;
}

razmarino
Oct 30, 2012, 10:17 AM
im guessin, if apple will release a fix for this with 8.3 update, do we have to reverse those changes we made before updatin, or just update as usual?
also noticed, that shutdown is not always quick after those changes to appleeventsd, looks like there is smth else which still hangin up..
but when i kill appleeventsd manually before shutdown, its always rapid, so a little confused here

RS2
Oct 30, 2012, 12:47 PM
im guessin, if apple will release a fix for this with 8.3 update, do we have to reverse those changes we made before updatin, or just update as usual? also noticed, that shutdown is not always quick after those changes to appleeventsd, looks like there is smth else which still hangin up.. but when i kill appleeventsd manually before shutdown, its always rapid, so a little confused here

You can update as usual and reverse the changes by deleting the ExitTimeOut key from the plist.

Please see above. The securityd daemon can also be the problem. Check the launchd-shutdown logs.

razmarino
Oct 30, 2012, 01:24 PM
guys, can anyone send me an original appleevents.plist in pm?)) looks i messed up everything here)) this is how looks mine now after those manipulations)))

RS2
Oct 30, 2012, 01:47 PM
guys, can anyone send me an original appleevents.plist in pm?

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ExitTimeOut</key>
<integer>2</integer>
<key>Label</key>
<string>com.apple.coreservices.appleevents</string>
<key>LowPriorityIO</key>
<false/>
<key>MachServices</key>
<dict>
<key>com.apple.coreservices.appleevents</key>
<true/>
</dict>
<key>ProgramArguments</key>
<array>
<string>/System/Library/CoreServices/appleeventsd</string>
<string>--server</string>
</array>
<key>RunAtLoad</key>
<true/>
<key>UserName</key>
<string>_eppc</string>
</dict>
</plist>

sudo defaults read /System/Library/LaunchDaemons/com.apple.coreservices.appleevents

{
ExitTimeOut = 2;
Label = "com.apple.coreservices.appleevents";
LowPriorityIO = 0;
MachServices = {
"com.apple.coreservices.appleevents" = 1;
};
ProgramArguments = (
"/System/Library/CoreServices/appleeventsd",
"--server"
);
RunAtLoad = 1;
UserName = "_eppc";
}

RS2
Oct 30, 2012, 01:57 PM
guys, can anyone send me an original appleevents.plist in pm?

Don't try to use TextEdit to read or change plist files! Please use terminal commands to reverse instead.

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.coreservices.appleevents.plist

sudo defaults delete /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut

sudo launchctl load /System/Library/LaunchDaemons/com.apple.coreservices.appleevents.plist

razmarino
Oct 30, 2012, 02:22 PM
Don't try to use TextEdit to read or change plist files! Please use terminal commands to reverse instead.

yes, i know that, i was using text wrangler, but not sure what i did wrong.. i have already replaced corrupted file and everythin is ok now. thanks a lot for your support! will make another attempt after reading correct info on the subject)

razmarino
Oct 30, 2012, 05:16 PM
pheeew, missed slash before second "integer", right before your nose and invisible)
used terminal this time and it turned out pretty simple, so fix itself is really :apple:

blatopilot
Oct 30, 2012, 10:20 PM
Sharing a couple of thoughts:

Is anyone experiencing this, and NOT using iCloud? Is anyone experiencing this and NOT have an mobile device they are syncing?

I'm curious because I backed up my MBP and iPhone 4s, then signed out of icloud and deleted all data related to iCloud I could find (contacts, calendars, notes, photo stream etc) on both devices. I tried to purge any trace of this data ever existed. On the MBP, this includes: Caches, application support, application saved state, even plists if you know what you are doing.

I then signed into iCloud on my phone, toggled what I wanted to sync, and now my iPhone and MPB are running like brand new. Very fast start up and shut down. My phone became more responsive and smooth (I forgot how fast it WAS), my MPB is loading pages faster than I can keep up. I have not re-set up iCloud on my Mac (I don't need it as much), but if you have backups, it wouldn't hurt to purge everything and start over.

Eithanius
Oct 31, 2012, 04:09 AM
Sharing a couple of thoughts:

Is anyone experiencing this, and NOT using iCloud? Is anyone experiencing this and NOT have an mobile device they are syncing?

I'm curious because I backed up my MBP and iPhone 4s, then signed out of icloud and deleted all data related to iCloud I could find (contacts, calendars, notes, photo stream etc) on both devices. I tried to purge any trace of this data ever existed. On the MBP, this includes: Caches, application support, application saved state, even plists if you know what you are doing.

I then signed into iCloud on my phone, toggled what I wanted to sync, and now my iPhone and MPB are running like brand new. Very fast start up and shut down. My phone became more responsive and smooth (I forgot how fast it WAS), my MPB is loading pages faster than I can keep up. I have not re-set up iCloud on my Mac (I don't need it as much), but if you have backups, it wouldn't hurt to purge everything and start over.

That does not make any sense at all... I don't use iCloud, yet ML still startup and shut down slower than SL...

If there are some correlations over iCloud and the the speed of ML starting up and shutting down, I'm glad iCloud is never on SL...

blatopilot
Oct 31, 2012, 09:29 AM
That does not make any sense at all... I don't use iCloud, yet ML still startup and shut down slower than SL...

If there are some correlations over iCloud and the the speed of ML starting up and shutting down, I'm glad iCloud is never on SL...

That is why I was asking if it was limited to icloud users. To assist in troubleshooting. Hopefully there is a fix soon.

RS2
Oct 31, 2012, 09:40 AM
If you have a very slow shutdown time (+20 seconds) please open the Console app and check the system launchd-shutdown logs and search for the text "timeout" to find out which processes that are causing the slow shutdown. For me the problem is the securityd daemon and the appleevents services.

spoon2eric
Oct 31, 2012, 09:45 AM
Mine is mid 2012, 2.7 GHz, 500 SSD, 16GB RAM. 30 seconds or more.

Wow.. that's a fast Mac w/ SSD.. 30 sec is RE-DONK-U-LUS!!

razmarino
Oct 31, 2012, 09:54 AM
who is this _eppc user running appleeventsd? icloud?

RS2
Oct 31, 2012, 10:13 AM
who is this _eppc user running appleeventsd? icloud?

Just the default Apple Events user name.

razmarino
Oct 31, 2012, 10:25 AM
only appleeventsd here

maxonthemac
Oct 31, 2012, 02:54 PM
Not just appleeventsd
I also had other services hanging on shutdown, but they were due to badly designed third-party drivers: I could track them using the same method (looking at the launchd-shutdown log) and I could solve them by just avoiding to load the associated kernel extension. I am saying this to highlight that appleventsd may still not be the sole cause, even though at present it seems the more likely and frequently observed.

Digging further into the problem
For some time I had some evidence that the AppleIDAuthAgent (com.apple.coreservices.appleid.authentication) was also hanging, but after further tests only appleeventsd seemed to actually slow down my poweroff sequence. However, during those tests on the AppleIDAuthAgent I could observe the origin of the problem: the agent just stopped handling the SIGTERM signal. The documentation (man page) of launchd.plist explains that, when a service is to be shut down, launchd first attempts to gracefully stop it by sending a SIGTERM: if the process does not quit spontaneously within the timeout, then launchd abruptly terminates it with a SIGKILL. So, what I did was to invoke the AppleIDAuthAgent "manually" (i.e., not through launchd) and run it through dtruss, a utility that tracks the system calls issued by a process. When I attempted to send a SIGTERM to that process nothing at all happened: no reaction, no system calls printed, no spontaneous exit. SIGQUIT and SIGHUP were instead processed successfully. And what was most strange is that this did not happen consistently, so it could not be ascribed to an overlook by the programmers that "forgot" to process the SIGTERM signal (which, also intuitively, looks very very unlikely).
I guess something similar could be happening with appleeventsd, but the true point is how to determine what makes it ignore the SIGTERM. Reading reports like this (http://blog.freron.com/2012/recipe-for-trouble-os-x-10-8-2-mailmate-and-spamsieve/) and this (http://brian-webster.tumblr.com/post/32830692042/a-workaround-for-aesendmessage-hanging-on-os-x-10-8-2) makes me prone to thinking it's really a bug, although I could not (yet) rule out potential third-party causes on my machine.

BTW, I am not using iCloud.

BTW again, when you use Console remember to look at the launchd-shutdown.log: the other file suffixed with a 1 is usually an older version of the same file that refers to the penultimate (i.e., not latest) shutdown sequence.

zosokm
Nov 1, 2012, 03:35 AM
Removing google chrome has definitely improved my shut down speed.

ParryD
Nov 1, 2012, 07:15 AM
If you have a very slow shutdown time (+20 seconds) please open the Console app and check the system launchd-shutdown logs and search for the text "timeout" to find out which processes that are causing the slow shutdown. For me the problem is the securityd daemon and the appleevents services.

I had these:

20005100 com.apple.launchd 1 com.apple.securityd 15 Exit timeout elapsed (20 seconds). Killing
20007444 com.apple.launchd 1 com.apple.diskarbitrationd 16 Exit timeout elapsed (20 seconds). Killing
20007499 com.apple.launchd 1 com.apple.coreservices.appleevents 51 Exit timeout elapsed (20 seconds). Killing

xgman
Nov 1, 2012, 12:00 PM
Thanks for all the above. Will give this a try.

togidogi
Nov 1, 2012, 07:07 PM
I am a 67yr tech impaired old fart but I think I'm having the same problem with my 2012 MacBook Air. I googled the issue and eventually got to you all and registered so that I could ask a question. I've read the entire thread and have the same kinds of error messages discussed. My question is simply why does it shut down in 2secs 75% of the time but the other 25% takes 22 secs? It's like a guessing game as to how long it will take to shut down. It's frustrating to have to get out my stopwatch each time I shut down to satisfy myself that all is good (or bad). Quite a few posts suggest that the "shut-down slowly" issue is experienced on a consistent basis.

Regards-

maxonthemac
Nov 2, 2012, 05:20 AM
My question is simply why does it shut down in 2secs 75% of the time but the other 25% takes 22 secs? It's like a guessing game as to how long it will take to shut down.
It is, the underlying reason being still basically unknown. The behavior is not always consistently observed, but may depend on how (much) you use the machine since its poweron. The more you do, the more chances you have to experience the slowdown. Since most users rightly use the machine for a while by running several applications before poweroff, the problem is very likely to become constantly present.
Quite a few posts suggest that the "shut-down slowly" issue is experienced on a consistent basis.
I think what you call "consistent" can be interpreted in the way I have mentioned above.

Mike MA
Nov 2, 2012, 07:23 AM
I am a 67yr tech impaired old fart but I think I'm having the same problem with my 2012 MacBook Air. I googled the issue and eventually got to you all and registered so that I could ask a question. I've read the entire thread and have the same kinds of error messages discussed. My question is simply why does it shut down in 2secs 75% of the time but the other 25% takes 22 secs? It's like a guessing game as to how long it will take to shut down. It's frustrating to have to get out my stopwatch each time I shut down to satisfy myself that all is good (or bad). Quite a few posts suggest that the "shut-down slowly" issue is experienced on a consistent basis.

Regards-

No, its on a random basis. In my case mostly after heavy usage or air play activities via iTunes/ Apple TV.

razmarino
Nov 2, 2012, 04:29 PM
one more tracked down

3rd Rock
Nov 2, 2012, 04:44 PM
Nov 2 com.apple.launchd[1] (com.apple.coreservices.appleid.authentication[118]): Exit timeout elapsed (20 seconds). Killing


Mine above.......

Risco
Nov 2, 2012, 05:15 PM
Has anyone tried 10.8.3 and seen if it fixes the issue?

atMac
Nov 2, 2012, 10:19 PM
i have 3 items slowing me down
20006916 com.apple.launchd 1 com.apple.iCloudHelper 351 Exit timeout elapsed (20 seconds). Killing
20010984 com.apple.launchd 1 com.apple.suhelperd 425 Exit timeout elapsed (20 seconds). Killing
20011065 com.apple.launchd 1 com.apple.securityd 15 Exit timeout elapsed (20 seconds). Killing

----------

Has anyone tried 10.8.3 and seen if it fixes the issue?

its not out for developers yet.

evgenyneu
Nov 9, 2012, 06:37 PM
Posted a bugreport on https://bugreport.apple.com. Apple replied immediately asking to attach system report file. It looks like Apple is working hard on this problem. I can also see that they marked my ticked as a duplicate to another ticket.

As it was already noted here, I would suggest everybody who has this problem file a bugreport at Apple. The more data they have the sooner they can fix it.

Troneas
Nov 9, 2012, 07:06 PM
yep i get this problem too.



reminds me of my days with microsoft windows: shutdown, prepare coffee, feed the dog, call a friend and then come back to close the lid.

RMSko
Nov 12, 2012, 03:24 PM
I'm not sure what I'm supposed to be looking for in Console so below is everything it said at the time of shut down. If someone can interpret this for me it would be great!

11/12/12 2:24:07.127 PM WindowServer[71]: dict count after removing entry for window 0x1d is 0
11/12/12 2:24:07.137 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.137 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.138 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.138 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.138 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.143 PM com.apple.launchd[1]: (com.apple.ShareKitHelper[570]) Exited: Killed: 9
11/12/12 2:24:07.144 PM com.apple.launchd.peruser.501[121]: ([0x0-0x10010].com.apple.inputmethod.ironwood[173]) Exited: Killed: 9
11/12/12 2:24:07.152 PM coreservicesd[31]: SendFlattenedData, got error #268435459 (ipc/send) invalid destination port from ::mach_msg(), sending notification kLSNotifyApplicationDeath to notificationID=159
11/12/12 2:24:07.156 PM com.apple.launchd.peruser.501[121]: ([0x0-0xb00b].com.apple.iTunesHelper[164]) Exited with code: 1
11/12/12 2:24:07.155 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.155 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.156 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.156 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.156 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.157 PM com.apple.launchd.peruser.501[121]: ([0x0-0x22022].com.apple.AppleSpell[221]) Exited: Terminated: 15
11/12/12 2:24:07.157 PM com.apple.launchd.peruser.501[121]: (com.apple.mdworker.shared.04000000-0000-0000-0000-000000000000[985]) Exited: Killed: 9
11/12/12 2:24:07.159 PM coreservicesd[31]: SendFlattenedData, got error #268435460 (ipc/send) timed out from ::mach_msg(), sending notification kLSNotifyApplicationDeath to notificationID=167
11/12/12 2:24:07.159 PM coreservicesd[31]: SendFlattenedData, got error #268435460 (ipc/send) timed out from ::mach_msg(), sending notification kLSNotifyApplicationDeath to notificationID=767
11/12/12 2:24:07.159 PM coreservicesd[31]: SendFlattenedData, got error #268435459 (ipc/send) invalid destination port from ::mach_msg(), sending notification kLSNotifyApplicationDeath to notificationID=140
11/12/12 2:24:07.187 PM loginwindow[53]: DEAD_PROCESS: 53 console
11/12/12 2:24:07.245 PM airportd[1038]: _doAutoJoin: Already associated to “Airport Express - LAJSR”. Bailing on auto-join.
11/12/12 2:24:07.407 PM coreservicesd[31]: SendFlattenedData, got error #268435459 (ipc/send) invalid destination port from ::mach_msg(), sending notification kLSNotifyApplicationDeath to notificationID=129
11/12/12 2:24:07.409 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.409 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.410 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.410 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.410 PM WindowServer[71]: CGXGetConnectionProperty: Invalid connection 45571
11/12/12 2:24:07.430 PM shutdown[1039]: halt by Rich:
11/12/12 2:24:07.430 PM shutdown[1039]: SHUTDOWN_TIME: 1352748247 430131

wrldwzrd89
Nov 12, 2012, 04:14 PM
I'm not sure what I'm supposed to be looking for in Console so below is everything it said at the time of shut down. If someone can interpret this for me it would be great!

(log entries snipped)
Oddly enough, there's nothing in that log suggesting any of the culprits identified in this thread is causing problems for you.

Prof.
Nov 12, 2012, 04:46 PM
yep i get this problem too.



Reminds me of my days with microsoft windows: Shutdown, prepare coffee, feed the dog, call a friend and then come back to close the lid.
lmao! Yes!!! :p:D

RMSko
Nov 12, 2012, 04:53 PM
Oddly enough, there's nothing in that log suggesting any of the culprits identified in this thread is causing problems for you.
Hmmm. Well I am certainly experiencing the slow shut down time and also the fact that every once in awhile it shuts down quickly so I would think there must be something else going on that's more innate to the the OS?

Krazy Bill
Nov 12, 2012, 05:11 PM
It's pretty bad when a SSD equipped MBP takes 30 seconds to shut down. My kid's machine running Snow Leopard on a 5400rpm drive does it in 3.

donalgodon
Nov 13, 2012, 02:18 PM
Just clean system caches and the restart will be super fast. This has worked for me for ages.

Open terminal and write these commands:


sudo chown root:admin / (enter password when asked)

sudo kextcache -system-prelinked-kernel

sudo kextcache -system-caches



I have this commands in dashboard notes, so every time boot up gets slow I use them to restore it. With a ssd drive it makes reboot ultra fast.

This actually worked.

Thanks so much!

3rd Rock
Nov 13, 2012, 03:43 PM
Tried the above suggestion using the terminal.....

Unknown what happened but as soon as I got to the "Password" entry part, I could not enter the password at all. None of the keyboard keys worked. Any suggestions ?

wrldwzrd89
Nov 13, 2012, 04:39 PM
Tried the above suggestion using the terminal.....

Unknown what happened but as soon as I got to the "Password" entry part, I could not enter the password at all. None of the keyboard keys worked. Any suggestions ?
That's normal. The Terminal does NOT echo your input at all for security reasons. Trust me, though - it's still receiving your keystrokes.

3rd Rock
Nov 13, 2012, 05:06 PM
That's normal. The Terminal does NOT echo your input at all for security reasons. Trust me, though - it's still receiving your keystrokes.

Thank you. Will try again :)

rhoydotp
Nov 14, 2012, 11:48 AM
Open terminal and write these commands:

sudo chown root:admin / (enter password when asked)



you've got bigger issues if you have to do this ... permission/ownership on this directory should not change unless you manually do it or a malicious program does it for you :cool:

3rd Rock
Nov 14, 2012, 12:24 PM
Tried the above suggestion but only worked once with the Terminal command, than back again to the 20 second shutdown. I'll wait until Apple comes up with its own fix, I hope

Mike MA
Nov 14, 2012, 01:22 PM
Tried the above suggestion but only worked once with the Terminal command, than back again to the 20 second shutdown. I'll wait until Apple comes up with its own fix, I hope

I doubt they will - even though asking some people for system logs...there're too many bugs which haven't been corrected recently.

nyolc8
Nov 15, 2012, 07:28 AM
Xagoth posted a workaround (http://forums.macrumors.com/showpost.php?p=16286758&postcount=14) that working nicely for me:
https://discussions.apple.com/thread/4339540?start=60&tstart=0

(I made this with "sudo pico" in terminal, so permission fixing was not needed after modified the file.)

joec1101
Nov 15, 2012, 10:23 PM
Xagoth posted a workaround (http://forums.macrumors.com/showpost.php?p=16286758&postcount=14) that working nicely for me:
https://discussions.apple.com/thread/4339540?start=60&tstart=0

(I made this with "sudo pico" in terminal, so permission fixing was not needed after modified the file.)

Unfortunately, I didn't have any luck with this one. It did work for a few restarts, but then it went right back to the slow shutdown :(

yjchua95
Nov 16, 2012, 10:22 PM
The culprit causing this is appleeventsd
When shutting down, the appleeventsd process refuses to terminate, hence causing a long shutdown.

I tried all steps in this thread, no go :(
Hopefully Apple will fix up this thing in 10.8.3

Mike MA
Nov 17, 2012, 04:42 AM
Hopefully Apple will fix up this thing in 10.8.3

Apple will seed the first beta of 10.8.3 in CW 48. Let's hope they made their homework :rolleyes:

RMSko
Nov 17, 2012, 08:25 AM
nm

bushido
Nov 17, 2012, 02:39 PM
this is mine ... any suggestions? there r so many commands to "fix" this issue posted by now that i dont even know which one i should try ;)

http://i48.tinypic.com/35jxevk.png

Krazy Bill
Nov 17, 2012, 04:23 PM
You guys are funny. :D

I really don't understand why you all are so keen on applying the short-lived and potentially dangerous terminal hacks.

Just live with it until 10.8.3. I do believe this one will be fixed as Apple has had some two-way correspondence with a few users about this very thing.

mentaluproar
Nov 21, 2012, 12:44 AM
I just shut down my system because it was acting up and it took over a minute. I just left before it finished. I have no idea why this is getting so bad. its constantly reindexing drives, "upgrading calendars", etc. What happened to apple making a reliable machine?

Mike MA
Nov 28, 2012, 08:05 AM
Posted a bugreport on https://bugreport.apple.com. Apple replied immediately asking to attach system report file. It looks like Apple is working hard on this problem. I can also see that they marked my ticked as a duplicate to another ticket.

As it was already noted here, I would suggest everybody who has this problem file a bugreport at Apple. The more data they have the sooner they can fix it.

Opened up an issue back in October and was also asked for system logs, received information today that it was closed as a duplicate too. Seems like they're making progress (and we hopefully see the result in 10.8.3...).

Krazy Bill
Nov 28, 2012, 08:19 AM
Opened up an issue back in October and was also asked for system logs, received information today that it was closed as a duplicate too. Seems like they're making progress (and we hopefully see the result in 10.8.3...).Now that 10.8.3 is in the hands of developers... I'm hoping one of them can risk torture, prison and confiscation of personal property by giving a hint this quirk is indeed fixed.

Atarikid
Nov 28, 2012, 11:51 AM
FYI:The latest beta 10.8.3 12D32 (released on 26/11) does not fix the slow shutdown issues on my rMBP. Pity..

Reading the seed note, 10.8.3 is mainly focused on graphics driver, game center, airplay, airport and Safari 6.0.2

Krazy Bill
Nov 28, 2012, 12:31 PM
FYI:The latest beta 10.8.3 12D32 (released on 26/11) does not fix the slow shutdown issues on my rMBP. Pity..

Reading the seed note, 10.8.3 is mainly focused on graphics driver, game center, airplay, airport and Safari 6.0.2

Makes total sense. Fix the general "consumer" crap first and then the core functionality if there's time. No surprise. :(

Atarikid
Nov 28, 2012, 12:55 PM
Makes total sense. Fix the general "consumer" crap first and then the core functionality if there's time. No surprise. :(

True. But it just the first beta of 10.8.3 so there is still some hope.

Mike MA
Nov 28, 2012, 02:59 PM
FYI:The latest beta 10.8.3 12D32 (released on 26/11) does not fix the slow shutdown issues on my rMBP. Pity..

Reading the seed note, 10.8.3 is mainly focused on graphics driver, game center, airplay, airport and Safari 6.0.2

As Apple never admitted there's a problem around there will never be an official fix or any mention of it.

If you're still facing the problem with 10.8.3 though I like to quote Krazy Bill :D

Now that 10.8.3 is in the hands of developers... I'm hoping one of them can risk torture, prison and confiscation of personal property by giving a hint this quirk is indeed fixed.

RMSko
Dec 15, 2012, 01:19 PM
I checked what is causing my delay and found the following:

20004971 com.apple.launchd 1 com.apple.securityd 15 Exit timeout elapsed (20 seconds). Killing

20007096 com.apple.launchd 1 com.apple.coreservices.appleevents 62 Exit timeout elapsed (20 seconds). Killing

I guess my problems are with "securityd" and "appleevents".

pollakalos
Dec 30, 2012, 12:49 PM
Guys

I spent a whole day searching. This is why i re-posting this here, hopefully to save other peoples' time....

Originally Posted by GerMo


:cool:Thank god! I have finally found the solution to this problem! Seems like there are old Java files floating around the system which you need to delete. I'll teach you how here.

1. Firstly, navigate to "Macintosh HD > Library" in Mac OS X Lion

2. Delete the folder named "Java" (will not cause any harm to your mac, you can easily install it again)

3. Empty Trash

4. Shut down! It should be instant, (as I said before, my late-2010 macbook air took 23 secs to shut down, now, it takes 2 seconds)

5. Boot back up, should be faster too, but shut down is much faster

6. You're done! Once you run anything Java related, Mac OS X Lion will prompt you and ask you to install the Java, press yes and install it. It won't affect your shut down time anymore because this is the brand new version. You need to take this step even if you installed the new version when you first upgraded to Lion.

I hope this helps everybody who are affected by this problem.

Give me a vote if it works!

wrldwzrd89
Dec 30, 2012, 01:25 PM
Guys

I spent a whole day searching. This is why i re-posting this here, hopefully to save other peoples' time....

Originally Posted by GerMo


:cool:Thank god! I have finally found the solution to this problem! Seems like there are old Java files floating around the system which you need to delete. I'll teach you how here.

1. Firstly, navigate to "Macintosh HD > Library" in Mac OS X Lion

2. Delete the folder named "Java" (will not cause any harm to your mac, you can easily install it again)

3. Empty Trash

4. Shut down! It should be instant, (as I said before, my late-2010 macbook air took 23 secs to shut down, now, it takes 2 seconds)

5. Boot back up, should be faster too, but shut down is much faster

6. You're done! Once you run anything Java related, Mac OS X Lion will prompt you and ask you to install the Java, press yes and install it. It won't affect your shut down time anymore because this is the brand new version. You need to take this step even if you installed the new version when you first upgraded to Lion.

I hope this helps everybody who are affected by this problem.

Give me a vote if it works!
SUCCESS!

Thanks. I wasn't prompted to reinstall Java as you said, but your fix most definitely worked! Shut down time went down from 25 seconds to 5 seconds, and stayed that way through 2 reboots. :D

SR45
Dec 30, 2012, 03:20 PM
Guys

I spent a whole day searching. This is why i re-posting this here, hopefully to save other peoples' time....

Originally Posted by GerMo


:cool:Thank god! I have finally found the solution to this problem! Seems like there are old Java files floating around the system which you need to delete. I'll teach you how here.

1. Firstly, navigate to "Macintosh HD > Library" in Mac OS X Lion

2. Delete the folder named "Java" (will not cause any harm to your mac, you can easily install it again)

3. Empty Trash

4. Shut down! It should be instant, (as I said before, my late-2010 macbook air took 23 secs to shut down, now, it takes 2 seconds)

5. Boot back up, should be faster too, but shut down is much faster

6. You're done! Once you run anything Java related, Mac OS X Lion will prompt you and ask you to install the Java, press yes and install it. It won't affect your shut down time anymore because this is the brand new version. You need to take this step even if you installed the new version when you first upgraded to Lion.

I hope this helps everybody who are affected by this problem.

Give me a vote if it works!

Sorry, but this does not work in the long run. Tried before (month or so ago when someone else suggested same fix, and failed. Tried it again today with the following results..

1. 20 second shut down prior to doing the suggested fix

2. 3 second shut down with so called fix

3. 9 second shut down afterwards

4. 11 second shut down later

5. 4 second shut down later still

6. 20 second shut down than after, with an occasional 5 second shut down on/off as has been reported weeks/months ago.... :( This fix suggestion, as shown has been tried months ago from many on this forum and the official Apple support forum. Not a good fix

Risco
Jan 8, 2013, 06:45 PM
Beta 12D50 seems to have a significant effect on shutdowns. Just over 6 seconds with the guy in this post!


I decided to test this on a 2012 cMBP. SSD

After closing all apps I shut it down. The timer started when I clicked on the pop up menu to shut down.

kvnfo
Jan 8, 2013, 09:34 PM
Beta 12D50 seems to have a significant effect on shutdowns. Just over 6 seconds with the guy in this post!

Nice, how can I get the beta?

Mike MA
Jan 9, 2013, 04:44 AM
Beta 12D50 seems to have a significant effect on shutdowns. Just over 6 seconds with the guy in this post!

Well, it depends on the individual systems.

I would still be very frustrated with a 6 seconds shutdown, as my standard shutdown time is less than a second on the SSD version (and 20 seconds once the problem occurs).

But the more people are reporting improvments, the more I start hoping Apple gets things sorted!

Badagri
Jan 13, 2013, 05:20 AM
I would still be very frustrated with a 6 seconds shutdown, as my standard shutdown time is less than a second on the SSD version (and 20 seconds once the problem occurs).

But the more people are reporting improvments, the more I start hoping Apple gets things sorted!

Considering Lion done it in 1 - 2. You more or less clicked shutdown then heard the click.

ultraspiracle
Jan 16, 2013, 11:53 PM
Wow.. that's a fast Mac w/ SSD.. 30 sec is RE-DONK-U-LUS!!

Not for an SSD machine it's not! With 10.8.1 would get 20 second restarts (from useable to cold shutdown, back to useable). 10.8.2 prolonged it to like two minutes (not why I spent 3K on SSD etc). Now that I'm back to Lion (10.7.5), it's 24" restart. Believe me- restart times are crazy fast with SSD and Retina machines. Spoils you really fast and makes you take notice when something is wrong! That's why no 10.8 for me until they fix it, but from what I understand apple is hard at work on it with either 10.8.3 or 10.8.4.

:)

xgman
Jan 17, 2013, 12:11 PM
In the meantime, always make sure your startup disk is selected in system preferences and then do this procedure every no and then:

This article proposes two actions:

Clear the dynamic loader shared cache by booting one time is Safe mode.
Rebuild Kernel Extension Caches with a few terminal commands.

The whole process will take you approximately 4 to 5 minutes to perform if that.

Step 1 : Clear the dynamic loader shared cache

So First: boot in safe mode by restarting your mac by holding the SHIFT key immediately after hearing the boot chime. When you reach the login window, don’t even log in, just hit restart.

Step 2 : Rebuild Kernel Extension Caches

Open a terminal window and type the following commands:

sudo chown root:admin /

(the system will ask your password to grant access to the sudo chown command as this requires admin privileges)

sudo kextcache -system-prelinked-kernel

sudo kextcache -system-caches

Then restart.

The Bulge
Jan 20, 2013, 07:40 AM
Not fixed in the latest dev seed. At least on my config it's still 20-30 seconds. Which is crazy.

hamiltonDSi
Jan 20, 2013, 08:17 AM
Same here. About 25 seconds. Clean install..
Late 2011 Macbook Pro

Jipster23
Jan 20, 2013, 02:30 PM
enter the following commands on terminal.

After you enter the first command you will be asked for your password.

This is the only workaround solution ive come across so far.

udo defaults write /System/Library/LaunchDaemons/com.apple.securityd ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchDaemons/com.apple.mDNSResponder ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchDaemons/com.apple.diskarbitrationd ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchAgents/com.apple.coreservices.appleid.authentication ExitTimeOut -int 2

Risco
Jan 20, 2013, 02:52 PM
enter the following commands on terminal.

After you enter the first command you will be asked for your password.

This is the only workaround solution ive come across so far.

udo defaults write /System/Library/LaunchDaemons/com.apple.securityd ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchDaemons/com.apple.mDNSResponder ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchDaemons/com.apple.diskarbitrationd ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchAgents/com.apple.coreservices.appleid.authentication ExitTimeOut -int 2

What are the defaults before I do this, and secondly what are the implications of changing these timeouts? Usually timeouts are there in order to allow writes to complete or prevent data loss?

Jipster23
Jan 20, 2013, 03:11 PM
I cannot exactly remember the details. Basically these are the parameters that actually contribute to the long period (20 seconds) to shut down on ML. You can check it out on your console report to see which processes are actually causing this and from what ive gathered from other forums its actually these parameters.

I typed these commands in once about a month back and shut down is prompt and there is no software/hardware related issues what so ever.

The Bulge
Jan 21, 2013, 12:38 PM
enter the following commands on terminal.

After you enter the first command you will be asked for your password.

This is the only workaround solution ive come across so far.

udo defaults write /System/Library/LaunchDaemons/com.apple.securityd ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchDaemons/com.apple.mDNSResponder ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchDaemons/com.apple.diskarbitrationd ExitTimeOut -int 2

sudo defaults write /System/Library/LaunchAgents/com.apple.coreservices.appleid.authentication ExitTimeOut -int 2

You can add this to all plist file it will still take ages to shut down. This worked for me maybe 3 times and even if log shows that service was killed fater 2 seconds it still took 15 to 20 seconds to shut down.

Atarikid
Jan 25, 2013, 01:45 PM
As I said before there is no way to fix the slow shut down process. All are temporally fixes.

But today Apple released another beta of OS X 10.8.3 and finally there is good news. The issue (seems to be) is solved.
I have working with this beta whole day with several reboots and my MBP Retina always closes within 1-2 second(s) as it should.

SR45
Jan 25, 2013, 02:29 PM
As I said before there is no way to fix the slow shut down process. All are temporally fixes.

But today Apple released another beta of OS X 10.8.3 and finally there is good news. The issue (seems to be) is solved.
I have working with this beta whole day with several reboots and my MBP Retina always closes within 1-2 second(s) as it should.

You are right about the fix thingy. Not one of them worked, but glad that there might be a solution in the latest beta. Thanks for sharing. ;)

The Bulge
Jan 26, 2013, 01:53 AM
As I said before there is no way to fix the slow shut down process. All are temporally fixes.

But today Apple released another beta of OS X 10.8.3 and finally there is good news. The issue (seems to be) is solved.
I have working with this beta whole day with several reboots and my MBP Retina always closes within 1-2 second(s) as it should.

Still slow here. Tested on last gen Mac Pro, retina MBP and last gen iMac.

Atarikid
Jan 26, 2013, 01:05 PM
Still slow here. Tested on last gen Mac Pro, retina MBP and last gen iMac.

Day two: still quick shutdowns on my MBP Retina 15"

Are you sure you are using the latest Build 12D58 released yesterday friday 25/1?
On the official Apple developers forum everyone says it is fixed too.

The Bulge
Jan 26, 2013, 02:47 PM
Day two: still quick shutdowns on my MBP Retina 15"

Are you sure you are using the latest Build 12D58 released yesterday friday 25/1?
On the official Apple developers forum everyone says it is fixed too.

I'm sure. I even did clean GM install and then 10.8.3 12D58 on top to be sure.

Badagri
Jan 26, 2013, 09:23 PM
I hope they fixed the memory not releasing itself. Because I get a lot of page outs at times unlike under Lion. Even though the system can sit idle for hours and the memory is still maxed out will all the apps closed down.

The Bulge
Jan 27, 2013, 03:17 AM
I hope they fixed the memory not releasing itself. Because I get a lot of page outs at times unlike under Lion. Even though the system can sit idle for hours and the memory is still maxed out will all the apps closed down.

This could be fixed i think. After using Vmware for example i always had 8-10 GB just hanging doing nothing while system was using swap file, now i don't see it anymore.

Prof.
Jan 27, 2013, 12:17 PM
If Apple doesn't fix this problem permanently with 10.8.3, their stock deserves to keep falling. :mad:

ultraspiracle
Jan 28, 2013, 08:46 PM
If Apple doesn't fix this problem permanently with 10.8.3, their stock deserves to keep falling. :mad:

I second that!

kensic
Jan 28, 2013, 10:20 PM
freaking blows, did a clean reinstall and it didnt help. about 40% of the time it shuts down fast :(

alec6542
Jan 29, 2013, 01:57 AM
Not sure if this would be of any help, but I had extremely slow startup and shutdown times on 2011 Macbook Pro. After trying almost everything, including format and reinstall, I decided to try updating the memory from 4GB to 8GB. Made a HUGE difference! Before it would take like 5 minutes to shutdown. Now it takes less than 10 seconds with safari open with 20 tabs and another 14 or so applications open. Very pleased.

kensic
Jan 29, 2013, 02:07 AM
Not sure if this would be of any help, but I had extremely slow startup and shutdown times on 2011 Macbook Pro. After trying almost everything, including format and reinstall, I decided to try updating the memory from 4GB to 8GB. Made a HUGE difference! Before it would take like 5 minutes to shutdown. Now it takes less than 10 seconds with safari open with 20 tabs and another 14 or so applications open. Very pleased.

update us in a couple of days, thanks

SR45
Jan 29, 2013, 12:22 PM
Not sure if this would be of any help, but I had extremely slow startup and shutdown times on 2011 Macbook Pro. After trying almost everything, including format and reinstall, I decided to try updating the memory from 4GB to 8GB. Made a HUGE difference! Before it would take like 5 minutes to shutdown. Now it takes less than 10 seconds with safari open with 20 tabs and another 14 or so applications open. Very pleased.

Does not work. Went from 4 GB to 8 GB to 16 GB and no difference. Have to wait for Apple to figure this out. Nothing on this thread has helped but just a few times than back to square one again. :(

Mike MA
Jan 30, 2013, 06:12 AM
Does not work. Went from 4 GB to 8 GB to 16 GB and no difference. Have to wait for Apple to figure this out. Nothing on this thread has helped but just a few times than back to square one again. :(

The slow shutdown even occured once in a while after a startup and immediate shutdown for testing purposes - and to me that clearly shouldn't be a memory intensive task...

Tech198
Jan 30, 2013, 06:56 AM
I had the same problem (Actually, I had the same problem with 10.8.0) but then I got it fixed by performing the following steps:

1. Shut down your computer with "Reopen windows when logging..." CHECKED. (The shut down will be slow this time ~ 20 seconds)
2. Turn your computer on
3. Shut down with "Reopen windows when logging..." UNCHECKED. It now shuts down in 2 seconds

Note: with 10.8.2, my MacBook seems to shuts down in about 2 seconds whether I leave it checked or unchecked.

Good Luck!

This..... doesn't work for me, since i prefer to leave the box unchecked

Theres a solution somewhere, and a clean install isn't always the answer.

Can applications do this ? For example you've just been using Toast 11, and due to it not being written very well it leave threads open even though it appears the applications been closed (no light in dock, no icon in task switcher etc).

If so, how can you target these in relation to the relevant app ?

tigres
Jan 30, 2013, 08:23 AM
Where on earth is 10.8.3
this shutdown issue for pushing a year is downright disgraceful.

Cleaned up my wife's MBP late 2011 this am; and shutdown took 2.5 min.
my MBA takes about 30 seconds, even when I fresh restart at the login screen.

damn I miss 10.6.8:mad:

nyolc8
Jan 30, 2013, 01:11 PM
They fix the slow shutdown in febuary, then 5 month later in June the 10.9 comes out with slow shutdown again... ;) :D

Mike MA
Feb 1, 2013, 04:56 AM
They fix the slow shutdown in febuary, then 5 month later in June the 10.9 comes out with slow shutdown again... ;) :D

I rather assume it won't be fix until 10.9 will be released. They already had a shot with 10.8.2 which they didn't make use of...

redfirebird08
Feb 3, 2013, 12:47 AM
Where on earth is 10.8.3
this shutdown issue for pushing a year is downright disgraceful.

Cleaned up my wife's MBP late 2011 this am; and shutdown took 2.5 min.
my MBA takes about 30 seconds, even when I fresh restart at the login screen.

damn I miss 10.6.8:mad:

It is pretty embarrassing. I have a 3 year old iMac running on a hard drive that shuts down much faster than my brand new Macbook Air running on SSD. Snow Leopard is a much better operating system as well. Not a fan of the look of Mountain Lion.

Badagri
Feb 3, 2013, 01:04 AM
This could be fixed i think. After using Vmware for example i always had 8-10 GB just hanging doing nothing while system was using swap file, now i don't see it anymore.

How can the memory leaks be so terrible in 10.8.2. For a few hours now, sitting with a few browser pages open and came back, the system went from 4.82GB use, up to now 11.66GB use. Nothing intensive at all.

https://discussions.apple.com/thread/4360412?start=15&tstart=0

Under Lion and Snow Leopard, page outs never happened.

The Bulge
Feb 3, 2013, 02:18 AM
How can the memory leaks be so terrible in 10.8.2. For a few hours now, sitting with a few browser pages open and came back, the system went from 4.82GB use, up to now 11.66GB use. Nothing intensive at all.

https://discussions.apple.com/thread/4360412?start=15&tstart=0

Under Lion and Snow Leopard, page outs never happened.

It is some kind of wide system memory leak. On. 10.8.2 i also see these spikes where idle system suddenly jumps from normal memory usage (depending how much memory there is) to eating almost all available memory. The best part is if you open Activity Monitor and arrange by memory use you won't see anything unusual. It could be that some system service is allocating that memory and reporting it as used or whatever then other apps seeing that there is no more RAM start writting to swap file.

But i haven't seen this since 10.8.3 beta 1.

adnbek
Feb 3, 2013, 09:00 AM
How can the memory leaks be so terrible in 10.8.2. For a few hours now, sitting with a few browser pages open and came back, the system went from 4.82GB use, up to now 11.66GB use. Nothing intensive at all.

https://discussions.apple.com/thread/4360412?start=15&tstart=0

Under Lion and Snow Leopard, page outs never happened.

Do you have any extensions installed for safari? Adblock used to cause crazy memory leaks. No more since I turned off extensions.

iTunes 11 has huge memory leaks as well. Forced to quit and reopen iTunes to free up ram.

Badagri
Feb 3, 2013, 11:41 AM
Do you have any extensions installed for safari? Adblock used to cause crazy memory leaks. No more since I turned off extensions.

I do indeed but I need them. Same extensions that never gave me problems with the previous OS's.

iTunes 11 has huge memory leaks as well. Forced to quit and reopen iTunes to free up ram.

So sad. :/ It makes sense since it was rushed.

scottsjack
Feb 3, 2013, 01:03 PM
It is pretty embarrassing. I have a 3 year old iMac running on a hard drive that shuts down much faster than my brand new Macbook Air running on SSD. Snow Leopard is a much better operating system as well. Not a fan of the look of Mountain Lion.

I was just updating Snow Leopard in my Mac Pro this morning. Even though I use ML in my Macs I pop the SL drive in every three weeks or so and grab email as well as perform any updates. Then I fiddle around a little.

I still really like SL, lots of Mac OS not much iToys OS.

redfirebird08
Feb 3, 2013, 02:10 PM
Just tested it and my 3 year old Snow Leopard iMac shuts down in 3-4 seconds. Brand new Mountain Lion Macbook Air takes around 20 seconds to shut down. That's just ridiculous since the Air has a lot better technology in it all the way around.

blatopilot
Feb 5, 2013, 03:58 PM
Just tested it and my 3 year old Snow Leopard iMac shuts down in 3-4 seconds. Brand new Mountain Lion Macbook Air takes around 20 seconds to shut down. That's just ridiculous since the Air has a lot better technology in it all the way around.

I had similar results in testing.

My sister's 13 inch 2009 MBP with Snow Leopard shuts down in 3-5 seconds. My 2011 15 inch MBP i7, with Lion or ML takes 4-5 times that.

Prof.
Feb 8, 2013, 02:19 PM
But seriously... If this issue isn't permanently fixed with Mac OS 10.8.3, I will have forever lost faith in Apple. This is getting ridiculous.

Krazy Bill
Feb 8, 2013, 02:36 PM
But seriously... If this issue isn't permanently fixed with Mac OS 10.8.3, I will have forever lost faith in Apple. This is getting ridiculous.I hear mixed reports form those with the latest beta. Honestly, I don't think some of them know what to look for.

spacerays
Feb 14, 2013, 03:08 PM
I was facing the same slow shutdown issue. Tried NVRAM reset, SMC, daemon timeout change etc, didnt work.

Used verbose mode and saw that httpd and mysqld were coming up a lot during shutdown.

I had a MAMP PRO setup running those daemons at startup. Disabled them from running at startup in MAMP PRO. And voila, problem solved!

SR45
Feb 14, 2013, 05:06 PM
I was facing the same slow shutdown issue. Tried NVRAM reset, SMC, daemon timeout change etc, didnt work.

Used verbose mode and saw that httpd and mysqld were coming up a lot during shutdown.

I had a MAMP PRO setup running those daemons at startup. Disabled them from running at startup in MAMP PRO. And voila, problem solved!

See you posted this twice now. So go back to other thread for a reply. Your attempt will probably fail as others have

tigres
Feb 16, 2013, 02:43 PM
Strange thing occurred today.

I was building an OSX bootable USB for my wife's MBP as we are putting an SSD in it.

While I was testing my bootable USB after build on my MBA, I ran a Disk Utility for the heck of it. Verified the disk, and found errors on my SSD. This has never been the case, so I repaired the disk.

I shut down, and started as normal.
When I did a restart it was <2 sec.

Tested 3 times thus far and my shutdown appears to be as expected- fast.
Will report back in a few days after more testing.


Edit/add
No fix. Back to 20-30 second shutdown.
Seems even worse now. Screen goes grey then blue.
Wonderful. :rolleyes:

SR45
Feb 16, 2013, 04:26 PM
Strange thing occurred today.

I was building an OSX bootable USB for my wife's MBP as we are putting an SSD in it.

While I was testing my bootable USB after build on my MBA, I ran a Disk Utility for the heck of it. Verified the disk, and found errors on my SSD. This has never been the case, so I repaired the disk.

I shut down, and started as normal.
When I did a restart it was <2 sec.

Tested 3 times thus far and my shutdown appears to be as expected- fast.
Will report back in a few days after more testing.

Did same with same results. Later it went back to 20 second shut down. These temp fixes are just that, temporary

tigres
Feb 16, 2013, 08:07 PM
Did same with same results. Later it went back to 20 second shut down. These temp fixes are just that, temporary

You are correct.

SR45
Feb 17, 2013, 05:40 AM
You are correct.

Guess we all have to wait it out for the next release to see if anything is fixed. So far all the different suggestions have not really worked...:(

Badagri
Feb 17, 2013, 07:51 AM
I can't get over how long this has been on the go. Mountain Lion released on July 2012, here we are February 2013. Usually we're at 10.x.5/6 by now. Sometimes with the memory leaks and shutdown problems it feels like Apple really doesn't use OS X.

Mike MA
Feb 19, 2013, 04:04 PM
Sometimes with the memory leaks and shutdown problems it feels like Apple really doesn't use OS X.

Guess what, they now own iPads...

The Bulge
Feb 24, 2013, 10:44 AM
Finally with 12D68 reboot and shut down is almost instant on all machines i was able to test it.

Krazy Bill
Feb 24, 2013, 11:27 AM
Finally with 12D68 reboot and shut down is almost instant on all machines i was able to test it.Hopeful once again. There have been many "misfires" on this supposed fix in prior betas. (It works for a while, then shut down takes forever once again).

I for one really prefer a quick shutdown. I can't "sleep" between usage stops because I need every bit of juice over a 12 hour travel day. Just sleeping for a few hours sucks precious minutes from my battery. What a pain in the arse to get up from a table only to stand and wait for 30 seconds before closing the lid. :(

Please keep taking this "fix" through its paces and report back. :)

The Bulge
Feb 24, 2013, 12:15 PM
Hopeful once again. There have been many "misfires" on this supposed fix in prior betas. (It works for a while, then shut down takes forever once again).

I for one really prefer a quick shutdown. I can't "sleep" between usage stops because I need every bit of juice over a 12 hour travel day. Just sleeping for a few hours sucks precious minutes from my battery. What a pain in the arse to get up from a table only to stand and wait for 30 seconds before closing the lid. :(

Please keep taking this "fix" through its paces and report back. :)

Indeed it was getting better on few betas, but just for a few random moments. At least in my cases it's now solid 3-4 seconds every time.

dastinger
Feb 24, 2013, 02:15 PM
Hopeful once again. There have been many "misfires" on this supposed fix in prior betas. (It works for a while, then shut down takes forever once again).

I for one really prefer a quick shutdown. I can't "sleep" between usage stops because I need every bit of juice over a 12 hour travel day. Just sleeping for a few hours sucks precious minutes from my battery. What a pain in the arse to get up from a table only to stand and wait for 30 seconds before closing the lid. :(

Please keep taking this "fix" through its paces and report back. :)
Macs don't work like Windows machines regarding shut down. As long as the grey screen is showing, you may close the lid and it will shut down instead of sleeping so you don't need to wait 30 seconds for it to shut down before closing the lid. Regardless, a 30 second shut down time is obviously not accepted.

Badagri
Feb 24, 2013, 03:45 PM
Macs don't work like Windows machines regarding shut down. As long as the grey screen is showing

Considering there was no grey screen with Lion. You clicked shutdown, desktop, black screen and click. 2 seconds.

SR45
Feb 24, 2013, 06:28 PM
Indeed it was getting better on few betas, but just for a few random moments. At least in my cases it's now solid 3-4 seconds every time.

How many times is "each and every time" now The Bulge ?

Krazy Bill
Feb 24, 2013, 07:46 PM
As long as the grey screen is showing, you may close the lid and it will shut down instead of sleeping so you don't need to wait 30 seconds for it to shut down before closing the lid.I did not know this! :eek: I think I'm just paranoid from my Leopard days when I would "sleep" my machine only to find the damn fans whirring at 6000rpm the next day.

Besides... there's just something "final" about a nice black screen while closing the lid after a 3 second shutdown.

bkends35
Feb 24, 2013, 08:26 PM
This is pretty ridiculous, my sister's base MBP Mid 2010 on 10.6.x shuts down much faster than my rMBP 2.6. Mine literally boots up 2x as fast as it shuts down sometimes. And when i'm running windows 7, it shuts down in 2-4 seconds.

MacMan988
Feb 25, 2013, 12:00 AM
Apple hasn't done anything about this yet? :(

The Bulge
Feb 25, 2013, 04:02 AM
How many times is "each and every time" now The Bulge ?

I gave up on testing after 20 reboots and shut downs.

SR45
Feb 25, 2013, 07:44 AM
I gave up on testing after 20 reboots and shut downs.

Thanks Bulge. Good indicator that maybe, just maybe the fix has arrived in the newest build :)

dastinger
Feb 25, 2013, 01:17 PM
Considering there was no grey screen with Lion. You clicked shutdown, desktop, black screen and click. 2 seconds.

I did not know this! :eek: I think I'm just paranoid from my Leopard days when I would "sleep" my machine only to find the damn fans whirring at 6000rpm the next day.

Besides... there's just something "final" about a nice black screen while closing the lid after a 3 second shutdown.
That's why I said that, regardless of being able to close the lid keeping the shut down process going, a 30 second shut down time is not acceptable. I never said I didn't mind about that ;)

Mike MA
Feb 27, 2013, 04:45 PM
I gave up on testing after 20 reboots and shut downs.

With what workload before shutting down? I just need to start iTunes & Airplay (and close again beforehand) for the slow shutdowns. Just for interest.

Krazy Bill
Feb 27, 2013, 05:15 PM
With what workload before shutting down? I just need to start iTunes & Airplay (and close again beforehand) for the slow shutdowns. Just for interest.Is this happening using the latest beta like theBulge? Or are you merely talking about your shutdown woes with 10.8.2. like everybody else here?

Mike MA
Feb 27, 2013, 05:37 PM
Is this happening using the latest beta like theBulge? Or are you merely talking about your shutdown woes with 10.8.2. like everybody else here?

The latter, but still with the same question.

The Bulge
Feb 27, 2013, 11:58 PM
With what workload before shutting down? I just need to start iTunes & Airplay (and close again beforehand) for the slow shutdowns. Just for interest.

Usually i turn the computer on in the morning and shut it down when i go home, i do video and web design mostly.

Prof.
Feb 28, 2013, 10:27 AM
My friend just bought a brand new 13" base model MBP. Hers takes forever to shut down.

Krazy Bill
Feb 28, 2013, 03:20 PM
My friend just bought a brand new 13" base model MBP. Hers takes forever to shut down.Well there we have it then. Now that a female has confirmed this issue it's a bonafide fact. (Just ask your wives if the female species is ever wrong about anything :eek:).

ultraspiracle
Mar 5, 2013, 03:44 AM
Please file a bug report on this issue. There are plenty of links on how to attach a system log in the "comments" section of the bug report.

http://www.apple.com/feedback/macbookpro.html

This is a very serious issue and one that we do not want to be overlooked by the development team in lieu of facebook integration or some other B.S., since it dramatically affects those of us who rely on stable operating systems to use our macs as work machines.

The Bulge
Mar 5, 2013, 07:00 AM
Had to Time Machine 600 GB, because not only slow shut down came back, but also very annoying wifi issues.

z06gal
Mar 5, 2013, 07:47 AM
Well there we have it then. Now that a female has confirmed this issue it's a bonafide fact. (Just ask your wives if the female species is ever wrong about anything :eek:).

I must be the exception then because I am ALWAYS wrong :D

Mike MA
Mar 14, 2013, 04:00 PM
Installed 10.8.3 and now counting....

Badagri
Mar 14, 2013, 04:05 PM
Heh, didn't fix it then... 5 months for the release to not rectify it?

meme1255
Mar 14, 2013, 04:17 PM
And have you installed combo update? I'm going to, because it replaces all files instead of editing existing ones.

Drew017
Mar 14, 2013, 04:49 PM
Updated to 10.8.3… seems to fix the issue so I'm not having slow shutdown time anymore

razmarino
Mar 14, 2013, 05:04 PM
appleeventsd is still hangin here on 2011mbai7/256ssd & 2012mbai7/256ssd.. but looks like manual modification of the plist still working without issues

SR45
Mar 14, 2013, 05:29 PM
10.8.3 update. Not full reformat

First shut down took 4 seconds

Second shut down took 12 seconds

Third shut down after making sure Safari was closed along with Pages and it took 3 seconds to shut down. Happy now....

August West
Mar 14, 2013, 06:19 PM
Just updated to 10.8.3 on a 2012 mini w/ Samsung 840 SSD and unfortunately find no change. Still have consistent 20 sec. shut downs.

Krazy Bill
Mar 14, 2013, 07:11 PM
Just updated to 10.8.3 on a 2012 mini w/ Samsung 840 SSD and unfortunately find no change. Still have consistent 20 sec. shut downs.Ditto here. And to prove this isn't fixed try shutting down from the login screen. This show there are no apps in memory causing this. It's pure OSX.

SR45
Mar 14, 2013, 07:17 PM
Update:

2011 MacMini 5400 rpm Hdd 16 Gb memory

1. 20 second shut off.....Reformat/Reinstall fresh copy of 10.8.3

2. 20 second shut off.....Second shut down after reformat

3. 3 second shut off......Third shut down test

4. 3 second shut off......Fourth shut down test

5. 3 second shut off......5th time test

6. 9 second shut off......6th time test

7. 17 second shut off..... 7th time, and final one using keyboard shut down method
-----------------------------------------------------
Shut down from login screen only...

1st test and shut down was 3 seconds

2nd test and shut down was 3 seconds again

3rd test and shut down was 3 seconds again :D

4th test and shut down was 3 seconds..... :D:D

5th test and shut down was 3 seconds......:D:D:D

End of test for now....

August West
Mar 14, 2013, 07:21 PM
Ditto here. And to prove this isn't fixed try shutting down from the login screen. This show there are no apps in memory causing this. It's pure OSX.

Just updated my 2009 MBP and see no change in it either. I was really hoping it would fix the MBP because I shut it down a lot but almost never shut down the mini. Maybe it will get fixed in 10.9 :(

Krazy Bill
Mar 14, 2013, 09:37 PM
Update:

2011 MacMini 5400 rpm Hdd 16 Gb memory

1. 20 second shut off.....Reformat/Reinstall fresh copy of 10.8.3

2. 20 second shut off.....Second shut down after reformat

3. 3 second shut off......Third shut down test

4. 3 second shut off......Fourth shut down test

5. 3 second shut off......5th time test

6. 9 second shut off......6th time test

7. 17 second shut off..... 7th time, and final one using keyboard shut down method
-----------------------------------------------------
Shut down from login screen only...

1st test and shut down was 3 seconds

2nd test and shut down was 3 seconds again

3rd test and shut down was 3 seconds again :D

4th test and shut down was 3 seconds..... :D:D

5th test and shut down was 3 seconds......:D:D:D

End of test for now....

Use your machine between tests. Give OSX time to bog down first.