PDA

View Full Version : iTunes Photo Sync: Unknown Error 1140




aross99
Sep 21, 2012, 12:50 PM
Seems to be a growing problem when syncing photos in iTunes after the iPhoto 9.4 update. Here is one thread:

https://discussions.apple.com/thread/2681427?start=0&tstart=0

Sync is interrupted with "Unknown Error 1140". It seems to be directed to "iPod Photo Cache", but removing these files doesn't seem to help. Repairing permissions in iPhoto (Launch and hold CTRL-CMD), doesn't seem to help...

Any other suggestions, other than wait?



highpti
Sep 21, 2012, 02:52 PM
Tried all of the suggestions in the various threads to no avail. Even re-imaged the iPad, and I added apps then photos after doing a minimal image rebuild. Got the same message when I clicked on Sunc Photos from iPhoto. Unclicking it allows the sync to complete fine.

aross99
Sep 21, 2012, 03:39 PM
I even tried reloading my 40GB iPhoto library from the day BEFORE the update, and it still wouldn't work.

The error seems to indicate some issue with your iPhoto library, and that would explain why you can't select the events, etc.

On my wife's machine, she upgraded to 10.8.2 but didn't load the iPhoto update. She says she can sync photos... I can't get her to load the update to see if that breaks syncing though. :-)

Makes me wonder has ANYONE on Mountain Lion 10.8.2 been able to sync photos after the iPhoto updates?

DarthBradicus
Sep 22, 2012, 12:25 AM
I noticed the same problem when trying to sync my new iPhone 5. If sync photos is checked, I get the error. If not, no error. I looked all over for a solution and couldn't find one. After reading here, it seems like a bug with the latest version of iPhoto.

fredbuchwald
Sep 25, 2012, 02:34 PM
I have had the same problem, and fixed it by turning off option to sync photos. Now will have to wait until the bug is fixed. Anyone know how to report this to Apple?

From A Buick 8
Sep 27, 2012, 03:37 PM
Thanks, unchecking the iPhoto sync worked.

spaceballl
Oct 1, 2012, 07:55 PM
Bug is hitting me too ;-(

wilsonlaidlaw
Oct 12, 2012, 10:36 AM
Me too. Had to disable iPhoto and sync via cable, otherwise got error -50. Taking their time to sort this one aren't they?

Wilson

spaceballl
Oct 12, 2012, 11:14 AM
Yup. Annoying. I've actually turned off photo syncing altogether now as I can't get it to re-sync. This is really annoying. Combine this bug w/ the duplicate iTunes song sync'ing bug, and I'm just getting really annoyed with this whole process. I wonder if it's a phone issue or iTunes issue. If it's the latter, perhaps they will all get fixed with the next major release of iTunes, the redesign this fall?

Anyhow, WM9 looks kinda neat. I think i'm going to try out a Nokia Lumia 920 for a little bit. And if I hate it, i'll sell it and get the iPhone 5 and come back into the ecosystem :).

aross99
Oct 12, 2012, 10:04 PM
There was an iPhoto update the other day that should have fixed this issue. Run the software update and try your sync again, I think it should be fine now...

spaceballl
Oct 12, 2012, 10:05 PM
There was an iPhoto update the other day that should have fixed this issue. Run the software update and try your sync again, I think it should be fine now...
I also thought it would fix it. Fixed the issue for my wife's iPhoto library and phone, but not mine.

With a K
Jan 22, 2013, 10:36 AM
Does anyone know if this problem has been fixed yet?