PDA

View Full Version : OS X 10.8.2 wifi issue




tommy060289
Sep 22, 2012, 04:21 PM
Hey everyone,

I upgraded to 10.8.2 when it came out but ever since I've been having wifi issues on my 2011 27" iMac.

There doesnt seem to be any pattern to it or anything but Ill be on the internet and all of a sudden the connection seems to time out. The iMac still says its connected to the wifi network but no web pages will load and the little green tick on drop box disappears. Sometimes disconnecting the wifi and reconnecting fixes it and sometimes it doesnt.

I've not noticed any issues with any other devices such as my iphone or my laptop on 10.8.2 but then again I barely use the laptop (a 2009 MBP). I also seem to have issues with time machine since the upgrade as I haven't had a successful back up since and now cant seem to get the time machine to readd the drive. This is a Western digital my world book.

I was hoping to google 10.8.2 wifi problems and find others were having problems and maybe a solution but I havnt seen any and wifi has always been solid as a rock prior to 10.8.2.

Cheers,

Tom



Krazy Bill
Sep 22, 2012, 04:42 PM
My wife's MBP does the same thing.

This has been an ongoing problem with the OSX "Lions" for as long as I can remember. Some people have this issues and others don't so it's hard to nail down. Ironically, my machine running Snow Leopard has no issues at all with wi-fi. (or anything else for that matter).

satcomer
Sep 22, 2012, 05:12 PM
1. First try a Reset Your PRAM (http://support.apple.com/kb/HT1379) to see if it helps.

2. Tell us what wireless signal OS X is having with (a, b, g or n).

3. Don't panic.

jackbauer538
Sep 22, 2012, 05:55 PM
I have exactly the same issue here, iMac 27 Inch end 2009 connected to a Netgear WNDR4000 (on 5Ghz).

Network signal is still there but no internet connection. All the other devices on the network (also WiFi) can still access the internet.

Problem can be solved by either rebooting my iMac or the Netgear router.

Never had this issue before, it happend now 2 times in 1 day after upgrading to version 10.8.2:mad:

tommy060289
Sep 23, 2012, 01:25 AM
Will try resetting the PRAM and see what happens.

Im using n-type wireless with 5-GHz network but ive tried adjusting things and never really had any luck with that:(

Turning wifi on and off again seems to fix it but irritating and doesnt stop it happening again. Also, the wifi just seems to have problems picking up other wireless networks when jst switched on like I have been using my iphone to tether (over wifi) to get round it but sometimes it takes a while to appear but then connection doesnt drop to the iphone strangely:/ but no other devices like laptops or iphone having problems wifi in the same room or even further away!

Edit: Just found this on Apple Support: http://support.apple.com/kb/HT1379?viewlocale=en_US&locale=en_US. Suggests resetting PRAM wont do anything for network problems.

mackid1993
Sep 23, 2012, 03:06 AM
Will try resetting the PRAM and see what happens.

Im using n-type wireless with 5-GHz network but ive tried adjusting things and never really had any luck with that:(

Turning wifi on and off again seems to fix it but irritating and doesnt stop it happening again. Also, the wifi just seems to have problems picking up other wireless networks when jst switched on like I have been using my iphone to tether (over wifi) to get round it but sometimes it takes a while to appear but then connection doesnt drop to the iphone strangely:/ but no other devices like laptops or iphone having problems wifi in the same room or even further away!

Edit: Just found this on Apple Support: http://support.apple.com/kb/HT1379?viewlocale=en_US&locale=en_US. Suggests resetting PRAM wont do anything for network problems.

I would recommend going into your router's settings and changing your network to 802.11g 2.4ghz. ML has a problem with n Wi-Fi. My connection used to drop constantly-- but after I tried this, it has been stable for nearly a month with heavy usage. This is really an issue that Apple needs to sort out. :rolleyes:

EDIT: I'm not sure if 2.4 vs 5.8 ghz actually matters with this... those happen to be my network settings. If you have interference issues (ie. a cordless phone) I'd suggest changing to 802.11g. If that doesn't solve it, then change your network to 2.4 ghz. Also, if you option click the Wi-Fi icon in your menubar, you can see if you are connected to an 802.11 b, g, or n network. It will also show you the channel, signal strength, and frequency. Good way to confirm if your protocol change worked. Hope it helps! :)

jackbauer538
Sep 23, 2012, 04:02 AM
Will try resetting the PRAM and see what happens.

Im using n-type wireless with 5-GHz network but ive tried adjusting things and never really had any luck with that:(

Turning wifi on and off again seems to fix it but irritating and doesnt stop it happening again. Also, the wifi just seems to have problems picking up other wireless networks when jst switched on like I have been using my iphone to tether (over wifi) to get round it but sometimes it takes a while to appear but then connection doesnt drop to the iphone strangely:/ but no other devices like laptops or iphone having problems wifi in the same room or even further away!

Edit: Just found this on Apple Support: http://support.apple.com/kb/HT1379?viewlocale=en_US&locale=en_US. Suggests resetting PRAM wont do anything for network problems.

My iMac has the Atheros 9280: 4.0.70.23-P2P chipset build in for WiFi, which chipset do you have in your iMac?

in my opinion it's a bug in 10.8.2, never had issues before with 10.8.1 and older.

tommy060289
Sep 24, 2012, 06:04 AM
Im not sure of my chipset as I havnt't checked it but it is most definetly OS X 10.8.2 as it never did this before.

Very frustating. Tried playing with different wifi settings but no fix:(

SyncFx
Sep 24, 2012, 06:37 AM
I had WiFi issues since I installed 10.8.1, which actually ported over to my Bootcamp as well. Here is a fix:

Open your Network preferences and select Advanced on WiFi. Go to the Hardware tab and change the MTU value to lower than 1500 *1500 is the highest and default* I set mine to 1400 and WiFi works like a charm, also set it to 1400 in Bootcamp, works like a charm.

tommy060289
Sep 24, 2012, 12:29 PM
nope. Didn't work. Its getting worse and its so frustrating.

How can I raise awareness of this happening as Apple need to know its still doing it in 10.8.2. Its making my iMac unusable. It's a waste of time me taking it in to the apple store as I know full well it wont even do it there as I cant get it to do it on the other router I have. Even though this router works fine with everything else and worked perfectly up until 10.8.2:(

yoseeep
Sep 24, 2012, 02:10 PM
I had WiFi issues since I installed 10.8.1, which actually ported over to my Bootcamp as well. Here is a fix:

Open your Network preferences and select Advanced on WiFi. Go to the Hardware tab and change the MTU value to lower than 1500 *1500 is the highest and default* I set mine to 1400 and WiFi works like a charm, also set it to 1400 in Bootcamp, works like a charm.

i had the same issue since 10.8.2 . thank you 100times, this fixed it! :apple:

SyncFx
Sep 24, 2012, 03:34 PM
nope. Didn't work. Its getting worse and its so frustrating.

How can I raise awareness of this happening as Apple need to know its still doing it in 10.8.2. Its making my iMac unusable. It's a waste of time me taking it in to the apple store as I know full well it wont even do it there as I cant get it to do it on the other router I have. Even though this router works fine with everything else and worked perfectly up until 10.8.2:(

You can try adding a new Location in the Network Preferences.

Top Center it should say Locations: Automatic. Click it and select Edit Locations. Add a new location and name it. Save it. You can delete the Automatic location, but I think that removes all your saved networks such as WiFi.

Everything will be "fresh" in a sense.

tommy060289
Sep 25, 2012, 11:45 AM
tried that as well with no luck. Its becoming really frustrating. I went to post on the apple support forum but the log in process was being ridiculous, saying I needed to create a username when logged in with my apple ID and then saying my email already has a username:/

tommy060289
Sep 26, 2012, 04:45 PM
Im currently having a play but I'm starting to suspect that the problem links to trying to sync a device wirelessly with iTunes. Seems to drop whenever this happens (I have an iPhone and an iPad 3).

Anyone else noticed this pattern?

jsmiley125
Sep 27, 2012, 09:24 PM
Im currently having a play but I'm starting to suspect that the problem links to trying to sync a device wirelessly with iTunes. Seems to drop whenever this happens (I have an iPhone and an iPad 3).

Anyone else noticed this pattern?

Yes! I am seeing this exact same problem since upgrading to 10.8.2. It *seems* to only happen when I have iTunes running and I try to sync my iPhone.

Not sure if it's related, but I've been having trouble getting iTunes to consistently see my iPad over Wi-Fi sync as well.

I'm thinking about ripping out iTunes and reinstalling it. And/or reinstalling the 10.8.2 update using Apple's combo updater.

If either works, I'll post here.

blatopilot
Sep 28, 2012, 01:00 AM
Try turning off your hardware (mac, phone, ipad etc) and then unplugging your modem and router for 2-3 minutes.

Plug modem in first, router second, then power on hardware.

Also it might be helpful to create a new location in network preferences. Create a new one, delete the old one and see how that works.

NewJorg
Oct 1, 2012, 08:50 AM
I found this solution elsewhere (http://forums.macrumors.com/archive/index.php/t-1410516.html) on MacRumors (by an apparent genius named troutspinner) and it WORKED:

"I believe I've proven my theory correct and have fixed it.

For starters, I've read many posts on the internet about resetting pram, deleting your network location, re-establishing you network etc. but after trying them, never once was I prompted to enter the password for my network. This tells me that my network password and configuration was stored somewhere.

That somewhere was keychain. Go to your Spotlight (magnifying glass in the upper right hand corner) and type keychain and you will see "Keychain Access". Click on it to enter Keychain Access.

In Keychain Access I noticed duplicate entries of my network in both system and login. Click on Login, then sort by Kind and you will see "Airport network password" for every network you belong to. Now delete the one you are having issues with as well if there are duplicate entries. If there are, this is most likely your problem. Now click on System and delete the one you are having issues with as well if there are duplicates. Once again, if there are, this is most likely your problem.

Close Keychain Access and click your WiFi Icon in the upper right hand corner and then click on the network you want to connect to. It should prompt you for a password, fill it in and then click on remember. Viola! Fixed!

I've made it sleep, I've shut down completely and now it just works.....like I am used to.

Let me know how you make out. Just because this fixed it for me does not mean it will work for everyone as our problems could be very different."

I'm a ROb
Oct 1, 2012, 02:32 PM
I had the same issue when upgrading to Mountain Lion. I too tried making a new location, switching to MTU=1453, resetting the PRAM, deleted the keychain items but all were not of much help. My internet speed kept on being something like 5 to 10 times slower than before.

I tried playing around with the settings of the wifi. I already tried switching to a specific band (instead of auto), but I found not much improvement. Until I decided to try all bands and I found one that brings it back up to speed. It could still be better, but I'm satisfied for now.

tommy060289
Oct 7, 2012, 04:05 AM
I've tried backing up the computer and installing fresh mountain lion and then updating before restoring from time machine and post update, pre-restore the wireless seems to work but then after restoring the problems seem to appear again so I think I am going to try starting a fresh. Just need to figure out what I need to save files wise to put on new machine.

Tech198
Oct 7, 2012, 04:51 AM
Theres a Wi-Fi issue ?? :eek:

Been using Wi-Fi all the time here, and no problem with 10.8.2.

Of course i didn't upgrade.... I re-downloaded 10.8.2 from the App store, backup-ed up & and did fresh instal from newly created 10.8.2 usb stick.

This is why i don't like upgrading..... (although i do it, at least i know to expect issues with anything).

But if there are no issues, touch wood :)

fisherking
Oct 7, 2012, 09:26 AM
i have a dual-band router; i have all kinds of issues using the 5ghz band (my GF, on an older mbp, has NO problems).

using the 2.4 band solved the problem completely (or rather, is a workaround...i cannot figure out the issue with the 5Ghz network)...

Tech198
Oct 7, 2012, 09:30 AM
i have a dual-band router; i have all kinds of issues using the 5ghz band (my GF, on an older mbp, has NO problems).

using the 2.4 band solved the problem completely (or rather, is a workaround...i cannot figure out the issue with the 5Ghz network)...


Try a different channel usually help.. Probably not that common on 5Ghz, but wouldn't hurt to see anyway.

jjmania
Nov 26, 2012, 11:57 PM
I found this solution elsewhere (http://forums.macrumors.com/archive/index.php/t-1410516.html) on MacRumors (by an apparent genius named troutspinner) and it WORKED:

"I believe I've proven my theory correct and have fixed it.

For starters, I've read many posts on the internet about resetting pram, deleting your network location, re-establishing you network etc. but after trying them, never once was I prompted to enter the password for my network. This tells me that my network password and configuration was stored somewhere.

That somewhere was keychain. Go to your Spotlight (magnifying glass in the upper right hand corner) and type keychain and you will see "Keychain Access". Click on it to enter Keychain Access.

In Keychain Access I noticed duplicate entries of my network in both system and login. Click on Login, then sort by Kind and you will see "Airport network password" for every network you belong to. Now delete the one you are having issues with as well if there are duplicate entries. If there are, this is most likely your problem. Now click on System and delete the one you are having issues with as well if there are duplicates. Once again, if there are, this is most likely your problem.

Close Keychain Access and click your WiFi Icon in the upper right hand corner and then click on the network you want to connect to. It should prompt you for a password, fill it in and then click on remember. Viola! Fixed!

I've made it sleep, I've shut down completely and now it just works.....like I am used to.

Let me know how you make out. Just because this fixed it for me does not mean it will work for everyone as our problems could be very different."


Thank you sooooo much! This is the only thing that seemed to work, at least so far! I have been going crazy for days having to boot my computer continuously just to get the connection, even though it said I was connected. Hope this continues!:D

s.hackler
Dec 17, 2012, 12:28 AM
I've tried everything y'all have suggested and it's still not working.
My Computer:
-MacBook Pro
-13-inch, Late 2011
-Processor 2.8 GHz Intel Core i7
-Memory 8 GB 1333 MHz DDR3
-Graphics Intel HD Graphics 3000 512 MB
-Software OS X 10.8.2

I got it in June of 2012 (I've had a MacBook since 2008) and everything worked fine on it. Well, when I moved to a different house like 5 miles away, I set up my wireless (same service provider, same router, same login and same password) and it worked fine. When I got roommates I decided to change my password and login information to something we could all remember fairly easily and because everyone around us had crazy names. On of my roommates has white Macbook from 2007/2008 and she used my wifi all the time before she moved in and everything switched over fine for her when we changed the information. Mine however will lose the signal if I close my laptop or if I let it sit for too long which is quite an inconvenience. My other roommate has no problems staying connected to the internet but she has a windows computer. :rolleyes:
I can go over to my friends houses and my computer picks up their wifi immediately and it never loses it. I don't even have to select their wifi, its just automatically connects when I open safari.

So for some reason my computer, and my computer alone, only hates my WIFI network. I've completely deleted every wifi network from my computer and I've started over like one of the posts suggests. I turned my MTU down to 1400. I'm desperate to get this fixed. I've been kicked out of my online homework and online quizzes. Thankfully my teachers were understanding the first time but having to go up to my school library (which closes at 11PM, crazy right?!) to do my work is a pain in the butt especially when my parents spent over $1300 on a laptop for me to do my work at home :mad: :mad:

Even though I've had a macbook since 2008 and I'm a total Apple fanboy I still haven't learned all the ends and outs of my computer so if anyone has any suggestions please please please help. I've put in a service request call but I won't be able to hear from them for a couple of days between my school/work schedule and their openings. If they help me out before someone replies I'll post what they did here.

Thanks in advance!! :D


ETA: My internet speed works fine

Goldenarmz97
Dec 17, 2012, 10:09 AM
Every device other than my Mac connects fine. I'm PO'ed.

s.hackler
Dec 17, 2012, 11:18 AM
I've been on the phone with Apple for 50 minutes.

-Select network preferences from the WIFI drop down menu
-Select WIFI on the left
-Check Ask to join new networks
-Click Advanced in the bottom right corner
-Delete all your preferred Networks (hit the minus button)
-Check Remember networks this computer has joined
-Check Require Admin to change network
-Check Require Admin to turn WIFI on/off
-Hit the + button to add your preferred network back
-Hit OK
-Hit Apply
-Click the lock on the bottom left hand


Hopefully y'all are able to fix your computer's network issues that way!!

Mike MA
Dec 21, 2012, 02:35 AM
1. First try a Reset Your PRAM (http://support.apple.com/kb/HT1379) to see if it helps.

Just for my understanding, doesn't the support link you mentioned explicitly say that no network settings are stored within NVRAM/PRAM memory?

satcomer
Dec 21, 2012, 03:50 PM
Just for my understanding, doesn't the support link you mentioned explicitly say that no network settings are stored within NVRAM/PRAM memory?

Yea I know but a lot of users say this helps. I was just throwing that out there, sorry.

Mike MA
Dec 21, 2012, 04:19 PM
Yea I know but a lot of users say this helps. I was just throwing that out there, sorry.

No, that's still a very interesting support document. Thanks for sharing.

iLog.Genius
Dec 21, 2012, 04:25 PM
Same problem here but this has been happening even with Leopard (Late-2008 MacBook Pro). Sometimes the AirPort icon would stay active but there would be no connection to the internet while other times it would completely drop and reconnect. Funny thing is it only happens to my Mac while all the other computers in the house are unaffected.

twintin
Dec 21, 2012, 05:00 PM
Same problem here but this has been happening even with Leopard (Late-2008 MacBook Pro). Sometimes the AirPort icon would stay active but there would be no connection to the internet while other times it would completely drop and reconnect. Funny thing is it only happens to my Mac while all the other computers in the house are unaffected.

The difference is that MACs unlike most other computers has 802.11d enabled by default (at least newer MACs). This features picks up a country code from nearby routers and configures the WiFi accordingly. Lot of routers unfortunately reports wrong country code and may give the kind of problem you described.

Check out your system console and search for "en0: 802.11d" and see what country code was used. This kind of issues can most of the time be resolved by selecting a channel manually from your router. It helped me.

stdvos
Dec 29, 2012, 05:31 AM
I found this solution elsewhere (http://forums.macrumors.com/archive/index.php/t-1410516.html) on MacRumors (by an apparent genius named troutspinner) and it WORKED:

"I believe I've proven my theory correct and have fixed it.

For starters, I've read many posts on the internet about resetting pram, deleting your network location, re-establishing you network etc. but after trying them, never once was I prompted to enter the password for my network. This tells me that my network password and configuration was stored somewhere.

That somewhere was keychain. Go to your Spotlight (magnifying glass in the upper right hand corner) and type keychain and you will see "Keychain Access". Click on it to enter Keychain Access.

In Keychain Access I noticed duplicate entries of my network in both system and login. Click on Login, then sort by Kind and you will see "Airport network password" for every network you belong to. Now delete the one you are having issues with as well if there are duplicate entries. If there are, this is most likely your problem. Now click on System and delete the one you are having issues with as well if there are duplicates. Once again, if there are, this is most likely your problem.

Close Keychain Access and click your WiFi Icon in the upper right hand corner and then click on the network you want to connect to. It should prompt you for a password, fill it in and then click on remember. Viola! Fixed!

I've made it sleep, I've shut down completely and now it just works.....like I am used to.

Let me know how you make out. Just because this fixed it for me does not mean it will work for everyone as our problems could be very different."

I've had the same problem for a couple of weeks now. Trying the network location or MTU-fixes did not do the trick for me and I did not fancy a "fresh start" as suggested earlier. This fix took me 3 minutes and works like a charm :). Rebooting, stand-by, returning from other networks all works fine now. A big thank you for this fix!

popcornjunky
Dec 30, 2012, 06:29 PM
I would recommend going into your router's settings and changing your network to 802.11g 2.4ghz. ML has a problem with n Wi-Fi. My connection used to drop constantly-- but after I tried this, it has been stable for nearly a month with heavy usage. This is really an issue that Apple needs to sort out. :rolleyes:

EDIT: I'm not sure if 2.4 vs 5.8 ghz actually matters with this... those happen to be my network settings. If you have interference issues (ie. a cordless phone) I'd suggest changing to 802.11g. If that doesn't solve it, then change your network to 2.4 ghz. Also, if you option click the Wi-Fi icon in your menubar, you can see if you are connected to an 802.11 b, g, or n network. It will also show you the channel, signal strength, and frequency. Good way to confirm if your protocol change worked. Hope it helps! :)


This has been driving me crazy for ages. The only good thing from it is that my kids stopped using my computer b/c the internet didn't work. It dropped me constantly - and always when I really needed it.

I just changed the router security to 802.11 and have been working without being dropped for the last 2 hours. That NEVER happened before.

THanks. These forums are great.

stdvos
Jan 2, 2013, 02:46 PM
I've had the same problem for a couple of weeks now. Trying the network location or MTU-fixes did not do the trick for me and I did not fancy a "fresh start" as suggested earlier. This fix took me 3 minutes and works like a charm :). Rebooting, stand-by, returning from other networks all works fine now. A big thank you for this fix!

After a full night's sleep, the problem of not automatically logging on to the wireless network persisted. I decided to mess around with the settings of the wireless network (via the router).

changed wifi-security from WPA to WPA2
changed wifi protocol to 802.11g
changed wifi channel to 6 (2,4GHz)

This worked for me, I don't know why, but I wanted to share my solution anyway. It could be the 802.11g as mentioned in the post above.

PS The channel doesn't have to be channel 6. It depends on possible other wireless networks around you. Use tools like iStumblr (http://www.istumbler.net) to find out on which channel there is least interference. More info on which channel to choose via http://www.dslreports.com/faq/14250

Gentfam
Jan 16, 2013, 01:52 PM
.. for me too. At least for the moment. Hopefully I'm not rejoicing too soon, but so far so good.

limelaxer
Jan 28, 2013, 11:38 PM
Tried above 'fix'

Did not work for me. Wife going to kill me if I cannot fix this. Cannot stay on net long enough to even post this (had to write and paste).

Erased the password from keychain and re-entered, no fix.

PLEASE help!

Really need step by step as I am, ummm, slow with this stuff.

Using Mac OS X Lion 10.7.5 (11G63)

HELP HELP HELP!

mijawe
Jan 30, 2013, 09:40 AM
I recently had wifi connectivity problems with a new macbook air and thought I'd share my experiences here. First, some background.

Years ago, we had a wireless network consisting of an Airport Extreme (the old one that was somewhat dome-shaped) and an Airport Express (the old one that plugged directly into the wall). This worked fine for a late 2006 white Macbook (OS 10.4, later 10.5) and an older Powerbook, but my Thinkpad T42 (win XP) would not stay connected reliably, dropping the signal at random times and requiring multiple resets and other annoyances. So after a bit of research I replaced the whole network with a pair of Linksys WRT54GLs flashed to DD-WRT v24. One ran in regular AP mode and the other in repeater-bridge mode so as to get an old (non-wifi) imac and the laser printer downstairs on the network.

This DDWRT configuration was one of the most reliable installations of any kind of technology I've ever used - I had to reset the routers maybe twice in three years, and neither the above white Macbook nor the Thinkpad, nor a November 2008 Al macbook (OS 10.5, later 10.6), nor a 2011 Macbook Pro (OS 10.7) ever had any problems staying connected.

Unfortunately, when the November 2008 Al macbook was replaced a few months ago with a 2012 Macbook Air (OS 10.8), the MBA would not stay connected reliably (although it had no problems in other places where it was regularly used, e.g. office wifi networks).

It's worth noting that the user account/data were copied via the Apple migration utility from the 2008 macbook to the new MBA. One theory of MBA problems is that (sometimes) they are caused by settings getting ported over from an older OS improperly, but that doesn't seem to have been the case here, I don't think - more below.

All of the following - gleaned from this and other threads/sites I found while trying to troubleshoot - were tried, but to no avail, or at least no regular avail (i.e. a restart would sometimes work, but only for a while, or sometimes not at all)

-disconnect / reconnect to the wifi network
-use network connection troubleshooting wizard
-turn wifi off/on
-DHCP release/renew
-reboot the MBA
-change the wifi channel
-change the wifi security method (e.g. WPA2 vs. WPA)
-change the network name
-change from a/b/g broadcast mode to forced g-only or b-only
-clear the SMC
-manually delete user/system keychain entries related to the wifi network in question
-disable IPv6
-set MTU = 1453
-add manual DNS entries (cf. picking these up via DHCP)
-add new location in location manager

I did not try the following, either due to lack of time or seeming inadequacy / hackishness of the solution:

-have Apple replace wifi card in MBA
-alternate wifi hardware (e.g. USB adapter)
-genius bar visit for troubleshooting generally
-keepalive shell script running in background

After at least 10 hours of researching and troubleshooting I started to consider more drastic measures - changing the firmware on the Linksys routers or buying new routers altogether.

DDWRT seems to have drifted from the open-source philosophy and had some security holes a while back, so I did not want to just upgrade to a newer version of that. I also didn't want to bother messing around with Tomato because I wasn't sure different firmware on the same hardware would address the problem. I then considered buying new non-Apple routers and flashing them to Tomato, but it seemed this might not absolutely fix the problem either, although I wouldn't mind upgrading to 802.11n (the Linksys hardware only supported 802.11g).

Ultimately I just drove to the nearest Apple Store (about 30 minutes away) and bought two Airport Extremes. After the usual setup, the MBA began to work normally again, and has functioned perfectly ever since (no issues with the Macbook Pro 2011 which had been fine on the old configuration as well). One would hope Apple laptops would work well on Apple's own wireless gear, and it seems to be true at least in this case.

I can't say for sure alternate firmware on the old Linksys hardware wouldn't have worked, or that Tomato/DDWRT/other alternate (or even stock) firmware on some new non-Apple hardware wouldn't have worked. But ultimately I ran out of time to keep troubleshooting.

I think at least in this case I can rule out the idea that the power management aspect of the MBA was cutting power to the wifi card and thereby dropping the signal (another theory I've seen at least for some MBA wifi problems), because if that were the case then the problem would have persisted even after switching to the Airport Extremes. I haven't looked in fine detail at how various wifi routers / adapters vary in their implementation of 802.11b/g/n, but I can only surmise based on this experience that they are not all perfectly equal, and that the risk of conflicts increases the greater is the age between (at least some) wireless routers and (at least some) wireless adapters.

In summary, if you've been having this kind of problem, you may save time and headache (although not necessarily money) by simply trying different wireless networking hardware. And if that doesn't work, you could always return it.

I hope this is helpful if you've been having the same problems we were having.

Techbox Service
Feb 11, 2013, 08:13 PM
Hey Guys,

Don't forget to disable the "Internet Sharing" option in the Sharing preferences pane. In particular if you're restoring or doing a data migration between dissimilar computers. (i.e. MacBook Pro 13" to and iMac or MacBook Air) We've noticed that if you've used WiFi Internet Sharing you need to cycle (on/off) to prevent the WiFi from constantly cycling between ON/OFF/AD-HOC modes upon a restore. The previous solutions would not prevent this and the symptoms are all very similar. So if you're still having trouble, be sure to check your sharing options.

Cheers,

Techbox VI

MigsVuitton
Feb 16, 2013, 02:43 AM
New 13in retina with wifi issues. This is ******** annoying. I was not able to work for a week during a work trip. My boss is not very happy. WTF can I do?

loicg
Feb 17, 2013, 05:49 AM
Im currently having a play but I'm starting to suspect that the problem links to trying to sync a device wirelessly with iTunes. Seems to drop whenever this happens (I have an iPhone and an iPad 3).

Anyone else noticed this pattern?

Hi there,
Exactly the same issue you described at the beginning here. Wifi network reset on the imac, internet for a minute, then no internet although the computer says I'm connected to the modem/router.

It drove me nut, you can imagine.

After several attempts in destroying my network settings, trying everything listed here and there, I realise that in fact, itunes was running. I switch it off, looks that internet is working.

Then I thought a bit what did I change recently as it all worked when I received my 2013 imac27 with 10.8.2.

Only thing I changed was to share itunes library on the network to read it with my ipad. I just switched that off right now in itunes, and fingers crossed, I'm surfing for more than a minute (actually 10 minutes) and it works.

I need now to reinstall my airplay but I'm happy this is sorted out. Hope this helps someone sometimes.

Cheers

avflinsch
Feb 18, 2013, 08:21 AM
Try a different channel usually help.. Probably not that common on 5Ghz, but wouldn't hurt to see anyway.

Forcing the channel on the access point to something other than auto worked for me. It seems that everyone nearby using 5GHz was using channel 1 or 11, I figured that it was in-channel interference, forcing the access point to use a channel nobody else was using solved the problem for me.

rcancill
Mar 3, 2013, 11:52 AM
Forcing the channel on the access point to something other than auto worked for me. It seems that everyone nearby using 5GHz was using channel 1 or 11, I figured that it was in-channel interference, forcing the access point to use a channel nobody else was using solved the problem for me.

I had a similar problem several of my neighbors were on channel 6 which is the default that my Airport router chose. There is a very cool hidden tool that will show you what channels you and your neighbors are using hidden on your Mac.

Hold the Option Key and click on the wifi symbol up in your status bar. You should see "Open Wifi Diagnostics" at the bottom of the menu. When the Welcome dialog opens press CMD-N and a new "Network Utilities" window opens. Click on the "Wi-Fi Scan" icon and wait. A list of all the networks your Mac can see appears along with the channels they were using.

When I first saw this my router and several neighbors were defaulting to channel 6. I specified 7 and have had dramatic improvements!

teeharju
Mar 21, 2013, 01:05 PM
Thanks rcancill!

For long time I have been wondering why my wlan is so slow.

If my use my Sierra AC762S wlan router using USB, speed to ISP is fast as it should - no issues.

But if I use wlan to router, wlan (and speed to ISP too) is very slow.

Immediately when I chose different wlan channel that no-one else uses in their networks here nearby, I have huuuge improvements (many many times faster), on both of my Macs.

My devices:
- Sierra Wireless AC762S router ("dna Mokkula 4G")
- Mac Mini, OSX 10.8.2
- MacBook Pro, OSX 10.6.8

Also other settings on router:
- wlan performance: short
- basic speed 802.11 b/g (if put to "n", wlan starts to disconnect)
- MTU 1400 (same in Mac network settings too)

reza99d
Jun 12, 2013, 07:36 AM
I tried the keychain thing described below and it worked for me, I deleted the whole keychain for this wifi. And then everything worked! =) =)

Hey everyone,

I upgraded to 10.8.2 when it came out but ever since I've been having wifi issues on my 2011 27" iMac.

There doesnt seem to be any pattern to it or anything but Ill be on the internet and all of a sudden the connection seems to time out. The iMac still says its connected to the wifi network but no web pages will load and the little green tick on drop box disappears. Sometimes disconnecting the wifi and reconnecting fixes it and sometimes it doesnt.

I've not noticed any issues with any other devices such as my iphone or my laptop on 10.8.2 but then again I barely use the laptop (a 2009 MBP). I also seem to have issues with time machine since the upgrade as I haven't had a successful back up since and now cant seem to get the time machine to readd the drive. This is a Western digital my world book.

I was hoping to google 10.8.2 wifi problems and find others were having problems and maybe a solution but I havnt seen any and wifi has always been solid as a rock prior to 10.8.2.

Cheers,

Tom

houstonalle
Oct 12, 2013, 01:44 PM
I found this solution elsewhere (http://forums.macrumors.com/archive/index.php/t-1410516.html) on MacRumors (by an apparent genius named troutspinner) and it WORKED:

"I believe I've proven my theory correct and have fixed it.

For starters, I've read many posts on the internet about resetting pram, deleting your network location, re-establishing you network etc. but after trying them, never once was I prompted to enter the password for my network. This tells me that my network password and configuration was stored somewhere.

That somewhere was keychain. Go to your Spotlight (magnifying glass in the upper right hand corner) and type keychain and you will see "Keychain Access". Click on it to enter Keychain Access.

In Keychain Access I noticed duplicate entries of my network in both system and login. Click on Login, then sort by Kind and you will see "Airport network password" for every network you belong to. Now delete the one you are having issues with as well if there are duplicate entries. If there are, this is most likely your problem. Now click on System and delete the one you are having issues with as well if there are duplicates. Once again, if there are, this is most likely your problem.

Close Keychain Access and click your WiFi Icon in the upper right hand corner and then click on the network you want to connect to. It should prompt you for a password, fill it in and then click on remember. Viola! Fixed!

I've made it sleep, I've shut down completely and now it just works.....like I am used to.

Let me know how you make out. Just because this fixed it for me does not mean it will work for everyone as our problems could be very different."

Problem was so annoying. OS X 10.8.5 on my MacbookPro was the only device having the issue. This seems to be working wonders. Thanks!

satcomer
Oct 13, 2013, 08:50 PM
Plus a;ll you non knowing wireless users on a Mac should have the freeware iStumbler Beta (http://istumbler.net/beta/) (don't worry it works in 10.8 & 10.9). This way you don;t use the same wireless channel as other wireless routers around you. This way you can mitigate crosstalk.