PDA

View Full Version : Messages keeps asking me for password




reservedegotist
Sep 24, 2012, 12:30 AM
Hi all, I'm not sure if other people are experiencing this, but I am getting extremely annoyed by the fact that Messages keeps asking for my iMessage password. I've been seeing logs like this whenever I try to enter the password and have a feeling that the key matching isn't working as intended...

Every 5 to 10 minutes I am seeing a prompt from iMessage asking for my password and it's highly annoying. (This prompt below):

http://i.imgur.com/fywLn.png

Has anyone seen this and solved the issue? It's only started happening once I upgraded to Mountain Lion 10.8.2

I've attached the logs below:



9/24/12 12:23:26.496 AM Messages[900]: [Warning] Updating typing guid on IMMessage from CBB7831F-A3B5-490A-A8B0-8FE3A9665EE4 to 7F9AA292-3202-44BD-890C-CF6663CB6F6A
9/24/12 12:23:58.512 AM mdworker[996]: Unable to talk to lsboxd
9/24/12 12:23:58.521 AM mdworker[995]: Unable to talk to lsboxd
9/24/12 12:23:58.000 AM kernel[0]: Sandbox: sandboxd(997) deny mach-lookup com.apple.coresymbolicationd
9/24/12 12:23:58.639 AM sandboxd[997]: ([996]) mdworker(996) deny mach-lookup com.apple.ls.boxd
9/24/12 12:23:58.664 AM sandboxd[997]: ([995]) mdworker(995) deny mach-lookup com.apple.ls.boxd
9/24/12 12:24:39.458 AM imagent[869]: [Warning] Error from SecKeychainFindGenericPassword: -67808
9/24/12 12:24:39.459 AM imagent[869]: [Warning] Error from SecKeychainFindGenericPassword: -67808
9/24/12 12:24:39.460 AM imagent[869]: [Warning] Error from SecKeychainFindGenericPassword: -67808
9/24/12 12:24:41.025 AM imagent[869]: [Warning] Error from SecKeychainFindGenericPassword: -67808
9/24/12 12:24:41.025 AM imagent[869]: [Warning] Failed storing public keychain data
9/24/12 12:24:41.026 AM imagent[869]: [Warning] Error from SecKeychainFindGenericPassword: -67808
9/24/12 12:24:41.026 AM imagent[869]: [Warning] Failed storing private keychain data
9/24/12 12:24:41.027 AM imagent[869]: [Warning] Error from SecKeychainFindGenericPassword: -67808
9/24/12 12:24:41.027 AM imagent[869]: [Warning] Failed storing keypair signature data
9/24/12 12:24:41.028 AM imagent[869]: [Warning] Error from SecKeychainFindGenericPassword: -67808



David085
Sep 24, 2012, 12:33 AM
What's your password?, My friend.

reservedegotist
Sep 24, 2012, 12:35 AM
hunter2

pls help kthxbai

:cool:

But seriously -- has no one else encountered this before where the password saving just doesn't work? And just in case someone asks, I am sure I am typing the password correctly.

Wiggleforce
Sep 27, 2012, 07:50 AM
I'm having the same issues as you when a upgraded to OS X 10.8.2. So i thought a clean install of OS X 10.8.2 could help, but it didn't. But there is less prompts for me now with the clean install.

Peace

MiamiBourne
Oct 4, 2012, 07:36 PM
I'm having the same issue. It was working fine last night and I login today and I'm getting prompted for my login for FaceTime and iMessage. FaceTime went in fine, but iMessage keeps asking every I enter my password. My iPad and iPhone are working just fine...

macmar7
Oct 6, 2012, 01:40 AM
This method seems to have worked for me:

1. Click on the Spotlight icon at the top-right of your screen and type "Keychain Access".

2. At the top-left, under "Keychains," select "login" item.

3. In the "Category," below "Keychains," select "Keys".

4. Double-click on the entry "iMessage Signing Key".

5. Under the "Access Control" tab, there is a big white field entitled "Always allow access by these applications:". If "imagent" is not listed there, click on the plus button on bottom-left to add it. In the finder window that should slide out, find your "Macintosh HD" (could be at the bottom of the left pane) and from there navigate to "/System/Library/PrivateFrameworks/IMCore.framework".

6. Choose the "imagent.app" and click add. Type in your password, if prompted.

7. When you close the Keychain Access window, do not lock the login keychain, unless you want iMessages and other apps to ask for your password again.

Hopefully, this will help!

MiamiBourne
Oct 29, 2012, 05:48 PM
This method seems to have worked for me:

1. Click on the Spotlight icon at the top-right of your screen and type "Keychain Access".

2. At the top-left, under "Keychains," select "login" item.

3. In the "Category," below "Keychains," select "Keys".

4. Double-click on the entry "iMessage Signing Key".

5. Under the "Access Control" tab, there is a big white field entitled "Always allow access by these applications:". If "imagent" is not listed there, click on the plus button on bottom-left to add it. In the finder window that should slide out, find your "Macintosh HD" (could be at the bottom of the left pane) and from there navigate to "/System/Library/PrivateFrameworks/IMCore.framework".

6. Choose the "imagent.app" and click add. Type in your password, if prompted.

7. When you close the Keychain Access window, do not lock the login keychain, unless you want iMessages and other apps to ask for your password again.

Hopefully, this will help!

I've tried the above and I still have this issue. One thing to note is that when I go back into keychain the 'imagent' that I added is not there anymore under Access Control and the default is 'Allow all applications to access this item'. I have to select 'Confirm before allowing access' to be able to add 'imagent'.

MiamiBourne
Oct 30, 2012, 07:58 AM
I finally got iMessage to work by deleting the keychain associated with iMessage.

macmar7
Oct 30, 2012, 02:05 PM
I finally got iMessage to work by deleting the keychain associated with iMessage.

Great! That sounds like a better solution than changing the key settings. I assume that when you deleted the key, iMessages asked for your password once more, but this time it created a new key, properly configured.

paeza
Nov 15, 2012, 07:54 PM
I am having the same issue. Mails imessage keep asking for the password. It is very annoying. If anyone know how to fix it pls help.

macmar7
Nov 17, 2012, 08:08 PM
I am having the same issue. Mails imessage keep asking for the password. It is very annoying. If anyone know how to fix it pls help.

This could be a problem with your login keychain. A login keychain
stores passwords for your apps, including Mail and iMessage.
If the keychain password and your user account password
become different, you may experience annoying password promts.
To fix this problem, try this:


Open the app "Keychain Access,” either from Spotlight
(top-right of your screen) or from Applications>Utilities.
Enter your password if requested.


In the application menu, at the top-left of your screen,
select "Keychain Access>Preferences"


In the preferences window, go to the "First Aid" tab
and make sure that all of the four checkboxes are checked.


Close the preferences window, go to the same menu
("Keychain Access” at the top left), and select “Keychain First Aid.”


In the First Aid window, make sure that your current user account name
appears in the “User Name:” field, and then enter your password.


At the right side of the window select “Repair” and click “Start.”
If problems are detected, repeat the “Repair” process to be sure
that it says at the bottom of the window:
No problems found
Repair completed


Relogin or restart the computer and see if the problem is fixed.
If the problem persists, please provide more details about the prompt
and whether any apps, other than iMessages and Mail, ask you for password.

drpretam
Dec 22, 2012, 10:51 AM
I had the same problem of message on the mac constantly asking for my password. I tried resetting Mac OSX, Keychain acces, pref. files. Nothing worked. This solution worked. Courtesy Apple Support.

Boot in Recovery system, press Command and R keys in boot and hold the keys until you see the Apple icon.
When it starts, select Utilities > Terminal, and type:

resetpassword


Press your user and type your password. Finally, reboot.

Also create a new keychain when it prompts.

This solution worked for me. Best of Luck.
Pretam