PDA

View Full Version : Apple TV 5.1 Update, Handbrake-encoded Files, and No 5.1 Audio




Osip
Sep 26, 2012, 07:41 AM
I'll try to keep this brief: I did AC3 Passthru PLUS AAC Stereo using the Handbrake presets for a handful of DVDs I own to test out converting my collection to an iTunes-compatible format. Prior to the 5.1 update, all was working well; 5.1 when playing through the Apple TV, stereo when I played the exact same file on my iPhone or iPad. Now the same files still play fine on my iPad and iPhone, but the Apple TV refuses to output any audio on files that have an option between 5.1 and 2.0 (stereo). I went into Netflix on my Apple TV, picked a movie with 5.1 audio, and it played back properly without an issue.

My Apple TV is connected to my receiver via HDMI-only and my receiver is connected to my TV via HDMI as well. I've tried both forcing Dolby Output to "On" and "Auto" as well. I've found some comments on Apple's support forum from several years ago stating that using optical might fix a similar issue, but I fail to see why Apple would take a step backwards in HDMI-connectivity. :/

Since no one else seems to be complaining about this recently anywhere I've seen, it must be me. Does anyone have any suggestions?



Ewan Hoozarmy
Sep 26, 2012, 02:46 PM
I'll try to keep this brief: I did AC3 Passthru PLUS AAC Stereo using the Handbrake presets for a handful of DVDs I own to test out converting my collection to an iTunes-compatible format. Prior to the 5.1 update, all was working well; 5.1 when playing through the Apple TV, stereo when I played the exact same file on my iPhone or iPad. Now the same files still play fine on my iPad and iPhone, but the Apple TV refuses to output any audio on files that have an option between 5.1 and 2.0 (stereo). I went into Netflix on my Apple TV, picked a movie with 5.1 audio, and it played back properly without an issue.

My Apple TV is connected to my receiver via HDMI-only and my receiver is connected to my TV via HDMI as well. I've tried both forcing Dolby Output to "On" and "Auto" as well. I've found some comments on Apple's support forum from several years ago stating that using optical might fix a similar issue, but I fail to see why Apple would take a step backwards in HDMI-connectivity. :/

Since no one else seems to be complaining about this recently anywhere I've seen, it must be me. Does anyone have any suggestions?

Exactly the same problem for me. Couldn't fix it :mad:

Had to roll back to the previous firmware :rolleyes:

iLuvMyMacToo
Sep 26, 2012, 03:07 PM
Have you gone into your Apple TV setting and turned off "digital dolby"? That worked for me.

rdpbass
Sep 26, 2012, 03:19 PM
I have two atv 3's did the update on one same problem. The one I didn't update works fine. How do you go about rolling back to previous version ?

Osip
Sep 26, 2012, 06:52 PM
Ok good - It's not just me!

I have not tried either suggestion, but I will when I get home. The rollback appears to involve jailbreaking, which I'm hesitant to do but I really don't feel like losing 5.1 audio because of an update that didn't affect anything I care about.

That's what I get for wanting to keep up-to-date! :)

Rushli0n
Sep 26, 2012, 06:56 PM
Definitely not HDMI specific. I have optical and I am experiencing th same thing. When I change it to Auto I get sound but not Dolby. If I choose On, I get no sound. But what's odd, some of the files I encoded with handbrake when the setting is On do work. Not sure what is different.

Starhawk
Sep 26, 2012, 09:14 PM
My handbrake files seem to be working fine with DD 5.1. I tested a couple today.

Rushli0n
Sep 26, 2012, 09:19 PM
So I found a weird workaround. Hold select and go up to the Audio options and select the stereo track. Then go back and select the surround track. The Dolby works after you reselect it. What sucks is after I close the movie and play it again, I have to do that workaround again.

orestes1984
Sep 26, 2012, 09:43 PM
Ok good, I was going to go up to iOS 5.1 but now I'm not...

Osip
Sep 26, 2012, 10:05 PM
Ok good, I was going to go up to iOS 5.1 but now I'm not...

I wouldn't. It totally screwed me over.

As for the other "options", disabling Dolby works. Re-enabling it and going back to the video does not work. I guess I'll look into jailbreaking my Apple TV this weekend and reverting to a previous version of Apple TV OS until this gets fixed. :/ Good thing I immediately texted my brother and told him not to upgrade yesterday or he'd be very disappointed :is filtering his language:. ;)

EDIT: I lied! Doing the re-enable actually does work! I'm using a Harmony Remote and I've visited a local brewery this evening... *ahem* :D

Rushli0n
Sep 26, 2012, 10:11 PM
I figured out what my problem was and how to fix it.

1. I looked at the movie that was working (LOTR) in Subler versus a movie that wasn't (Avengers).
2. I noticed that the Surround box was checked on Avengers and NOT checked on LOTR. I unchecked the Surround box and remuxed the Avengers file.
3. I play the file on my AppleTV with Dolby set to ON and bam, it selects Dolby on my receiver.

Again, I am using an optical audio cable, so I don't know if that matters.

Osip
Sep 26, 2012, 10:23 PM
I figured out what my problem was and how to fix it.

1. I looked at the movie that was working (LOTR) in Subler versus a movie that wasn't (Avengers).
2. I noticed that the Surround box was checked on Avengers and NOT checked on LOTR. I unchecked the Surround box and remuxed the Avengers file.
3. I play the file on my AppleTV with Dolby set to ON and bam, it selects Dolby on my receiver.

Again, I am using an optical audio cable, so I don't know if that matters.

The problem with that is that when you uncheck the "Surrorund" checkbox, you're basically telling Subler to not include the actual surround track when you "Save" (aka "remux") it - Correct? If so, you're only getting faux-surround from your Apple TV, which brings us back to the whole "Why did this work before 'Update 5.1'?" issue. For now, pressing and holding "Select" (aka "OK" or "the button in the middle of the navigation buttons on the Apple Remote") until the menu pops up on-screen that lets you select different chapters OR audio options seems to be the only fix that allows you to use the *actual* 5.1 audio mix. As stated earlier, you have to select the 2.0 mix, play the video for a moment, and then select the 5.1 mix and play the video file again. This is a bug in Apple TV OS 5.1, in my rarely humble opinion, and I think I'm going to look into the downgrade some time this weekend because constantly having to do this for each file is lame. ;)

Rushli0n
Sep 26, 2012, 10:47 PM
The problem with that is that when you uncheck the "Surrorund" checkbox, you're basically telling Subler to not include the actual surround track when you "Save" (aka "remux") it - Correct? If so, you're only getting faux-surround from your Apple TV, which brings us back to the whole "Why did this work before 'Update 5.1'?" issue. For now, pressing and holding "Select" (aka "OK" or "the button in the middle of the navigation buttons on the Apple Remote") until the menu pops up on-screen that lets you select different chapters OR audio options seems to be the only fix that allows you to use the *actual* 5.1 audio mix. As stated earlier, you have to select the 2.0 mix, play the video for a moment, and then select the 5.1 mix and play the video file again. This is a bug in Apple TV OS 5.1, in my rarely humble opinion, and I think I'm going to look into the downgrade some time this weekend because constantly having to do this for each file is lame. ;)

I'd normally agree with you, but when I deselect the Surround checkbox and look at the Audio options on the movie on the AppleTV, it looks exactly the same as when it was selected. I don't think the AppleTV can generate a faux Dolby. If it's in the file, it will play it. I'm not an expert at this at all, but that process worked for me.

As for why it worked before...got me.

Osip
Sep 27, 2012, 07:48 PM
I don't think the AppleTV can generate a faux Dolby.

Not what I meant, sorry. My concern was that the A/V Receiver would be the device creating the simulated surround from a stereo source if you disabled Dolby Digital output on the Apple TV. I'm testing it now and I was correct - If you disable Dolby Digital output on the Apple TV, the Apple TV outputs 2.0 (stereo) audio over HDMI. The only solution that will provide you with a true surround mix seems to be the one mentioned above:

1. Start playback of the affected video file.
2. Press and hold the Select/OK button on your remote.
3. Select the "Audio" tab when the menu appears on-screen.
4. Select the 2.0 audio track and return to the video.
5. Repeat Step 2-3 and select the surround track.

Surround should work after that. You have to do this every time you play a video with a surround track. I'm assuming this isn't a problem with videos purchased from Apple, but I don't have anything from Apple with 5.1 to test this theory with... Wait! I do have one thing. I'll try it and update this post in a bit!

EDIT: The Store-purchased file's surround, of course, plays properly (the free episode of Battlestar Galactica that was offered a few years ago, if anyone is curious). I guess we're stuck with this workaround until if/when Apple decides to fix it. :/ Thanks, Rush, for at least coming up with some kind of fix! :)

I'll have to look at the Store-purchased file and see if I can figure out what's different about their audio encode. My guess is that a stereo track was not included with the HD video file that I played off of my Home Share. The steps above did not work for the Store-purchased video.

Diode
Sep 27, 2012, 08:00 PM
Open your files in Subler and make sure both sound tracks aren't checked.

Having one "unchecked" won't remove it from the file - the selection just tells the ATV which is the default. If both are checked - the ATV gets confused and you get the problem you describe.

Osip
Sep 27, 2012, 08:42 PM
Open your files in Subler and make sure both sound tracks aren't checked.

Having one "unchecked" won't remove it from the file - the selection just tells the ATV which is the default. If both are checked - the ATV gets confused and you get the problem you describe.

I had forgotten that I needed to test this as well. I've confirmed that it works, but it's going to be mildly annoying if you have a large number of files to process (i.e. Multi-season TV Shows @ about 24 episodes per season). I have 52 or so that I'm going to have to fix that were working perfectly fine before this update. A minor nuisance, sure, but a nuisance nonetheless. Thanks for the assist as well, Diode!

Rushli0n
Sep 27, 2012, 09:19 PM
I had forgotten that I needed to test this as well. I've confirmed that it works, but it's going to be mildly annoying if you have a large number of files to process (i.e. Multi-season TV Shows @ about 24 episodes per season). I have 52 or so that I'm going to have to fix that were working perfectly fine before this update. A minor nuisance, sure, but a nuisance nonetheless. Thanks for the assist as well, Diode!

I guess that's what I meant in my post, just didn't articulate it. To the point of the original post, having them both checked didn't make a difference with 5.0.2 but does in 5.1. I had to correct most of my files as both were checked and now they all work.

omni
Sep 27, 2012, 09:26 PM
Doesn't default Handbrake + Subler processed file result in only 1 audio file checkmarked (2 channel)? Meaning if you just follow the presets everything should still work fine?

Rushli0n
Sep 27, 2012, 10:13 PM
Doesn't default Handbrake + Subler processed file result in only 1 audio file checkmarked (2 channel)? Meaning if you just follow the presets everything should still work fine?

Yes, it does do that. I thought they both needed to be set and as it worked before the update I just assumed that was the way they had to be set. Guess not.

Starhawk
Sep 28, 2012, 12:18 AM
I checked a couple more of my Handbrake encoded files and they all play the DD 5.1 track just fine.

Curious, you guys that are seeing the issue, do you encode with your DD 5.1 track in the 1st place or 2nd? Mine were all encoded with the AAC in the first slot and DD passthru in the second.

I vaguely remember something about that being the "standard" way to encode for Apple TV files, but this was a long time ago.

Idgit
Sep 28, 2012, 03:31 AM
I checked a couple more of my Handbrake encoded files and they all play the DD 5.1 track just fine.

Curious, you guys that are seeing the issue, do you encode with your DD 5.1 track in the 1st place or 2nd? Mine were all encoded with the AAC in the first slot and DD passthru in the second.

I vaguely remember something about that being the "standard" way to encode for Apple TV files, but this was a long time ago.

Correct. For standard ATV 2 compatible files, the first audio track should be AAC Stereo and it should be checked. The second audio track can be surround sound AC-3 or AAC 5.1 and it should be un-checked.

Also, when you open the file in Subler, the audio tracks should both belong to Alternate Group 1. The video track should belong to Alternate Group None.

When set like that, the Apple TV should select the surround sound track automatically if you have receiver capable of playing surround sound audio.

ConvertApple
Oct 3, 2012, 04:15 AM
Hi, I have also been knobbled by the 5.1 update in exactly the same way on my ATV3's. I have a lot of files that are now afflicted by this bug and am today going to apple store to get them to downgrade me to 5.0.2 which I believe is still being signed by Apple (or get micro-usb cable and do it myself). I hope this is still do-able as I've read of others who've done it. It is such a PITA and has dented my trust in Apple forever more.

To a certain extent I am fortunate as I spent the last few months on/off writing my own program to re-encode and tag all video files into apple format so I could easily mod the code and re-run all my files through it, which as it does so automatically by examining the original file, would take none of my own time. I was going to release the app soon, but, typically this spanner is thrown in the works!

Grouping audio tracks, disabling one? If someone can elucidate... Is this done in the meta-data or...?

ConvertApple
Oct 3, 2012, 06:12 AM
Apple Shop were useless, saying it couldn't be done, wouldn't let me download a different firmware etc (hit stop on the download), so I had to do it while they weren't looking! And now back on 5.0.2 and all files work fine.
They wanted 20 for a micro-usb cable!!! got one for 4 in phone shop nearby!

So anyway I now have 2 apple TV's one still on 5.1 so it is easy to contrast and compare. Why would apple do this and why is it that files converted by other tools work? Using MediaInfo I can see no noticeable differences in the metadata etc, very confusing. I used FFMpeg to encode mine and they used to be fine, but...

Idgit
Oct 3, 2012, 10:50 AM
Grouping audio tracks, disabling one? If someone can elucidate... Is this done in the meta-data or...?

Have you used Subler? Subler allows you to order and group your audio tracks. If you only have a 5.1 audio track, subler can also encode a 2-channel track for the file.

http://code.google.com/p/subler/

ConvertApple
Oct 3, 2012, 11:13 AM
I don't have a mac. I wrote a program for windows that automatically does everything you need, re-encodes only if needed, generates the aac2+ac3 from dts or aac6 and an aac2 from that also etc etc, tags via themoviedb + thetvtb, just point it at a folder and it does the rest, however apple just broke it!

I'd fix the code but not sure what needs to be done, talk of alterntive groups, checking first audio? etc. I can see no options for that in ffmpeg or atomicparsley that I use at back-end to do the donkey-work.

Shame as the prog might have been a revelation to people who want to convert/tag their entire library of non apple+apple files to apple format with a single click and NO crashes, which was something I couldn't find and why I wrote it, but hey just when you think you're done. No point releasing an app that no longer works properly.

So If anyone knows at a code level what needs to be done, or if Apple are intending fixing this nonsense, plese let me know, until then....

Idgit
Oct 3, 2012, 11:50 AM
I'd fix the code but not sure what needs to be done, talk of alterntive groups, checking first audio? etc. I can see no options for that in ffmpeg or atomicparsley that I use at back-end to do the donkey-work.

So If anyone knows at a code level what needs to be done, or if Apple are intending fixing this nonsense, plese let me know, until then....

You can actually enable/disable audio tracks, as well as set the alternate fallback audio in Quicktime, but it's cumbersome and time-consuming. You test it out with a movie file or two to see if it makes any difference.

I wonder if MP4Tools (cli) can enable/disable audio tracks.

You also might find the following two sites to be interesting and/or helpful.

This detailed article from someone on the Quicktime engineering team (http://www.mactech.com/articles/mactech/Vol.18/18.07/July02QTToolkit/index.html) seems to have some code on how to set these various options.

Here is a technical Apple Developer Library article on Quicktime Modifier Tracks and Alternate Tracks (https://developer.apple.com/library/mac/#documentation/QuickTime/RM/MovieInternals/MTTimeSpace/F-Chapter/6ModifierTracks.html). Maybe there is something useful in there.

ConvertApple
Oct 3, 2012, 03:00 PM
Thanks for your help, I read those 2 links, but they don't really help. Ideally I don't want to use any other tools beyond ffmpeg to encode and atomicparsley to tag as they're working fine, doing everything I need - almost. I still cannot ascertain if it is some metadata that defines these "alternate tracks" groups and sets the ac3 track to disabled and if so what they are and if I can set them with either ffmpeg or atomicparsley

Idgit
Oct 3, 2012, 03:04 PM
Thanks for your help, I read those 2 links, but they don't really help. Ideally I don't want to use any other tools beyond ffmpeg to encode and atomicparsley to tag as they're working fine, doing everything I need - almost. I still cannot ascertain if it is some metadata that defines these "alternate tracks" groups and sets the ac3 track to disabled and if so what they are and if I can set them with either ffmpeg or atomicparsley

Do you have a sample file that you can provide (e.g., via Dropbox) that I can look at? I can run it through Subler and make changes, if necessary. Then send it back to you to see if it works.

BTW, HandbrakeCLI correctly enables the first 2-channel track, disables the second surround sound track (AC-3 5.1), and puts them in the correct alternate group. Have you tried the Apple TV 2/3 preset in Handbrake (app or CLI)? Could you integrate it into your workflow?

ConvertApple
Oct 3, 2012, 05:14 PM
Here's some short 4mb 40s samples I used uploaded to dropbox. My prog detects what is in original file so in case of an m4v will just re-mux it and tag it. (This file has tag data from 'a clockwork orange' in it, just chosen at random)

original working file (https://dl.dropbox.com/u/110448925/aac%2Bac3.m4v)

re-muxed+tagged non-working (https://dl.dropbox.com/u/110448925/aac2%2Bac3eng%2Btags.m4v)

I am loath to use different progs as ffmpeg can do all encoding/remuxing I need and atomicparsley can do all tagging, which worked great until atv 5.1.

TBH I've finished converting all MY files, tagged most of them and downgraded my ATV back to 5.0.2, so this surprise from Apple just prohibits a public release of my app as NOW it doesn't work properly! I'm not sure if I should even bother trying to work it out! 5 hours googling has revealed no clues as to what to do.

If anyone knows if ffmpeg or atomicparsley can - enable the first 2-channel track, disable the second surround sound track (AC-3 5.1), and put them in the correct alternate group - I'm all ears!

Idgit
Oct 3, 2012, 06:22 PM
Here is a screenshot from Subler of the two files you provided. The one on the left is the working one, and as you can see, the second track (surround sound) is disabled. The one on the right doesn't work and you can see that both tracks are enabled. Also, no fallback track is set but that shouldn't affect playback. The alternate groups for audio tracks are set correctly so you don't have to worry about that.

http://members.shaw.ca/techforum/subler1.jpg


Below is your file after I ran it through Subler. Download it (http://d.pr/v/jnAM) and see if it works.

http://members.shaw.ca/techforum/subler3.jpg

omni
Oct 3, 2012, 06:33 PM
http://members.shaw.ca/techforum/subler3.jpg



This is how the file should look. The only thing extra I would add - the video does not have to be tagged as English - unknown is fine. I know of no instance where this will break anything - but Video English is kind of weird.

The other thing I noticed that *could* be weird in the long run - if you ever want to use the video on something else. The video profile is 3. I'm not at home - but I have a small dvd file here at work on a thumb drive which reads it as 3.1. I think the current appletv3 preset is 4.1 but don't quote me on that - could be 3.1 as well.

I have no idea what fallback is - never set it, never had to - never had a problem with aac/ac3 issues

ConvertApple
Oct 3, 2012, 06:38 PM
Yes, you're fixed file plays fine on ATV3+IOS-5.1. Thanks for the heads up on alternate tracks being correct, I've been googling that for hours, reading ffmpeg source code etc. So I just need to figure out IF ffmpeg can set audio track 2 to disabled.

Thanks for your help

Idgit
Oct 3, 2012, 06:57 PM
I'm not the best with the command line, but I tried disabling track 3 using mp4track and it worked.

I renamed your non-working file and used the following command in the Terminal.

mp4track -z --track-id 3 --enabled false test.mp4

Track info before running the command:
user$ mp4track --list test.mp4
track[0] id=1
type = video
enabled = true
inMovie = true
inPreview = true
layer = 0
alternateGroup = 0
volume = 0.0000
width = 672.00000000
height = 272.00000000
language = Undetermined
handlerName = VideoHandler
userDataName = <absent>
track[1] id=2
type = audio
enabled = true
inMovie = true
inPreview = true
layer = 0
alternateGroup = 1
volume = 1.0000
width = 0.00000000
height = 0.00000000
language = Undetermined
handlerName = SoundHandler
userDataName = <absent>
track[2] id=3
type = audio
enabled = true
inMovie = true
inPreview = true
layer = 0
alternateGroup = 1
volume = 1.0000
width = 0.00000000
height = 0.00000000
language = English
handlerName = SoundHandler
userDataName = <absent>


And after:

user$ mp4track --list test.mp4
track[0] id=1
type = video
enabled = true
inMovie = true
inPreview = true
layer = 0
alternateGroup = 0
volume = 0.0000
width = 672.00000000
height = 272.00000000
language = Undetermined
handlerName = VideoHandler
userDataName = <absent>
track[1] id=2
type = audio
enabled = true
inMovie = true
inPreview = true
layer = 0
alternateGroup = 1
volume = 1.0000
width = 0.00000000
height = 0.00000000
language = Undetermined
handlerName = SoundHandler
userDataName = <absent>
track[2] id=3
type = audio
enabled = false
inMovie = true
inPreview = true
layer = 0
alternateGroup = 1
volume = 1.0000
width = 0.00000000
height = 0.00000000
language = English
handlerName = SoundHandler
userDataName = <absent>

----------

This is how the file should look. The only thing extra I would add - the video does not have to be tagged as English - unknown is fine. I know of no instance where this will break anything - but Video English is kind of weird.

The other thing I noticed that *could* be weird in the long run - if you ever want to use the video on something else. The video profile is 3. I'm not at home - but I have a small dvd file here at work on a thumb drive which reads it as 3.1. I think the current appletv3 preset is 4.1 but don't quote me on that - could be 3.1 as well.

I have no idea what fallback is - never set it, never had to - never had a problem with aac/ac3 issues

Fallback is used when you have an AC-3 track in the same language as the 2-channel AAC track. My understanding is that it just tells Quicktime and other players that both tracks are connected and provide the same audio and to select the AAC track if the AC-3 track can't be played. Don't use fallback if the AC-3 track is in a different language. Truth be told, I don't believe the fallback setting is required to be set.

Tagging the video track as English is just me being anal-retentive. It's not necessary but it is tidy.

Idgit
Oct 3, 2012, 07:11 PM
CovertApple,

Can you integrate mp4tools and/or MP4Box (http://gpac.wp.mines-telecom.fr/mp4box/) into your workflow?

MP4v2 (http://code.google.com/p/mp4v2/)

MP4v2 Command-line Tools Guide (http://mp4v2.googlecode.com/svn/doc/1.9.0/ToolGuide.html)

MP4Box (http://www.videohelp.com/tools/mp4box)

ConvertApple
Oct 3, 2012, 07:25 PM
Well theoretically I can add another program to workflow BUT I had hoped there would be someway that ffmpeg could do it as I did';t want app to bloat or get less stable.

MP4Box that I've seen other tools use, seems to unpack all the components of the files then re-pack them. I'd probably rather find out what the coder did.

I'll have to think about it, need zome Zzzzz's now. Still cannot understand why apple did this in 5.1

mic j
Oct 3, 2012, 07:49 PM
Well theoretically I can add another program to workflow BUT I had hoped there would be someway that ffmpeg could do it as I did';t want app to bloat or get less stable.

MP4Box that I've seen other tools use, seems to unpack all the components of the files then re-pack them. I'd probably rather find out what the coder did.

I'll have to think about it, need zome Zzzzz's now. Still cannot understand why apple did this in 5.1
Just to be clear, Apple has always required the first audio track to be AAC 2-channel default and the second audio track (if it exists at all) to be AC3 not set to default. Has nothing to do with the 5.1 version. As you can see from above posts, people using other applications to generate their aTV3 compatible files are not having a issue with 5.1.

Idgit
Oct 3, 2012, 08:19 PM
ConvertApple,

I came across this Windows utility for modifying/muxing/demuxing Quicktime-compliant MP4s. Might be worth checking out.

MP4Creator (http://sourceforge.net/projects/mp4creator/)

Idgit
Oct 4, 2012, 03:26 AM
Well theoretically I can add another program to workflow BUT I had hoped there would be someway that ffmpeg could do it as I did';t want app to bloat or get less stable.

MP4Box that I've seen other tools use, seems to unpack all the components of the files then re-pack them.

I think I found the answer (http://www.videoredo.net/msgBoard/showthread.php?t=29620) to your question and it looks as if you'll need to use MP4Box or HandbrakeCLI.

From that thread (http://www.videoredo.net/msgBoard/showthread.php?t=29620):

Note that you need to disable the ac3 track and group the audio tracks together (a recent ATV change) for ATV to pass it through. Suspect you know this.

As I do all my conversion 'offline' using the script (COM) interface my external muxer of choice is a command line one - MP4BOX but there are lots about - GOOGLE. The advantage of MP4BOX is that it also allows tracks to be disabled and grouped

ConvertApple
Oct 4, 2012, 04:02 AM
MP4v2 would be great but I can find no windows binary for it. Downloaded the source but it won't compile, got a missing file from svn but still won't compile, tried for 2 hours so given up on that. Best hope is if ffmpeg can do it.

ConvertApple
Oct 4, 2012, 06:40 AM
SUCCESS!!! Thx for tips guys. I svn'd latest source + reinstalled vs2008 (didn't like vs2010) and got it compiled - So I now have a solution! Next comes the simple part writing the code.

It'll probably take me a week or 2 after that to get time to polish it, but then I'll release it. It's aim was the be mega-fast, require no user-intervention (beyond naming your files properly), minimal user options and to NEVER crash!

So beyond disabling track2 (or is that disabling all tracks bar track1?) are there any other maggots in the apple that might bite me in the future I should be aware of?

GarrettL1979
Oct 4, 2012, 08:49 AM
are you all still having problems with this? i haven't updated yet...

ConvertApple
Oct 4, 2012, 10:24 AM
I am running my app to FIX all my video files (only alters those with 2+ audio streams in). It seems to take about a minute per file. I wouldn't upgrade yet. In a week or two I can let you have an app that will auto-fix all your files with a single click. BUT it's a windows app and on a mac forum perhaps that is sacriledge!

Rushli0n
Oct 4, 2012, 12:38 PM
Just to be clear, Apple has always required the first audio track to be AAC 2-channel default and the second audio track (if it exists at all) to be AC3 not set to default. Has nothing to do with the 5.1 version. As you can see from above posts, people using other applications to generate their aTV3 compatible files are not having a issue with 5.1.

I'm not disagreeing with you regarding Apple's policy...but both Audio Files on my movies were checked on 5.0.2 and it worked. After updating to 5.1, I had to uncheck the 5.1 file for it to work. So something in the update broke it.

mic j
Oct 4, 2012, 12:54 PM
I'm not disagreeing with you regarding Apple's policy...but both Audio Files on my movies were checked on 5.0.2 and it worked. After updating to 5.1, I had to uncheck the 5.1 file for it to work. So something in the update broke it.

Understood, but "checking" a file says this is the default, so by checking both files you were telling the aTV that both files are default. If you look back through previous posts here, you will see that the recommendation is to only have the first file (stereo) checked as default. Apparently, something in the new version was changed to no longer allow 2 default files. IMO, that doesn't sound like "breaking", it sounds like it was "fixing".

Idgit
Oct 4, 2012, 01:03 PM
So beyond disabling track2 (or is that disabling all tracks bar track1?) are there any other maggots in the apple that might bite me in the future I should be aware of?

Glad to hear you got it working.

I could be wrong, but I think chapters are only supported if the video has the file extension M4V (rather than MP4).

Also, be sure to use mp4file (part of MP4v2) to "optimize" your MP4/M4V files.

[Optimize] interleaves the audio and video samples, and puts the "MooV" atom at the begining of the file, restoring the Quicktime "fast-start" (also known as "pseudo-streaming") ability of the file.

For example, optimizing the file allows Plex Media Server to "direct stream" the file to Plex clients rather than transcoding it. So the computer that is running the Plex Media Server will use very little CPU when direct streaming vs lots of CPU when transcoding.

If you make changes to the file (like changing or adding tags) after optimizing, the "MooV" atom will no longer be at the beginning of the file, so you'll have to optimize it again if you want to keep the "fast-start" feature. Just make the optimize option be the last thing you run on the file.

If the MP4/M4V file will be bigger than 4 GB, be sure to enable "64 Bit chunk offset" or the file may not work on older devices.

dynaflash
Oct 4, 2012, 01:08 PM
I could be wrong, but I think chapters are only supported if the video has the file extension M4V (rather than MP4).

You are not wrong. correct use .m4v

If the MP4/M4V file will be bigger than 4 GB, be sure to enable "64 Bit chunk offset" or the file may not work on older devices.
If you don't use 64 bit chunk offset and the file ends up over 4 GB, it will not work on *any* devices. It will be a broken file.

Rushli0n
Oct 4, 2012, 02:15 PM
Understood, but "checking" a file says this is the default, so by checking both files you were telling the aTV that both files are default. If you look back through previous posts here, you will see that the recommendation is to only have the first file (stereo) checked as default. Apparently, something in the new version was changed to no longer allow 2 default files. IMO, that doesn't sound like "breaking", it sounds like it was "fixing".

Right, and it apparently has caused users to have to go back and "correct" their files by only checking 1 default. I understand why, just saying it wasn't a problem before.

My novice understanding was that checking meant it was enabled, not defaulted. Seeing the checks as defaults makes more sense to me that only 1 should be selected.

Bymatt
Oct 4, 2012, 03:23 PM
handbrake, using about 1700 AND selecting AC3 pass through for either 2.0. 5.1 OR HOLD ON NOW, DTS pass thru for those that have it and send it via HDMI to an input port on my AVR...then to the flat screen, VIDEO and AUDIO have never been better.. My ATV is basically a nite lite. Why have crippled audio and have to put up with all this. In MY case I have access to flea markets, ( great dvds @ 3 for 5.00), and a great library which gives me an ENDLESS supply of material.
I can see why those that rent APPLE media or those that still stream to the ATV like it, but I cut the cord to that thing and ever since have enjoyed SUPERB MOVIE sound and audio with very little trouble.
Just my .02

mic j
Oct 4, 2012, 04:01 PM
handbrake, using about 1700 AND selecting AC3 pass through for either 2.0. 5.1 OR HOLD ON NOW, DTS pass thru for those that have it and send it via HDMI to an input port on my AVR...then to the flat screen, VIDEO and AUDIO have never been better.. My ATV is basically a nite lite. Why have crippled audio and have to put up with all this. In MY case I have access to flea markets, ( great dvds @ 3 for 5.00), and a great library which gives me an ENDLESS supply of material.
I can see why those that rent APPLE media or those that still stream to the ATV like it, but I cut the cord to that thing and ever since have enjoyed SUPERB MOVIE sound and audio with very little trouble.
Just my .02
How are you getting Handbrake mkv to your AVR?

Idgit
Oct 4, 2012, 05:15 PM
SUCCESS!!! Thx for tips guys. I svn'd latest source + reinstalled vs2008 (didn't like vs2010) and got it compiled - So I now have a solution! Next comes the simple part writing the code.

It'll probably take me a week or 2 after that to get time to polish it, but then I'll release it. It's aim was the be mega-fast, require no user-intervention (beyond naming your files properly), minimal user options and to NEVER crash!

SublerCLI source (http://code.google.com/p/subler/source/checkout)

Is it possible for you to recompile the source code for SublerCLI so it works in Windows? If so, it might be helpful.

The-Pro
Oct 4, 2012, 07:28 PM
Its all interesting and stuff that you are finding out how to fix it but has anyone bothered writing to apple about what has changed? maybe they did not realise and it was a mistake. Quite possible that they change it back in an update.

I am currently in the process of ripping 600+ dvd for someone I know. They want to be able to watch them on the ATV 3. I am using handbrake and selecting the apple tv 3 preset. This results in two audio tracks. The first being English (AC3) (5.1ch) AAC (CoreAudio) and the second being English (AC3) (5.1ch) AC3 Passthru.
To my knowledge they have not yet upgraded the software to 5.1. Should I tell them not to so that they will be able to watch the ripped dvd's with audio?

Idgit
Oct 4, 2012, 08:13 PM
Its all interesting and stuff that you are finding out how to fix it but has anyone bothered writing to apple about what has changed? maybe they did not realise and it was a mistake. Quite possible that they change it back in an update.

To my knowledge they have not yet upgraded the software to 5.1. Should I tell them not to so that they will be able to watch the ripped dvd's with audio?

Files ripped with Handbrake using the Apple TV 3 preset should work fine with the Apple TV 2/3 and the current firmware. And assuming this current problem in the latest iOS ATV update is a bug, Apple will most likely issue a fix.

There's no need to install the update immediately, so if they haven't done it yet, tell them to hold off for a month.

The-Pro
Oct 5, 2012, 04:44 AM
Files ripped with Handbrake using the Apple TV 3 preset should work fine with the Apple TV 2/3 and the current firmware. And assuming this current problem in the latest iOS ATV update is a bug, Apple will most likely issue a fix.

There's no need to install the update immediately, so if they haven't done it yet, tell them to hold off for a month.

Ok great, I will tell them to not install it yet. Hopefully the fix this :)

MichaelLAX
Oct 5, 2012, 05:03 AM
...I am currently in the process of ripping 600+ dvd for someone I know. They want to be able to watch them on the ATV 3. I am using handbrake and selecting the apple tv 3 preset. This results in two audio tracks. The first being English (AC3) (5.1ch) AAC (CoreAudio) and the second being English (AC3) (5.1ch) AC3 Passthru.
To my knowledge they have not yet upgraded the software to 5.1. Should I tell them not to so that they will be able to watch the ripped dvd's with audio?

Your first audio track seems inconsistent: either it is 6 channel AC3 or 6 channel AAC (or even potentially converted to a 2 channel AAC); but it cannot be both!

"...ripping 600+ dvd for someone I know" -- what a friend!?! So can I become a friend and have a copy, too?:D

The-Pro
Oct 5, 2012, 06:22 AM
Your first audio track seems inconsistent: either it is 6 channel AC3 or 6 channel AAC (or even potentially converted to a 2 channel AAC); but it cannot be both!

"...ripping 600+ dvd for someone I know" -- what a friend!?! So can I become a friend and have a copy, too?:D

hmm ok, I have attached a screenshot with what the apple tv 3 preset chooses. I have used this for over 300 movies so far and all works perfectly on apple tv 3 with the one older software.
6channel doesnt exist on any of the DVDs I am converting so im confused.

Haha, yeah family friends. But they are paying me and I am getting a copy of all of them on a 2TB external HDD :D
I doubt thats going to happen mate, no offense :D

MichaelLAX
Oct 5, 2012, 06:37 AM
The first audio channel is a mix down of the 6 channel AC3 to 2 channel AAC stereo for non Dolby/2 channel playback, such as a 2 channel TV. As an extra bonus, it is encoded in Dolby Pro Logic II (which is an encoded version that can be dematrixed back to a form of 5.1 surround sound by certain, primarily analog, home theater equipment).

The second audio channel is a pass-thru of the 6 (discrete) channel AC3 for Dolby Digital Surround systems. Most home theater equipment will play this channel as true discrete (non-matrixed) surround sound.

The-Pro
Oct 5, 2012, 06:41 AM
The first audio channel is a mix down of the 6 channel AC3 to 2 channel AAC stereo for non Dolby/2 channel playback, such as a 2 channel TV. As an extra bonus, it is encoded in Dolby Pro Logic II (which is an encoded version that can be dematrixed back to a form of 5.1 surround sound by certain, primarily analog, home theater equipment).

The second audio channel is a pass-thru of the 6 channel AC3 for Dolby Digital Surround compatibility. Most home theater equipment will play this channel as true discrete (non-matrixed) surround sound.

OK,
so am I doing it correctly then? :D

MichaelLAX
Oct 5, 2012, 06:51 AM
Yes: although I did not understand this comment - "6channel doesnt exist on any of the DVDs I am converting so im confused."

6 channel AC3 clearly exists on the particular DVD that was the basis of the screenshot.

If you ever have this screenshot (where the 2nd audio track is only 2 channels), you want to change the 2nd audio track to NONE (no point in wasting file space with a redundant 2nd track that is also 2 channel):

The-Pro
Oct 5, 2012, 07:12 AM
Yes: although I did not understand this comment - "6channel doesnt exist on any of the DVDs I am converting so im confused."

6 channel AC3 clearly exists on the particular DVD that was the basis of the screenshot.

If you ever have this screenshot (where the 2nd audio track is only 2 channels), you want to change the 2nd audio track to NONE (no point in wasting file space with a redundant 2nd track that is also 2 channel):

i think I get it now :D It doenst say 6channel in handbrake so I didnt understand what you meant. :D
I dont know much about this. I read about whats best to use in handbrake for converting dvds to be watched on apple tv.

Good to know that :) I did that a few time all ready, won't anymore. cheers

ConvertApple
Oct 5, 2012, 07:33 AM
I have to beg to differ that what apple have done is a very BAD idea.

Previously if two tracks were both selected it would 'gracefully' select the stereo/dolby one dependant on your audio pref in the settings. The NEW behaviour is to play the file with no sound coming out at all! No error or warning or indication of the problem. So most people will assume their hardware is broken or something and waste ages wondering why and not be able to easily fix it as it appears to be playing. Their first action will be to press unmute on their tv/amp!

Anyway my app fixed all my files overnight while I slept. I would release the app but I HATE apps that crash and break so need to do more testing, refinement. I had planned to in approx 2 weeks anyway, I'll see if I can speed it up.

ConvertApple
Oct 5, 2012, 08:42 AM
Glad to hear you got it working.

I could be wrong, but I think chapters are only supported if the video has the file extension M4V (rather than MP4).


Also, be sure to use mp4file (part of MP4v2) to "optimize" your MP4/M4V files.


If the MP4/M4V file will be bigger than 4 GB, be sure to enable "64 Bit chunk offset" or the file may not work on older devices.

It only ever creates .m4v files anyway

-z on mp4track does that already does optimisation doesn't it (according to the help)

I assume 64 bit chunk is handled by ffmpeg as I have files > 4gb that play fine

Yebubbleman
Oct 5, 2012, 03:36 PM
Forgive my confusion, but is this a bug that is only in effect with Handbrake-encoded files that worked in the previous version of the AppleTV OS/Firmware? Or is this bug in effect with everything? I don't have a 5.1 Audio setup, but I do have a third generation AppleTV and I did update it to the latest OS/Firmware, so I'd like to know whether I can expect similar bugs in my daily usage of it. I don't use Handbrake; haven't for a long while, because I got tired of trying to catch up with the various device resolutions that have come out since I was last using it.

MichaelLAX
Oct 5, 2012, 04:00 PM
There is some confusion generated because in this thread there are two "5.1" concepts being discussed:

1) iOS v5.1 which seems to be causing loss of audio on Handbrake'd DVDs encoded in the ATV3 setting. I have not updated to iOS 5.1 and many are recommending that we do not upgrade to iOS 5.1 until this loss of audio problem is solved.

2) Discussion of Dolby Surround's AC3 5.1 track (five channels plus sub-woofer), which Handbrake will provide as a "pass-thru" in addition to a newly encoded 2 track AAC stereo track. This provides compatibility with all devices: Home Theater which supports 5.1 surround sound and stereo 2 channel/speaker devices, such as TVs.

mic j
Oct 5, 2012, 04:44 PM
There is some confusion generated because in this thread there are two "5.1" concepts being discussed:

1) iOS v5.1 which seems to be causing loss of audio on Handbrake'd DVDs encoded in the ATV3 setting. I have not updated to iOS 5.1 and many are recommending that we do not upgrade to iOS 5.1 until this loss of audio problem is solved.

2) Discussion of Dolby Surround's AC3 5.1 track (five channels plus sub-woofer), which Handbrake will provide as a "pass-thru" in addition to a newly encoded 2 track AAC stereo track. This provides compatibility with all devices: Home Theater which supports 5.1 surround sound and stereo 2 channel/speaker devices, such as TVs.
I think this comes from someone early in the thread that was having the problem, discovering that their problem file, had both stereo and AC3 passthrough checked. Others that had the loss of audio found that switching the aTV Dolby on and off restored the sound. And actually, those people never really posted enough information to deduce where their problem originated.

I think it's an over-reaction to not download 5.1 as long as your files don't have both stereo and AC3 pass-through checked as default tracks. Something may have changed in 5.1 but the basic problem is probably with the files and thus 5.1 would not be "fixed".

On the other hand, 5.1 is a pretty marginal change. If there is not something in it that you absolutely must have, why change.

Bymatt
Oct 5, 2012, 05:16 PM
How are you getting Handbrake mkv to your AVR? Sorry to be so long in answering. I send the MKV from my macpro to a mac book via a 10ft ethernet. Takes about 2 minutes to xfer a 100 minute mkv. Can do a weeks worth in about 9 minutes. All done with the apple share software. Once in the macbook or any computer, I output the mkv on the DVI jack and an HDMI converter then into the AVR. Its really simple and an easy workflow all told. NO jail breaking. I play the movies with Movist. Love it and the true quality of sound, esp DTS.... Just cant do that through the ATV and the encode to MKV really takes no longer than encoding for atv.

mic j
Oct 5, 2012, 05:20 PM
Sorry to be so long in answering. I send the MKV from my macpro to a mac book via a 10ft ethernet. Takes about 2 minutes to xfer a 100 minute mkv. Can do a weeks worth in about 9 minutes. All done with the apple share software. Once in the macbook or any computer, I output the mkv on the DVI jack and an HDMI converter then into the AVR. Its really simple and an easy workflow all told. NO jail breaking. I play the movies with Movist. Love it and the true quality of sound, esp DTS.... Just cant do that through the ATV and the encode to MKV really takes no longer than encoding for atv.

Thanks. I had the suspicion you were not using the aTV. I used to use my MBP hooked up to my AVR by cable, but it was just too inconvenient having it tied up. That's why I have used a series of media streamers and have settled on the aTV.

sampdoria
Oct 7, 2012, 09:26 AM
Correct. For standard ATV 2 compatible files, the first audio track should be AAC Stereo and it should be checked. The second audio track can be surround sound AC-3 or AAC 5.1 and it should be un-checked.

Also, when you open the file in Subler, the audio tracks should both belong to Alternate Group 1. The video track should belong to Alternate Group None.

When set like that, the Apple TV should select the surround sound track automatically if you have receiver capable of playing surround sound audio.

I typically have both audio tracks enabled (2ch and 6ch) in my m4v files (ripped and purchased from iTunes). No problems with the 6ch audio track playing automatically in ATV2 prior to software update 5.1. But since updating to 5.1, I also have the same issue as mentioned above. Once I disabled the 6ch audio track in Subler, problem solved- 6ch audio track plays automatically.

Not sure if this is a bug or not. Maybe this (6ch audio track disabled) is the way it is supposed to be. Seems like a bug to me, since the problem also occurs on ones purchased from iTunes as well. But the fix is easy (thank goodness for Subler!), just a bit inconvenient to apply the fix to all my m4v's.

KenniJH
Oct 7, 2012, 02:22 PM
Same problem as OP, everything worked before 5.1. I ude HandBrake as Well as PavTube iMedia converter and rips from before and after the 5.1 Update has the problem.
So deffo the Update... Please fix Apple!
:-)

MrXiro
Oct 7, 2012, 10:01 PM
I'll try to keep this brief: I did AC3 Passthru PLUS AAC Stereo using the Handbrake presets for a handful of DVDs I own to test out converting my collection to an iTunes-compatible format. Prior to the 5.1 update, all was working well; 5.1 when playing through the Apple TV, stereo when I played the exact same file on my iPhone or iPad. Now the same files still play fine on my iPad and iPhone, but the Apple TV refuses to output any audio on files that have an option between 5.1 and 2.0 (stereo). I went into Netflix on my Apple TV, picked a movie with 5.1 audio, and it played back properly without an issue.

My Apple TV is connected to my receiver via HDMI-only and my receiver is connected to my TV via HDMI as well. I've tried both forcing Dolby Output to "On" and "Auto" as well. I've found some comments on Apple's support forum from several years ago stating that using optical might fix a similar issue, but I fail to see why Apple would take a step backwards in HDMI-connectivity. :/

Since no one else seems to be complaining about this recently anywhere I've seen, it must be me. Does anyone have any suggestions?

I haven't read through any of the pages yet... just your post. I figured out a temporary fix.

Just hold down the select button and switch to stereo audio and play, hold down select again and then switch back to surround audio and it works fine again... hopefully it'll be fixed in the next update. (This is a handful of files I ripped using Handbrake about a month back) Most of my other rips seemed fine which is weird.

----------

So I found a weird workaround. Hold select and go up to the Audio options and select the stereo track. Then go back and select the surround track. The Dolby works after you reselect it. What sucks is after I close the movie and play it again, I have to do that workaround again.

Seems it's been mentioned... and solved with Subler... good... I was having a fit trying to fix it earlier today!

The-Pro
Oct 16, 2012, 09:21 AM
any updates on this?

GarrettL1979
Oct 16, 2012, 12:09 PM
It's mildly amusing that the 5.1 update caused 5.1 surround issues, no?

slothrob
Oct 16, 2012, 07:04 PM
It's unclear to me, is this only happening to files that have gone through Subler, or is this true for files right out of Handbrake?

It doesn't seem like a lot of people are complaining about this. Is it just that people aren't aware whether they have DD or not?

I'd like to update to 5.1, but I'm not willing to sacrifice DD for it.

mic j
Oct 16, 2012, 07:20 PM
It's unclear to me, is this only happening to files that have gone through Subler, or is this true for files right out of Handbrake?

It doesn't seem like a lot of people are complaining about this. Is it just that people aren't aware whether they have DD or not?

I'd like to update to 5.1, but I'm not willing to sacrifice DD for it.
The problem is, some people has some files that have somehow gotten AAC stereo and AC3 5.1 tracks checked as default tracks. Only the AAC stereo track should be checked as default. For some reason, v5.0 software was tolerant of have 2 tracks checked as default and v5.1 is not tolerant of it. Obviously, you should not have multiple tracks checked as default. Subler is used to correct the double default track selection.

slothrob
Oct 16, 2012, 08:14 PM
The problem is, some people has some files that have somehow gotten AAC stereo and AC3 5.1 tracks checked as default tracks.
This is part of what is confusing me. How are people choosing multiple tracks as Default in Handbrake?

That sound like something that you can only do in a secondary program, like Subler.

Diode
Oct 16, 2012, 08:26 PM
This is part of what is confusing me. How are people choosing multiple tracks as Default in Handbrake?

That sound like something that you can only do in a secondary program, like Subler.

As subler is a great tool for adding Tags - a lot of people use it. Probably partly user error and partly poor design on Subler's fault. I can see a user thinking everything needs to be checked when it's loaded in Subler and your saving the file.

Intuitively you would think if you "unchecked" something it would remove it from the file when you save it - but that's not the case with Subler.

I had this problem way before iOS 5.1 as did others (http://forums.macrumors.com/showthread.php?t=1308852).

slothrob
Oct 16, 2012, 08:42 PM
So, just to be clear, this is not an inherent problem with Handbrake (dispite the title of this thread) or OS 5.1, but modifications that people are making to their files after Handbrake.

Is that correct?

Ritsuka
Oct 17, 2012, 01:20 AM
In an alternate group, only one track needs to be enabled. Multiple enabled tracks are meant to be played at the same time.

mic j
Oct 17, 2012, 08:59 AM
So, just to be clear, this is not an inherent problem with Handbrake (dispite the title of this thread) or OS 5.1, but modifications that people are making to their files after Handbrake.

Is that correct?
I believe that to be the case. I have no idea how people are getting both tracks checked as default, but it is not something that can be set in HB (at least as far as I am aware of). I think Diode's explanation is a likely one. When I first started using Subler, I did the same thing (check both tracks so they would be "included" in the file processing).

Toeside
Oct 21, 2012, 08:55 PM
I believe that to be the case. I have no idea how people are getting both tracks checked as default, but it is not something that can be set in HB (at least as far as I am aware of). I think Diode's explanation is a likely one. When I first started using Subler, I did the same thing (check both tracks so they would be "included" in the file processing).

Thanks to this thread, I now understand why none of my ripped movies have audio on my new AppleTV 3 even though they worked just fine on my 1st gen.

Like it was theorized, I misunderstood what the "enabled" checkbox option did in Subler. It was part of my workflow to check all tracks of the M4V file. Oops.

Now I'm opening each file in Subler, unchecking the surround track, and saving. Not a hard task to do, but certainly tedious and mundane.

JMEANS
Oct 24, 2012, 09:36 AM
Thanks guys for clearing the issue up as far as the culprit being Subler! Back to the drawing board to uncheck the surround tracks on a ton of files : (

It's weird that Subler would make this audio default option an option anyway. I mean ATV always will default to the surround track if there is one present right? At least in my experience it has.

Thanks Jim

mic j
Oct 24, 2012, 10:13 AM
Thanks guys for clearing the issue up as far as the culprit being Subler! Back to the drawing board to uncheck the surround tracks on a ton of files : (

It's weird that Subler would make this audio default option an option anyway. I mean ATV always will default to the surround track if there is one present right? At least in my experience it has.

Thanks Jim
Sorry, Jim, but Subler is not the culprit. People not have a good understanding of what they are actually doing is the culprit. IMHO.

JMEANS
Oct 25, 2012, 05:19 AM
Well yes if you mean we didn't know we weren't suppose to check both audio field defaults in Subler yes. The latest ATV update called a bunch of us out lol

Unchecked a bunch of 'surround' fields last night and these files are working again through the ATV2! Annoying process, learned the hard way but Overall happy that its figured out!

jeff92k7
Dec 14, 2012, 03:12 PM
Two questions:

Has anyone noticed if Apple TV OS 5.1.1 has gone back to the old way of playing the audio, where surround sound tracks would play even if they are both checked?

Secondly, I see references in this thread to an app that would run on Windows to automatically "uncheck" the second audio track in the itunes files. Any update on if this is available to download?

Unfortunately, I don't use Mac computers. I do use Handbrake to encode most content, but I also use xmedia recode to remux MKV files (foreign tv shows) where the video is already in h264 and doesn't need to be reencoded by going through handbrake. The problem is that these xmedia recode files come out the same way that others have mentioned above - two tracks: one is AAC stereo, the other is AC3 surround; but when played, I get no audio without doing the select, change audio track, select, change it back workaround.

I was hoping that someone had a utility that I could run on those files to "uncheck" the surround track so they could play. I want to avoid having to use handbrake for everything since re-encoding takes so much longer and reduces image quality needlessly.

Jeff

mic j
Jan 16, 2013, 08:58 AM
I have a bunch of movies (h264 +DTS 5.1) and some in (h264 + ac3 5.1) in .mkv format. I use subler to convert them to ATV2 format. Subler repacks the (h264 + ac3 5.1).mkv to (h264 + ac3 5.1).m4v just fine. I have no issues playing this on ATV2 with surround sound.

However, when I convert (h264 + DTS 5.1).mkv, with subler (using discrete channel preset in the audio), the output file is (h264 + AAC 6 channel).m4v. ATV2 can play this file just fine - but I can only hear stereo - the surround is lost even though the file has 5.1 in AAC format. Is this a limitation of ATV2 or am I missing something?

Few AVR's support AAC 6-channel. You will need to convert the DTS to AC3. Subler can't do that. Your options are: 1) convert with Handbrake, 2)use MP4Tools (v3.2.x) to change containers, or 3) find another app that will just convert the track to AC3.

dynaflash
Jan 16, 2013, 10:16 AM
However, when I convert (h264 + DTS 5.1).mkv, with subler (using discrete channel preset in the audio), the output file is (h264 + AAC 6 channel).m4v. ATV2 can play this file just fine - but I can only hear stereo - the surround is lost even though the file has 5.1 in AAC format. Is this a limitation of ATV2 or am I missing something?
correct, atv's mixdown aac 6 channel discrete to a bogus 3.0 dpl stereo track, in other words its not what you want.

And to address the above about subler and handbrake. Using the atv presets (any of them) the audio track layout is the way it is because its what the atv's expect. Then sent to subler it stays the same. Stop checking checkboxes on the audio track layout from hb in subler and you will stop having issues. There is a reason the preset is written the way it is. :)

----------

I'd also listen to Ritsuka above ... he knows an awful lot about Subler :rolleyes:

stiwi
Jan 18, 2013, 10:36 PM
I am still not getting it. In Subler "enabled" field is to make the track / subtitle default, right? If so then why having Stereo aac checked and other than english subtitles, iTunes on 1st launch defaults to opposite values, i.e. playing surround and showing english subtitles?

My understanding is the iTunes should default to the options checked and display (turn on) default subtitles. I can't see any difference in iTunes / iPad having all audio tracks / subs "enabled" or only one from each group.

Ritsuka
Jan 19, 2013, 02:21 AM
iTunes defaults to what you set in its preferences.

mic j
Jan 19, 2013, 08:25 AM
iTunes defaults to what you set in its preferences.
I would like to thank you for developing such a fine app. I use it constantly.

Looked over your project home for a way to send you some cash. Couldn't find anything. Is it possible?

Ramboxman
Mar 20, 2013, 10:51 PM
Unfortunately, I don't use Mac computers. I do use Handbrake to encode most content, but I also use xmedia recode to remux MKV files (foreign tv shows) where the video is already in h264 and doesn't need to be reencoded by going through handbrake. The problem is that these xmedia recode files come out the same way that others have mentioned above - two tracks: one is AAC stereo, the other is AC3 surround; but when played, I get no audio without doing the select, change audio track, select, change it back workaround.

I was hoping that someone had a utility that I could run on those files to "uncheck" the surround track so they could play. I want to avoid having to use handbrake for everything since re-encoding takes so much longer and reduces image quality needlessly.



Just curious if their is a why of doing this on a PC, I know a Mac with Subler works but was wondering if this is possible without a using a Mac.

Thanks!

lovelopez
Mar 21, 2013, 12:33 AM
Have you gone into your Apple TV setting and turned off "digital dolby"? That worked for me.

kmackenz
Apr 10, 2013, 12:30 PM
SUCCESS!!! Thx for tips guys. I svn'd latest source + reinstalled vs2008 (didn't like vs2010) and got it compiled - So I now have a solution! Next comes the simple part writing the code.

It'll probably take me a week or 2 after that to get time to polish it, but then I'll release it. It's aim was the be mega-fast, require no user-intervention (beyond naming your files properly), minimal user options and to NEVER crash!

So beyond disabling track2 (or is that disabling all tracks bar track1?) are there any other maggots in the apple that might bite me in the future I should be aware of?

Curious if this application was ever published... Love to clean up my files....

Idgit
Apr 10, 2013, 06:15 PM
Just curious if their is a why of doing this on a PC, I know a Mac with Subler works but was wondering if this is possible without a using a Mac.

Thanks!

Check out ConvertApple (http://forums.macrumors.com/member.php?u=748318)'s posts in this thread (starting on the first page). He seems to have made his own app for the PC to do this. Try sending him a private message.

Or try out MP4v2 (command line). Use mp4track to identify which MP4s have both audio tracks enabled and then use mp4track to disable the second audio track. But I believe you'll have to compile a version that works with Windows.

kmackenz
Apr 11, 2013, 08:06 AM
Idgit thanks for the reply. Might be new user syndrome but I don't see how to send a personal message via the forum.

I will check out those other tools as well.

Idgit
Apr 11, 2013, 11:46 AM
Click on his name in my post to view his profile. You should see a tab that says "Contact Info." That's where you'll find the "Send private message" option.

Idgit thanks for the reply. Might be new user syndrome but I don't see how to send a personal message via the forum.