PDA

View Full Version : OS X Server 2.1 hangs




martva
Sep 27, 2012, 08:20 AM
Hi all,

I've updated the my server software of my 10.8.2 to version 2.1 through the App Store.
When starting the Server.app it says to me that it needs to be configured. So I follow the steps as you would normally, but when it goes configuring for real, I see my clock go back for at least 16 hours and the configuration hangs up my system completely (with rainbow cursor and all ).

So I decided to reboot and try again. But now with a top -o cpu running aside.
Once again it changes my time. And it hangs just after starting the postgres database software. The terminal window hangs as well and slowly it hangs up my complete system.

This is what the log says:

I, [2012-09-25T21:56:33.478285 #25336] INFO -- : *** PostgreSQL migration start ***
I, [2012-09-25T21:56:33.478555 #25336] INFO -- : /Applications/Server.app/Contents/ServerRoot/System/Library/ServerSetup/MigrationExtras/05_postgresmigrator.rb --purge 0 --sourceRoot /Library/Server/Previous --targetRoot / --sourceType System --sourceVersion 10.7.4 --language en
I, [2012-09-25T21:56:33.522518 #25336] INFO -- : Confirmed /Library/Logs/PostgreSQL/PostgreSQL.log exists
I, [2012-09-25T21:56:33.832686 #25336] INFO -- : Migrating data from an earlier PostgreSQL version
I, [2012-09-25T21:56:34.285763 #25336] INFO -- : Postgres is running; stopping to apply new settings
E, [2012-09-25T21:56:34.386399 #25336] ERROR -- : initdb failed: 256
Command: sudo -u _postgres /Applications/Server.app/Contents/ServerRoot/usr/bin/initdb --encoding UTF8 --locale=C -D "/Library/Server/PostgreSQL/Data"
Output: The files belonging to this database system will be owned by user "_postgres".
This user must also own the server process.

The database cluster will be initialized with locale C.
The default text search configuration will be set to "english".


I, [2012-09-25T21:56:34.388687 #25336] INFO -- : *** PostgreSQL migration end ***
purge: 1
sourceRoot: /Library/Server/Previous
sourceType: System
sourceVersion: 10.7.4
targetRoot: /
language: en
purge: 1
sourceRoot: /Library/Server/Previous
sourceType:
sourceVersion:
targetRoot: /
language:
Overriding purge option: 1
purge: 1
sourceRoot: /Library/Server/Previous
sourceType: System
sourceVersion: 10.7.4
targetRoot: /
language: en
purge: 1
sourceRoot: /Library/Server/Previous
sourceType: System
sourceVersion: 10.7.4
targetRoot: /
language: en
Overriding purge option: 1
purge: 1
sourceRoot: /Library/Server/Previous
sourceType: System
purge: 1
sourceRoot: /Library/Server/Previous
sourceType: System
sourceVersion: 10.7.4
targetRoot: /
language: en
Overriding purge option: 1
purge: 1
sourceRoot: /Library/Server/Previous
sourceType: System
sourceVersion: 10.7.4
targetRoot: /
language: en
Overriding purge option: 1

Anyone else having this problem? :mad:



martva
Sep 27, 2012, 02:52 PM
So no one has seen this behaviour before.....

JFreak
Sep 29, 2012, 01:16 AM
So no one has seen this behaviour before.....

Not this one, but I had a nightmare of emails not working after updating to 2.1 (had to revert to time machine backup thus downgrade to 2.0) so I don't trust this release at all. Perhaps next point-release will gain my trust again?

martva
Oct 2, 2012, 07:24 AM
Same issue with 2.1.1... Takes a little bit longer before the system hangs... :mad:

alacratstore
Oct 4, 2012, 02:00 AM
Hey thanks a lot for this information about uprated software. Actually many of us facing the problem as it is new and there are some of issues at initial level.