PDA

View Full Version : Network Connection issues - 2 Macs - tried a lot before I posted




fartheststar
Oct 2, 2012, 01:45 AM
Hope this is an easy one.

Macbook Pro (via wifi)
MacPro (via ethernet)
Galaxy Nexus (via wifi)

Have recently been networked together on a netgear WNDR3700 router... and they can't see each other, but they all see the internet.

Before I start -- I moved. They were networked on a Time Capsule at my last place, worked fine. The Netgear router is another family members, and apparently has no special restrictions on it.

Top priority is two macs to see each other. Nice to have would be the galaxy nexus connection.

-The two macs can't see each other
-Both macs running Lion 10.7.3
-Finder preferences to show "shared" on both.
-Occasionally the Mac Pro will appear in the shared section of the Macbook Pro's finder, but will never connect.
-I can see 3 windows computers atm in the shared section on the mac pro (I think they're hard wired too)
-I can't see any computers on the Macbook pro

-In system preferences, both set to share some folders
In both cases: File Sharing is checked.
Some folders Admin is read and write, I'm read and write, everyone is read.
Sharing file folders by AFP is checked.

I tried:
Rebooting the router
Rebooting the machines and flushing the P-Ram.
Disabling AFP check, reboot, (both).
Tried using Command-K in finder and typing in the AFP # in there and connecting.

None of these work.

I don't know if this helps solve the main issue, but the side issue is that the Galaxy Nexus (wifi) won't connect to either the Macbook pro (via wifi) or MacPro using Doubletwist with airsync. Neither computer can see the device when they scan the network.....

I may try to see if I can hook the galaxy nexus up to a windows machine that's not mine, but I am pretty windows illiterate.

My time capsule will be arriving in 6 weeks (my partner is moving after me), in case that'll help?



garybUK
Oct 2, 2012, 07:17 AM
Hope this is an easy one.

Macbook Pro (via wifi)
MacPro (via ethernet)
Galaxy Nexus (via wifi)

Have recently been networked together on a netgear WNDR3700 router... and they can't see each other, but they all see the internet.

Before I start -- I moved. They were networked on a Time Capsule at my last place, worked fine. The Netgear router is another family members, and apparently has no special restrictions on it.

Top priority is two macs to see each other. Nice to have would be the galaxy nexus connection.

-The two macs can't see each other
-Both macs running Lion 10.7.3
-Finder preferences to show "shared" on both.
-Occasionally the Mac Pro will appear in the shared section of the Macbook Pro's finder, but will never connect.
-I can see 3 windows computers atm in the shared section on the mac pro (I think they're hard wired too)
-I can't see any computers on the Macbook pro

-In system preferences, both set to share some folders
In both cases: File Sharing is checked.
Some folders Admin is read and write, I'm read and write, everyone is read.
Sharing file folders by AFP is checked.

I tried:
Rebooting the router
Rebooting the machines and flushing the P-Ram.
Disabling AFP check, reboot, (both).
Tried using Command-K in finder and typing in the AFP # in there and connecting.

None of these work.

I don't know if this helps solve the main issue, but the side issue is that the Galaxy Nexus (wifi) won't connect to either the Macbook pro (via wifi) or MacPro using Doubletwist with airsync. Neither computer can see the device when they scan the network.....

I may try to see if I can hook the galaxy nexus up to a windows machine that's not mine, but I am pretty windows illiterate.

My time capsule will be arriving in 6 weeks (my partner is moving after me), in case that'll help?


Have you checked that all the machines have got IP Addresses' i know basic networks use the 192.168.x.x type addresses and that they have all got the same subnet mask. Have you also tried plugging both the mac's in by ethernet and trying that way?

Also open up a tool in Applications -> Utilities -> Network Utilities and try and ping the other machine. (you can get the IP's from System Pref's -> Network

Also check out if you have Firewall enabled in security.

Also check on the router, under wifi there's something called 'Privacy Seperator' or something enabled, this is typically used in public hotspots to disallow clients from seeing or talking to each other, whilst still be able to use the router.

DJLC
Oct 3, 2012, 11:42 AM
Kind of as garybUK said -- make sure you're not on a "Guest" network or something. A lot of newer routers support broadcasting multiple SSIDs, and usually Guest networks are enabled by default w/ client isolation (meaning clients cannot contact each other).

fartheststar
Mar 11, 2013, 04:19 PM
Haven't been on here in a while, but in case anyone wants to know:

There was no multicast enabled on the PC network, which is why the macs could not talk to each other. It took a while before I even knew that I should be searching for 'multicast'.

The router, which actually had a multicast option, was incompatible with the macs. When my wife flew out with the dog and the Time Capsule, we attached the Time Capsule to the existing router, we gave it a seperate network name to the main one, turned of DNS assignment, and now the macs speak to each other again.