PDA

View Full Version : Powerbook 12" 1.5 vertical lines on screen




mike457
Oct 2, 2012, 11:37 AM
Hi,
I bought a used 12" 1.5 Powerbook for parts, so I didn't pay much for it. I was surprised to find that it does boot, but the screen shows thin vertical pale lines across its whole width, like the lines on a pinstripe suit. It does not get to the operating system, at least not that I can see. I have tried resetting the pram, which had no effect, and I don't have the connectors to join it to an external monitor.

Should add: it does not have a hard drive in it. If I boot from the Leopard disk, it shows the Apple logo but does not go the next step to show the actual operating system.

Is this more likely to be the video chip failing or the display data cable? I've looked at the instructions on ifixit for the cable, and I'm not keen on trying that. :eek:

As I bought this for parts, I'm not heartbroken, but if there's an easy fix to get it back working, I'd hate to just cannibalize it.

Thanks



Detig
Oct 2, 2012, 12:57 PM
Hi,

I had the same problem with one of my previous 12" 1.5Ghz. As I had opened it before to install an SSD and re-set the thermal system my guess was that the graphics card fried in the meanwhile. If I recall correctly their GeForce 5200 graphics chip was known to give up the ghost. Never ocurred to me the cable could be defective as I could see the Apple logo as well.

Ended up buying a "new" one for around 100 ($150) and just some parts from the old one like the battery and the keyboard. Installed the G4 Fan Control (or whatever the name it has) to kick in the fans when either the CPU or the GPU gets over 52c to avoid frying anything.

Have already killed the ethernet jack on this new one on the meanwhile :).

mike457
Oct 2, 2012, 08:05 PM
Thanks. I was afraid that might be the answer. I've fixed up three of these lately, and I'm now planning to work on one to keep for myself. The pity is that this is the one with the case in the best condition. I'm not too keen on the more radical repairs because my eyesight is lousy nowadays.

tom vilsack
Oct 3, 2012, 01:16 AM
I had similar thing with old ibook..if i tryed booting from "c" i would get messed up video...if however i booted using "alt" and then picking cd/dvd it would load fine and could install osx....

mike457
Oct 4, 2012, 07:30 AM
Thanks. I think I tried that, but I'll give it another shot when I get back home on Monday.

mike457
Oct 10, 2012, 03:30 PM
Well, now that I'm back home, it's been a frustrating day. I tried putting in a hard drive from a beaten-up powerbook 12 that I got off an auction site. Much to my surprise, it booted fine into Tiger, though it had a password, and the lines disappeared as it started. Rather than trying to crack the password, I decided to erase the drive and do a clean install. Bad idea!

1) Whenever I put a disk into its internal drive, it spits the disk back out.
2) If I try to install Leopard from an external firewire drive, the installation gets past the Apple symbol with the spinning wheel and then stops on a grey screen and goes no further.
3) Ditto if I try to install from a USB.
4) I did set it up in firewire target mode and did an installation of Tiger from that (I'm going from my Cube, so I couldn't try Leopard). I then did all the updates, using the drive in the Powerbook as the boot disk.
5) Sometimes it boots properly; sometimes it goes from a pale blue screen to a black screen and no further; sometimes it kernel panics.

Things I have tried:
1) Reseating/replacing the RAM.
2) Resetting the PRAM.
3) Resetting the power management.
4) Taking a stiff drink

Any ideas gratefully appreciated. :confused:

Thanks,
Mike

California
Oct 10, 2012, 04:02 PM
Sounds like the video card is cr*pping out to me. I don't know if the 12" PB could be fixed with a heat reflow or not. Also sometimes the wires in the hinges got pinched to the screen...

I have a lot of Powerbook boards 12" -- I know the 1.5 and the 1.33 work, let me know if you need one after you figure this out.

mike457
Oct 10, 2012, 06:39 PM
Sounds like the video card is cr*pping out to me. I don't know if the 12" PB could be fixed with a heat reflow or not. Also sometimes the wires in the hinges got pinched to the screen...

I have a lot of Powerbook boards 12" -- I know the 1.5 and the 1.33 work, let me know if you need one after you figure this out.

I was afraid of that. I've been fixing these up for fun (weird obsession with 12" Powerbooks) to give to friends, so I've been avoiding big repairs; I've done five in the past few months. I try to avoid any that are too much money. This one lured me in because the case is the best I've seen and it was cheap. I'll have to think about whether I can afford a 1.5 board, and I know if I do that I'll be tempted to replace the DVD burner. It's the one part Apple really cheaped out on with this model. I really feel sorry for Powerbooks that don't work right. :(

mike457
Oct 24, 2012, 06:38 PM
I decided to go ahead with fixing this guy, so I bought a used logic board from an auction site. I was nervous about the installation. The instructions on iFixit are a little daunting, and I haven't done anything like this since I left the Windows world ten years ago. As it turned out, the instructions on iFixit were clear and easy to follow. The whole process took me much less time than I expected (about a couple of hours), and I've now restored a 1.5 to life. :D