PDA

View Full Version : Help with WPA in Debian on iBook Clamshell




Ariii
Oct 8, 2012, 02:42 PM
My Indigo Paris iBook has Debian 6.0 installed, with WICD, wpa_supplicant, and wpa_gui. Right now, it can only connect through EtherNet. wpa_gui doesn't display any networks at all, and WICD displays networks, but upon trying to connect, WICD states that the password is incorrect. I could show the log if I need to. Should I do that? I have the default configuration for everything. Also, it could connect to WPA networks when I booted from Mac OS X 10.3.9.



SuperJudge
Oct 8, 2012, 07:27 PM
Did you get the binary blob drivers for your Airport card? That's a perennial issue with Debian on Macs.

MacinDan
Oct 8, 2012, 10:46 PM
Install the package "firmware-linux-nonfree" for the proprietary firmware you need for the first generation Airport card. First you have to update your repositories to include contrib and non-free packages if you haven't already. I wrote a Debian guide with a wireless section here (http://ppcluddite.blogspot.com/2012/03/installing-debian-linux-on-ppc-part-iv.html#wireless).

Once you have the firmware installed you can connect to WPA but not WPA2 networks, exactly as on OS X 10.3.9.

Ariii
Oct 9, 2012, 12:38 AM
Install the package "firmware-linux-nonfree" for the proprietary firmware you need for the first generation Airport card. First you have to update your repositories to include contrib and non-free packages if you haven't already. I wrote a Debian guide with a wireless section here (http://ppcluddite.blogspot.com/2012/03/installing-debian-linux-on-ppc-part-iv.html#wireless).

Once you have the firmware installed you can connect to WPA but not WPA2 networks, exactly as on OS X 10.3.9.

I forgot to mention I already have it installed, sorry. Should I post the log?

MacinDan
Oct 9, 2012, 03:08 PM
I forgot to mention I already have it installed, sorry. Should I post the log?

I'm not really an expert so I don't know how much help I can be with a log. The only suggestion I have is to double check everything. Did you enter the correct wireless interface in Wicd preferences (you can look it up with sudo iwconfig)? Probably either eth1 or eth0? Does the passphrase you entered work in OS X? There's a section for troubleshooting which may help reading a log file here (http://wiki.debian.org/orinoco#troubleshooting).