PDA

View Full Version : [Safari 6] When I type in the search/address bar Safari always try to submit? Why?




colloc
Oct 10, 2012, 04:01 AM
Hi,

I am currently running 10.8.2 now.

I don't know why but when I type in the search/address bar of Safari 6, just a few words only (I haven't pressed "Enter" yet,) then the search form automatically submits itself either to an autocompleted address or to a Google search.

It's like this:

1/ I type in "macr" in to the address bar
2/ Safari 6 shows the address autocomplete suggestion for macrumors.com
(Haven't pressed Enter or anything yet)
3/ Safari goes straight to macrumors.com without my consent

It happens so frequently I am getting annoyed. Anyone getting the same problem?

----------

By Safari 6 address bar I mean this:
http://i.imgur.com/sRhDR.png

Update - April 2, 2014:
It's been a while since I created this thread, and I'm surprised to see it's still alive and that many people are still experiencing this bug (or feature?). I confirm that it also happens in Mavericks, and can be quite annoying at times.

Anyway, I think our efforts of complaining finally paid off - after almost 2 years, Apple finally decided to release a patch for this bug:


I will give it a try and see if it fixes the problem



colloc
Oct 10, 2012, 04:41 AM
update: it happens when I don't touch the address bar for a while.

Skoopman
Oct 10, 2012, 07:25 AM
I had the same problem yesterday with Google. Today I deleted my history and it's okay for now.

colloc
Oct 10, 2012, 09:11 AM
I had the same problem yesterday with Google. Today I deleted my history and it's okay for now.

Could it be because of the history?

justperry
Oct 10, 2012, 09:21 AM
Could it be because of the history?

No, but since history is erased there is nothing to autocomplete so it won't do what you have.
You could do a few things, try resetting Safari, it should be under the safari Menu in Menu Bar.
If that does not help, clear the caches in your home folder.
Or, delete the com.Apple.Safari.plist file in your preferences folder.
Last thing you could do is to move the Safari folder in your Library folder to the desktop, if that does not work put it back.

colloc
Oct 10, 2012, 09:47 AM
No, but since history is erased there is nothing to autocomplete so it won't do what you have.
You could do a few things, try resetting Safari, it should be under the safari Menu in Menu Bar.
If that does not help, clear the caches in your home folder.
Or, delete the com.Apple.Safari.plist file in your preferences folder.
Last thing you could do is to move the Safari folder in your Library folder to the desktop, if that does not work put it back.

I'm gonna try what you suggest. But it seems like this is not a common problem to everyone. Hmm.

colloc
Oct 10, 2012, 12:50 PM
No, but since history is erased there is nothing to autocomplete so it won't do what you have.
You could do a few things, try resetting Safari, it should be under the safari Menu in Menu Bar.
If that does not help, clear the caches in your home folder.
Or, delete the com.Apple.Safari.plist file in your preferences folder.
Last thing you could do is to move the Safari folder in your Library folder to the desktop, if that does not work put it back.

It seems the problem ceased for a while. I think I will do a clean install anyway just to see whether the problem is because of my ML installation

Skoopman
Oct 11, 2012, 11:27 AM
It seems the problem ceased for a while. I think I will do a clean install anyway just to see whether the problem is because of my ML installation

It's not, I did a clean install and still had the problem.

colloc
Oct 11, 2012, 09:54 PM
It's not, I did a clean install and still had the problem.

It's becoming really annoying now! Safari what's wrong???

hazsam2005
Oct 14, 2012, 09:35 PM
I am having the same problem, any one has found a solution?

Thanks

Edie Brickell
Oct 15, 2012, 02:11 AM
It's new feature in safari 6,if you type any word or match first time it will give you instant results or it's just like Goggle Instant. It will provide you searches very fast.

hazsam2005
Oct 15, 2012, 02:12 AM
Is there a way to disable it?

Vandefilm
Oct 15, 2012, 02:26 AM
It's not a bug, its a feature :D.

I have no trouble working with it. I use the 'tags' (?) mostly because I always use the same sites, but if I have to type in an address manualy I just type fast and ignore the autocomplete. No problems for me.

colloc
Oct 15, 2012, 03:43 AM
It's not a bug, its a feature :D.

I have no trouble working with it. I use the 'tags' (?) mostly because I always use the same sites, but if I have to type in an address manualy I just type fast and ignore the autocomplete. No problems for me.

But many times I pause during typing to think/remember what I want to type in, and Safari just acts smart and press enter for me. Plus this feature is so inconsistent (only work at random times) I'd rather live without it.

seqiro
Oct 26, 2012, 02:17 AM
I'm glad I wasn't imagining it. I just started noticing this and it's driving me nuts! Sometimes I start typing something and before I've even finished typing the first word Safari just goes somewhere on its own. And I'm not a slow typist.

Annoying.

elchemor
Nov 9, 2012, 02:50 PM
and i thought i was having imagination issues as well loll !!!! glad to see someone else having the same problem !

would love to see what's causing this..... and how to fix it !

laudern
Nov 9, 2012, 08:56 PM
what really pisses me off is when i open safari and I start typing in the address bar, google's homepage finishes loading and then magically, instead of continuing to type in the address bar, I've been moved to the google search box on the webpage and I'm typing an incomplete sentence because I was originally typing in the address but then was moved to the webpage's search box...

bbfc
Nov 10, 2012, 12:48 PM
Bizarre. I've never experienced this issue. If I type Macr into the address bar, Safari will autocomplete the URL and show the drop down box. It will never go to the page automatically.

Nermal
Nov 10, 2012, 12:56 PM
what really pisses me off is when i open safari and I start typing in the address bar, google's homepage finishes loading and then magically, instead of continuing to type in the address bar, I've been moved to the google search box on the webpage and I'm typing an incomplete sentence because I was originally typing in the address but then was moved to the webpage's search box...

That's the main reason that I've changed my homepage to an empty page rather than Google. There's a script on the Google page that basically says "when loading is complete, set focus to the search box". I despise software that steals focus and this is no exception!

As for the issue mentioned by the OP, I had it for the first time yesterday. I haven't had it again since so I'll have to wait and see whether it repeats itself.

EssentialParado
Nov 22, 2012, 11:11 PM
Thank GOD other people have this issue!

It's happening to me more and more. It'll keep taking me to sites I don't want to go to! I was trying to get to discussions.apple.com to actually search about this very issue but Safari took me to docs.unity3d.com instead.

This has GOT to be a bug. There's no way it's a feature. It's far too inconsistent.

leotreasure
Dec 5, 2012, 02:31 AM
Hi I think I just worked out how to temporarily fix this unexpected behaviour. Go into Safari preferences and under Privacy, tick 'Prevent search engine from providing suggestions' then untick - or just leave ticked. I'm sure this is a bug in Safari 6.0.2.

EssentialParado
Dec 5, 2012, 08:30 AM
So it is a bug Apple are aware of and will likely be fixed in a future update.

l008com
Dec 29, 2012, 01:00 PM
I have this problem all the time and it is super annoying.

The other problem I have is that there is no delay at all on auto complete. So if i type "mac" and hit return right away, it's going to auto completely to some random website i visited weeks ago, like macsautorepairandcleaning.com when I just wanted to do a google search for "mac". Combined with the abortion that is safari's new web developer tools, I'm really NOT loving Safari 6 AT ALL.

BrianGC
Jan 7, 2013, 05:41 AM
Happens to me on both personnal and pro computers, it's so annoying!

Last time I was going to show website statistics to my boss, started typing (quickly) analytics to get to my Google Analytics account, Safari hit enter by himself at anal[…]. Quite a moment when the Google Search page loaded…

It can't be a feature, even if you type fairly quickly it will cut you off.

edit: 10.8.2, Safari 6.0.1

svkrzn
Jan 11, 2013, 02:21 PM
Ok, i thought it was me pressing accidentally touchpad or enter while fast typing, but now i see it's a bug/feature!

kovacm
Feb 14, 2013, 02:44 AM
But many times I pause during typing to think/remember what I want to type in, and Safari just acts smart and press enter for me. Plus this feature is so inconsistent (only work at random times) I'd rather live without it.

I absolutely agree with you!

It is so annoying that I thinking to switch to another browser. I hate it. This reminds me to Windows... decay after S. Jobs already begin.

there is no more "one man to rule them all" ...!

I'm glad I wasn't imagining it.
I have same feeling!

kovacm
Feb 14, 2013, 07:37 AM
Hi I think I just worked out how to temporarily fix this unexpected behaviour. Go into Safari preferences and under Privacy, tick 'Prevent search engine from providing suggestions' then untick - or just leave ticked. I'm sure this is a bug in Safari 6.0.2.

I try this and it works now!!! :) :) (no more "auto-hitting" enter!)

zin
Feb 14, 2013, 12:07 PM
Just found this thread.

I suffer from this, too. At first I thought I was doing something unknowingly but I'm glad it's not just a part of my imagination.

kovacm
Feb 19, 2013, 04:00 AM
I try this and it works now!!! :) :) (no more "auto-hitting" enter!)

****!

this "auto submitting" starts again... it was fine for few days but it start again! :( :( :(

MonkeySee....
Feb 19, 2013, 04:06 AM
****!

this "auto submitting" starts again... it was fine for few days but it start again! :( :( :(

What if you change your default search engine in safari? Maybe is a google thing.

kovacm
Feb 19, 2013, 04:10 AM
What if you change your default search engine in safari? Maybe is a google thing.

good idea! Now I set Bing as default.. .we will see...

kovacm
Feb 20, 2013, 02:17 PM
It is same with Bing... :(

SoldOnApple
Mar 8, 2013, 06:13 AM
Was a solution ever found for this? It's driving me insane and has been for a long time now.

l008com
Mar 15, 2013, 02:24 AM
I uploaded to 10.8.3 tonight which included Safari 6.0.3
Just had this bug again after updating.

WTF Apple?
Give us the separate address and search bars back until you fix this bug.

EssentialParado
Mar 15, 2013, 07:14 AM
I uploaded to 10.8.3 tonight which included Safari 6.0.3
Just had this bug again after updating.

WTF Apple?
Give us the separate address and search bars back until you fix this bug.

Seriously? This was the single reason I was going to update...

jlnr
Mar 29, 2013, 12:09 AM
Same problem, I've filed this as rdar://12651123 in Nov 2012.

It is incredibly hard to reproduce on purpose.

Fietsbel
Mar 31, 2013, 01:59 PM
I have the same annoying problem, I thought I touched the trackpad by accident. But it occurs random, not with one 1 specific website

e!ia
Apr 16, 2013, 08:47 AM
Check the contents of /Library/InputManagers/

I just deleted the GearsEnabler plugin from google which has been installed during 2008 (!)

Oli3000
May 15, 2013, 05:19 AM
I have this problem regularly on my MBA, but not my iMac running identical preferences and 10.8.3!

Really frustrating when you start searching for something at it searches for only half the word... GRRRR! Again, i'm not a slow typer, typically when it does it it auto-searches after about 1 second of typing.

cjt3007
Jun 7, 2013, 01:59 PM
I've had this issue for a while, probably since I installed ML.

zver
Jul 30, 2013, 12:53 AM
Same problem here! 10.8.4, Safari 6.0.5

pwhty
Sep 27, 2013, 08:11 AM
I've been having this issue for about an year now. While I was sure I'm not doing something unconsciously, I never took the time to search for this. Now I did and I'm disappointed to see there's still no solution.

jg321
Sep 29, 2013, 06:02 AM
Same problem[...]

It is incredibly hard to reproduce on purpose.

This. It's been happening to me for a while, but not sure on the exact circumstances needed to reproduce. Haven't noticed it for a while actually!

ManuCH
Sep 29, 2013, 07:36 AM
I've been having this very same issues for months. Has anyone ever found a solution?

Currently on OS X 10.8.5 with Safari 6.0.5. I don't have any Input Managers (I don't even have the directory). It's driving me crazy and it just happens every now and then.

jlnr
Sep 29, 2013, 09:39 AM
I've been having this very same issues for months. Has anyone ever found a solution?

Yes :) Sign up for Apple's free Safari developer program and download the preview build of Safari 6.1. The current build is much more stable than the public Safari for me, and it does not have this bug.

Fishrrman
Sep 30, 2013, 09:54 AM
If you want to prevent Safari from "auto-completing" as you type in the URL/search bar, do this:

Click in the search bar to select it.

Type a space character BEFORE YOU TYPE ANYTHING ELSE. You want a space character to be the first character entered.

Now type in whatever you wish.
This will "suspend" Safari's attempts to auto-complete or auto-suggest.

Safari will still display a list of "suggestions" _under_ the entry bar, but it will not insert text INTO the bar as you try to type (which I find very frustrating).

Lazlow
Oct 3, 2013, 03:41 PM
Happens to me too. I'll press  + L, start typing, and then a few characters in, Safari will just automatically press "enter" for me. Been happening for many months, but I just now decided to Google it and realized others have the same issue!

BrEacK
Nov 23, 2013, 06:02 AM
Still happening on Mac Book Air 13" with 10.9 and Safari 7.0

Happening on a Hackintosh 10.8.5 with Safari 6.x, too.

Anyone got a solution ?

Razvan

iEdd
Nov 23, 2013, 06:03 AM
I sometimes wonder if Apple (and other companies) uses its own products.

EssentialParado
Dec 21, 2013, 07:44 AM
Still around in Mavericks… I mean really Apple??


I am surprised not more people complain about this though… does not everybody have the bug or does everyone else like the "feature" ?

pencilcheck
Jan 6, 2014, 01:03 AM
I have experienced this problem as well, but it is not reproducible. It just happens sometimes but it's still annoying... I hope someone can contact his Apple friends and tell them to fix this!

Scott90
Jan 22, 2014, 09:34 PM
I guess we'll keep this thread active as long as it's an issue, I've been experiencing it too for quite some time now.

ConnYoungy
Feb 1, 2014, 08:16 AM
I get this problem all the time, incredibly frustrating

OSXFirePussy
Feb 26, 2014, 10:37 AM
+1

I can't believe it's a feature. I hate it. Checked to disable search engine suggestions.

Using Safari 7.0.1 on OS X Mavericks 10.9.1.

ddanecki
Mar 1, 2014, 06:20 AM
I am under impression that it has been fixed in Safari 7.0.2. After I've updated my OS, it didn't happen so far....

So it just happened again. Only few minutes after I wrote this message :/

Mavericks 10.9.2, Safari 7.0.2

jasoncodes
Mar 1, 2014, 06:29 AM
Iíve had this bug reoccur a couple of times already with Safari 7.0.2 on OS X 10.9.2.

ddanecki
Mar 1, 2014, 06:35 AM
Iíve had this bug reoccur a couple of times already with Safari 7.0.2 on OS X 10.9.2.

Yeah, me too. During first few minutes when I was doing everything to trigger it, it did not happen. Then after posting my message, closing this forum and trying to open another website it happened again.

This is really frustrating. There are moments when my browser is useless as out of 5 pages I try to open, one after another, only one or none is the one I really wanted. What is it supposed to be anyway ? Feature or bug ? If it's a feature, where's the option to disable it ?

OSXFirePussy
Mar 6, 2014, 05:39 AM
Me too.

muouyiyi
Mar 27, 2014, 02:52 AM
...what i should say...
glad to see so many are in the same boat...:o

Fishrrman
Mar 27, 2014, 10:43 AM
[[ Feature or bug ? If it's a feature, where's the option to disable it ? ]]

Folks, please read carefully post #46 above...

IceMustard
Mar 31, 2014, 08:31 AM
Folks, please read carefully post #46 above...
Excerpt from your post #46:
Type a space character BEFORE YOU TYPE ANYTHING ELSE. You want a space character to be the first character entered.

It is not that autocomplete is the problem.

The annoying issue this thread is about can be named Auto-Enter or Auto-Return. You start typing in the address bar and magically after one, two (or if you are fast more letters) Safari opens the first url found within the autocomplete list. And this depends on how many letters you actually typed. It is impossible to willingly enter letters in this situation, cause the auto return kicks in really fast, like after 0.3 secs or so. And it is intermittent. It does not always happen. Some people pointed out, it is more likely to happen if you did not open a url for a while.

The conclusion must be: This is not a feature, it is definitely a BUG. And it is still present in OS X 10.9.2 and Safari 7.0.2.
I came from OS X 10.6.8 directly to Mavericks and for me the issue started then. I am not sure if maybe some plugin/extension is the root of this issue. For example I have Glims for Safari installed.

Is there anyone with vanilla Safari experiencing this issue?

Also, I wonder if anyone has raised an issue at Apple support and how Apple comments on that?

jbarley
Mar 31, 2014, 10:32 AM
What can I say, I feel for all of you with this problem.
But I must admit I've never experienced it myself.
I'm running 10.8.5 and Safari 6.1.2 and it always behaves as expected,
when I start typing in the address bar Safari takes it's best guess and adds characters, along with a dropdown menu of selections, but it NEVER autocompletes or opens any selection until I hit the return key, which is what I expect is the way it is designed to work.

IceMustard
Mar 31, 2014, 11:15 AM
I can add some more details on my usage pattern of Safari. Safari is opened all the time. I never close it. I have several windows of Safari open on multiple spaces (or in MissionControl speak: desktops). Some windows contain 5 or 6 tabs. Others contain 20 to 30 tabs, thanks to the Glims feature to have small tabs (they can shrink to the width of the favicon).

In total my current session contains 8 windows with in sum 104 tabs, I arranged my working sets on 4 Spaces (desktops). If I look at Activity Monitor this results in 20 WebContent processes each of 9 to 18 threads.

I often hotplug a second monitor. So sometimes I have a dual monitor setup, sometimes its just my little 13 inch mac book pro screen. So far I have not payed attention, if the issue is maybe restricted to only one of those setups. I ll try to do so now.

Right now I started experimenting with BetterTouchTool to maybe workaround the issue:

I try to use BetterTouchTool to automatically add some harmless key combination after activating the address bar. Atm I try CMD+A.
So if I type CMD+L Bettertouchtool opens File-->"Open URL ..." followed by a "CMD+A" which selects the url. The extra CMD+A does not change anything, cause the URL is already selected by default.

In BetterTouchTool looks like this:
http://forums.macrumors.com/attachment.php?attachmentid=466955&stc=1&d=1396283028
(German "Ablage" = English "File")

Another possible harmless key stroke might be just "ESC". Or if anybody does not like that autocomplete is done within the address bar one could even use "SPACE" as suggested in #46.
But I like autocomplete in address bar, I just do not need auto enter. ;)
Furthermore, if we use SPACE as prefix some urls from history cannot be found. For example if u enter
"[SPACE]forums.mac" then forums.macrumors.com will not be part of the autocomplete list. So prefix SPACE is a bad idea imho. It breaks autocomplete in many cases.

However, I will see if adding dummy key strokes helps with the original issue. As we all know we have to use the system for a while to experience the bug. It cannot be reproduced at will.

IceMustard
Apr 1, 2014, 03:59 AM
Ok, I had my first occurrence of the issue today with above BetterTouchTool experiment setup.

It happened on NewTab. That means the sequence CMD+T,CMD+A does not surpress the issue.
I have now setup BetterTouchTool like follows:

CMD+L triggers the sequence MenuItem-OpenUrl, CMD+A (same as above)
CMD+T triggers the sequence MenuItem-NewTab, SPACE, BACKSPACE, ESC
CMD+N triggers the sequence MenuItem-NewWindow, SPACE, BACKSPACE, ESC

... will see if that helps. But my hope fades a bit.

colloc
Apr 2, 2014, 02:27 AM
It's been a while since I created this thread, and I'm surprised to see it's still alive and that many people are still experiencing this bug (or feature?). I confirm that it also happens in Mavericks, and can be quite annoying at times.

Anyway, I think our efforts of complaining finally paid off - after almost 2 years, Apple finally decided to release a patch for this bug:
http://i.imgur.com/iqp2pzz.png

I will give it a try and see if it fixes the problem

IceMustard
Apr 2, 2014, 02:36 AM
Yippee, so I immediately stop experimenting with dummy key strokes. Also, it did NOT work very well. I had the BUG occur 2 times since I started my experiment.

I am so happy about this news. Thanks for pointing to this. Downloading right now the update. I really hope they caught it ...

jbarley
Apr 10, 2014, 11:08 AM
Can anyone who was having this Safari problem confirm the "fix" claimed in the Safari 7.0.3 update (http://www.macrumors.com/2014/04/01/apple-releases-safari-7-0-3/)?

kronborg
Apr 10, 2014, 11:41 AM
I still experience the bug in 7.0.3. So annoying, but I've almost gotten used to it by now.

ddanecki
Apr 11, 2014, 05:24 AM
Can anyone who was having this Safari problem confirm the "fix" claimed in the Safari 7.0.3 update (http://www.macrumors.com/2014/04/01/apple-releases-safari-7-0-3/)?

I can confirm that it does not happen any more for me. OSX 10.9.2, Safari 7.0.3.

I still experience the bug in 7.0.3. So annoying, but I've almost gotten used to it by now.

That's strange. It seems to be fixed for me.

It is a little bit strange now when I don't have to type urls few times, however I think I'll manage to get used to it ;)

IceMustard
Apr 12, 2014, 03:22 AM
OS X 10.9.2, Safari 7.0.3. The auto-return bug has not happened for 10 days now.

jbarley
Apr 12, 2014, 09:53 AM
Sounds like maybe Apple does listen, at times...