PDA

View Full Version : Apache2 Error when PC is restart




bwan37
Oct 12, 2012, 11:43 AM
Everytime I restart my Mac, the following error shows up...

[Sat Oct 13 00:35:43 2012] [error] Init: Pass phrase incorrect
[Sat Oct 13 00:35:43 2012] [error] SSL Library Error: 218710120 error:0D094068:asn1 encoding routines:d2i_ASN1_SET:bad tag
[Sat Oct 13 00:35:43 2012] [error] SSL Library Error: 218529960 error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag
[Sat Oct 13 00:35:43 2012] [error] SSL Library Error: 218595386 error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error
[Sat Oct 13 00:35:43 2012] [error] SSL Library Error: 218734605 error:0D09A00D:asn1 encoding routines:d2i_PrivateKey:ASN1 lib
[Sat Oct 13 00:35:43 2012] [crit] (17)File exists: mod_rewrite: Parent could not create RewriteLock file /var/log/apache2/rewrite.lock
Configuration Failed
[Sat Oct 13 00:35:55 2012] [notice] Apache/2.2.22 (Unix) DAV/2 PHP/5.3.15 with Suhosin-Patch mod_ssl/2.2.22 OpenSSL/0.9.8r configured -- resuming normal operations

but when I sudo apachectl restart, seems to be normal...
[Sat Oct 13 00:41:42 2012] [notice] caught SIGTERM, shutting down
[Sat Oct 13 00:41:45 2012] [notice] Apache/2.2.22 (Unix) DAV/2 PHP/5.3.15 with Suhosin-Patch mod_ssl/2.2.22 OpenSSL/0.9.8r configured -- resuming normal operations


Can anyone give me a hand into solving this problem?
Thanks a million times.



kevinh456
Oct 12, 2012, 11:34 PM
Here is a solution for your problem:

http://ubuntuforums.org/showthread.php?t=774692

Basically, it's waiting for an SSL passphrase. You have two choices: use an ssl passphrase that doesnt' require a passphrase on startup OR manually start apache after the system starts. After the system starts, the passphrase is unlocked. That's why it works when you start it manually.

There is a second problem:

File exists: mod_rewrite: Parent could not create RewriteLock file /var/log/apache2/rewrite.lock

Try to delete /var/log/apache2/rewrite.lock

It looks like the file got leftover after a crash.

bwan37
Oct 15, 2012, 02:46 AM
Here is a solution for your problem:

http://ubuntuforums.org/showthread.php?t=774692

Basically, it's waiting for an SSL passphrase. You have two choices: use an ssl passphrase that doesnt' require a passphrase on startup OR manually start apache after the system starts. After the system starts, the passphrase is unlocked. That's why it works when you start it manually.

There is a second problem:

File exists: mod_rewrite: Parent could not create RewriteLock file /var/log/apache2/rewrite.lock

Try to delete /var/log/apache2/rewrite.lock

It looks like the file got leftover after a crash.


Thanks for your info, so I now wait for the Mac to load up and waited for a few second before logging into mac, and the 1st problem was solved. ^_^

however, all I did was a normal restart for my mac, and rewrite.lock showed up, when I try to look at the file, it was 0kb, with nothing inside the file.
Seems it will not hurt the operation of my server for now.
hope this is not a serious issue for the long run :)