PDA

View Full Version : ipod either not mounting, or not completing update with itunes.




claudette
Aug 31, 2005, 05:10 AM
hello, i've been wandering this forum in search of help...although i have found quite the bit of cool tid-bits, nothing specific to my 'issue'...

the low down:
i have: a 4G 20GB iPod; 1.33GHz PowerBook G4, 512mB RAM (80gB HD)

its my first mac in 15yrs, and i love it. recently, i tried to update my ipod three days ago, the update started, but then the ipod and itunes froze. i forced quit the itunes. attempt to eject the ipod through finder, which didn't work. so i just unplugged it.
i then reset the ipod (select+menu), and attempted the update again. i recieved an error message that said ~there are no readable volumes on the device. in disk utility, i attempted to verify & repair disk. both failed because the underlying task failed. (i have since learned to keep better records of the errors, sorry for the vague wording/descriptions). i have restored it to the latest ipod update, (didn't solve the problem), in my searching, i read somewhere that the feb/mar update worked better for someone, tried that as well, it was a no go.
after that, i have been re-attempting the update, and getting one of two results: 1. the ipod doesn't mount on the laptop, but the ipod says 'updating do not disconnect'. it seems to just run, it gets very hot, very quick (temp is fine when it is working right). i have to reset it, and try again. -or- 2. the ipod mounts, itunes starts the update. after 1/3 of the update it freezes, requiring force quit, and the ipod then gets very hot, very quick, continues to say 'do not disconnect', and needs resetting.

i would really appreciate any hints/places to start/ideas. also, i think i've included all pertinent info, but if i missed something, let me know, i'll post it right away.

thanks. claudette



mad jew
Aug 31, 2005, 05:19 AM
I had exactly the same problem a few weeks ago and after a bit of a side chat in another thread (which I can't find :o ), we worked out it needs to be repaired by an Apple dealer, or more likely replaced.


I haven't bothered (despite promising otherwise to Applespider) since it's now working a bit. I let the thing cool off and then tried again. After syncing about 1,500 songs, it froze iTunes again. I manually ripped it out (ignoring the warning) and reset it, let it cool down, and then repeated. I eventually got about 7,000 songs on before I gave up. Strangely, it performs okay now, it even syncs when plugged in but it doesn't like doing it when hot or if there are too many songs to swap (more than 100).

I ran it through Disk Utility's Verify Disk process and it failed last week (I forget the reasons) but now it's absolutely fine. :confused:

Sorry, but I'm not sure there's a sure-fire solution to your problem other than doing as I did or getting a replacement. Hopefully I'm wrong though.

Mitthrawnuruodo
Aug 31, 2005, 05:23 AM
I fear that the iPod might have a bad HD and should be replaced, but you can try to reinstall the latest iPod Updater (should be in /Applications/Utilities if you've downloaded it from Software Update) and if that don't help, see if some of these tips from Apple (http://docs.info.apple.com/article.html?artnum=32222) are any good, before calling/going to Apple (or where you bought the iPod) for a replacement (I would guess a 4G is still under warranty).

Edit: Beaten by 4(!) minutes... :o I got to stop opening more than a couple of tabs... ;)

claudette
Aug 31, 2005, 05:26 AM
thanks for the uberquick replies. i'll try the "cool-down". see where that gets me. its only 8mos old, i'd hate to have to replace it. but i'm aware thats where this is heading :(

mad jew
Aug 31, 2005, 06:29 AM
Mine's only about ten months old and it started playing up at about eight months anyway. They're not the most reliable of things if you plan on using them roughly (which I do unfortunately). The way I see it, they're not all that expensive and I don't really mind buying a new one each year. I know that's not really what you want to hear, sorry, not very helpful.

Hopefully the cool-down will help. :)

Oh, and for the record, reinstalling the firmware seems to achieve nothing for me. :(

claudette
Sep 2, 2005, 12:46 AM
thanks again for the responses. what i ended up doing was... restoring the ipod to the previous update (i think it was march or feb) again. then i kept attempting to mount it. when it finally mounted, i got a 'itunes has detected new software for your ipod' i agreed to the update, then voila! it worked. sync-ed with itunes (all 4000+ songs). have no clue what worked, but it did. and because i'm a glutton for punishment, i even tried to get it to sync again, and it did! although i'll probably not have enough nerve to try to do a major sync with it soon, i'm glad i have enough music to make do.

thanks again.
claudette