PDA

View Full Version : Why cannot ping 192.168.2.1




rockinmyshoe
Oct 18, 2012, 12:44 PM
I set up a G4 Mac 10.5.8 with two ethernet connections. Both with Static addressing. I have internet sharing turned on, with en0 being shared with en1

en0 is 172.20.0.75, 255.255.255.0, Router 172.20.0.1
en1 is 192.168.2.1, 255.255.255.0, Router 172.20.0.75

a laptop using 172.20.0.1 255.255.255.0 is tied to port en0
a mini using 192.168.2.75 255.255.255.0 is tied to port en1

so the schematic looks like;

(laptop 172.20.0.1) <--> (172.20.0.75 en0 - G4 - en1 192.168.2.1) <--> (192.168.2.75 mini)

from the laptop I can ping 172.20.0.1, 172.20.0.75
from the G4 I can ping 172.20.0.1, 172.20.0.75, 192.168.2.1, 192.168.2.75
from the mini I can ping 192.168.2.75, 192.168.2.1, 172.20.0.75, 172.20.0.1

but from the laptop I cannot ping 192.168.2.1 or 192.168.2.75

Any suggestions as to why?



RoadKill
Oct 18, 2012, 02:47 PM
Sounds like routing or firewall

What is the default gateway of the laptop?

It should be 172.20.0.75 or you need a static route to 192.168.2.0 255.255.255.0 via 172.20.0.75

If one of these is true then try disabling any firewall

rockinmyshoe
Oct 18, 2012, 03:08 PM
I had in the laptop 172.20.0.1 as the gateway. I set it to 172.20.0.75 and now i can ping 192.168.2.1 and 192.168.2.75.

Thank you, that tests out the link as being good end to end.

the next thing is to replace the laptop with LAN port on a router. :)

RoadKill
Oct 18, 2012, 03:11 PM
Glad you got it working :-)

rockinmyshoe
Oct 18, 2012, 03:23 PM
First time on this forum. Do I award points or is just a atta-boy

RoadKill
Oct 19, 2012, 06:49 AM
Thank you, that tests out the link as being good end to end.

That was all the feedback required :-)