PDA

View Full Version : iTunes 10.6.3 running on iBook G4!




RedCroissant
Oct 23, 2012, 12:25 PM
I was able to download and install iTunes 10.6.3 onto my iBook G4 1.33GHz 1.5Gb RAM and running OS X 10.5.8. It also works just fine for the most part with of course some limitations.

It was available in Software Update and installed normally.

http://s1078.beta.photobucket.com/user/RedCroissant/media/iBookG4_zps8410c116.png.html?sort=3&o=0



RedCroissant
Oct 23, 2012, 12:51 PM
I have even connected my iPhone 4S and it comes up just fine in iTunes(albeit not as fast as it does on my iMac) and everything looks normal. Has anyone else been able to download, install and run iTunes 10 on their PowerPC machines?

skateny
Oct 23, 2012, 01:19 PM
I was able to download and install iTunes 10.6.3 onto my iBook G4 1.33GHz 1.5Gb RAM and running OS X 10.5.8. It also works just fine for the most part with of course some limitations.

It was available in Software Update and installed normally.

http://s1078.beta.photobucket.com/user/RedCroissant/media/iBookG4_zps8410c116.png.html?sort=3&o=0

This version of iTunes has always worked on PowerPC.

RedCroissant
Oct 23, 2012, 01:39 PM
This version of iTunes has always worked on PowerPC.

I thought that 9.2.1 was the last version with PowerPC support. I also checked the system requirements on Apple's website and it specifically states that an Intel Processor with 512MB RAM and OS X 10.6.8 or later.

skateny
Oct 23, 2012, 01:49 PM
I was able to download and install iTunes 10.6.3 onto my iBook G4 1.33GHz 1.5Gb RAM and running OS X 10.5.8. It also works just fine for the most part with of course some limitations.

It was available in Software Update and installed normally.

http://s1078.beta.photobucket.com/user/RedCroissant/media/iBookG4_zps8410c116.png.html?sort=3&o=0

I thought that 9.2.1 was the last version with PowerPC support. I also checked the system requirements on Apple's website and it specifically states that an Intel Processor with 512MB RAM and OS X 10.6.8 or later.

I know that 10.6.3 has always worked on Leopard. I don't know about G3s and earlier versions of OS X.

Jessica Lares
Oct 23, 2012, 02:00 PM
I know that 10.6.3 has always worked on Leopard. I don't know about G3s and earlier versions of OS X.

8.2.1 for G3, otherwise 10.6.3 for G4 and G5, depending on if you have Tiger or Leopard.

skateny
Oct 23, 2012, 02:21 PM
I thought that 9.2.1 was the last version with PowerPC support. I also checked the system requirements on Apple's website and it specifically states that an Intel Processor with 512MB RAM and OS X 10.6.8 or later.

Even without support for iTunes 10.7, the iBook is a sweet machine.

I started out with an Amiga 1000. Then a PowerBook 520c, a Kanga (that was a Beast!), 300 MHz Wall Street, Pismo and my current iBook.

As many people have expressed on this forum, I just like the PowerPC enough to keep on using. Besides, I like doing maintenance, repairs and upgrades myself.

Intell
Oct 23, 2012, 08:38 PM
8.2.1 for G3, otherwise 10.6.3 for G4 and G5, depending on if you have Tiger or Leopard.

iTunes 9.1 is the last unofficial version that works on G3s. But the iTunes installer refuses to install it. But once you get it installed, somehow, it works just fine. The only things that don't work are iTunes Extras and a few other iTunes 9 features. And the last version for Tiger is iTunes 9.2.1.

RedCroissant
Oct 23, 2012, 11:05 PM
Well fine. I though that there was some crazy glitch that allowed it and I was really happy about that. I just wish that I had looked at it earlier.

skateny
Oct 23, 2012, 11:15 PM
Well fine. I though that there was some crazy glitch that allowed it and I was really happy about that. I just wish that I had looked at it earlier.

Better late than never. ;)