PDA

View Full Version : G4 iMac Video Issues




GP1138
Nov 14, 2012, 08:32 PM
Picked up an 800mhz G4 iMac, traded my Nano Touch for it. I have been looking for one for awhile. Seems to work great, even with 512MB of RAM. But, after it is on for awhile, the display gets corrupted, and it will not wake from display sleep. Once it's rebooted it will not boot past the blue screen and mouse pointer, which is corrupted. Sometimes it gets vertical lines and sometimes it's just a corrupted cursor.

If I let it sit for a few hours, and cool down, it goes back to normal.

Is there something that I can do about this? I have a tube of Arctic Silver, is there something that needs to be re-coated properly? Or is this just going to get worse? I'd love for this to be reliable, I'm going to use it as a bedside alarm clock/jukebox, as it's compact enough to be useful for just such a purpose. Otherwise it'd just sit in my basement and look cool.



fhall1
Nov 15, 2012, 06:17 AM
Search the web for some videos for your specific model....there are differences in the internals. Then take it apart and blow out the dust and ensure the fans still spin easily. Yes - you need to recoat the heat transfer surfaces when you reassemble it....the videos will show you where - that's why you need videos for your specific model.

wobegong
Nov 15, 2012, 08:53 AM
You could start by kicking the guy that sold it to you……

But seriously, as said previously check the thermals, check the fans spin up ok (I would imagine if its graphical glitches, cursor etc it would be the GPU fan but I don't even know if your model had a GPU fan, if not then as the previous poster suggested check the thermal paste on the GPU heatsink) both GPU (if it has one) and CPU. Hopefully that's all it is and you'll be enjoying the most beautiful Apple desktop ever made :)

Jethryn Freyman
Nov 16, 2012, 01:21 AM
So far it sounds more like a logic board/GPU failure, though screenshots would be good :)