PDA

View Full Version : Help, Powerbook completely irresponsive


Googol
Sep 14, 2005, 06:34 AM
My G4 powerbook is utterly dead.
It refuses to start up.

The power supply connector is glowing up red!

I already tried:
- new, full battery
- another power supply
- pressing power button for seconds
- reset PMU, Power Management Unit:
command-option-shift-power

I'm desperate.

wordmunger
Sep 14, 2005, 07:13 AM
Make sure your battery is properly seated in the computer. You may want to clean the battery contacts. Then try holding down the power key for a few seconds. If that's not it, I can't help you.

mad jew
Sep 14, 2005, 07:20 AM
Glowing red? Not orange? :confused:

What was it last doing before it died on you? Is it possible a power surge wrecked the internals?

Googol
Sep 14, 2005, 07:36 AM
Glowing red? Not orange?


Yes, it is glowing orange, I'm colorblind.


What was it last doing before it died on you?


My Powerbook worked normally the last time.
But then I didn't use it for about 6 months.

Could some internal battery or so have run out? :confused:

Passante
Sep 14, 2005, 08:00 AM
I think your charger is fried

Try this
Check if your battery needs to be recharged. Press the small button on the battery.
You should see one to four lights indicating the battery’s level of charge. If only one
battery level indicator light is flashing, allow the power adapter to charge the battery
until at least one indicator light is glowing continuously.
If that does not work, return to the computer’s factory settings by disconnecting the
power adapter, removing the battery, and holding down the power button for at
least 5 seconds.