PDA

View Full Version : G5 panic




kaliyuga
Nov 24, 2012, 02:20 PM
Having trouble with my g5 not starting. by a fluke it seems it did start on one occasion and I managed to get this report, can anyone help?


Interval Since Last Panic Report: 24552693 sec
Panics Since Last Report: 7
Anonymous UUID: 87AF7368-F7E1-43BB-8169-1C642A962EF8

Sat Nov 24 15:48:20 2012


Unresolved kernel trap(cpu 0): 0x300 - Data access DAR=0x0000000000000010 PC=0x000000000008404C
Latest crash info for cpu 0:
Exception state (sv=0x1ecb9280)
PC=0x0008404C; MSR=0x00009030; DAR=0x00000010; DSISR=0x40000000; LR=0x00084034; R1=0x26E67B60; XCP=0x0000000C (0x300 - Data access)
Backtrace:
0x000B0738 0x000857A8 0x00078B04 0x0007916C 0x0007A1C4 0x0006C290
0x0006D2A4 0x0029CF3C 0x003100AC 0x000B4448 0x00000000
backtrace terminated - frame not mapped or invalid: 0xBFFFF880

Proceeding back via exception chain:
Exception state (sv=0x1ecb9280)
previously dumped as "Latest" state. skipping...
Exception state (sv=0x1ecb9a00)
PC=0x97547764; MSR=0x0200F030; DAR=0x015B9000; DSISR=0x42000000; LR=0x97549490; R1=0xBFFFF880; XCP=0x00000030 (0xC00 - System call)

BSD process name corresponding to current thread: kextd

Mac OS version:
9L31a

Kernel version:
Darwin Kernel Version 9.8.0: Wed Jul 15 16:57:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_PPC
System model name: PowerMac9,1

System uptime in nanoseconds: 19070964378
unloaded kexts:
(none)
loaded kexts:
com.apple.driver.ApplePulsar 1.5.2d0 - last loaded 462696275
com.apple.driver.AppleCPUThermo 2.0.0a0
com.apple.driver.AppleFileSystemDriver 1.1.0
com.apple.iokit.IOUSBHIDDriver 3.4.6
com.apple.driver.AppleUSBMergeNub 3.5.2
com.apple.iokit.IOSCSIMultimediaCommandsDevice 2.1.1
com.apple.iokit.SCSITaskUserClient 2.1.1
com.apple.driver.XsanFilter 2.7.91
com.apple.iokit.IOATABlockStorage 2.0.6
com.apple.iokit.IOATAPIProtocolTransport 1.5.3
com.apple.driver.AppleUSBHub 3.4.9
com.apple.iokit.IOUSBUserClient 3.5.2
com.apple.driver.AppleK2SATA 1.0.4f2
com.apple.driver.AppleGPIO 1.3.0d0
com.apple.driver.MacIOGPIO 1.3.0d0
com.apple.driver.AppleMPIC 1.5.3
com.apple.driver.AppleI2C 4.0.0d2
com.apple.driver.AppleFWOHCI 3.9.7
com.apple.driver.AppleKauaiATA 1.2.1f4
com.apple.driver.AppleK2SATARoot 1.0.5b1
com.apple.driver.AppleUSBEHCI 3.4.6
com.apple.driver.AppleUSBOHCI 3.4.6
com.apple.driver.AirPortBrcm43xx 366.91.21
com.apple.driver.AppleK2 1.7.2f1
com.apple.iokit.AppleGMACEthernet 1.5.9f1
com.apple.driver.AppleSMU 1.2.1d1
com.apple.driver.AppleMacRiscPCI 3.4.0
com.apple.driver.AppleCore99NVRAM 1.1.1
com.apple.driver.AppleFlashNVRAM 1.0.5
com.apple.security.seatbelt 107.12
com.apple.nke.applicationfirewall 1.8.77
com.apple.security.TMSafetyNet 3
com.apple.BootCache 30.4
com.apple.driver.DiskImages 199
com.apple.driver.AppleMacRISC4PE 2.0.4d9
com.apple.driver.AppleUSBComposite 3.2.0
com.apple.iokit.IOBDStorageFamily 1.5
com.apple.iokit.IODVDStorageFamily 1.5
com.apple.iokit.IOCDStorageFamily 1.5
com.apple.iokit.IOSCSIBlockCommandsDevice 2.1.1
com.apple.iokit.IOSCSIArchitectureModelFamily 2.1.1
com.apple.iokit.IOFireWireFamily 3.4.9
com.apple.iokit.IOATAFamily 2.0.1
com.apple.iokit.IOUSBFamily 3.5.2
com.apple.iokit.IO80211Family 216.1
com.apple.iokit.IOKeyLargo 1.7.2f1
com.apple.iokit.IONetworkingFamily 1.6.1
com.apple.iokit.IOHIDFamily 1.5.5
com.apple.iokit.IOStorageFamily 1.5.6
com.apple.iokit.IOPCIFamily 2.6
com.apple.driver.IOPlatformFunction 1.8.7d5
panic(cpu 0 caller 0xFFFF0003): 0x300 - Data access
Latest stack backtrace for cpu 0:
Backtrace:
0x0009CC88 0x0009D63C 0x00029DA0 0x000B0A10 0x000B4278
Proceed`

mac os x 10.5.8

Model: PowerMac9,1, BootROM 5.2.2f2, 1 processor, PowerPC G5 (3.0), 1.8 GHz, 1 GB
Graphics: GeForce FX 5200, GeForce FX 5200, spdisplays_agp_device, 64 MB
Memory Module: DIMM2/J4100, 512 MB, DDR SDRAM, PC3200U-30330
Memory Module: DIMM3/J4101, 512 MB, DDR SDRAM, PC3200U-30330
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x4E), Broadcom BCM43xx 1.0 (4.170.25.8)
Modem: Jump, V.92, Version 1.0
Serial ATA Device: Maxtor 6Y080M0, 76.34 GB
Serial ATA Device: Hitachi HDP725050GLA360, 465.76 GB
Parallel ATA Device: HL-DT-ST DVD-RW GWA-4082B
USB Device: Hub in Apple Extended USB Keyboard, (null) mA
USB Device: Apple Optical USB Mouse, (null) mA
USB Device: Apple Extended USB Keyboard, (null) mA



Jethryn Freyman
Nov 25, 2012, 04:34 AM
I'm drunk and can't currently remember the exact command, but try booting in "Safe Mode", from my quick peek at the crash report it appears that some kind of kernel extension you have [knowingly or not] installed is causing your panics.

kaliyuga
Nov 28, 2012, 02:47 AM
I have tried to get into safe mode but it doesn't start. all i get is the apple logo screen with a line of black pixels above it and then the fans go mad:(

havokalien
Nov 28, 2012, 02:25 PM
Last Lin says a CPU has died. If its a dual swap the CPUs and it should run. You will have to run the Apple Service Disk to reset the fan speed and it will show the one CPU fail or not there at all. You can get replacement CPUs as they are common failure points on e b a y.

Good Luck.

MisterKeeks
Nov 28, 2012, 09:04 PM
I believe it's a single 1.8 (2004).

kaliyuga
Nov 29, 2012, 01:00 AM
Thankyou, that sheds some light.
I am in new zealand and we don't have ebay, what would I look for as a replacement cpu?

666sheep
Nov 29, 2012, 03:13 AM
Thankyou, that sheds some light.
I am in new zealand and we don't have ebay, what would I look for as a replacement cpu?

Hold on for a while with buying CPU. Your panic log type (kernel_trap) suggests only that CPU has problem with data access at some addresses. This could be caused by bad RAM or HDD not the CPU itself. No kext in backtrace, so you can probably rule out driver/kext issue. First do some basic troubleshooting: try boot from Install disc, check RAM, reset PRAM and PMU – if it won't help it won't hurt.
Obtain Apple Service Diagnosctis and run all tests.

Jethryn Freyman
Nov 29, 2012, 04:28 AM
My best guess is that you've installed an incompatible kernel extension [.kext], have you tried backing up your files and reinstalling OS X?

EDIT: And disconnect any stuff you've added that isn't fully Apple-approved.

Process of elimination.

bizzle
Nov 29, 2012, 05:46 AM
Looks like a CPU failure to me as well. It was pretty common on G5s of all generations.

You can try swapping RAM, but I've seen a lot of this in my day and it's usually the CPU (or one of them in dual CPU configurations).

You can try reseating it to the socket, perhaps thermal expansion from heat over the years has it slightly loose, which will cause all sorts of issues. It's been a while but I believe you need a 2.5mm hex bit with a really long handle.

kaliyuga
Dec 1, 2012, 12:35 AM
I have tried swapping the RAM around but that made no difference. the computer will not boot from the install disk or the diagnostic disk, so does that also indicate cpu failure?

keremtezcan
Dec 1, 2012, 02:53 AM
Probably