PDA

View Full Version : iSight 'not connected' solution




Mdv2
Nov 29, 2012, 04:15 AM
I don't post much here, but I felt this was worth sharing for all people who are experiencing the issue of the iSight camera not showing up in the system profiler as well as applications indicating 'no camera connected'.

The other day, I installed Mountain lion on my new SSD and installed a second hard drive in the optical bay. Although I had been having issues with iSight under Lion - it would sometimes work and sometimes it would not - rebooting always solved the problem.

When iSight wouldn't want to work under ML, I assumed it was software-related. Especially after reading many threads on this forum of people also experiencing this problem. I did all the ordinary stuff like resetting SMC, PRAM and even did a second clean reinstall. No luck.

Today I talked to Applecare and they told me it is probably a hardware issue, but since my late 2008 Macbook unibody is four years old, I didnt really feel like bringing it in for reparation. It would definitely be costly from what I've read.

So I decided to check the iSight cable. Maybe it got loose when I installed the optical hard disk caddy. It didnt, but what I did notice was one of the connector pins bent up. I bent it back and iSight is now working flawlessly again.

This is probably not a solution for many people, but I'd say its definitely worth checking if you are experiencing the 'not connected' issue and you've been messing around on the inside of your Macbook.