PDA

View Full Version : iTunes 11: newly added song not listed in iTunes library




MacMan988
Dec 2, 2012, 02:24 AM
Hi, I just clicked on a mp3 file to add it and play it on itunes as i used to do with previous versions. iTunes were opened but it did not play the song and the song was not seems to be in iTunes library. I clicked several times on the mp3 file but the result was same.

Then I exited from iTunes and re-opened it. Now I can search the song from search and play it from there. But I cannot see the song or the artist listed when browsing the library by artists or by songs.

Any ideas?



vladobizik
Dec 2, 2012, 04:55 AM
This occasionally happened to me on 10.7 - the songs would always appear in the library after a while, when I chcecked in an hour or so. Alas, I have no clue what causes it. I hoped 11 would fix this, but now I see you have the same problem too on 11...:confused:

sensorian
Dec 2, 2012, 05:01 AM
I find if I quit itunes then relaunch it, they then appear. Which is a bit poor really.

vladobizik
Dec 2, 2012, 05:06 AM
Restarting never worked for me, had to wait despite how many times I relaunched iTunes. My only guess would be it has something to do with iTunes Match / iCloud communication, as every time I didn't see the newly added music, the cloud icon next to "Music" in the left sidebar was always "in progress" (but no actual iTunes matching was taking place). Haven't had this problem on 11 yet, though, so I don't know how differnt is it now.

MacMan988
Dec 2, 2012, 06:54 AM
This occasionally happened to me on 10.7 - the songs would always appear in the library after a while, when I chcecked in an hour or so. Alas, I have no clue what causes it. I hoped 11 would fix this, but now I see you have the same problem too on 11...:confused:

Thats sucks. Apple should think about doing a bit more QA on their software products before they release them.

aufmobi
Dec 12, 2012, 08:58 AM
Finally solved this issue by going into iTunes preferences > Store

then uncheck the option for:

"Show iTunes in the Cloud purchases"

Then immediately the music I had added started to appear as it should in the library.

rgdigital
Jan 2, 2013, 11:55 PM
Finally solved this issue by going into iTunes preferences > Store

then uncheck the option for:

"Show iTunes in the Cloud purchases"

Then immediately the music I had added started to appear as it should in the library.

Great find! It worked for me, and I was able to re-check that option and they stayed visible.

unobtainium
Jan 4, 2013, 02:01 AM
Finally solved this issue by going into iTunes preferences > Store

then uncheck the option for:

"Show iTunes in the Cloud purchases"

Then immediately the music I had added started to appear as it should in the library.

Thanks for the tip. I feel like that really shouldn't be necessary though. The quality control on Apple's software and services over the past few years has gotten steadily worse. iTunes Match, Maps, and Siri have all been atrocious. I kind of like iTunes 11 and Mountain Lion, but they're both a bit plagued with bugs. Disappointing :/

dwilt
Feb 23, 2013, 12:19 PM
Great find! It worked for me, and I was able to re-check that option and they stayed visible.

Worked for me! Thank you.