PDA

View Full Version : Accessing Windows PC from MacBook Pro - Error




kathy13
Dec 8, 2012, 02:19 PM
After setting up sharing on my Windows PC, I can see my Windows PC in my Finder window on from my MacBookPro (running OS X 10.6.8). However, whenever I attempt to double click to access any files within a folder on my PC, I get the following Error Message: "The operation can’t be completed because the original item for “File Folder Name” can’t be found."

Anyone have any suggestions on how to fix this error? Thanks



PaulKemp
Dec 8, 2012, 03:54 PM
After setting up sharing on my Windows PC, I can see my Windows PC in my Finder window on from my MacBookPro (running OS X 10.6.8). However, whenever I attempt to double click to access any files within a folder on my PC, I get the following Error Message: "The operation can’t be completed because the original item for “File Folder Name” can’t be found."

Anyone have any suggestions on how to fix this error? Thanks

I can see all sorts of devices in my finder window. My router, my wdtv etc. That doesnt mean anything if they cannot communicate.

I dont know, but if the file system on the win box is unsupported on the mac I'm guessing this is the error you would get. Are you sure they are compatible? I dont have a guide for this, but you could try this.

Empty usb pen, format as NTFS
Make a folder on the USB drive
Left click, sharing, permissions (add a user) and then advanced sharing and add the same user (read permissions is the only thing that works on NTFS)
Then try to access that with the (option + K) keyboard command in OS X. Try afp://ip_of_windows_machine


Ive done this on a windows 2008 (vista kernel) and I was able to access NTFS files from the file system. But the network protocol settings can change between OS X versions and Windows versions.

Anyway, I would suggest googling "sharing files between windows and os x". Of course after you've tried my solution (so you could give me credit if it works) :)

TheKingOfHearts
Dec 9, 2012, 09:39 AM
OS X requires the use of "Samba" to communicate with Windows Machines.

Why don't you try clicking on Finder, then Go (at top) > Connect To Server > then type smb:// and follow by the Windows Machines IP or Hostname (IP advisable) for example smb://192.168.0.2/ and click Ok. Should give you the option to mount any shared folders you have on that given machine. May ask you for Authentification, choose Registered User, type in your WINDOWS login details here, not Mac.

Should work.

Mac_Max
Dec 10, 2012, 12:32 AM
When accessing a Windows PC from the finder it will automatically use Samba (as thats how its able to see it in the first place). NTFS also has nothing to do with this as the network protocols at work here are file system agnostic. Also OS X does have NTFS read support out of the box.

First try rebooting both computers. Maybe something is just in a wacky state.

I've had this problem when the Windows or OS X wasn't configured properly.

Windows Cases include:

Windows Firewall blocking file sharing.
(Vista-Win8) Windows network type not being set or set to Public (Closing out of the network type dialog seems to default to public).
(XP mostly) Computer hasn't joined a workgroup. On XP running the Network Sharing wizard fixes this usually.


OS X Cases

Mac isn't on the same Workgroup as the Windows computers. You can set the workgroup in the WINS tab under System Preferences->Network->Advanced button.