PDA

View Full Version : FTDI USB-Serial Cable not working in ML




trevorh7000
Dec 12, 2012, 09:13 AM
I have an FTDI USB-Serial cable

USB <-> Serial Cable:

Product ID: 0x6001
Vendor ID: 0x0403 (Future Technology Devices International Limited)
Version: 6.00
Serial Number: 12345678
Speed: Up to 12 Mb/sec
Manufacturer: FTDI
Location ID: 0xfa132000 / 7
Current Available (mA): 500
Current Required (mA): 100

I installed the latest version of the 64bit VCP driver downloaded from the FTDI web site. It mentioned the driver was good for 10.5 to 10.7 or so. I emailed support about 10.8 and got an unhelpful reply

I installed the driver and it completed successfully and when I plug the device in I can see the following ports appear

cu.usbserial-000013FD
tty.usbserial-000013FD

The number can change when plugged into a different usb port

So it appears to be installed and working. The documentation mentioned you needed to go to Network in the Sysytem Preferences and add a USB-Serial port. WHen I add a new port there is no option to add a USB-Serial port.

I only really want to use this n the command line with gpsbabel to read / write data from y serial Etrex-H gps.

I set the Etrex-H into text output mode 9600 baud and then did a

cat /dev/tty.usbserial-000013FD (or cu.xxxx) and expect to see the gps outputting its coordinates - but I get nothing. gpsbabel also just sits there doing nothing when I specify the same as the serial port.

I downloaded zterm and from there when setting up the modem I get offered one of the ports above - but I have no serial modem to see if there would be communication taking place.

Is there anything I can do to make this work in 10.8 - the driver version is 2.2.18 released August 2012

I really would like to get this working

Thanks in advance

Trev