PDA

View Full Version : MBA Won't Charge But Passes AHT (Huh??)




dnspade
Dec 19, 2012, 11:04 PM
13" mid-2011 MBA. Spilled water on it when it was 3 months old about a year ago. Replaced keyboard/top half assy as a result (in addition to the rice/alcohol/etc). Worked fine. Had cracked screen replaced as well. Worked fine. Lost charger about 9 months ago, bought new one. It worked for about six months, then failed and was replaced under warranty.

Reason for background: At this point, Apple store is useless to me as this laptop is "known" and any technical issue is attributed to the water damage and they are hotter to do the $900 depot repair than a single guy at last call. They did a quick check with another charger which did not work either, but am skeptical they did not leave it on long enough.

My charger does not charge the batteries nor does the diode light come on. Yet it powers the computer to operate, and power is acknowledged on the indicator (the battery with lightning bolt, but "(Not Charging)". Ran the AHT extended test and no faults found, with power charger acknowledged at 6.65v. Hardware profile acknowledges power adapter but has a 0x000 type serial number, etc. Have done the SMC reset routine as well.

I personally am baffled. My gut tells me to replace the I/O board, but would prefer to avoid the $100 if that isn't the problem. Have seen numerous posts re the charger behaving this way, but does not necessarily correlate to liquid damage.

Any ideas on next steps???

Also, does anyone know why Apple - if they only replace components (don't repair boards) - did not apply conformal coat (epoxy) to the circuit boards to make them more moisture resistant? Made boards for a defense contractor for about 10 years, and know the cost isn't prohibitive, particularly with these margins!!!